[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    I got some problems, my NPC won't look at me. I tried everything, and my NPC just disapear when i stop or reload server.
  3. Offline


    This is a great plugin
  4. Offline


    When i type /toggle guard or anything it says invalid NPC type. What am i going to do?
  5. Offline


  6. Offline


  7. Offline


    The support of this plugin is a joke... they release the 1.25 version but.... it's really really bugged
    Trader disappear with minebackup
    Unable to interract with trader after a chunk reload
    Can't interract with a trader if you're not a OP

    seriously... wtf
  8. Offline


    Please tell me what the hell I am doing wrong!!!

    "Feed Wondwi":
    description: "<Wondwi> I am coming very close to running out of food.
    <br>I need more food asap since I am all alone up here, you see.
    <br>Could you please do me a favor and fetch me 5 cooked beef?
    <br>&6Quest: <g>Feed Wondwi started.
    <br>&6Objective: Take 5 cooked beef to Wondwi."
    completion: "<Wondwi> Thanks! Come back later, I might need some more food. <g> You have recieved 16 pine logs and $100.00.
    acceptance: "<Wondwi> I knew you were a good pal!"
    repeats: -1 # May be repeated an unlimited amount of times.
    delay: 1440 # 1440 minutes is equal to 24 hours. Cannot repeat until this amount of time.
    type: delivery # First objective is a collection quest.
    materialid: 364 # Cooked Beef
    amount: 5 # Must Collect 5
    npcdestination: 0 # deliver to Wondwi
    message: "<Wondwi> I knew you could do it! Thank you very much. *Nom Nom Nom*"
    type: item
    id: 369 # Blaze_Rod
    amount: 1
    type: money # Rewards the player money when objectives are complete.
    money: 100
  9. Offline


    The error is

    while scanning for the next token
    found character '\t' that cannot start any token
    in "<unicode string>", line 18, column 1:
    npcdestination: 0 # deli ..
  10. Offline



    I know there isn't a ton of example quests there, but it should give you a good grasp of how to build quests.

    You can't use tabs in YAML files. Make sure that you are only using spaces. I recommend using Notepad++ and turning on the "Replace tabs with spaces" setting. http://npp-community.tuxfamily.org/documentation/notepad-user-manual/settings/preferences

    We apologize, a lot of the problems that are left with Citizens 1.2 are being addressed in Citizens2, which is a complete rewrite which contains much more efficient code. We are aware of the problem with Minebackup, and I believe the problem has been forwarded to the Minebackup developers. Unfortunately it is something Minebackup would have to address. You can always try the #citizens IRC channel if you require any additional help that the wiki.citizensnpcs.net wiki doesn't cover -- as of now, it's a work in progress as the new features of Citizens2 solidify.

    You can always get the latest version at ci.citizensnpcs.net.

    In Citizens2 you would type /npc create --type enderdragon. In Citizens 1.2, this functionality does not exist. You can see what version you are using by typing /citizens.

    Be sure your type.jars (blacksmith.jar, trader.jar, etc.) are in /plugins/citizens/types/ if using Citizens 1.2. Note: In Citizens2, the types are simple plugins and should be installed the same place the citizens.jar is... /plugins/.

    Install Vault. Sorry for not letting users know in a better fashion as this dependency is relatively new. We will get it on the main thread.

    Check out http://wiki.citizensnpcs.net/1.x/Guard for information on the 1.2 Guard. I believe to do what you are requesting, you would type /npc create myGuard, /toggle guard, /guard bouncer, /guard addflag [groupname] -g, then /guard aggro. Note: You will need a permissions system AND Vault installed.

    Install Vault. Sorry for not letting you know.

    Please use the official wiki. For Citizens 1.2, use http://wiki.citizensnpcs.net/1.x. For Citizens2 use http://wiki.citizensnpcs.net/Citizens_Wiki. If you have any specific problems, please visit us on EsperNet in #citizens. Note: I do not believe database support is finished with Citizens2.
  11. Offline


    Short answer is no. Skins are handled by the minecraft client, so changing skins would require a Client-side mod. Long answer is yes, you can, if you are willing to force your players to use SpoutCraft, or install a Client-side mod. If you have any questions, this may be better suited for help in #citizens on EsperNet.

    The core features the ability to make NPCs walk paths and talk when interacted with, so slightly more functionality than your standard Villagers. With Character Types, the functionality gets more involves, with the ability to have NPCs fix armor and weapons, making potions with alchemy, to Guards that attack specific players.

    On a clean shut down, Citizens should save its NPCs. You can manually force it to do so with /citizens save. If you are still having problems, I suggest #citizens on EsperNet.

    Be sure you are using the official wiki.
    http://wiki.citizensnpcs.net/Citizens_Wiki for Citizens2.
    http://wiki.citizensnpcs.net/1.x for Citizens 1.2.

    That being said, both do require more work, and we are doing that as fast as we can.

    Be sure your type.jars(blacksmith.jar, trader.jar, etc.) are in /plugins/citizens/types/, if using Citizens 1.2.

    You can always get the latest version at http://ci.citizensnpcs.net/.

    Do you have Vault installed?

    This definitely sounds like a plugin conflict. Catch us in #citizens on EsperNet if you require any
  12. Offline


    Your quests look fine. Give us a visit at #citizens in EsperNet.
  13. on bukkit 1.2.5 R1.3 running citizens 1.2 i get the following message upon server start:

    14:47:22 [INFO] [Citizens] Unable to fetch player map from CraftEntity: players. Conflicting names will do funny things.
    So far i could not see any problems but i'd like to know what causes this and if it will be fixed eventually ?
  14. wow what an "fast" respond XD
    does it connect with esper.net? XD dunno how to join there
  15. Offline


    nice, nice...
    but why when we reload the server (even after saving them)
    all the npcs disapear ???[sheep]
  16. Offline


    When i installed Citizens, i got this error: 2012-05-08 19:21:54 [INFO] [Citizens] Enabling Citizens v1.2
    2012-05-08 19:21:55 [INFO] [Citizens] NPC types loaded: blacksmith, guard, healer, quester, trader, wizard
    2012-05-08 19:21:55 [SEVERE] Error occurred while enabling Citizens v1.2 (Is it up to date?)
    java.lang.NoClassDefFoundError: net/milkbowl/vault/economy/Economy
    at net.citizensnpcs.Economy.init(Economy.java:21)
    at net.citizensnpcs.Citizens.onEnable(Citizens.java:122)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:215)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:336)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:250)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:232)
    at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:371)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:358)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:187)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:422)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    Caused by: java.lang.ClassNotFoundException: net.milkbowl.vault.economy.Economy
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:41)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 12 more
  17. Offline


    if you use essentials use /spawnmob enderdragon
  18. Offline


    Hi. What this? Error? This affects to anything?
    [INFO] [Citizens] Unable to fetch player map from CraftEntity: players. Conflicting names will do funny things.
  19. Offline


    java.lang.NullPointerException: null

    I already have vault and i updated it so i don't know what to do. I still can't use /npc create.
  20. Offline


    If i will put NPC in one place that is far away and no one will come there would that place(chunks) be always loaded(so updates like growing don't stop)?
  21. Offline


    I really love this plugin. It make's the spawn in my server look so alive. There is one problem though, whenever i refresh/restart my server. All of my NPC's disappear. I really find this annoying. Please fix it. Btw i did save before i refreshed. If there is a way to fix this, please tell me!
  22. Offline


    jujulogey - are you using Minebackup? Seems to be a conflict with it.
    Finding us on IRC for support will always be 100% better and easier than on the thread/dev.bukkit.org, where it's much harder to monitor things. I'm always available to talk you through things, listen to suggestions or debug an issue.
  23. Offline


    I have a problem with Citizens 1.2. The quest objective "player combat" does not work. I dont know why an i have relocatet something, but it didn't help anything.

    Here is the Quest:
    quest.yml (open)
            description: <g>Cro <y>Kill someone.
            completion: <g>Cro <y>Here you are.
            acceptance: <g>Du <y>Okay!
        repeats: -1
                    type: player combat
                    string: '*'
                    amount: 1
                    optional: False
                    finishhere: True
                    message: <y>He is dead!
                type: item
                id: 1
                amount: 1
                take: false

    Plugins on the Server:
    Plugin List Image (open)

  24. Offline


    Hmmm... This plugin need skin support, :C
    Anyway, is it planned?
  25. Offline


    no im not using that . idk whats wrong i want to be able to save my npcs.
  26. Offline


    Will this plugin have skin support :C?
  27. Offline


    Citizens aren't costing money, essentials is my econ system, and i also tried (and still have) iconomy on. What's wrong?
  28. Offline


    my npcs don't cost anything to make, the config file has it set to 1000 for each type, yet it costs nothing, not even any flowers like in my old version that worked. I have essentials, it didn't work, so i added Iconomy, but again, last time it worked just fine with the essentials econ system.
  29. Offline


    Just tried creating my first quest. dumped it into the YAML parser cleared all the errors. reloaded the server, citizen shows the quest there, i assigned it to my npc(made it a quester type) when i go to select the quest, no text shows up about the available quest nor any of the description, acceptance and completion. i do get the objective message and i complete it. just trying to find out why the quest text isn't showing up<used the example on the wiki to make it>:

    "City Defense":
            description:"<Laura> Welcome to Reasi <name>. The city guard could use some help
                <br>if you have some time. out side the gates of the city are a number
                <br>of dangerous creatures that make it very dangerous for the near by
                <br>farmers and other travelers. think you could clear a few of them out?
                <br>&aQuest - &eCity Defence
                <br>&aTask - &fKill 5 Zombies."
            acceptance:"<Laura> Excellent, once you have cleared the roads return to me
                <br> for your reward.
                <delay=60>&eUse /quest status to check progress."
            completion:"<Laura> Your back <name>, i hope that wasn't to much trouble.
                <br>here's the payment for helping us.
                <br>&aYou Receive 15 Rea!
                <br>that won't be the last of them. come back and see me later.
        repeats: 10
                    type: hunt
                    string: 'zombie'
                    amount: 5
                    message: "&aThat should be enough for now, return to Laura."
                type: money
                money: 15
  30. Offline


    U can see him/her/it
  31. Offline


    nice plugin :confused:
    but i have a big problem :/
    i can't toggle the types off the npc's an the list : /toggle [type] is empty... what is wrong../sry for my english :D

Share This Page