[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


  3. Offline


    it says which i don't have permission to that :/ help plz!
  4. Offline


    What permissions plugin are you using?
  5. How can I update from 1.1 to 1.1.1 without deleting my npc's?
  6. Offline


    I do but is PEX supported by citizens?

    EDIT: Nvm, answer at the previous page.
  7. Offline


    Just installed the lated 1.1.1. My quest text now isn't colored, but prints the tags. So <g> and <br> print out. Known bug? I was previously running the dev builds but it choked on a recent update to another dev build (sry, don't have those numbers) so I went to 1.1.1. No changes to my quests.yml file otherwise.
  8. Offline


    i don't know, but i create a bukkit server, and install this mod, but says to me that i post up
  9. Offline


    This is a thank you for aPunch and fullwall. I really can't thank you enough for all this hard work you've put into this plugin. This is better than anything I could ever do. Both you, fullwall and aPunch have made a huge difference on how fun minecraft is now with npcs. I just came to stop by and thank you for all this work and time dedicated to us, Citizenonions (I made that up) :D.
  10. Offline


    When using /npc copy it appears it is only copying the name and not any of the current settings. I started with a new 1.1.1. Is anyone else experiencing this?
  11. Offline


    I'm running permissionsbukkit 1.2and superpermsbridge 1.2, and have my nodes like so:
    superpermbridge.citizens.basic.use.*: true
    superpermbridge.citizens.basic.use.info: true
    superpermbridge.citizens.basic.modify.*: true
    superpermbridge.citizens.trader.use.*: true
    superpermbridge.citizens.trader.use.trade: true
    Yet none of them work. I get a 'you do not have permission'
  12. Offline


    Wtf , The new release of bukkit broke this plugin. theres a npc version of myself following my everymove , flying with me, moving with me , EVERYTHING WTF FIX
  13. Offline


    npc following me (stalker)
    server freezes
  14. Offline


    Is it possible to give my trader unlimited money?
    Also you should make it so Wizards can run commands through the server
    and you should be able to set individual prices per wizard through in game commands
  15. Offline


    Nope, still doesnt works. Even with PEX configured with the node and 1.1.1 My players still can't access the trader...

    EDIT: Managed to make it work by giving the node citizens.* and then using -citizens.(whatever is going here) to remove the perms i didnt wanted them to use and TADAH!!! IT now works. Awesome plugin BTW.
    OmniLicious likes this.
  16. Offline


    Upload the new jar.
    If you are afraid of losing npcs, backup the citizens folder.. But the update should delete nothing

    fullwall posted earlier that this current version will break if you update to the latest cb of bukkit. They are working on it, so just be patient
  17. Offline


  18. Offline


    Citizens v1.1.2

    We released this version so that you can have an official build that is compatible with the latest CraftBukkit RB. Enjoy. :)
    Don Redhorse likes this.
  19. Offline


    Can you add:
    That you need to use a command for a quest?
    That way i can get some realy nice quests setup.
  20. I did, but it deleted my npcs! help!
  21. Offline


    Anyone have quests that they can share to me, can't figure out a good one...
  22. Offline


    My Server Hoster closed my Server 10 Minutes ago, because all other Customers on the same Server are not able to play because of lag, produced by me, they say. Well, i got 9 NPC from Citizens on the Map so far and the Server smokes, lol :-P
  23. Offline


    Hi - I have noted some issues with your plugin, as follows:

    1. Even though I am apparently using 1.1.2, I keep seeing a login message that says that there is a new version 1.1.1. I allowed it to recreate the prefs and still saw the message. Doesn't really make any sense. It would really help if you (and other plugin developers) would start putting version numbers in the plugin filenames. It's no problem to delete old plugins with different filenames.
    2. The Evil mob NPCs don't work very well, particularly around water. The main issue is that when you kill them, they never disappear and can no longer be damaged. They usually disappear when they die on land - maybe not in 1 case I saw. Anyway - don't know if it's mc, bukkit, or the plugin that is causing this behavior, but it's worth a look. To reproduce it, just kill a bunch of evil mob npcs while they are standing in water.
    3. I gave the evil npc phrases, and even though a bunch of them spawned, they never said their phrases while I was fighting them, or when they approached me.
  24. Offline


    Hey uhm, when i try to /toggle guard
    I get the following
    GUARDS AREN'T FINISHED YET, Be patient! <3 The Citizens team.

    But it seems here that people are using them, also my NPC's can only wear/hold one item.
    Please can I have some help?

    Okay fixed that (i think) but now when i type /npc create XXX
    It returns:
  25. Offline


    I have 30 NPCs on my server. Most with Quests and Trader.
    Just that sometimes when I leave the place and come back, the NPC is invisible. Sometimes just for me, time for everyone.

    Use the Spout, is it incompatible? I do not know.
  26. Offline


    Same here, reverted back to 1.1.1 and now its all working fine.
  27. Offline


    says to me which I don't have permission, also in 1.1.2 help me!
  28. Offline


    Whenever I have a player online with the same name as an NPC it follows the person.
  29. Offline


    i know i thought that issue would be fixed in 1.1.2
  30. Offline


    so im trying to set up a chain quest and also more then one quest on a NPC but im running into a few problem.

    chain quest:
    now when i finish the first test1 and hand it in a get a msg
    "Now your ready to start test2"
    but when i do /quest status it tells me i do not have a quest,

    more then one quest on a NPC:
    i then after not getting the chain quest to work i tried just setting them both on the same NPC changing the reward from quest to giving the player a gold bar, but i can not left click the NPC to scroll thru the list of quest it will only let me right click and that only lets me do quest test1 so i can't change it to do quest test2. i set up both quest the same just the blocks you destroy are not the same so i cant see how one works and the other does not.

    i can list the full quest info if you need more to see if maybe i did something wrong in writing it. also im using CB 1185 and citizen 1.1.1

    Edit: tried updating to 1.1.2 as i just saw you got a new one out. not i cant even create an NPC i get this error when i try

    so i removed the citizen plugin fully and started with a fresh install of it and i still get this error (i tried that because i didnt know if it was because of me having an old config file somewere it was not liking)

    but that didnt change anything still got that error.
  31. Offline


    Seems like alot of people are getting this.
    Anyone have ANY idea why?

Share This Page