[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline

    Shay Williams

  3. Offline


    Using this latest 2 dev builds I don't seem to be able to create an NPC. Actually upon further investigation it seems the entire range of /npc commands are not working.

    Running RB CB and Groupmanager (essentials)
  4. Offline


    Encountered same problem. Change the op color to your color, op yourself, and unop everyone else. Wait for fix.
  5. Offline


    @pudd1nG what error is it giving you? just a permissions error? If so, you probably need to use a different permissions manager or update to the latest developer build which can be found here: http://ci.citizensnpcs.net/ when you visit the link, click on "Last Successful Artifacts" then "All files in Zip" and download that .zip. It has the newest files in it.
  6. Offline


    I am using the latest citizens build. Pretty sure we are still on a random groupmanager build for 1.8 so I'll check for updates.

    No error, actually nothing even comes by the console (or client) upon using a /npc command
  7. Offline


    @aPunch @Citizens @fullwall

    -Can one of you tell me how to correctly set up coordinates for a "move location" quest?

    -I tried setting it up like this: world,-522.0,66.0,226.0

    -and I tried like this:
    world: world
    x: -522.0
    y: 66.0
    z: 226.0
  8. Offline


    needs an all target type for addflags, less I'm missing something. Like '/guard addtypes all -m'
  9. Offline


    @sintri pretty sure /guard addflag -a -m does what you're after

    @Citizens @aPunch @fullwall I've updated everything and Citizens is on the latest dev build, still nothing happening when using /npc - nothing in console either.
  10. Offline


    Thank you sir.. sorry for jumping the gun on dev builds :) Appreciate the great work you've done by the way!
  11. Offline


    Thanks, the wiki posting's a bit thin on usages, tried -m -m earlier.
  12. Offline


    Does "anyone" know how to enter coordinates for the "move location" quests?
    It's driving me insane.
  13. Offline


    Could anyone share a quest or two for the quester?
    Im having a hard trouble creating one :(
    I can't find any decent guide on how to write them..
    I didn't get any examples it the auto-generated config file :(
  14. Offline


    @Magge read back a couple pages on this forum, people keep asking for examples, @fullwall pasted a link to examples a couple times already.
  15. Offline


    2011-09-25 21:53:38 [SEVERE] java.lang.NullPointerException
    2011-09-25 21:53:38 [SEVERE]     at net.citizensnpcs.economy.EconomyManager.format(EconomyManager.java:62)
    2011-09-25 21:53:38 [SEVERE]     at net.citizensnpcs.traders.TraderMessageUtils.getPriceMessage(TraderMessageUtils.java:13)
    2011-09-25 21:53:38 [SEVERE]     at net.citizensnpcs.traders.TraderMessageUtils.getStockableMessage(TraderMessageUtils.java:19)
    2011-09-25 21:53:38 [SEVERE]     at net.citizensnpcs.traders.TraderCommands.stock(TraderCommands.java:298)
    2011-09-25 21:53:38 [SEVERE]     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2011-09-25 21:53:38 [SEVERE]     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    2011-09-25 21:53:38 [SEVERE]     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    2011-09-25 21:53:38 [SEVERE]     at java.lang.reflect.Method.invoke(Method.java:616)
    2011-09-25 21:53:38 [SEVERE]     at net.citizensnpcs.resources.sk89q.CommandsManager.executeMethod(CommandsManager.java:517)
    2011-09-25 21:53:38 [SEVERE]     at net.citizensnpcs.resources.sk89q.CommandsManager.execute(CommandsManager.java:405)
    2011-09-25 21:53:38 [INFO] [Citizens] An error has occurred, please wait while it is sent to the developers...
    2011-09-25 21:53:39 [INFO] [Citizens] Below is the stacktrace that has been transmitted to the developers, no other information has been included other than Citizens version information.
    2011-09-25 21:53:38 [SEVERE]     at net.citizensnpcs.Citizens.onCommand(Citizens.java:200)
    2011-09-25 21:53:39 [SEVERE]     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:39)
    2011-09-25 21:53:39 [SEVERE]     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:163)
    2011-09-25 21:53:39 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:353)
    2011-09-25 21:53:39 [SEVERE]     at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:756)
    2011-09-25 21:53:39 [SEVERE]     at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:721)
    2011-09-25 21:53:39 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:714)
    2011-09-25 21:53:39 [SEVERE]     at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    2011-09-25 21:53:39 [SEVERE]     at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2011-09-25 21:53:39 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
    2011-09-25 21:53:39 [SEVERE]     at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:500)
    2011-09-25 21:53:39 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    2011-09-25 21:53:39 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
    2011-09-25 21:53:39 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    2011-09-25 21:53:39 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    Here.. Anyone able to help ?
  16. Offline

    Drei Gyuu

    I hate to be a bother, but can someone link me to a fully functional sample quest.yml
    I'm one of those people who can learn by seeing. Once i get hold of a quest.yml i'd be able to start making more quest. Much appreciated :)

    EDIT: Apologies, started reading 2 previous page and got my answer. :)
  17. Offline


    I think the issue with no commands is to do with the new essentials groupmanager. Any chance we can get citizens working with it?
  18. Offline


    We cant figure out how to make a quest for the Quester there is no example's for quests or how to make them y is this and how to make the quest if any can help?
  19. Offline


    Dude read any of the last 3 pages. Dev provided example link + plenty of discussion.
  20. Offline


    questers dont bring money or take money, issue with iconomy 6.
  21. Offline


    I'm also getting a bunch of these.. From what I've read the server thinks NPCs are actual players and is freaking out a bit.. I just wonder if this causes high memory usage or cpu spikes.
  22. Offline

    Drei Gyuu

    Likewise, I was wondering about that
  23. Offline


    Not compatible with spout?
  24. Offline


    Running dev build of spout (#393) and dev build of citizens - no issues. Definitely on my donation list if I can figure out these move quest chains :D:D

    Great work @Citizens !
  25. Offline


    Could someone provide a working example of a location (move to) quest?
  26. Offline


    @mspau86 - there is the top node 'location' with the child nodes 'x, y, z, pitch, yaw, world'
        x: 124
        y: 123
    @Vezorock - please download the latest dev version.
    @rehatiel @Drei Gyuu - these shouldn't cause any errors/slowdown, just a bit of log spam.
    I believe GroupManager is the remaining Permissions system unsupported atm, will look into that as a few people have reported it.
  27. Offline


    I have a few problems with this plugin. I wonder if there's anyone that knows how to solve these problems.
    First problem:
    Whenever i create a NPC and switch off the lookat function, these NPC's change the direction they are looking at (depening on what direction the npc in, there seems to be some kind of standard direction they look at) when i reboot the server. Anyone know how i can make them keep their direction they're looking at? even if the server is rebooted?
    Second problem:
    With all the new sorts of npc, when i type /healer create, or any other kind of npc, it tell me type /healer help for help. then i type /healer help, and get the same message... these are not working, anyone know's why?
  28. Offline


  29. Offline


    i think you may have to explain how to make a quester where u take 1 item to another npc, this is how i thought it was but it is not

  30. Offline

    Boon Pek

  31. Offline


Share This Page