[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    @mspau86 - please download the latest dev build until we promote a new 1.1.
  3. Offline


    Link removed to avoid confusion.

    EDIT: Thank you @fullwall for your all your quick responses and good answers.
  4. Offline


  5. Offline


    First of all: Awesome Plugin, love it! Makes every server 1000 times more interesting!

    But I have a question. Could you post an example quest for the quests.yml for the new Quester NPC, because I don't find any examples and I don't know how to make quests?
  6. Offline


    Hi im using PermissionsEx and i did the permissions node but still no one is allowed ? only ops can do stuff with it
  7. Offline


  8. Offline


  9. Offline


    @thedark54 - uh, that's a very strange error. Are there any before that in the server log?
  10. Offline


    hey fullwall, aPunch told me to ask you about some Questers. My problem isn't really big, I'm just a little confused on how to create quests. I know your busy so, whenever you can please just give me a basic instruction or example on how to create a quest and I think I can work it out. Thank you very much ^.^

    (P.S - my quests.yml is just blank and in it, it says {}
  11. Offline


  12. Offline


  13. Offline


    @thedark54 - hmmmmmm... still very strange. Have you updated your Guard.JAR from the latest dev build?
  14. Offline


    Re always the same error
  15. Offline


    I usually hate bugging other people with my problems, but I'm running into this error message:
    It's one of many, but I've looked all over my permissions and no one has that permission set. Any suggestions?
  16. Offline

    Shay Williams

    For some reason, after updating to 1.1 none of the old NPC's show up. I receive no errors and my npc-profiles.yml file is fully intact, any ideas?

    The plugin works fine, I can create NPCs and all, I just can't seem to load old ones.
  17. Offline


    rehatiel likes this.
  18. Offline


    Did you take your server completely offline before updating? I tried to upload my npc-profiles after the upgrade, but I think it converts it the first time then ignores it after that. Try taking your server completely offline, then deleting the citizens folder. Reupload the new one, then place your old npc-profiles file in the citizens directory and restarting the server.
  19. Offline


    @fullwall - okay next issue. I've used your sample quest document and the quests work fine.

    However, I cannot "scroll" between quests by left clicking. I am not sure if I am missing a specific mechanic of this, but I cannot figure it out.

    Also, for example, my NPC has two quests. The first quest can only be completed once, the second quest is infinite. When I approach the NPC after completing the first quest, it will not offer me the second quest, it simply says "you are not allowed to repeat this quest again." I already know this, I just want to do the second quest instead, how can I get to it?

    Thank you again,
  20. Offline


    k its not a super big deal to me (if it wont spam that 20 times :))
  21. Offline

    Shay Williams

    Did that, no help; it gives some error saying index outside bounds of array and points to this line of their code:

    public static void load(HumanNPC npc) {
    for (Properties saveable : properties.values()) {
    if (exists(npc) && saveable.getEnabled(npc)) {

  22. Offline


    Hi ,

    I assign the "example3" to my npc.
    I take the quest but when i kill monster (pig/zombie...) i don't able to completed it. I check the status i have always 3 kills in remaining.

    I don't understand. Bug?

    (I'm op) i don't have any error in log file. I can give you more information.
  23. Offline


    Can anyboby give me example quest? I can't do this :X
  24. Offline


  25. Offline


    The Download On The website Does Not Work Says

    500 - Internal server error.

    There is a problem with the resource you are looking for, and it cannot be displayed.
  26. Offline


    It works for me just fine. Use INTERNET-EXPLORER 8 or above, and simply click the link:

    then when the "Open" or "Save" box comes up, click SAVE and save it. The files are inside the .zip.
  27. Offline


    So in addition to my quest above about not being able to scroll between quests with left click...
    My rewards aren't giving me MONEY. It takes money from me when I create NPCs, but it wont reward me money when I complete a quest. What's wrong?

    EDIT: I FIXED IT.. I switched "amount:5" in the rewards node to "money:5"
    description: <g>(Quest) <y>I forgot to pack my husband, Miner, his lunch, please find a loaf of bread and bring it to him<g>.
    completion: <g>Yay! I'm sure he was very pleased. <y>Here's 5 rupees<g>.
    acceptance: <g>Quest <y>accepted<g>.
    repeats: 1
    type: delivery
    npcdestination: 6
    materialid: 297
    amount: 1
    message: <g>Item delivered. <y>Return to Lauria<g>.
    type: money
    money: 5
    take: false
  28. Offline


    Whenever I copy an NPC it doesnt copy the amor/settings I had it set to...
    I created a guard and gave it diamond armor and made it attack spiders/creepers etc, but when I copied it, it had none of the things i gave the original NPC... Help please??
  29. Offline


    Use CraftBukkit 1185.
  30. Offline



    Well, I'll show you what a "working" Guard NPC looks like. Notice the "items" node. That is where their equipment is.

    name: Uthslorsen
    color: '15'
    look-when-close: 'true'
    items: 267:0,306:0,307:0,308:0,309:0,
    location: world,-361.0,64.0,230.3537408263714,69.979355,0.0
    owner: mspaulding86
    inventory: 267/1/0,AIR*35,
    text: Who goes there?;Orsylox always lies.;I love the smell of dead creeper...;Welcome to the Marketplace.
    talk-when-close: 'false'
    safe: 'false'
    type: MOB
    priority: '1'
    type: BOUNCER
    toggle: 'true'
    radius: '12.0'
    aggressive: 'true'
  31. Offline


Share This Page