[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    Guards perhaps. They're getting pretty close, we just need to add patrol areas.
  3. Offline


    20:22:14 [INFO] CraftPlayer: Set time to 0
    20:22:23 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'npc' in plugin Citizens v1.0.8
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:97)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:278)
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:701)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:666)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:660)
    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:377)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:292)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorldManager.<init>(Lnet/minecraft/server/WorldServer;)V
    at com.fullwall.resources.redecouverte.NPClib.NPCSpawner.spawnBasicHumanNpc(NPCSpawner.java:39)
    at com.fullwall.Citizens.NPCs.NPCManager.register(NPCManager.java:65)
    at com.fullwall.Citizens.NPCs.NPCManager.register(NPCManager.java:99)
    at com.fullwall.Citizens.Commands.CommandExecutors.BasicExecutor.create(BasicExecutor.java:439)
    at com.fullwall.Citizens.Commands.CommandExecutors.BasicExecutor.onCommand(BasicExecutor.java:49)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    ... 12 more

    I cant spawn a npc and it is saying an internal error anyone have an idea
    i have no plugins installed just this one to test
  4. Offline


    my trader npcs do not want to trade with me
    (yes, I changed them to not being owned by me)
  5. Offline


    I did not get any output in my server, but I DID get an internal server error message when trying to use "/npc create" while ingame as well

    1.6.6 using Bukkit 818
  6. Offline


    It does not support for craft build 818
  7. Offline


    Well, easy explanation for my problem then. I'll just have to wait lol
  8. Offline

    Jonathan Thorpe

    Citizens 1.0.8d is NOT compatible with CraftBukkit greater than build 803! Read the damn thread title and quit asking questions that have been answered at least 20 times already, you stupid, lazy people!:mad:
    zipfe, Wolfeman, gmore70 and 3 others like this.
  9. Offline

    Brandon Egnell

    hold on so its not compatible?
  10. Offline


    Hey amigos,

    Is there any support for multi-line dialogue? I'd like people to be able to read a paragraph or so of text...

    Otherwise, I can add some kind of text-wrapping feature...
  11. Offline


    Ooooh, okay ! So I just have to write for my players :




    Thank you a lot ! :)
  12. Offline


    Here's my idea for the questers:

    You should be able to make a list of quests that the Quester can give out like this:

    Right click with an empty hand to receive and deliver quests.

    Quester NPC 1:

    Quest 1: Welcome to the server! (Intro Q (Go get some wood))

    When you deliver that you can get the second quest by right clicking again.

    Quest 2: Start making some tools! (Make a pickaxe)

    Quester NPC 2:

    Quest 1: Mine some coal!

    Quest 2: Make a torch!

    And so on.

    I love your plugin, so keep up the good work! I cannot wait to get npcs in my town again.
  13. Offline


    So I've setup a Test server, with only Permissions and Citizens 1.0.8e.
    I've noticed that on the 1.0.8d version I get [INFO] [Citizens]: Permissions enabled
    This doesn't appear on startup in the new version, and I can only use commands when opped. So it seems this is not linking with permissions 2.7.4

    Going to run more tests and try different version of permissions and will report back.

    2011-06-02 12:59:51 [INFO] [Permissions] (Phoenix) was Initialized.
    2011-06-02 12:59:51 [INFO] [Permissions] version [2.7.4] (Phoenix) loaded
    2011-06-02 12:59:51 [INFO] [Citizens]: version [1.0.8e] (Realist) loaded
    2011-06-02 12:59:51 [INFO] Done (0.200s)! For help, type "help" or "?"
    2011-06-02 12:59:52 [INFO] [Citizens]: Loaded 21 NPCs.
  14. Offline


    Ohhh... I see it now. Permissions is loading before Citizens.
  15. Offline


    Yep, sure.
  16. Offline


    Tried latest permissions to no avail, still no response unless opped. Installed iChat to make sure permissions were running OK.

    2011-06-02 13:36:08 [INFO] [Permissions] (Yeti) was initialized.
    2011-06-02 13:36:08 [INFO] [Permissions] version [3.1.1] (Yeti) loaded
    2011-06-02 13:36:08 [INFO] [iChat] Found Permissions (v3.1.1)
    2011-06-02 13:36:08 [INFO] iChat (v2.3.0) enabled
    2011-06-02 13:36:08 [INFO] [Citizens]: version [1.0.8e] (Realist) loaded
    2011-06-02 13:36:08 [INFO] Done (0.183s)! For help, type "help" or "?"
    2011-06-02 13:36:08 [INFO] [Citizens]: Loaded 21 NPCs.

    Maybe I'm overlooking something obvious....
  17. Offline


    i have craftbukkit 818 and it works fine
  18. Offline


    @DetCox - you have an inprogress build that was released early.
  19. Offline


    i want to apologize but i just love this plugin so much and i am having a hard time missing it...
    i just look every minute whether the new version has been released or not but i almost never look at the comments,
  20. Offline


    @DetCox Lol I Know, And Nice Angry Face You Have There. It Made My LOL
  21. Offline

    John Garettt

    I wonder when we can get support for the new CraftBukkit, cause i really need this plugin badly ;D
  22. The test build works really well :) No complaints here
  23. Offline


    @fullwall Hey, i got an idea. Why wont you make some kind of chattering for bots? i mean chatter between bots, not talk_when_close. I mean, if bot sees another bot in look-range, they both will start looking at each other and nod heads like they are talkin'. For example, there can be few types of animations (like just looking, speech, nod in agreement, nod in disagreement, and so on). Placing few bots together in same location will live it up. However, the still can act like before - if player comes up, they will stop talking and start looking at player.
  24. Offline


    Where can I download it please ?
  25. Offline


    What's the deal with the trailing comma.
  26. Offline


    dont confuse the issue, d is doesnt work e does. Very very clearly stated by developers
  27. Offline



    Whenever i use a command for this plugin it tells me:

    An Internal Error has occured!

    Please help meh! I really want this plugin!

    I use bukkit
  28. Offline



    Jonathan Thorpe said:
    Citizens 1.0.8d is NOT compatible with CraftBukkit greater than build 803! Read the damn thread title and quit asking questions that have been answered at least 20 times already, you stupid, lazy people!:mad:
  29. Offline


    So how can i fix that?
  30. Offline


    You wait. :)
  31. Offline


    Using the link you provided with e, I am having issues using essentials group manager.

    I gave permission to every person, including citizens.admin

    Is this an issue with this build? or can I not use essentials?

Share This Page