Inactive [FIX/ADMN] NoLagg v1.88.1 - Prevent common lag causes on your server [2338]

Discussion in 'Inactive/Unsupported Plugins' started by bergerkiller, Sep 17, 2011.

  1. Offline


    I had already made this plugin before after having a major lag issue. (lots of torches being filled, turned into items, lag for 20 minutes) It also works for 1060.

    Some feature ideas are taken over from PerformanceTweaks by @LexManos so some credit goes to him. Code, however, written from scratch by me. :)


    If you get a warning message [NoLagg TLN] followed up with a stack trace in the log, this has to do with the main thread not having responded within 10 seconds. When a plugin takes more than this time to enable, it will show that. The warning is NOT an error and is no bug, and not a bug related to NoLagg. To disable this feature, disable 'threadlocknotifier' in the config.yml. This feature is mainly intended to notify you what plugin is causing the server to freeze, may it ever happen. It is used to debug plugins in general, as they may get stuck for whatever reason.

    NoLagg's features in a nutshell


    Prevent lag caused by many items

    Every time an item gets spawned, it is buffered per chunk. For example, you spawn 30 items using Q and the maximum allowed items per chunk is 20, then the 10 remaining items are not spawned. They are spawned as soon the item count in this chunk is < 20 again.


    Form item stacks - fully automatically

    Whenever two or more (configurable) items or experience orbs get near each other, they form a single stack of that item type. If someone drops 64 dirt blocks on the ground using Q, it will show a single item of 64 dirt instead.


    Prevent lag caused by TNT

    This plugin takes over tnt ignition caused by explosions. When exploding stacks of tnt, it does not rush all tnts into a single tick, but detonate them nicely in sync. This results in pretty awesome fireworks. :)


    Prevent lag caused by lighting glitches

    Whenever a new chunk is generated, it's lighting information is generated and all nearby players receive the updated chunk data. If the auto-method fails, you can use /nolagg fix to do it manually. This fixing fixes, for example, dark spots in and around caves lagging the client.


    Set entity spawn limits

    You can set a spawn limit on virtually every entity in the game. From mobs to items to TNT. Only thing being excluded is Players, since I can't simply kick someone 'like that'. :)
    Note: It removes already spawned entities too. So, if you want to keep your animals alive, don't set mob or animal limits, or it will possibly clear your farm animals. (or you can disable the spawn limiter all together)

    I recommend finding an alternative plugin for this instead. Removing entities after they are spawned causes more lag than it prevents!

    Global auto-saver

    Since asynchronous chunk saving is now implemented internally, it is no longer a problem to save entire worlds frequently. You can set auto-save intervals in the configuration. If used with an interval higher than 400 ticks (20 seconds) it will use a scheduled task instead of the internal saver to prevent chunks never getting saved. Another benefit is that player information is also auto-saved, preventing your players losing their inventory state.

    New chunk sending mechanics

    Instead of loading chunks all around the player, the player direction is used to load the visible chunks first. This means that players can expect chunks in front of them to load quickly, while chunks on the sides take a bit longer to appear. When the player looks into another direction, the direction changes and thus the new visible chunks get loaded first. Only if all chunks ahead of the player are loaded, chunks around the player are sent. This all can be configured using a simple minimum and maximum sending rate.


    Examining the server tick rate

    If you encounter very low tick rates and you want to find out what plugin is causing it, you can use the examine component to find it out. It comes with a graphic viewer, which makes bug tracking the easiest thing ever.


    Prevent cross-thread access for events

    As it seems, some plugins don't follow the rules and use Bukkit methods in another thread. This plugin will notify you and cancel if possible whenever this happens so other plugins understand their mistake. If you encounter a lot of spam in the console, first check the stack trace for the plugin that caused the error. Report this error to the author or remove the plugin, if you have questions you are free to ask.

    Configuration (on BukkitDev)

    Commands and Permissions (on BukkitDev)

    Synchronized code accessed by another thread? (BukkitDev)


    Video by brandcool86


    - Help I experience missing chunks
    If you are using Spout, don't use Reloads. This is also the reason why Spout added a warning when a player tries to reload the server. Not using Spout, then it's a bug which you can report.

    - Can this plugin be used with PTweaks
    (this message was really old...) Yes, they are compatible, but if certain features overlap, make sure you disable these features in either plugin.

    - I get a warning about the async auto save and interval. Wat do?
    Change the autoSaveInterval value in the configuration to a value higher than 400, like 600. The warning is to prevent endless autosaves to occur, clogging up CPU.

    - I have experienced CPU usage
    CPU usage is not the same as lag. NoLagg uses multiple (2-3) extra threads to prevent tick and network lag. If a lot has to be done, it does this quicker, but this takes more CPU obviously.

    - I have lag when using NoLagg
    See also the FAQ above. Explain what type of lag you have: tick lag, client lag, network lag and/or 'block placement' lag. You can use /nolagg monitor to check the tick rate. If this is normal (>15), then you have network lag. Client lag is when the FPS drops. Block placement lag is lag when the tick rate is normal and other network messages, like chat, are instant.

    - WorldEdit causes lag...
    YES because it is unsafe to take over the main thread while another plugin is having hold over it. I can try fixing this, but it could ultimately lead to some serious concurrency exceptions. Don't expect this to be implemented very soon...

    - Do spawn limits interfere with mob-spawning plugins like MobArena?
    No, it does not. It only limits mobs spawned by 'nature': all custom creature spawns are ignored throughout the run of the plugin. Only after you reload will it lose track of these entities and will it remove custom-spawned mobs. If you use MobArena, be sure nothing is going on when you reload the server.

    - Does item stacking interfere with Showcase or BleedingMobs?
    It supports Showcase and ShowcaseStandalone entirely. (showcased items are completely ignored at all times) The same applies to the 'particles' created by the BleedingMobs plugin. Know of a plugin where it stacks items which should not be stacked? Post the plugin name so I can add support. You are an owner and want to add support? Only having a function in your plugin to check if an item is 'ignored' is enough.

    - Can this plugin be used with Chunk Manager
    If you want to use the Chunk Manager with Nolagg, disable the chunk sending of Nolagg first. If you don't do that, this plugin will do that by itself and send a warning in the log. Of course, compare the results first. :)

    - What are the best settings if I have a lot of RAM memory?
    This plugin does not deal with reduced RAM memory. If I could, I would, but you simply can't reduce the amount of memory Java uses. This data is locked and secured, so I can't simply throw away bits of data or write and read data from/to disk. Any plugin claiming to reduce RAM usage on a server, is probably 'garbage collecting'. This fakes having less RAM usage by removing unused data, but Java does this by itself as well once it hits a certain limit. All these plugins will do is make the Garbage Collector run in overdrive, which will only kill your tick rate and/or CPU speeds. A bad thing.

    - I get a lot of 'Synchronized code accessed from another thread' errors
    Find out what plugin is acting up by inspecting the stack trace. If the plugin that causes this is inactive, all you can do is wait for a refurnished version or someone to fix it for you, or use an alternative plugin. If it's still under development, notify the author of this, it IS an error caused by that plugin. If you can't find out the cause, PM me or post in this thread.

    Before you begin writing a lag issue

    This is very important, just posting a 'it causuz lagz und shitz' won't do, won't help and I won't be able to help you any further either. Question is if I even want to help you, if you post such a message without anything worth looking at. Things to include in your message:
    - Errors in the log if possible
    - What CB version you use and what NoLagg version you use
    - When this lag occurs. Tick rate drop in general?
    - The configuration you used when running this plugin
    - What type of lag if applicable. Options are: tick lag, client lag, network lag (see above)

    Important links

    NoLagg Download page and others at Dev Bukkit
    View the source code of NoLagg at GitHub

    Use an archive extracting program (WinRar, WinZip) to open the archive.

    - Add option to disable physics when the tick delay becomes too high


    Show your appreciation for my plugins by donating
  2. Offline


    For me it was Pre 1.0 CB if I used 1337 Versions it was not an issue. Something must have happened I will double check to see if issue does go away with out this.

    and yea if u want to I can set my live server to offline mode since I moved to that, I have not tested with your latest version tho they are installed.
  3. Offline


  4. Offline


    Stay online and I will do a quick test then come back on here to let u know the address actually it should be in my sig.

    While your on I will try replicate the cart stop issue.

    Got that error again!!!, the one I mentioned but had not got for a while.

    2011-12-04 01:56:16 [SEVEREjava.lang.NoSuchMethodErrornet.minecraft.server.NBTTagCompound.a(Ljava/lang/String;I)V
    -12-04 01:56:16 [SEVEREat
    2011-12-04 01:56:16 [SEVEREat net.minecraft.server.ChunkLoader.a(SourceFile:135)
    2011-12-04 01:56:16 [SEVEREat net.minecraft.server.ChunkRegionLoader.a(SourceFile:84)
    2011-12-04 01:56:16 [SEVEREat net.minecraft.server.ChunkProviderServer.saveChunk(
    2011-12-04 01:56:16 [SEVEREat net.minecraft.server.ChunkProviderServer.saveChunks(
    2011-12-04 01:56:16 [SEVEREat
    2011-12-04 01:56:16 [SEVEREat net.minecraft.server.MinecraftServer.saveChunks(
    2011-12-04 01:56:16 [SEVEREat net.minecraft.server.MinecraftServer.stop(
    2011-12-04 01:56:16 [SEVEREat
    2011-12-04 01:56:16 [SEVEREat
    This appears for me in 1550 and prev CB 15xx it clearly has your name in it and I think this is where your sign issue is, not in Nolagg nor Nolaggchunks as these two are not installed right now of me.

    I only have Traincarts 1.0/Myworlds/Signlink/Streamremover of yours installed and If I had to guess this is coming from Signlink or Myworld.

    I think this is where your sign wipe issue may be coming from.

    This error is actually crashing server to a halt for me as in it kicks player and everything.

    Full Server Console log for you.
    174 recipes
    27 achievements
    -12-04 01:58:48 [INFOStarting minecraft server version 1.0.1
    -12-04 01:58:48 [INFOLoading properties
    -12-04 01:58:48 [INFOStarting Minecraft server on *:7767
    2011-12-04 01:58:48 [WARNINGThe server will make no attempt to authenticate usernamesBeware.
    2011-12-04 01:58:48 [WARNING] While this makes the game possible to play without internet accessit also opens up the ability for hackers to connect with any username they choose.
    2011-12-04 01:58:48 [WARNINGTo change thisset "online-mode" to "true" in the file.
    2011-12-04 01:58:49 [INFOThis server is running Craftbukkit version git-Bukkit-1.8.1-R4-77-ge86a355-b1550jnks (MC1.0.1) (Implementing API version 1.0.0-R1-SNAPSHOT)
    2011-12-04 01:58:49 [INFOMCBansSet Core API Key and Language
    -12-04 01:58:49 [INFO] [PermissionsExsql backend registered!
    2011-12-04 01:58:49 [INFO] [PermissionsExfile backend registered!
    2011-12-04 01:58:49 [INFO] [PermissionsExPermissionEx plugin initialized.
    2011-12-04 01:58:49 [INFO] [PermissionsExp2compat backend registered!
    2011-12-04 01:58:49 [INFO] [PermissionsCompatCompatibility Layer Initalized!
    2011-12-04 01:58:49 [INFO] [PermissionsExInitializing file backend
    -12-04 01:58:50 [INFO] [RegisterPreferred method [nullnot foundusing first found.
    2011-12-04 01:58:50 [INFO] [RegisterPayment method found (iConomy version6)
    2011-12-04 01:58:50 [INFO] [Registerversion 1.5 is enabled.
    2011-12-04 01:58:50 [INFO] [SpoutSpout 579 has been initialized
    -12-04 01:58:50 [INFOPreparing level "Earth"
    2011-12-04 01:58:50 [INFO] Default game type0
    -12-04 01:58:50 [INFOPreparing start region for level 0 (Seed: -5774760318650830494)
    2011-12-04 01:58:51 [INFOPreparing start region for level 1 (Seed: -2413113458816892225)
    2011-12-04 01:58:51 [INFOAutoHelp version 0.2 is enabled!
    2011-12-04 01:58:51 [INFO] [boosCoolDownversion 1.5.0 by [Boosikis enabled!
    2011-12-04 01:58:51 [INFO] [boosCoolDownPermission system found
    -12-04 01:58:51 [INFOBorderGuard version 4.2 is enabled!
    2011-12-04 01:58:52 [INFO] ----------------------------------
    2011-12-04 01:58:52 [INFO] | Buycraft version 3.0 enabled! |
    2011-12-04 01:58:52 [INFO] ----------------------------------
    2011-12-04 01:58:52 [INFOCommandBook 1.6-customized enabled.
    2011-12-04 01:58:52 [WARNINGCommandBook0 Warps(sloaded
    -12-04 01:58:52 [WARNINGCommandBook0 Homes(sloaded
    -12-04 01:58:52 [INFOCommandBookMaximum wrapper compatibility is enabledSome features have been disabled to be compatible with poorly written server wrappers.
    2011-12-04 01:58:52 [INFOCommandBook0 banned name(sloaded.
    2011-12-04 01:58:52 [INFOCommandBook0 kit(sloaded.
    2011-12-04 01:58:52 [INFOCommandBookUsing the Bukkit Permissions API.
    2011-12-04 01:58:52 [INFO] [ FalseBook Block 3100 Books loaded!
    2011-12-04 01:58:52 [INFO] [ FalseBook Block 2 Cauldrons successfully loaded.
    2011-12-04 01:58:52 [INFO] [ FalseBook Block FalseBookBlock v0.90alpha by GeMo enabled
    -12-04 01:58:52 [INFO] [ FalseBook Core using PermissionsEx for Permissions!
    2011-12-04 01:58:52 [INFO] [ FalseBook Core FalseBookCore v0.90alpha by GeMo enabled!
    2011-12-04 01:58:52 [INFO] [ FalseBook Extra FalseBookExtra v0.90alpha by GeMo enabled
    -12-04 01:58:52 [INFO] [ FalseBook IC FalseBookIC v0.90alpha by GeMo enabled
    -12-04 01:58:52 [INFOFlamboyantFlock version 0.2 is enabled!
    2011-12-04 01:58:52 [INFO] [HELP0 extra help entries loaded
    -12-04 01:58:52 [INFO] [HELPPermissions enabled usingPermissions v2.7.7
    -12-04 01:58:52 [INFO] [HELP0.3.2 enabled
    -12-04 01:58:52 [INFO] [iConomy CeltyEnabled (188 ms)
    2011-12-04 01:58:52 [INFO] [LazyRoad] : Version 0.6 is enabled!
    2011-12-04 01:58:52 [INFO] [LocketteVersion 1.4.8 beta is being enabledYay! (Core version 1.3)
    2011-12-04 01:58:52 [INFO] [LocketteDetected craftbukkit build [1550ok.
    2011-12-04 01:58:52 [INFO] [LocketteUsing ops file for admin permissions.
    2011-12-04 01:58:52 [INFO] [LocketteReady to protect your containers.
    2011-12-04 01:58:52 [INFO] [Lumberjackversion 1.8.1v6 enabled!
    2011-12-04 01:58:52 [INFOMCBansCan only run in online mode!
    2011-12-04 01:58:52 [INFOMCBansDisabled
    -12-04 01:58:53 [INFO] [MinecraftViewerv1.0d Plugin Enabled.
    2011-12-04 01:58:53 [INFO] [MyWorldsUsing build-in 'Bukkit SuperPerms' as permissions plugin!
    2011-12-04 01:58:53 [INFO] [MyWorldsLoading or creating world'space' using seed 0 and chunk generator'BananaSpace:planets'
    2011-12-04 01:58:53 [INFOPreparing start region for level 2 (Seed3248337431591517621)
    2011-12-04 01:58:53 [INFO] [MinecraftViewerQuery running on
    -12-04 01:58:53 [INFO] [MyWorldsSuccessfully bound variable to region file cache.
    2011-12-04 01:58:53 [INFO] [MyWorldsFile references to unloaded worlds will be cleared!
    2011-12-04 01:58:53 [INFO] [MyWorldsversion 1.3 is enabled!
    2011-12-04 01:58:53 [INFO] [NoCheatYou run an unsupported version of MinecraftSome parts of NoCheat get disabled for your safety.
    2011-12-04 01:58:53 [INFO] [NoCheatversion [2.19is enabled.
    2011-12-04 01:58:53 [INFO] [Orebfuscatorversion 1.1.2 initialization complete!
    2011-12-04 01:58:53 [INFO] [PermissionsExSuperperms support enabled.
    2011-12-04 01:58:53 [INFO] [PermissionsExv1.16 enabled
    -12-04 01:58:53 [INFOCommandBookPermissionsEx detectedUsing PermissionsEx for permissions.
    2011-12-04 01:58:53 [INFO] [LocketteEnabled link to plugin PermissionsEx for Groups/Permissionsversion 1.16
    -12-04 01:58:53 [INFO] [LocketteOps file overriddenusing linked plugin for admin permissions.
    2011-12-04 01:58:53 [INFO] [ProtectingWolfPlugin v0.6.0 has been enabled!
    2011-12-04 01:58:53 [INFOSafeFire 1.3 Enabled.
    2011-12-04 01:58:53 [INFO] [SafeFirePermission system detected.
    2011-12-04 01:58:53 [INFOScheduledAnnouncer v1.7.0 is enabled!
    2011-12-04 01:58:53 [INFO] [MyWorldsUsing build-in 'Bukkit SuperPerms' as permissions plugin!
    2011-12-04 01:58:53 [INFO] [SignLinkversion 1.12 is enabled!
    2011-12-04 01:58:53 [INFO] [SpawnMobPermission system foundplugin enabled
    -12-04 01:58:53 [INFO] [SpawnMobVersion 1.9.9 enabled.
    2011-12-04 01:58:53 [INFOStream Remover version 1.02 is enabled!
    2011-12-04 01:58:53 [INFOWeatherReducer v210 is now enabled!
    2011-12-04 01:58:53 [INFO] [WebAuctionWebAuction is initializing
    -12-04 01:58:53 [INFO] [WebAuctionMySQL Initializing
    -12-04 01:58:53 [INFO] [WebAuctionMySQL connection successful
    -12-04 01:58:53 [INFO] [WebAuctionCurrent Auction id 79
    -12-04 01:58:53 [INFO] [WebAuctionPayment method found (iConomy version6)
    2011-12-04 01:58:53 [INFOWorldEdit 4.7 enabled.
    2011-12-04 01:58:53 [INFOWorldEditPermissionsEx detectedUsing PermissionsEx for permissions.
    2011-12-04 01:58:54 [INFO] [ChatManagerChatManager enabled!
    2011-12-04 01:58:54 [INFO] [PermissionsCompatCompatibility layer enabled.
    2011-12-04 01:58:54 [INFOCommandBookPermissionsEx detectedUsing PermissionsEx for permissions.
    2011-12-04 01:58:54 [INFO] [LocketteIgnoring fake Permissions plugin version 2.7.7
    -12-04 01:58:54 [INFOWorldEditPermissionsEx detectedUsing PermissionsEx for permissions.
    2011-12-04 01:58:54 [INFO] [BananaSpaceThe plugin will now start sending usage statsYou can disable this in plugins/stats!
    2011-12-04 01:58:54 [INFOBananaSpace is keeping usage statsTo opt-out for whatever bizarre reasoncheck plugins/stats.
    2011-12-04 01:58:54 [INFO] [BananaSpaceEnabled version 1.4_2
    -12-04 01:58:54 [INFO] [Factions v1.6.1] === ENABLE START ===
    2011-12-04 01:58:54 [INFO] [Factions v1.6.1Will use this plugin for permissionsPermissionsEx v1.16
    -12-04 01:58:54 [INFO] [Factions v1.6.1Loading board from disk
    -12-04 01:58:54 [INFO] [Factions v1.6.1Found and will use features of Spout v579
    -12-04 01:58:54 [INFO] [Factions v1.6.1Economy integration through Register plugin successful.
    2011-12-04 01:58:54 [INFO] [Factions v1.6.1] === ENABLE DONE (Took 196ms) ===
    2011-12-04 01:58:54 [INFO] [LocketteEnabled link to plugin Register for Economyversion 1.5
    -12-04 01:58:54 [INFO] [TrainCartsSignLink detectedsupport for arrival signs added!
    2011-12-04 01:58:54 [INFO] [TrainCartsMyWorlds detectedsupport for portal sign train teleportation added!
    2011-12-04 01:58:54 [INFO] [TrainCarts0 Trains have been loaded in 0 worlds. (0 Minecarts)
    2011-12-04 01:58:54 [INFO] [TrainCartsversion 1.49.4 is enabled!
    2011-12-04 01:58:54 [INFOServer permissions file permissions.yml is empty, ignoring it
    -12-04 01:58:54 [INFODone (0.363s)! For helptype "help" or "?"
    2011-12-04 01:58:54 [INFOStarting GS4 status listener
    -12-04 01:58:54 [WARNINGUnable to initialise query system on (Socket): Address already in use: Cannot bind
    -12-04 01:58:54 [INFO] [ FalseBook Block 0 Areas loaded.
    2011-12-04 01:58:54 [INFO] [ FalseBook Block 0 Bridges successfully loaded.
    2011-12-04 01:58:54 [INFO] [ FalseBook Block 4 Doors successfully loaded.
    2011-12-04 01:58:54 [INFO] [ FalseBook Block protected gateblocks successfully loaded.
    2011-12-04 01:58:57 [INFO] [ FalseBook IC Loaded selftriggered ICs9 done
    -12-04 01:58:57 [INFO] [ FalseBook IC Failed selftriggered ICs26 failed
    -12-04 01:58:57 [INFO] [ FalseBook IC ] List of failed ICs:
    2011-12-04 01:58:57 [INFO] [ FalseBook IC ID3UNKNOWN Location Worldspace X276 Y58 Z249
    -12-04 01:58:57 [INFO] [ FalseBook IC ID6UNKNOWN Location Worldspace X276 Y59 Z249
    -12-04 01:58:57 [INFO] [ FalseBook IC ID8UNKNOWN Location Worldspace X141 Y25 Z199
    -12-04 01:58:57 [INFO] [ FalseBook IC ID9UNKNOWN Location Worldspace X141 Y24 Z199
    -12-04 01:58:57 [INFO] [ FalseBook IC ID10UNKNOWN Location Worldspace X157 Y21 Z211
    -12-04 01:58:57 [INFO] [ FalseBook IC ID11UNKNOWN Location Worldspace X157 Y21 Z209
    -12-04 01:58:57 [INFO] [ FalseBook IC ID14UNKNOWN Location Worldspace X247 Y63 Z319
    -12-04 01:58:57 [INFO] [ FalseBook IC ID15UNKNOWN Location Worldspace X243 Y65 Z315
    -12-04 01:58:57 [INFO] [ FalseBook IC ID16UNKNOWN Location Worldspace X242 Y67 Z315
    -12-04 01:58:57 [INFO] [ FalseBook IC ID17UNKNOWN Location Worldspace X252 Y67 Z317
    -12-04 01:58:57 [INFO] [ FalseBook IC ID18UNKNOWN Location Worldspace X242 Y61 Z319
    -12-04 01:58:57 [INFO] [ FalseBook IC ID19UNKNOWN Location Worldspace X: -436 Y92 Z97
    -12-04 01:58:57 [INFO] [ FalseBook IC ID22UNKNOWN Location Worldspace X: -436 Y92 Z91
    -12-04 01:58:57 [INFO] [ FalseBook IC ID23UNKNOWN Location Worldspace X: -436 Y92 Z85
    -12-04 01:58:57 [INFO] [ FalseBook IC ID24UNKNOWN Location Worldspace X: -436 Y92 Z79
    -12-04 01:58:57 [INFO] [ FalseBook IC ID25UNKNOWN Location Worldspace X258 Y54 Z255
    -12-04 01:58:57 [INFO] [ FalseBook IC ID26UNKNOWN Location Worldspace X294 Y54 Z256
    -12-04 01:58:57 [INFO] [ FalseBook IC ID27UNKNOWN Location Worldspace X: -441 Y73 Z9
    -12-04 01:58:57 [INFO] [ FalseBook IC ID28UNKNOWN Location Worldspace X: -450 Y76 Z16
    -12-04 01:58:57 [INFO] [ FalseBook IC ID29UNKNOWN Location Worldspace X: -441 Y73 Z17
    -12-04 01:58:57 [INFO] [ FalseBook IC ID30UNKNOWN Location Worldspace X: -442 Y76 Z2
    -12-04 01:58:57 [INFO] [ FalseBook IC ID32UNKNOWN Location Worldspace X: -452 Y70 Z14
    -12-04 01:58:57 [INFO] [ FalseBook IC ID33UNKNOWN Location Worldspace X: -441 Y69 Z15
    -12-04 01:58:57 [INFO] [ FalseBook IC ID34UNKNOWN Location Worldspace X: -437 Y69 Z10
    -12-04 01:58:57 [INFO] [ FalseBook IC ID35UNKNOWN Location Worldspace X281 Y41 Z266
    -12-04 01:58:57 [INFO] [ FalseBook IC ID36UNKNOWN Location Worldspace X281 Y41 Z250
    -12-04 01:58:59 [INFOledhead900 [/ in with entity id 49 at ([Earth133.3959840906772764.0180.13106395615898)
    2011-12-04 01:59:00 [INFO] [WebAuctionPlayer foundcanBuy1 canSell1 isAdmin1
    -12-04 01:59:01 [SEVEREjava.lang.NoSuchMethodErrornet.minecraft.server.NBTTagCompound.a(Ljava/lang/String;I)V
    -12-04 01:59:01 [SEVEREat
    2011-12-04 01:59:01 [SEVEREat net.minecraft.server.ChunkLoader.a(SourceFile:135)
    2011-12-04 01:59:01 [SEVEREat net.minecraft.server.ChunkRegionLoader.a(SourceFile:84)
    2011-12-04 01:59:01 [SEVEREat net.minecraft.server.ChunkProviderServer.saveChunk(
    2011-12-04 01:59:01 [SEVEREat net.minecraft.server.ChunkProviderServer.saveChunks(
    2011-12-04 01:59:01 [SEVEREat
    2011-12-04 01:59:01 [SEVEREat net.minecraft.server.World.doTick(
    2011-12-04 01:59:01 [SEVEREat net.minecraft.server.MinecraftServer.w(
    2011-12-04 01:59:01 [SEVEREat
    2011-12-04 01:59:01 [SEVEREat
    2011-12-04 01:59:01 [SEVEREUnexpected exception
    at com
    at net.minecraft.server.ChunkLoader.a(SourceFile:135)
    at net.minecraft.server.ChunkRegionLoader.a(SourceFile:84)
    at net.minecraft.server.ChunkProviderServer.saveChunk(
    at net.minecraft.server.ChunkProviderServer.saveChunks(
    at net.minecraft.server.World.doTick(
    at net.minecraft.server.MinecraftServer.w(
    2011-12-04 01:59:11 [INFO] [AutoHelpSearching active plugins' plugin.yml files for command help
    2011-12-04 01:59:11 [INFO] [AutoHelp] Skipping command '
    help', already has a help entry
    2011-12-04 01:59:11 [INFO] [AutoHelp] '
    Help' support enabled.
    2011-12-04 01:59:47 [INFO] CONSOLE: Stopping the server..
    2011-12-04 01:59:47 [INFO] Stopping server
    2011-12-04 01:59:47 [INFO] [AutoHelp] '
    Help' support disabled.
    2011-12-04 01:59:47 [INFO] [boosCoolDown] version 1.5.0 disabled!
    2011-12-04 01:59:47 [INFO] ----------------------------------
    2011-12-04 01:59:47 [INFO] | Buycraft version 3.0 disabled! |
    2011-12-04 01:59:47 [INFO] ----------------------------------
    2011-12-04 01:59:48 [INFO] FalseBookBlock v0.90alpha by GeMo disabled
    2011-12-04 01:59:48 [INFO] [ FalseBook Core ] FalseBookCore v0.90alpha by GeMo disabled!
    2011-12-04 01:59:48 [INFO] FalseBookExtra v0.90alpha by GeMo disabled
    2011-12-04 01:59:48 [INFO] FalseBookIC v0.90alpha by GeMo disabled
    2011-12-04 01:59:48 [INFO] [HELP] disabled
    2011-12-04 01:59:48 [INFO] [iConomy] Closing general data...
    2011-12-04 01:59:48 [INFO] [iConomy] Disabled. (0 ms)
    2011-12-04 01:59:48 [INFO] [Register] Payment method was disabled. No longer accepting payments.
    2011-12-04 01:59:48 [INFO] [WebAuction] Payment method was disabled. No longer accepting payments.
    2011-12-04 01:59:48 [INFO] [LazyRoad] : Plugin disabled
    2011-12-04 01:59:48 [INFO] Lockette is being disabled... ;.;
    2011-12-04 01:59:48 [INFO] [Lockette] Closing all automatic doors.
    2011-12-04 01:59:48 [INFO] [Lumberjack] disabled
    2011-12-04 01:59:48 [INFO] [MinecraftViewer] v1.0d Plugin Disabled.
    2011-12-04 01:59:48 [INFO] My Worlds disabled!
    2011-12-04 01:59:48 [INFO] [NoCheat] version [2.19] is disabled.
    2011-12-04 01:59:48 [INFO] [Orebfuscator] version 1.1.2 disabled!
    2011-12-04 01:59:48 [INFO] [PermissionsEx] v1.16 disabled successfully.
    2011-12-04 01:59:48 [INFO] CommandBook: Using the Bukkit Permissions API.
    2011-12-04 01:59:48 [INFO] [Lockette] Disabled link to plugin PermissionsEx, version 1.16
    2011-12-04 01:59:48 [INFO] WorldEdit: Using the Bukkit Permissions API.
    2011-12-04 01:59:48 [INFO] [ProtectingWolf] Plugin v0.6.0 has been disabled.
    2011-12-04 01:59:48 [INFO] ReservedList v1.0 is now disabled!
    2011-12-04 01:59:48 [INFO] SafeFire 1.3 Disabled.
    2011-12-04 01:59:48 [INFO] ScheduledAnnouncer v1.7.0 is disabled!
    2011-12-04 01:59:48 [INFO] [SignLink] is disabled!
    2011-12-04 01:59:48 [INFO] [SpawnMob] Version 1.9.9 disabled.
    2011-12-04 01:59:48 [INFO] Spout 579 has been disabled
    2011-12-04 01:59:48 [INFO] Stream Remover disabled!
    2011-12-04 01:59:48 [INFO] WeatherReducer v210 is now disabled!
    2011-12-04 01:59:48 [SEVERE] Error occurred while disabling WorldEdit v4.7 (Is it up to date?): loader constraint violation: loader (instance of org/bukkit/plugin/java/PluginClassLoader) previously initiated loading for a different type with name "com/sk89q/worldedit/LocalConfiguration"
    java.lang.LinkageError: loader constraint violation: loader (instance of org/bukkit/plugin/java/PluginClassLoader) previously initiated loading for a different type with name "com/sk89q/worldedit/LocalConfiguration"
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at Source)
    at Source)
    at$100(Unknown Source)
    at$ Source)
    at$ Source)
    at Method)
    at Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at com.sk89q.worldedit.WorldEdit.getSession(
    at com.sk89q.worldedit.bukkit.WorldEditPlugin.onDisable(
    at org.bukkit.plugin.SimplePluginManager.disablePlugin(
    at org.bukkit.plugin.SimplePluginManager.disablePlugins(
    at org.bukkit.craftbukkit.CraftServer.disablePlugins(
    at net.minecraft.server.MinecraftServer.stop(
    2011-12-04 01:59:48 [INFO] [ChatManager] ChatManager disabled!
    2011-12-04 01:59:48 [INFO] CommandBook: Using the Bukkit Permissions API.
    2011-12-04 01:59:48 [INFO] WorldEdit: Using the Bukkit Permissions API.
    2011-12-04 01:59:48 [INFO] [BananaSpace] Disabled version 1.4_2
    2011-12-04 01:59:48 [INFO] [Factions v1.6.1] Disabled
    2011-12-04 01:59:48 [INFO] [Lockette] Disabled link to plugin Register, version 1.5
    2011-12-04 01:59:48 [INFO] TrainCarts disabled!
    2011-12-04 01:59:48 [INFO] Saving chunks
    2011-12-04 01:59:48 [SEVERE] java.lang.NoSuchMethodError: net.minecraft.server.NBTTagCompound.a(Ljava/lang/String;I)V
    2011-12-04 01:59:48 [SEVERE] at
    2011-12-04 01:59:48 [SEVERE] at net.minecraft.server.ChunkLoader.a(SourceFile:135)
    2011-12-04 01:59:48 [SEVERE] at net.minecraft.server.ChunkRegionLoader.a(SourceFile:84)
    2011-12-04 01:59:48 [SEVERE] at net.minecraft.server.ChunkProviderServer.saveChunk(
    2011-12-04 01:59:48 [SEVERE] at net.minecraft.server.ChunkProviderServer.saveChunks(
    2011-12-04 01:59:48 [SEVERE] at
    2011-12-04 01:59:48 [SEVERE] at net.minecraft.server.MinecraftServer.saveChunks(
    2011-12-04 01:59:48 [SEVERE] at net.minecraft.server.MinecraftServer.stop(
    2011-12-04 01:59:48 [SEVERE] at
    2011-12-04 01:59:48 [SEVERE] at
    2011-12-04 01:59:48 [INFO] Stopping server
    2011-12-04 01:59:48 [INFO] Saving chunks
    2011-12-04 01:59:48 [SEVERE] Exception in thread "Thread-2"
    2011-12-04 01:59:48 [SEVERE] java.lang.NoSuchMethodError: net.minecraft.server.NBTTagCompound.a(Ljava/lang/String;I)V
    2011-12-04 01:59:48 [SEVERE] at
    2011-12-04 01:59:48 [SEVERE] at net.minecraft.server.ChunkLoader.a(SourceFile:135)
    2011-12-04 01:59:48 [SEVERE] at net.minecraft.server.ChunkRegionLoader.a(SourceFile:84)
    2011-12-04 01:59:48 [SEVERE] at net.minecraft.server.ChunkProviderServer.saveChunk(
    2011-12-04 01:59:48 [SEVERE] at net.minecraft.server.ChunkProviderServer.saveChunks(
    2011-12-04 01:59:48 [SEVERE] at
    2011-12-04 01:59:48 [SEVERE] at net.minecraft.server.MinecraftServer.saveChunks(
    2011-12-04 01:59:48 [SEVERE] at net.minecraft.server.MinecraftServer.stop(
    2011-12-04 01:59:48 [SEVERE] at
    2011-12-04 02:00:00 [WARNING] MC Server GUI: Error sending server input. Server is likely not running!
  5. Offline


    @ledhead900 Well if it's signlink, then this is pretty obvious that it casues issues. SignLink isn't even recommended for MC 1.00 yet, and I am pretty sure it will fail on 1.00...


    Although I am using it on 1.00 right now...odd
  6. Offline


    Well that is pretty dang dumb considering that myworld and Traincarts both rely on it to put to use most of their main functions for portals and train control.

    Still I am willing to bet that everyone with sign issues is using signlink as it goes hand in hand with myworld and traincarts :).

    Let me run another test with out signlink then ;) but with Nolagg and Nolaggchunks
  7. Offline


    Hey Guy,
    your plugin "NoLaggChunks" kicks everyone with the Message "xxxx compress data" ... if i delete this "addon" its work fine ... i already tryed with clearRawData: true / false but not worked....

  8. Offline


    @SilencShadoW no errors in the log? (and what is displayed at the spot of xxxx, the player name?)

    @ledhead900 SignLink updated for cb 1550, should fix that error
  9. Offline


    Confirmed for ME wiped signs are working with nolagg and nolaggchunk once u remove signlink.

    Short Details about testing
    An area of the world I know had wiped signs when testing before were wiped all the time and you had no idea why, well u do now, as recent discovery by me *cough*, leads to signlink causing an error thus not completely sending sign data with the chunks and sometimes crashing server.

    I tested this by
    1.removing nolaggchunk and nolagg
    2 start server and join
    3. ERROR


    1.Remove nolaggchunks and nolagg
    2. start server and join
    3. Error


    1.Remove signlink
    2.install nolagg and nolaggchunks
    3.start and join
    4. check troubled area with wipes
    5. found to be not wiped
    6. cheered!

    Once I removed signlink the signs were back to normal and no more error.

    Testing Signlink Update
  10. Offline


    The log just show something like "silencshadow. endofstream:disconnect
    no. something like "java.ioExeption: Bad compressed data format"
  11. Offline


    @ledhead900 There is now a 1550 build available which is compatible though. And yeah, with the issues occuring there, it would fail to obtain the packet (thus no text is displayed) AND it was unable to save the sign data to file, which leads to wiped signs in general.

    @SilencShadoW Could you post the entire error, with stacktrace etc? I got a feeling that it is a compression (deflater) issue, being incompatible somehow. What Java version do you have on your server?
  12. Offline


    @SilencShadoW Could you post the entire error, with stacktrace etc? I got a feeling that it is a compression (deflater) issue, being incompatible somehow. What Java version do you have on your server?[/quote]

    java 6 jdk, stacktrace? Where i get this ... the user just get KICKED in the log with: "
    [INFO] lost connection: disconnect.endOfStream"

    and the CLIENT kick msg is: "java.ioExeption: Bad compressed data format"
    No other messages logs or something else
  13. Offline


    And the update has indeed fixed the signlink error and the signs are staying not wiped and working normally.
    Get others to test this out and you should have with my help solved it, I know you tried hard to fix it but it appears I stumbled onto the real cause, I ment to give you that error before but It went away during a test and I dismissed it at the time due to fact I had traincart installed twice.

    I do have an issue you will want to see that is the trains still stop on chunk unload when player is not on server map.
    I have it enabled to keep the chunks loaded but I really REALLY don't want trains keeping chunks loaded around them as this is a ram waster.

    Scratch chunkloaded - seems the 1.0 version of traincarts had no chunkload feature in options :|
    a fresh generated options looks like

      cartDistance: 1.5
      cartDistanceForcer: 0.1
      cartDistance: 1.6
      cartDistanceForcer: 0.2
    nearCartDistanceFactor: 1.2
    removeDerailedCarts: false
    maxCartDistance: 4.0
    breakCombinedCarts: true
    spawnItemDrops: true
    poweredCartBoost: 0.1
      x: 0.0
      y: 0.0
      z: 0.0
    pushAwayForce: 0.2
    pushAwayIgnoreGlobalOwners: false
    pushAwayIgnoreOwners: true
    useCoalFromStorageCart: false
    setOwnerOnPlacement: true
    use: true
    Excuse the wrong thread about issue but if your online my server is offline mode and ready for you to come look at this,
  14. Offline


    I'm getting the blank sign issue reported by my users. They tell me there signs have been wiped in there houses.
    I'm like "wut"... Then read through this forum and see it's a bug with nolaggchunks and , I tested and yes it is.
    Seems like I would be far better off not using nolaggchunks.
  15. Offline


    Get it from your server console it will have "Severe" just before the error occurs.

    U obviously did not read the last 5 or so posts, Its been fixed from what I can tell , try it, it was not even nolagg or nolaggchunks, your a developer you should be reading up before posting.

    Start here

    Then test it and come back if you have more issues with sign wipes.
  16. Offline


    @ledhead900 Keep chunks loaded is moved to train properties so you can set this for individual trains (so the random minecart won't keep chunks loaded, was requested)
    Set it in default flags or do it for an individual train.

    @SilencShadoW I can only think of a possible packet compression change (weird?), I'll take a look at the native coding. Just to be sure, what CB build do you use?

    @Jadedwolf did you use SignLink or not?
  17. Offline


    16:54:51 [INFO] This server is running Craftbukkit version git-Bukkit-1.8.1-R4-62-gdc48657-b1538jnks (MC: 1.0.0) (Implementing API version 1.0.0-R1-SNAPSHOT)

    Sorry guy, but if i not get any error right before ... ^^ ... btw a tip, its not just 1 user ... its kick up to all users ... but most 2-3 users at the same time ... same error and just a "endofstream" in the console ... :(
  18. Offline


    zzzz these tiny updated never get to my eyes :rolleyes: I will try that on the cart with issues then come back see if are able to come on server see what is going on.

    FYI, the issue that @SilencShadoW was the same kind of thing signlink was doing to me kicking anyone online ;) with that error.

    Might need to ask him if he has that and to update it.
  19. Offline


    I do not
    I do not use any other plugins of yours.
  20. Offline


    Ok decided to add @Thulinma his method of chunk send changing, slightly adapted to improve it and/or allow it to be disabled and configured. This means there is now a 'chunkSendInterval' and 'chunkSendRate' in NoLaggs config as well, which can be enabled/disabled by setting 'useChunkManager'.

    This in an effort to at lest have that feature without the need of Spout and/or NoLaggChunks, as the chunks add-on appears to dislike signs for some reason. You can still use NoLaggChunks with this new NoLagg feature, which will be better if possible. (it can then filter out smaller block changes as well)

    So, in 1.50.5, NoLagg has somewhat the same features as NoLaggChunks inside, but not as advanced.
  21. Offline


    Going to give this new version a try now. I'm interested to see if having both nolaggchunks and the new built in chunk sending enabled at the same time adds much to the server load.
  22. Offline


    Forget this. My mistake, not a NoLagg BUG.

  23. Offline


    @Flatliner Same, and I decided to get rid of the spout addon and just use Thulinma's method in general. I'm tired of all the sensitive coding in NoLaggChunks causing me a headache, plus, it is better to deal with it at the source than at the very last moment.

    In short: NoLaggChunks will be included in NoLagg eventually, removing the Spout dependency and improving it in general. This way I both deal with packet generation AND sending, and it improves compatibility with other packet-changing plugins.
  24. Offline

    The Wizard

    Can you give me more details about "worldedit lag"?
    I use worldedit with worldguard and command book. I don't edit the world often.
    The server works fine without lag, but I want to know how/when worldedit cause lag.
  25. Offline


    @The Wizard it causes tick lag when a player decided to change a huge block region into a certain type, or do some sort of heavy-duty calculation like a sphere edit.


    GREAT progress on the new NoLaggChunks. I got to admit, it's 200% as good and 1000% as simple. It will definitely replace NoLaggChunks and get rid of all sign issues with it. It can already:
    - Send chunks based on an interval, can be set player-specific
    - Set the max amount of chunks sent per tick (rate)
    - Set sending interval for a player
    - Multi-world working correctly
    - Send a trigger packet to get rid of any transparent chunks
  26. Offline


    awesome, cant wait to try it out. I dont use Spout for anything else so if i can remove a plugin, thats always a plus.
  27. Offline


    @fffizzz Only have to transfer the Sending Alghorithm of NoLaggChunks over, since the current is still a bit 'useless', it simply sorts it on distance. But even then, it really works great :)
  28. Offline


    im getting spammed to hell with this right now..
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'WolfyWillis': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'WolfyWillis': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'martisboys': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'martisboys': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'martisboys': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'leechhunter59': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'leechhunter59': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'leechhunter59': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of '1008Samuel': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of '1008Samuel': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of '1008Samuel': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'martis973': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'martis973': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'martis973': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'gamblerguy1996': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'gamblerguy1996': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'gamblerguy1996': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'mrsuperpiggy': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'mrsuperpiggy': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'mrsuperpiggy': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'mega_Wolf': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'mega_Wolf': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'mega_Wolf': [Packet24MobSpawn]
    17:24:00 [WARNING] [NoLagg] [Chunks] Packet out of reach of 'remington57': [Packet24MobSpawn]
  29. Offline


    @fffizzz Ok just disable NoLaggChunks for now, all of the features (except the 'download size') will be added in NoLagg eventually. With the current set-up I could even use custom view distances :)


    All working now. Final thing I am doing now: getting rid of NoLaggCHunks in my NoLagg coding.
  30. Offline


    Thanks for the Exp bug fix.

    Another thing, I do not know if it is intentional, desired, or unintentional benefit, but with NoLagg, we can now make stacks of potion. Its simple: make potions, drop said potions on the ground, watch them clump together, and tada.

    I personally really like this, as we can now carry much more potions with us. But some PvP servers may dislike this. Perhaps potion stacking should be made into an option?
  31. Offline


    You're a coding machine berger :) Seems like every time I check in on this thread your last post is updated saying what seems like some ridiculous amount of work has been completed!

Share This Page