First Minecraft 1.0.0 Bukkit Build Released----Keep Discussion Here

Discussion in 'Bukkit Discussion' started by Teh Kitteh, Nov 20, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    @panborsuk You say LogBlock doesn't work? Are you sure you're not logging chests? (Which requires Spout)

    I've heard some people say it does work is all...
  2. Offline


    logblock doesnt error like it should for a non working plugin,

    but its mentioned on the main post of logblock
  3. Offline


    What version off essentials are u using for me they dont work. My server just keeps restarting..
  4. Offline


    @discoverdan List updated. Older LogBlock - #43 works fine but latest 1.41 not. Check my post and thread about LogBlock :)
  5. Offline


    @panborsuk Ah I see, does #43 work perfectly? No bugs at all? Thanks for the list too.
  6. Offline


  7. Offline


    Anyone getting a long delay with this dev build?
  8. When ?
  9. Offline


  10. Offline

    Nathan C

    Well, it doesn't nerf creepers, enderman and the region protection system doesn't work for me.

    BTW, for anyone getting "Read timed out" errors, remove PermissionSEX.
  11. Offline


    PEX erroring aswell? :O
    I'm using that too!
  12. Spout makes a lot of changes to the Notch part of the Minecraft server and also has a client mod which obviously needs to be updated to match the client changes. But the Spout dev team waits for a recommended Craftbukkit build as well as some coding tools before releasing anything. They may have a development version already, I haven't checked.
  13. Offline


    I tried using
     @echo off
    "%ProgramFiles%\Java\jre7\bin\java.exe" -Xmx1536M -Xms1536M -jar craftbukkit-1.0.0-SNAPSHOT.jar
    and it worked fine for me.
    elias79 likes this.
  14. Offline


    Tested the latest build with no plugins and for some reason the Ghast projectiles aren't doing any damage and neither are the Blazes. Also tried it with the very few plugins we currently are using (LWC, WorldGuard/WorldEdit, BorderGuard and Hawkeye). I've tried changing the difficulty and everything seems to work fine on vanilla.

    Think I'm going to try to turn off spawn-monsters and then turn it on again to see what that does.

    Didn't see this in the thread so figured I'd post it.


    Also, there is no error message, just no damage. Turning off mobs and turning them back on didn't do anything.
  15. Offline

    Josh McCleerey

    Hi, my server was working fine for the previous build, I do have some programming expirance and went ahead and dled this new dev version. Modified the batchfile, however now I get this:
    174 recipes
    27 achievements
    23:39:50 [INFO] Starting minecraft server version 1.0.0
    23:39:50 [INFO] Loading properties
    23:39:50 [INFO] Starting Minecraft server on
    23:39:50 [WARNING] **** FAILED TO BIND TO PORT!
    23:39:50 [WARNING] The exception was: Cannot assign requ
    ested address: JVM_Bind
    23:39:50 [WARNING] Perhaps a server is already running on that port?

    I restarted my computer to make sure I had nothing else running. This problem did not exist before this development version. As I just recently got into running a minecraft server (I have ran servers for other games in the past however) I figured I'd go ahead and ask if this is more the problem with this build binding to the port or not, and see if I just missed something stupid.

    Plugin list
    spout (taken out of the folder as I know it doesnt work)

    double checked all plugins are up to date, all are up to date.

    Any help would be welcome. and just tips in general about running minecraft servers :p
  16. Offline


    To those who are getting (seemingly) random NPE's when running the latest developer build, keep in mind that even the base Minecraft server code is buggy. Give this a try: Download the "minecraft_server.jar" file straight from Mojang and then use it to generate a brand new world, then delete the world and generate another brand new world. Repeat until you've generated ten or more worlds.

    I can almost guarantee you that you will see at least one NPE crash and probably several, within just this small sample. And this is with the basic, unmodified Minecraft SMP server code.

    This is what the Bukkit team has to work with. :) Give them a break and wait awhile so that they can get some work done.
  17. Offline


    Thanks @stellarfirefly.

    And a huge thanks to the bukkit dev team!

    I've been running latest stable builds in a scratch environment that's a partial clone of our prod server... Mostly in hopes that I can find reproducible issues to report. I've mostly been beaten to the punch tho :)

    I have noticed that the current Multiverse build in our config is tending to corrupt worlds at startup on occasion (observed on builds 1469 and 1487). This mostly seems to happen at startup after upgrading Bukkit. No NPEs, it just hangs silently at the offending world. Kill CB, delete the world folder and try again and it works fine.

    I can continue investigating this if it might prove of use to anyone. Otherwise I'll ignore it and plow on testing what I can, in hopes I can find something of use to the bukkitdevs.
  18. Offline


    yup noticed this too, fireball spells on my server have become useless! lol
  19. Offline


    When i run the server with this 1.0.0 build and i joined the game the server says ''socket timed out"or something like that.
    Is there any way of fixing this?
    If not im probably just gonna wait for the actual 1.0.0 build[creeper]
    Aqawtic likes this.
  20. Offline


    PermissionsBukkit + mChat = Fail.

    I dont know if this is just me, but my ranks were messed up upon joining the server, I set my self as Admin, it should have [Admin] tag but lol its [Member]. When [Member]s joins, it said [Admin]. So confused.
  21. Offline


    Wait 4 the actual 1.0.0!
    Wait 4 the actual 1.0.0 build
    My brother own 2 bukkit servers on his mac and windows and he cant get v1.0.0 on them (hes an expert of hostin games)
    Pinchi likes this.
  22. Offline


    I'll probably do that.
    The proper build will probably be out tommorow or something anyway![grass][grass][creeper][grass][grass]
  23. Offline


    the show is already on my friend, no need to pay. just pull up a seat, grab a beverage and enjoy :p (just be careful, it can be dangerous drinking and laughing at the same time)
  24. Offline


    Hey guys, can someone assist please?
    when trying the latest dev build of bukkit, i get the following error;
    any ideas why im getting that?
    java -Xms512M -Xmx1024M -jar bukkit-1.0.0-R1-SNAPSHOT.jar 
    my run.bat
  25. Offline


    Download craftbukkit, not bukkit
  26. Offline


    Am I the only one experiencing a bug where WorldGuard regions don't protect Enchantment tables ?
  27. Offline


    I have had my main server running 1.0.0 with the first bukkit dev build available with no issues, other than a lack of spout. And I also get the occasional corrupted world at startup with Multiverse, but nothing a 10 minute rollback can't fix. Can't be that expert if hosting on a mac :)
    Vhab likes this.
  28. Offline


    The Only Solution is to wait untill the PluginsDev's update there plugins. Or Like me re compile them with the newest bukkit build.
  29. Offline


    Hi guys what would you type for the code for the Start batch file coz nothing happens to mine
    Any ideas?
  30. Offline


    Cheers mate

    java -Xms512M -Xmx1024M -jar craftbukkit-1.0.0-SNAPSHOT.jar 
    thats what i use :D
    if you wanna allocate more RAM, change the values.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 21, 2016
Thread Status:
Not open for further replies.

Share This Page