Solved Essentials help is not recognizing commands for certain ranks

Discussion in 'Plugin Development' started by bmckalip, Dec 16, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    I run essentials, and I just finished a plugin called staffbook which implements various commands. When I do ./help staffbook as an admin, all of the plugin help displays correctly. However, when I demote to a moderator, /help staffbook returns this: and is not followed by any commands. Both the admin and moderator ranks have the single required permission for all of the commands, and the commands work for both groups, just the help list isn't populating. What am i missing?
  2. Offline


    To start you might get more help in the Bukkit Help forum, as here is the forum about creating plugins.

    I would guess and say there is a permission you need from essentials to see the permissions from another plugin. There should also be a config options. See if there is a permission like "<plugin>" or something like that.

    P.S. Just guessing here, I am probably wrong! :p
  3. Offline


    Problem's solved.
  4. Offline


    @bmckalip Please mark thread as solved then.
Thread Status:
Not open for further replies.

Share This Page