Error: Unable to access jarfile craftbukkit.jar Press any key to continue . . .

Discussion in 'Bukkit Help' started by 420Smokes, Jul 14, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Error: Unable to access jarfile craftbukkit.jar
    Press any key to continue . . .

    always appears whenever i run my Run.BAT file.

    i have followed instructions on the wiki and they have not helped me at all i've downloaded the latest build and everything the wiki told me to do and it still won't work.

    I've watched several videos and downloaded several different programs and such claiming to set up a server and none of them has worked. i run windows 7 with java 7u5 it's a 64 bit. if anyone has a pre-made file they could share with me so me and my friends may start a server of our own. or any help would be appreciated. :)
  2. Offline


  3. Offline


    I have before and i have not found my problem in any of those.

    I have fixed this issue but now a bunch of other stuff pops up whenever i run it

    java.lang.NoClassDefFoundError: Could not initialize class org.fusesource.jansi.internal.kerne123
    at org.fusesource.jansi.internal.WindowsSupport.getConsoleMode<
    at jline.WindowsTerminal.getConsoleMode<>
    at jline.WindowsTerminal.init<"80>
    at jline.TerminalFactory.create<>
    at jline.TerminalFactory.get<>
    at jline.console.ConsoleReader.<init><>
    at jline.console.ConsoleReader.<init><
    at net .minecraft.server.MinecraftServer.<init><>
    at net.minecraft.server.MinecraftServer.main<>
    at org.bukkit.craftbukkit.Main.main<Main:136>
    Press any key to continue . . .

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  4. Offline


    Can you maybe post your .bat file I have a feeling I know what it is.
  5. Offline


    Sure :)

    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles%\Java\jre7\bin\java.exe" -Xmx1024M -Xms1024M -jar craftbukkit.jar
  6. Offline


    You clearly have not, its covered in the document.

    The unable to access jarfile issue is due to a mismatched filename and the name in your bat file.

    This error:
    Is caused by you not having Visual C++ 2008 Redistributable installed. The version of Visual C++ 2008 Redistributable (x64 or x86) MUST match the version of Java you are using. In this case, you likely are using Java x86 and have Visual C++ 2008 Redistributable x64 installed.

    I will add that to the troubleshooting thread.
  7. Offline


    So i have to install Visual C++ 2008 redistributable?
  8. Offline


    Or use the correct Java version to correspond with the version of Visual C++ 2008 Redistributable that is likely already on your system. Visual C++ 2008 Redistributable comes on Server 2008 R2 by default, and I believe it is on Windows 7 by default as well.
  9. Offline

    Cosmin Tanislav

    hey you simply rename the file from bukkit craftbukkit.........jar to craftbukkit.jar
  10. Offline


    so then if i have Visual C+++ 2008 why am i getting the errors with my .bat?
  11. Offline


    Because you have the wrong filename in your bat file, as I said earlier.
Thread Status:
Not open for further replies.

Share This Page