EpicQuest - Moved to DevBukkit. Link in thread!

Discussion in 'WIP and Development Status' started by Randy Schouten, Jun 27, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    i was testing with default configs. ill try again later and double check them all. do you mean the quest.yml? i just opened the .rar i downloaded and looked in it and 'worlds' is lower case for every single quest. should i go through and change them all? its even lower case for the leather pants quest that i managed to turn in. this is the file in its default state as it appears in your download link (at least as it appeared last night when i downloaded it).

    do we require the spoutcraft launcher as Williamsson says above me?
  2. Offline

    Randy Schouten

    You don't need it, it's optional ;)
    It detects if you use it, if you do, it uses the new Spout stuff.
    If you don't it'll just show normal text.

    I know about the default config problem...
    I should mention it somewhere or upload a new one.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  3. Offline


    Oh, as we understood it in the first post, it's not optional :p
    Lol, then I'll just go ahead and use this instead of uQuest, in time :)
  4. Offline


    ok i just did find/replace and turned all the 'worlds' into 'Worlds' and it seems to be working a bit better. its strange though, i got the quest to make 5 boats so i made them, /q info said i only had 1/5, so i dropped them all and picked them back up and got the green complete text and did /q turnin and it worked. i tried another and got the leather pants one again. i made the pants and it didnt 'see' them so i dropped them/picked up, got the green text and did /q turnin and got the following error. i retyped /q turnin a few times and it worked? kinda strange.

    14:23:30 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'q' i
    n plugin EpicQuest v0.7
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:12
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:3
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
            at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NullPointerException
            at randy.eq.eqAPI.turnInQuest(eqAPI.java:106)
            at randy.eq.eq.onCommand(eq.java:447)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
            ... 12 more
    tried a few more and they are working for the most part. that same errors get thrown sometimes, and for whatever reason it doesnt recognize that i have the items required unless i pick them up off the ground (taking them from crafting table or furnace doesnt work). ill keep messing around (i havnt got a kill quest yet so i dont know what happens with them at all) and include npc-quester and see if that changes anything. is there any other info or something else i should try to do or report?

    edit - ok i was taking quests (/q solo) and dropping them (/q drop 1) trying to get a basic kill quest to test and 'an internal error occurred' which lead to my client crashing out and that same error in my logs.
  5. Offline

    Randy Schouten

    I will look into it.
    Quest dropping doesn't seem to work 100% yet..
  6. Offline


    ok, let me know if there is anything i can do to further help you or test anything :) thanks for all your work on this plugin as well.
  7. Offline

    Randy Schouten


    All you can really do, I suppose, it just report bugs you find :p
  8. Offline


    ok. here is a link to my quests.yml with the 'worlds' variable capitalized (no other changes)...in case anyone wants it or you havnt had time to fix it yet.
  9. Offline


    "An internal error occured while attempting to preform this command" when i type /q help
  10. Offline

    Randy Schouten

    It's probably Permissions.
    I forgot to make it optional...

    There'll be a new update out within this hour, making permissions optional, adding drop all quests and fixing a bug.
  11. Offline


    Still receiving this (and more had to cut it short). I've replaced all the worlds with Worlds, it had no effect. I also gave my members epicquest.* permissions. Does this work? Is that the issue?
  12. Offline

    Randy Schouten

    Well, you have cut out exactly what the problem is. :p
    I need the lower part, it should say something like "caused by eq.blablab".
  13. Offline


    Players also receiving Internal errors everytime they do any command.
  14. Offline

    Randy Schouten

    Then it is probably Permissions.

    Try adding them all seperately, instead of "epicquest.*".
    I will add that node in the next update.

    Something that is almost done as well, is quest saving and loading.
  15. Offline


    Can't seem to turn in quests. Also, I get an error in my server log.
    [WARNING] Task of 'EpicQuest' generated an exception
        at randy.eq.eqQuestLoader.loadQuests(eqQuestLoader.java:130)
        at randy.eq.eq$1.run(eq.java:111)
        at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:137)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:438)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  16. Offline


    I did as you say, but players are still bringing required items to the quest giver and they are not turning in. Gives players "You have no quests to turn in".

    Works the same when they do /q turnin

    Another one when trying to turn in the quest collect 128 stone. The quest had said "completed"

    If this is not helping you let me know and I'll stop posting :p

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  17. Offline


    Spout support please?
  18. Offline

    Randy Schouten

    *Cough* Title + first post *Cough*
  19. Offline


    Seems we are narrowing down the issue. If you take items out of a chest or spawn them they won't count. you need to actually pick them up for it to count towards the quest. This works most the time. However sometimes there are still errors on turnins. Kill quests and crafting quests are working fine it seems.
  20. would it be possible for an ingame add quest functionality? Therefore op's on my server could set quests for items that they need to finish comunal building etc...
    Cheers, great plugin by the way!
  21. Offline


    Amazing plugin im using it on my RPG server! :)

    I do have some feature requests that are quite challenging but i think Spout could make this possible...

    1. Have permission ranks as quest rewards

    2. Have quests to kill Citizens NPC's

    3. Instead of text quests you could maybe have an interface? (just an idea)

    If you could TRY to get some of these features in the far future that would be AMAZING!
  22. Offline

    Randy Schouten

    Thanks for invesigating!
    I will see if there's anything I can do about those 2 things.

    I think that that would be too much commands.

    1: Will look into this
    2: The "killplayer" quest type works for this, or if you are referring to having only NPC's, I'll see what I can do
    3: That's already implemented a little with Spout, but it'll be way better when I see better how it works.
  23. Offline


    Thank you! :)
  24. I see what you mean, although you wouldn't be forced to use them (i.e. you could choose to enable it), to be honest I am only really talking about item fetch quests, any other I agree would need to be set using the config files. It would be nice though, perhaps you could use a spout style gui? Anyways, thanks for the plugin! Also @Cedar 's comment about the permission based rewards would be incredible. With this combined with worldguard regions could be created for 'quest levels and rewards' (as worldguard can restrict access based on groups). For example a guild hall for warriors where you must have completed x number of quests before you are allowed in! Sorry if this is worded badly, am in a bit of a rush!
  25. Offline

    Randy Schouten

    I am running into some weird bugs with quest saving.
    I will try to get it out as quickly as I can!
  26. Offline


    Sounds amazing! If that is possible then this plugin will certainly be a big step for Spout, Bukkit and SMP all together..especially for RPG servers like mine :)
  27. Offline


    Cough*Cough* Thanks!
  28. Offline


    It seems i have the same error with permissions on this as with NPC quest with uQuest. If i manually give everyone permissions on both, they will both work?
  29. Offline


    is there anyway to let players accept specific quests?
  30. Offline


    Any plans or ETA on SQL support?
Thread Status:
Not open for further replies.

Share This Page