Inactive [EDIT/RPG] Catacombs v2.6 - Random Dungeons (Adventure-like) [1.3.1-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by Steeleyes, Aug 30, 2011.

  1. Offline


    Great I'll give you a review of my session after Thursday!
  2. Offline


    it looks great ! I'll test.
    Okayy :
    bukkit 1337, 1.8.1
  3. That is very strange. It's the first time you've run it. It looks like you have a problem with your install. I notice there is a "FileNotFoundException: . ....craftbukkit-0.0.1-SNAPSHOT.jar" .......
    Move the Catacombs.jar out of the plugins directory and double check it's a Catacombs problem.
    If it is then remove the file called 'plugins/Catacombs/Catacombs.db' and try loading again, and repost letting me know what happened at each stage.
  4. Offline


    It looks working !
    Thank you > incompatibility with the last citizen plugin.

    Really great mod, congratz.
  5. Ah great, thanks for getting back and letting me know the problem was related to something else.
    jycs likes this.
  6. Offline


    No problem, your plugin give a lot of interest for the game.
  7. Offline


    Worked for the longest time and I love it, but for some reason, killing mobs doesn't give money anymore, and whenever I try to use a command (either to reset, plan, or build, etc), I get this error:

    Exception trapped java.lang.NullPointerException minecraft

    It was fine until about yesterday.

  8. Offline


    Okay, I finally had time to test it, I had to

    /cat plan test 2 20
    /cat create test

    My question to you is, how do I make it generate as it goes through the world, if its possible, with random values? (Floor, difficulty, etc?)

    Also is it possible to remove that iron block in the tent?

    p.s. (It's amazing!)
    p.p.s I had to randomly break blocks to find the next passage, is that how it's suppose to be? (It was a mossy)
  9. If the mobs don't give money check that Catacombs has found an economy system as the server is started. There hasn't been a release recently so if it's just stopped working that is strange. Did you install another plugin?

    What was the error message below the null pointer exception?

    It's not a worldgen plugin so it doesn't generate as you go through the world. You can use the '/cat scatter' command to generate some distant dungeons for you to find. You can change the dungeon difficulty and game balance by changing the settings in the config file, but there is no built in difficulty settings.

    The Iron block in the hut is an anvil for the mcmmo plugin which can be used to repair items if you have the plugin and the required materials. It's there to stay, but you can suspend a dungeon and remove it if you like on each dungeon.

    You shouldn't have to dig out any blocks to go through the dungeon, but some doors are secret and open when you left click on them. Mossy cobble is often a clue there is a secret door. Yes that's deliberate.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  10. Offline


    That's all the error message said.

    And no, I swear it stopped working in a matter of hours. I was creating some catacombs in our survival world, left for work, then came back home and they weren't working anymore.

    I'll go through the configs just one last time to make sure.
  11. Do you get something like this near the top of the server console?
    19:00:37 [INFO] [Catacombs] Looking for Permissions plugin
    19:00:37 [INFO] [Catacombs] Found and will use plugin Permissions v3.1.6
    19:00:38 [INFO] [Catacombs] Preferred payment method [any] not found, using first found.
    19:00:38 [INFO] [Catacombs] Payment method found (Essentials version: 2.2)
    The other way to get rid of the iron block in the hut is to use one of the other hut options in the config file.
    The choices are 'default, small, tiny, pit, medium, large'. Small doesn't have an iron block (or anything else either).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  12. I found and fixed this bug (or one very similar). It was unusual in that the null pointer exception came up in game rather than in the console (you are right that was all it said). It was caused when the code tried to use a special room as the end of dungeon room and the special room had some walls that with no access points.

    If you can turn special rooms down to zero percent that should act as a work around until the next release is made.
  13. Offline


    I try to build a kind of a "dungeon-mine". So i added iron_block to "breakable" in the config-file but it doesn't work. I always get the message: Exception trapped java.lang.NullPointerException
  14. What where the main settings you changed to generate your "dungeon-mine"? I fixed one bug today related to end rooms. Making iron_blocks breakable appears to work ok for me. Have you checked the syntax of your config.yml and used spaces not tabs? The number of spaces is critical.
  15. Offline


    I created a standard-dungeon without any changes of the config-file. Then i added iron_ore (sorry, wrong block name in the first post) and wanted to add the ore manually ingame (just for testing the first time):

        - torch
        - red_mushroom
        - brown_mushroom
        - web
        - iron_ore
    I made sure of using spaces.
    When I type e.g. /cat suspend now, I got the error message. After deleting "iron_ore" everything is working fine again.
  16. What message did you get? I ran a few tests on a dungeon with iron_ore as the minor block and everything appeared to be ok for me. These where the configuration changes I made, then I built a dungeon using 'mine' as the style. I had no problems with suspend, try v0.9 which is released and awaiting approval or send the error messages.
      - torch
      - red_mushroom
      - iron_ore
      - brown_mushroom
      - web
        Major: cobblestone
        Minor: iron_ore
    Release v0.9 (released and awaiting approval from BukkitDev)
    • Fixed an in-game Null pointer exception during planning caused by special end rooms
    • Fixed bug which caused lava to be able to ignite things in dungeons
    • Fixed problem getting stuck in walls when teleporting to the dungeon end
    • Fixed problem with blocks getting messed up (byte code was lost) when reseting secret doors
    • Fixed serious bug in the dungeon overlap checking code (now also reports offending dungeon)
    • Confirmed spawner protection config option works. Set this to 'true' to force players to place torches around spawners to disable them rather than removing them.
    • Converted code to use bukkit's new configuration code to avoid deprecated warnings during compile
    • Dungeon maps now get saved as text files when dungeons are built
    • Added a series of debug commands to help identify user problems (list <name>, dump, map)
    • '/cat which' or '/cat ?' will now report the name of the dungeon in the crosshairs if you aren't in a dungeon (and it's close enough).
    • Integrated lots of code related to boss mobs that will guard the final chest currently disabled while I run some more tests on it and get an ok from the original author of the code (due in v1.0)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  17. Offline


    Ok the update fixed all the problems.
    But the iron ore blocks are not respawng by typing /cat reset. Is there a trick for this or is this just not (yet?) a feature?
  18. Good to hear the problems were resolved by the new release.
    As you noticed reset doesn't rebuild the dungeons, it just closes doors, removes torches and re-fills chests. This allows for customization, but isn't what everyone might expect. A rebuild command is on the to-do list.
  19. Offline


    This is a great mod, koodos Steeleyes
  20. Offline


    Allright, can't wait until this works :)
    Its really an awesome mod!
  21. Offline


    Hey Steeleyes,

    Having a bit of an issue with the plugin here... basically I'm downloading it, placing it in my plugins folder, restarting the server and as I watch the server log, Catacombs is automatically pulling Permissions 3.1.6 which isn't the permissions system I use (which is Essentials). After that, things seem fine but immediately I get:

    [SEVERE] Error occurred while enabling Catacombs v0.9 (Is it up to date?): null

    Then the server proceeds to boot up. In game, I can query the commands using /catacombs but actually /cat planning it will trigger Exception trapped java.lang.NullPointerException which I know has been previously posted. So I begin to troubleshoot. My first thought is to check plugins/Catacombs but the .jar never created the directory so there's no config or database files anywhere.

    Any direction would be great, thanks so much.

    [EDIT] I have figured out the issue and it seems it was not your plugin. I updated bukkit and that was it. For anyone running into a similar issue, just visit: and update your craftbukkit. By default it fixed like 3 of the non-working plugins. Cheers.
    Steeleyes likes this.
  22. Many thanks for posting the solution to your problem. It may help others with the same problem, glad you got it working. :)
  23. Offline


    Not a problem at all, I hate when people ask the same question that I have, they figure it out, then say "OKAY I FIXED IT BYE!" and not leave the solution. By the way, wonderful plugin, we've already had a lot of fun <3
  24. Offline


    I GOT A BUG! The java.lang error aint outdated cb... i got the latest recomended, (1337) and it works good in the beginning, then suddenly starts to create the java lang problem. I have to delete the perm it generates to fix it, and then all the dungeons is rested :/

    **EDIT** It was the world plugin i used xD however, can you make so if even if 1 map dosent works, the other works? if one catacom is broken, they are all broken :/
  25. Glad the problem wasn't in Catacombs. Can you explain the fix you are suggesting a bit more?
  26. Offline


    Sorry, but i just realised it was in catacombs :( it is a error that seems to randomly occur :( However, it seems that it occurs when you Example, name a catacom NEWB (just felt for typing that xd) Then delete it, then make it again called NEWB, it starts happening after a while :/
  27. Are you seeing an issue where the minecraft client freezes (the screen goes blank pale blue) or is there a full error message you can post?
  28. Offline


    I can't copy the message, but next time it shows up, i'll check. k?
    However, it only happends if you add a cat, remove it then add it again. Atleast in my experience
  29. Offline


    My dungeons are not protecting against creeper damage when everything should be fine, if not here my config:

        GoldOff: false
        CalmSpawns: false
        emptyChestonDelete: true
        MessyEndermen: false
        SecretDoorOnlyInDungeon: false
        Economy: any
        MessyCreepers: false
        SecretDoorOff: false
        - /spawn
        - /kill
        - /warp
        - /setwarp
        - /home
        DungeonProtectOff: false
        SaveDungeons: true
        ProtectSpawners: true
        - torch
        - red_mushroom
        - brown_mushroom
        - web
                EquipPct: 100
                List: []
                EquipPct: 100
                - diamond:100:1-3
                - golden_apple:30:1
                - leather:10:1-6
                - torch:50:1-30
                - ink_sack:10:1-5
                - wheat:10:1-5
                - gold_ingot:10:1-5
                - redstone:5:1-4
                - glowstone_dust:15:1-6
                - slime_ball:7:1
                - iron_ingot:20:1-4
                - arrow:10:1-25
                - sulphur:10:1-5
                - pumpkin:5:1
                - flint:10:1-6
                - gold_record:2:1
                - green_record:2:1
                - saddle:2:1
                - diamond:1:1
                - mossy_cobblestone:5:1-12
                - obsidian:2:1-8
                - golden_apple:2:1
                - cookie:4:8
                - bread:3:4
                - apple:3:4
                - cooked_fish:3:4
                - cooked_beef:3:4
                - cooked_chicken:3:4
                - grilled_pork:3:4
                - melon_seeds:2:1
                - pumpkin_seeds:2:1
                - bowl:7:1
                - seeds:4:1-6
                - book:7:1-4
                - paper:7:1-4
                - compass:5:1
                - watch:5:1
                - painting:5:1
                LeatherEquipPct: 10
                CaveSpiderPct: 10
                WolfPct: 10
                SkeletonPct: 25
                PigmanPct: 10
                SpiderPct: 5
                Max: 10
                Min: 0
            DoubleWidthPct: 60
                DoorPct: 20
                HiddenPct: 10
                WebDoorPct: 10
                BenchPct: 3
                SpawnerPct: 50
                ChestPct: 35
                    PoolPct: 15
                    FullPoolPct: 40
                    LavaPct: 30
                ShroomPct: 10
                SandPct: 10
                OvenPct: 2
                TrapPct: 10
            Max: 10
            Min: 3
        CorridorPct: 30
        RadiusMax: 12
            roof: 1
            floor: 3
            firstLevel: 2
            room: 3
            Width3Pct: 10
            Width2Pct: 40
            Max: 9
            Min: 3
            AirWebPct: 1
            MossyPct: 2
            Major: cobblestone
            Minor: mossy_cobblestone
            - stone
            - dirt
            - sand
            - sandstone
            - gravel
            - coal_ore
            - iron_ore
            - redstone_ore
            - gold_ore
            - diamond_ore
            - lapis_ore
        SpecialPct: 10
        UnderFill: false
            Type: default
        OverFill: false
        ResetButton: false
            - arrow:100:10
  30. Strange. Which version of the plugin are you using? v0.9? Is it creepers on the surface or deep inside
    that are causing problems? Remember the dungeon will only be protected against creepers if it's
    an enabled, registered dungeon.

    Confirm that the dungeon structure is protected against your pickaxe (it will only be protected against
    creepers if it's protected against changes with the pickaxe).

    Ah yes one other thing. Check you are using bukkit 1337. There was a fix made recently to bukkit to allow block damage to be cancelled more simply and I changed the Catacombs code to take advantage of this. I bet this is your problem.

Share This Page