Inactive [EDIT/RPG] Catacombs v2.6 - Random Dungeons (Adventure-like) [1.3.1-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by Steeleyes, Aug 30, 2011.

  1. Offline


    Forcing torches works great! any chance you can force it to allow chests now? forgot there's no way to loot things on the way down w/o the same override! you're the best!
  2. What does it say in the console after the "[Catacombs] Using WEPIF to find permissions plugin" (I'll fix the typo)?
    If it's found a permissions system (like bukkit's own API) then you'll have to read up on the system and fill in the appropriate files, or disable the system in the wepif.yml to fall back on "ops.txt"
  3. Offline


    This plugin is kidding me . I am admin on my server but i cant use /cat plan :/
    . When i use /cat plan it doesnt shows an error in my console or something other . help :(
    I tested it again and i cant use any permission of /cat - .
    That says the console
    12:47 PM [INFO] [Catacombs] Loading Catacombs v1.5.
    12:47 PM [INFO] [Catacombs] Using WEPIF for find permissions plugin
    12:47 PM [INFO] [Catacombs] Preferred payment method [any] not found, using first found.
    12:47 PM [INFO] [Catacombs] Payment method found (iConomy version: 6) 
  4. Try v1.6 and double check your character name is in the ops.txt file.
  5. Offline


    Ok , my character name is in the ops.txt file. but when i download catacomb plugin i always download version 1.5
    Where is the download for version 1.6? Srry for my dumbness :D
  6. We are still waiting on the bukkit team to release the v1.6 version I uploaded. Check here to see when it's been released.
  7. Offline


    I finally solved it thanks to your help i can't even start to describe your helpfulness+ 1.6 is up there.
  8. Offline


    Thanks, it finally works, but I have another problem:(. I the first room of the first dungeon i spawned there was no door. i kno that thier are hidden ones but I kept clicking for it and couldnt find it, I finally just puched a hole through it and made to the next room.
  9. Offline

    Derek Mager

    whenever i try to plan the catacomb i says i dont have permission to use /cat plan yet im the admin, its probaly because im not exactly sure what im doing since this is my first server. any one know what im doing wrong?
  10. Did you try clicking with both buttons on the mossy cobble blocks? If you look at the map in the maps directory you can find the exact location of the secret door because they are mark with a '$'. The only other time I've heard of secret doors not opening correctly is when a dungeon has been built in a protected zone. The secret door clicking relies on the block being damaged event and if another plugin is cancelling this then the doors won't open. Briefly disable all your other plugins to confirm if this is a Catacombs problem or not.

    My guess is in the start up console of your server Catacombs has found the bukkit permissions API and that you haven't needed to configure that so it's not configured. If you check out the thread on bukkitdev you'll see a post from me showing you how to disable all the permissions plugins so that all you need to do is add your name to 'ops.txt'

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  11. Offline


    ok i downloaded version 1.6 but i says again You dont have permission for /cat plan or any other commands

    This says catacombs plugin
    01:10 PM [INFO] [Catacombs] Loading Catacombs v1.6.
    01:10 PM [INFO] [Catacombs] Using WEPIF to find permissions plugin
    01:10 PM [INFO] [Catacombs] Creating SQL table 'dungeons'
    01:10 PM [INFO] [Catacombs] Creating SQL table 'levels2'
    01:10 PM [INFO] [Catacombs] Creating SQL table 'flags'
    01:10 PM [INFO] [Catacombs] Creating SQL table 'locations'
    01:10 PM [INFO] [Catacombs] Preferred payment method [any] not found, using first found.
    01:10 PM [INFO] [Catacombs] Payment method found (iConomy version: 6) 
  12. Did you filer out a message like '01:10 PM [INFO] WEPIF: ........' in this block of info?

    I ask because you should either get a WEPIF message like one of these:
    WEPIF: Permissions plugin detected! Using Permissions plugin for permissions.
    WEPIF: Using the Bukkit Permissions API.
    or you should get a Catacombs message like this (and you appear to have neither).
    [Catacombs] No permissions plugin found, will use player's Op flag
    [I've changed the Catacombs WEPIF messages going forwards so they are more clearly related to Catacombs]

    It's the "Bukkit Permissions API" message that is causing all the problems for people who aren't set up for any permissions system. The simple solution to this is to disable DinnerPermsResolver (aka Bukkit Permissions API) in the wepif.yml.
    [I'll change this in the code so that it's off by default to help people running simpler setups]
        - PluginPermissionsResolver
        - PermissionsExResolver
        - bPermissionsResolver
        - FlatFilePermissionsResolver
        - NijiPermissionsResolver
        - DinnerPermsResolver
    Chaosnoxus likes this.
  13. Offline


    Hey, im having some trouble. Whenever i try to use a command, ie /cat plan starter 1 12
    It says i dont have the permission to do it. I dont have permissions on my server, and im OP, any idea whats going on? Thanks :p
  14. Offline


    Now everythings works fantastic thanks a lot (like) :p only one problem: i cant set torches in the catacombs
  15. When this has been reported in the past it's because the zone is protected by another plugin (briefly turn them all off to check) or it's because you built the dungeon too close to a protected spawn location.
    Chaosnoxus likes this.
  16. Offline


    ah ok my world guard protected this, i am stupid :p and why i cant use stone_brick for the shelter?
    i get this error 11:21 PM [SEVERE] [Catacombs] Invalid block material 'stone_brick'
  17. You have to use the bukkit names for the blocks you choose (or the numbers)

    smooth_brick might be what you are after.
    Chaosnoxus likes this.
  18. Offline


  19. Offline


    I finally figured it out. I was in creative mode and when I tried to hit the block it would insta break instead of opening the door. thanks for the help:D
  20. Offline


    any chance of allowing chest looting in world guarded zones like you did w/ the torch planting?
  21. Offline


    This Is soo cool put i download it but if i use it it says u dont have premission for /cat so how to fix that!?
  22. Read back through the last couple of pages.
  23. Offline


    I got it working because I switched permissions, but I had to switch back to Pex because the other one was outdated. I am back to the problem where it gives me the help bar for everything. ex: /cat plan= command page[] /cat build= command page.
  24. The list of help commands only appears when you get the command name wrong or give the wrong number of arguments to the command (you get a different message when the permissions are wrong). See the Youtube video and the documentation,
  25. Offline


    My catacombs are coming out crappy. 3 problems. 1) about 50 mobs in 1 room. 2) VERY small rooms, and 3) dead end catacombs... like literally I go down the ladder, 2-3 rooms in and then 'poof' all dead ends. I have checked EVERY spot on all of the walls for secrets and have found none.

    Oh, also one of my catacombs aren't listed on '/cat list'. I disconnected from the server, I also restarted the server and nothing... :-( Otherwise its a very good plugin... Is there an alternative? My players want more to minecraft! The chests are a great reward for them.
  26. Life's a bitch.

    The room size is on configurable. More importantly reduce the chance of the corridors to improve your chances of a room.

    Check the map file under Catacombs/maps and see where the secret door is. You must damage the wall (left click) to open the secret door.

    If the dungeon name doesn't appear in '/cat list' then that dungeon is "lost" and you'll have to forget about it. '/cat unprotect' could cause this, or if there is some kind of error/bug during the building process.
  27. Offline


    Alright. Well now my big issue, I cannot plan a dungeon. I keep getting the response 'dungeonname is incomplete(usually too small for final room/stairs). I initially was making a small dungeon just fine. The dungeon has been made these ways...

    /cat plan asdf 1 20
    /cat plan asdf 3 20
    /cat plan asdf 1 400
    /cat plan asdf 2 400
    /cat plan asdf 3 400

    Am I doing something wrong.
  28. The first planning command is probably a good one to go with. Did you change some of the settings in the config file?
  29. Offline


    There is also the undocumented "scatter" command, which takes one additional parameter than planning a dungeon, which is a range to try to create the dungeon. It will attempt to place the dungeon in a number of locations and build the dungeon if/when it succeeds.

  30. Offline


    how do i put myself in the permissions, every time i do the command it sais i dont have the permissions

Share This Page