Inactive [EDIT/RPG] Catacombs v2.6 - Random Dungeons (Adventure-like) [1.3.1-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by Steeleyes, Aug 30, 2011.

  1. Offline


    this looks so dope, will it work if i have mobs off on my server?
  2. Offline


    I have another question.
    How can I know how many level a dungeon have ?
  3. It depends what you mean by "work". Certainly you won't get any mobs in the dungeons if you have mobs off on the server, because the plugin currently uses Minecraft's natural code to create the mobs from spawners in the dungeons.

    The unreleased v1.3 has an option to reduce the number of mobs that spawn on the surface, maybe I need a mobs-only-in-dungeons option too?

    You see the number of levels on the screen when the level is being planned. After that the
    only way to get it is to do /cat list <name> and look in the console. Maybe this needs changing
    a little?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  4. Offline


    thx. it's perfect i can look at the console.
    For a future update could you add somdthings for manage the team who perform the dungeon ?
    because aometimes people hurts eachother ^^ and it's the source of complains for MJs lol
  5. The unreleased v1.3 has an option to turn PvP off inside dungeons.
  6. Offline


    You could use something like mcMMO or Heroes, both have party features that allow for no pvp. I actually use both on my server.
  7. Offline

    Thunder Peel

    Fantastic plugin, though I keep getting a spot like this... :C

    Has happened one time on two dungeons.
  8. What is the block we can see in the door way? Is it the 'minor' building block for this dungeon?
  9. Offline


    Using 1.2 with craftbukkit-1.1-R3.jar

    After a successful plan the following error occurs on build.

    /cat build cata
    In game error in chat
    Exception trapped java.lang.NullPointerException

    Error in console
    15:24:06 [SEVERE] Exception in thread "Connection #20 wri
    (Console error is truncated)
  10. Ah yes I get the same thing with the latest bukkit recommended build, I'll look into it.
  11. Offline

    Thunder Peel

    It's the minor block.(mossy) This is on the 'grand' style, and one happened on the 'default' style. It's becoming more and more common as well, in one dungeon, about 5 hidden doors are 1x1.
  12. My null pointer issue is now fixed and was related to unreleased Catacombs code, and probably isn't the issue you are seeing.

    I'm using MC1.1 and 1.1.R3 of bukkit. Apologies, I have no plans to support pre-release versions of either Minecraft or bukkit.
  13. Offline


    I'm using Catacombs v1.2, downloaded from the dev page, with craftbukkit-1.1-R3.jar running on Java 7 64bit Linux.

    I've tried building Catacombs multiple times of different sizes and levels, each time after a successful build I get a Exception trapped java.lang.NullPointerException in chat, and '[SEVERE] Exception in thread "Connection #26 wri' in console.
  14. Offline


    cant place torches in dungeon.. any clue why?
  15. Offline


    This has also occurred to us a few times when opening secret doors. It will open and close the top block, but not the bottom block, therefore not allowing you to move on with the dungeon. :(

    Other than that, this is a very good plugin, we enjoy it a lot. [diamond]
  16. Did you build the dungeon too close to a protected spawn location?
    Do you have any other protection plugins running?
  17. Offline


    Awesome mod. Everyone on my server loves it.

    I was wondering if this would be possible: when a dungeon is given the reset command, and all torches are being deleted / chests refilled, could all Switches be set to the Off state as well?

    Thanks again for the amazing mod!
  18. I'd love if you could fill the chests with stuff yourself and save it. I use magicspells on my server but the only way for anyone to get the spells is to find them in the catacombs. To be able to put a spellbook in a chest and then, somehow, save the catacomb so that the spellbook reapear in the chest after a reset would be great.

    Also. Giving the players the right to reset the catacomb by pulling a lever would be awesome. A lever outside the catacomb with the sign "Reset dungeon" would be all that's needed to let the players choose themself if they want to restart it. :)
  19. Done. Added to v1.3

    I'm not familiar with magicspells. Is there no way to add these as loot to chests, in other words don't they have an item ID?

    There is a button you can enable in the config to reset the dungeon. Would that do? When enabled it appears above the end of dungeon chest.

    I've released v1.3 in an attempt to fix the secret door problems people have reported (I haven't been able to re-create the problem so please let me know if the changes have done the trick).
    This release also uses a new database structure. The conversion should happen automatically when the plugin is run for the first time, again let me know if you have any issues with your older dungeons.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
    zyros likes this.
  20. I actually don't know. It's a combination of MagicSpells and Bookworm that let you bind a spell to a book. How the ID's are handled. Well.. I'm to noobish to know, but I'll check it out. Most things are learnable by reading, right? :)

    Ah, nice. But is there any way to add it so you could put a button like that at the start of an instance? This way you can easily reset the instance before you go through it even if the last people that did it didn't reset.

    I've noticed that people usually doesn't put much thought to other people when they play ;P
  21. Offline


    Nope its way out in the open...

    Worldguard is all I know of..
  22. Mobs keep going right through closed doors and closed hidden walls. Gets hard as hell when the just show up everywhere all the time no matter whats in the way...
  23. Offline


    Wow. Three hours later, and my suggestion was implemented. Steeleyes, you are *amazing!* Awesome work!
  24. Make sure all the corners of the rooms are well lit, as they may be spawning on top of you (pigmen do this especially). If the mobs are moving through things they shouldn't like floors, walls and doors then you'll need to speak to Notch about it. :)

    Try turning worldguard off briefly and see if you can place torches inside and just outside the dungeon. Also try suspending the dungeon and see if you can put torches inside. My bet is that another plugin is stopping the torches being placed (not Catacombs).

    Well a release was going out and it was only 2 lines of code.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  25. Offline


    Congrats on 1.3, since installing it any previous issues have disappeared.

    However, I am now having the same issue as boduzapho, where it is not possible to place torches within a catacomb. If the catacomb is suspended, with the suspend command, then torches can be placed, but as soon as the catacomb is enabled again the problem comes back and you can't place torches any more.
  26. That is very strange. It works for me when the dungeon is not suspended or not. I've also checked the code and there is almost nothing that can go wrong. I wonder if it's a clash with another plugin (although the fact you can place them when the dungeon is suspended suggests not). Did you turn all the other plugins off briefly to eliminate that?
  27. Offline


    I made a mirror of the server and tried experimenting on there. On the mirror, my first catacomb build was made in exactly the same spot, with the same depth and radius, and without making any changes to the server configuration at all. There was no problem placing torches! How strange. I'm going to do some more experimentation to work out what went on on the live server, but at the moment players are enjoying the extra challenge of not being able to place torches. I'll report back with any findings in the next day.
  28. Try typing '/cat test' in one of the problem protected dungeons and then try placing a torch. If you get a debug message giving details of the block being placed then we'll know the place hasn't already been cancelled by something else.

    Also try this version:
  29. Offline


    Here are the results from using '/cat test'

    Placing a torch
    PLACE : AIR (614,59,235)

    Placing stone
    PLACE : AIR (614,59,235)

    Placing redstone
    PLACE : REDSTONE_WIRE(614,59,235)

    I'll try the version you attached in a few minutes or so.
    And then suddenly it clicked. Placing AIR. The server had rollbacked to craftbukkit-1.1-R2. Oops. Problem solved.

    Tried this version and the same problem occurs for me. With '/cat test' the following messages appear in the console.

    Placing a torch
    16:41:26 [INFO] [Catacombs] Block place=AIR(0) already_cancelled=false

    Placing stone
    16:41:28 [INFO] [Catacombs] Block place=AIR(0) already_cancelled=false

    Placing redstone
    16:41:31 [INFO] [Catacombs] Block place= REDSTONE_WIRE(0) already_cancelled=false

    And then suddenly it clicked. Placing AIR. The server had rollbacked to craftbukkit-1.1-R2. Oops. Problem solved.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  30. Offline


    I was also having issues with secret doors. After suspending the dungeons and smashing blocks I discovered that apparently the sticky pistons and sometimes the redstone torches that need to be below the secret door blocks were not being created properly. The sticky piston looked like, as best I can explain it, the base of a piston block without the actual moving part of it. On some doors the redstone torch was below as it should be, other times not.

    If I replaced the "damaged" piston with a sticky piston block out of my inventory and placed a redstone torch if necessary, then replaced the moss and regular cobblestone around it, it worked just fine. Obviously quite a chore though if dealing with a large dungeon to have to go through and fix every secret door.

    I've uploaded your 1.3 update to my server but haven't had a chance to see if it fixed the issue or not. I just wanted to post my findings in case it helped you nail down the issue. I'll report back once I get home from work to see whether 1.3 solved the issue or not.

    Thanks for the awesome mod! My players are loving it very much.

Share This Page