[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Sounds like something in bukkit has broken then, because the two commits that happened were:
    Reduced console spam under certain conditions.
    Made the server not accept Packet27 as it is not used.

    So it sounds like maybe something broke in bukkit. I looked through the changes and it appears that could easily be the case. As EvilSeph has stated, the current builds may be riddled with bugs not only bukkit, but Minecraft. I'd sit tight and wait for a newer build and see if that fixes it.
  3. Offline


    Just an FYI, CB #711:
    22:28:12 [SEVERE] D loading MultiVerse v1.6.2 (Is it up to date?)
    java.lang.NoSuchFieldError: D
            at com.onarandombox.Rigby.MultiVerse.MultiVerse.loadWorlds(MultiVerse.java:428)
            at com.onarandombox.Rigby.MultiVerse.MultiVerse.onEnable(MultiVerse.java:158)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:584)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:218)
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:116)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:94)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:217)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:204)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:144)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:259)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
  4. If you want to use a CB version higher than 684, you must use the beta version stated in the OP: NOTE It may be very broken, as will the build of craftbukkit.
  5. Offline


    Ever since updating past 617, all my worlds load at startup.
    Well, they attempt to all load, but only get through 75 percent of them and they slow down and then I get heap errors.
    They never used to load all at server startup. Is there a way I can disable this? I love this mod, it's the cornerstone to my server and one of the main reasons I can't update past 617 :(
  6. Offline



    It's to do with command signs sending long strings.

    On my server it was a minecart mania sign. Removed the sign and everything is fixed.

    The errors are local to the world in which the sign is located which is what made me think it was Multiverse.
  7. Offline


    You should try making a compatible version for the stable release build 705, its the one I'm using for version 1.5 and it seems to be doing fine. Only multiverse and NPCTrader broke. It'd be nice if you try to update it.. but no rush :D.
  8. Offline


    I agree, some 700+ compatibility would be nice :D
  9. Offline


    Having a couple of issues with SP-like behaviour. Everything else works great.

    My problems are:

    1. Portal creation occurs in the same location for everyone each and every-time people go to the nether. (Have ended up with a massive tower of portals in the nether)
    2. Portals auto-created on the other side stop working when another is created and don't return people to the constituent portal in the other world but instead every time to what seems to be a randomly chosen co-ordinate.
    Is this something which has happened to anyone else or have I missed a silly setting somewhere? (No errors in console btw).

    Running 684 and recommended multiverse for 684.

    #Prefix Chat with World Name.
    prefix: true
    #Choose whether or not Players have to pay to use the portals.
    iconomy: false
    #True/False - Whether MultiVerse should handle all respawns on every World including the Default.
    #Disable this if you have a form of Respawn Teleportation plugin.
    globalrespawn: false
    #True/False - Whether MultiVerse should handle all respawns on the MultiVerse Worlds.
    #If 'globalrespawn:true' then this will have no effect.
    alternaterespawn: true
    #How long a player has to wait before using another portal.
    #In Milliseconds - Default is '5000' which is 5 Seconds.
    tpcooldown: 5000
    #How long to leave in between sending an alert to the player.
    #In Milliseconds - Default is '5000' which is 5 Seconds.
    alertcooldown: 5000
    #How long the player has to wait before they can get more information from a portal.
    #In Milliseconds - Default is '5000' which is 5 Seconds.
    infocooldown: 5000
    #The Item a player has to use to get information from a portal.
    #Default is 49 - Obsidian
    infowand: 49
    #The Item a player has to use to set the coordinates to create a portal
    #Default is 270 - Wood Pickaxe
    setwand: 270
    #SinglePlayer Styled Nether - You still have to "/mvimport" the World for Nether.
    #The settings below only affect the SPLike portals.
    #SPLike - True/False - Portals without a Destination or Sign will act like a SinglePlayer portal.
    #AutoBuild - True/False - AutoBuild a destination portal if none are found nearby?
    #Nether - Folder/WorldName of the Nether world.
    #Default - Folder/WorldName of the default world setup in server.properties.
    #RespawnToDefault - True/False - When a player dies do we respawn them back to the default world.
    splike: true
    autobuild: true
    nether: Underworld
    default: Sekai
    respawntodefault: true
    here is my multiverse config file. Could it be the wormholextreme plugin? Not the worlds one...obviously... just the portals one.
  10. Offline

    Celtic Minstrel

    I'd like the ability to have multiple portals teleport you to some specific portal, and then that portal teleports you back to whichever one you came from. Would that be possible to implement?

    For reference, the server has three worlds, one of which is a nether world, and it has MultiInv installed to separate the two non-nether worlds; I'd like players entering and leaving the nether to be able to keep the same inventory regardless of which world they came from, but without giving them the ability to use the nether to take stuff between the two non-nether worlds.
  11. Offline


    AFAIK the 1.6.3 version linked in my OP is compatible with 705, I have users using it on 709+.

    SP-Like was added to the plugin quickly and it all worked fine during testing etc, however something happened between testing and release of the version which broke the feature. It's not correctly teleporting people back and forth and the auto-portal creation is rather dodgy.

    I don't intend to fix this in the current versions because the code is quite messy and it would be a lost cause. I have however got it working in the 2.0 version and it seems to work a charm.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  12. Offline


    ok thanks :)
  13. Offline


    ah thats good news :) it cant come quickly enough :D - can I be really annoying and ask if there is an e.t.a on that?
  14. Offline


    Not compatible with 714 though :(
    Pretty sure compatibility stopped at 711. :\
  15. Offline


    There's no eta currently as there's too much going on to distract me at this moment in time. If I gave an ETA then it wouldn't be a very accurate one and I don't wan't to annoy people by getting their hopes up just for it to be delayed.

    Looking at the commit notes there's nothing in #712 #713 #714 which would of broken the plugin. I'll take a look at the actual code changes but I'm sure nothings changed that could/would affect it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  16. Offline


    I actually posted this last night, couldn't find my post again so instead of quoting it I'll just tell you what's wrong.
    Basically since I updated from... I do believe 711 to 712... Whenever I would try to create a portal it would tell me "You have not set your coordinates yet!".
    And yes, I have set them with the wooden pickaxe. No go.
    It worked fine on 711, just doesn't work now since I updated. :\
  17. Offline


    Strange will see if I have time to look into it.

    Is all that changed from 711 to 712, simple Sign text length.
  18. Offline


    when i change some parameters in the world.yml i cant teleport with the command /mvtp and multiverse says that the world doesnt exist, but i can switch between the world with my private ports and portals. i use multivers 1.6.2 and the latest bukkit server 1.5.02
  19. Offline


    the modified version is working perfectly fine on 714 for me.

    In fact, all of these are working 100%.

  20. I dont get it....its not working for me....I make a portal then light it up and i see [INFO] 0, 1 on the console.
    I stand on the portal and nothing happens.
    If i /mvcreate one then it creates it....i can /mvtp on it and back...but why doesnt the normal portal work ?
    I am using 714
  21. Using 709. Was working last night, and this morning it's giving me errors.
  22. Offline


    I don't have much time atm to explain things in detail so you're best taking a look at the HowTo in the OP.

    hmm can you explain more? Errors in what way? Whats it doing? Can you pastebin the server log?

    Nothing has changed within Bukkit which would make Multiverse itself fail, if it is failing it's likely caused outside of the plugin such as other plugins or Bukkit.
  23. Offline


    I got the same error with the 0,1. So, is this an easy fix, or a problem with the new update?
  24. Offline


    2011-04-24 18:55:14 [SEVERE] special characters are not allowed loading MultiVerse v1.6.2 (Is it up to date?)
    unacceptable character #FFFD special characters are not allowed
    in "<reader>", position 1159
        at org.yaml.snakeyaml.reader.StreamReader.checkPrintable(StreamReader.java:68)
        at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:159)
        at org.yaml.snakeyaml.reader.StreamReader.forward(StreamReader.java:89)
        at org.yaml.snakeyaml.scanner.ScannerImpl.scanLineBreak(ScannerImpl.java:1753)
        at org.yaml.snakeyaml.scanner.ScannerImpl.scanToNextToken(ScannerImpl.java:977)
        at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:237)
        at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:183)
        at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:564)
        at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
        at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:228)
        at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
        at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
        at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
        at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
        at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
        at org.bukkit.util.config.Configuration.load(Configuration.java:73)
        at com.onarandombox.Rigby.MultiVerse.MultiVerse.onEnable(MultiVerse.java:132)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:584)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:218)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:115)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:93)
        at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:285)
        at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(SimpleCommandMap.java:196)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:254)
        at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:637)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:600)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:594)
        at net.minecraft.server.Packet3Chat.a(SourceFile:24)
        at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    I use Bukkit #684, and MultiVerse 1.6.2. Where is the problem?
  25. Offline


    Looks like an encoding error to me. Check that your multiverse config files don't have any special characters in them, or recreate them from scratch to be safe.
  26. Offline


    2011-04-24 20:59:39 [SEVERE] allowMonsters loading MultiVerse v1.6.3 (Is it up to date?)
    java.lang.NoSuchFieldError: allowMonsters
        at com.onarandombox.Rigby.MultiVerse.MultiVerse.loadWorlds(MultiVerse.java:457)
        at com.onarandombox.Rigby.MultiVerse.MultiVerse.onEnable(MultiVerse.java:158)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:584)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:218)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:115)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:93)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:215)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:202)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:142)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:257)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    I have install MultiVerse agian, and now i have this problem.
  27. Offline


    I had to remove this plugin, not sure if it is a problem with the version of bukkit, or the plugin it self.
    I had a nether world, but every time the server would be restarted, the nether would be over written with a normal world.
    When I created a new world to play with, any users that went to the new world would get rapid disconnects until they returned to the default world.
  28. Offline


    are you using the 'Ancient Gates' plugin?
    that plugin was the reason my nether world changed to a normal one. A simple solution is to let the plugin load after the multiverse plugin by renaming the 'AncientGates.jar' to 'ZAncientGates.jar'
  29. Offline


    Minor bug:
    If a player has an iConomy balance of 0 and a portal costs 0.0 to use, the player cannot go through the portal.

    CraftBukkit: 714 - MultiVerse: Whatever the 700+build is - iConomy 4.6.5
  30. Offline


    So, I have a question.
    This may have been asked before, but as this forum lacks a "Search thread" feature (unless there is one and it is well hidden), I'm gonna ask it now:

    Is there a way to restrict a portal to a specific permissions group?
  31. Offline


    I continue to get the "Internal error has occurred" problem while trying to use any command except /mvcreate

    This happened while i was trying to make a portal to a second world.

    I'm running CB 709

Share This Page