[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    hmm not that I can think of... it may be possible if you could get the IP they connected to the server using, however again I'm not sure of this.

    Atm the plugin doesn't allow a default world however it's something to add into it.

    Until then your best bet is to do what Celtic said.

    What versions of CB and Multiverse?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  3. These errors are being thrown due to a dependency error. Do you have permissions 2.5.5?
  4. Offline


    i have trouble with setting this up... it say´s it can´t find permissions 2.1 I have perm 2.5.5, any chance to get this to work? (sorry for bad english, i am german)
  5. Offline


    I constantly spawn in a chunk error when I use /mvtp. I'm running craftbukkit 617, the latest version of multiverse and permissions (I just updated). I have also been getting occasional lag spikes in the non-main-world maps.

    Edit: Also I've tried changing the spawn locations, it doesn't seem to matter.
  6. Offline


    Do you mean that you teleport into a big gap which all of a sudden fills up? That's just the chunk loading.
  7. Offline


    No. It never loads.
  8. This is just a small typo in the plugin, if you're using MultiVerse 1.6.2, it will look for Permissions 2.5.5
  9. Offline


    I've got a 40-60 man server on average, and I'm starting to see this bug as well. We get random crashes when I open up a new world and people start to teleport to it.
  10. Offline


    you get those annoying inventory wipes as well? (i use multi inv so that maybe why it doesnt save) but i also get chunks that seem to never load and when i relogin im underground lol
  11. Offline


    I'm not really sure if this is already answered, but would it be possible to enable per-world permission nodes?
    For example:
    I would like to set up a VIP only world, and if there's another workaround (using MultiVerse) could someone tell me how to set this up?
  12. Offline


    It seems that Permissions didn't copy over as I thought it had. Thanks for the info
  13. Offline


    hrmm.. I imported a world yesterday and it worked fine. Server has been restarted a few times since as im working on plugins..

    now when i mvtp creative, i get the following

    2011-04-07 09:53:41 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'mvtp' in plugin MultiVerse v1.6.2
    	at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
    	at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
    	at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:233)
    	at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:594)
    	at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:557)
    	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:551)
    	at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    	at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
    	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
    	at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    Caused by: java.lang.IllegalStateException: Entity is already tracked!
    	at net.minecraft.server.EntityTracker.a(EntityTracker.java:72)
    	at net.minecraft.server.EntityTracker.a(EntityTracker.java:62)
    	at net.minecraft.server.EntityTracker.a(EntityTracker.java:51)
    	at net.minecraft.server.WorldManager.a(WorldManager.java:17)
    	at net.minecraft.server.World.b(World.java:750)
    	at net.minecraft.server.WorldServer.b(WorldServer.java:94)
    	at net.minecraft.server.World.a(World.java:1590)
    	at net.minecraft.server.Chunk.d(Chunk.java:470)
    	at net.minecraft.server.ChunkProviderServer.c(ChunkProviderServer.java:75)
    	at net.minecraft.server.PlayerInstance.<init>(PlayerInstance.java:33)
    	at net.minecraft.server.PlayerManager.a(PlayerManager.java:37)
    	at net.minecraft.server.PlayerManager.a(PlayerManager.java:76)
    	at org.bukkit.craftbukkit.entity.CraftPlayer.teleport(CraftPlayer.java:180)
    	at com.onarandombox.Rigby.MultiVerse.MVCommands.MVTP(MVCommands.java:617)
    	at com.onarandombox.Rigby.MultiVerse.MultiVerse.onCommand(MultiVerse.java:251)
    	at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    	... 12 more

    fixed: some how the world folder emptied itself.
  14. Offline


    Hello i want to make 2 portails to go to the same world but not the same coordonnates, it's possible to set something else than spawn point ?
  15. Any news on a feature I suggested? Hoping it gets implemented as it would greatly expand the use of MV in my worlds.


    You'd have to link portals in each world.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  16. Offline


    can figure out how to make people spawn in nether when they die
    same with no/permissions
  17. Offline


    I added all the permission things to Permissions and it still says I'm not able to use the commands. Is this right for Permissions?

    group: Admins
  18. Offline


    .... i wont lol.... remove the - from everything....... and if you have '*' under admins then you dont need to enter any permissions the - removes them from permissions and '*' gives you them all. with the exceptions you put - before after the first '

    and beyond that if you wanted to give a person without
    - '*'
    in their permissions you have to add four spaces then a - then one more space then type your command for example. to get rid of multiverse tp you'd type
    - '-multiverse.tp'
    or if you wanted to give someone it without the '*' you'd type
    - 'multiverse.tp'
  19. Offline


    this is a function of permissions 2.5.5 already. Name the permissions file the same as the world name. tested and working on my setup.
  20. Offline


    for some strange reasons its impossible to add new existing worlds. I for example wanted to add "stad2" wich i already had in my server folder, and when i did "/mvimport stad2 normal" it imported and the map was newly generated, overwrote the old map.
    And when i removed it with "/mvremove stad2" and deleted it in the folder, added new world and did the /mvimport "stad2" it loaded the old map! (ofcourse i did restart the server after deleting it with /mvremove
  21. Offline


    I don't understand how to use the "/mvtpt" command...

    And it does nothing when I only write "/mvtpt", I was excepting some help. ^^;
  22. Offline


    Not a show stopper but just a heads up:

    Nag author: 'Rigby' of 'MultiVerse' about the following: onPluginEnable has been replaced with a new signature, (PluginEnableEvent)

    I am on CB617 and MV 1.6.2
  23. Offline

    Celtic Minstrel

    No. Try this.

             group: Admins
             - 'multiverse.world.create'
             - 'multiverse.world.import'
             - 'multiverse.world.remove'
             - 'multiverse.world.list'
             - 'multiverse.tp'
             - 'multiverse.world.setspawn'
             - 'multiverse.world.spawn'
             - 'multiverse.portal.create'
             - 'multiverse.portal.remove'
             - 'multiverse.portal.select'
             - 'multiverse.portal.destination'
             - 'multiverse.portal.rename'
             - 'multiverse.portal.list'
  24. Offline


    Hey everyone... I'm using Permissiosn 2.5.5 and Craftbukkit b617. I can't seem to get MV working. Any time I try to do anything it's saying "Permissions 2.1 is not Enabled, or hasn't been found." I'm Admin, but just in case I added myself to a permissions group and gave myself all the privileges listed in the post above mine. I even dropped down to the unupdated Permissiosn 2.1, and then it was telling me there was internal errors. Any ideas? Any other information which might help?
  25. Offline


    This may be asking a lot from a community that largely gets off on insulting people, But has anyone considered the possibility of releasing this without the need for permissions? I've got close to 20 plugins on my server, and this is the only one being requested that I haven't been able to use because I don't use permissions. I just don't have the time to read on how to set it up right, and god forbid I should ask for help and actually get a decent reply.
    ChronicSyncope likes this.
  26. Offline


    Still having a problem where I spawn in a chunk that never loads. I've tried reinstalling on a vanilla craftbukkit 617 server to no avail.

    I know this isn't what you want to hear, but permissions is actually quite easy to set up. You just install it, name the configuration file "world" and if you want everyone to have access to every command, just put * as the allowed commands for the default group and all of the other groups will inherit that.

    Edit: Commands from plugins that don't use permissions will not be affected.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  27. Offline


    Hi guys !

    After the update for the 1.4 my messages were looking like that :

    [world][group] player : message

    And now with the update multiverse work fine, but now my message are like that :

    [group (in grey :O )] player : message

    Please, how can I set the name of the world ?

    Thank you ! And Sorry for my bad english, i'm french ;)
  28. Offline


    For some reason I keep getting this errors:

    2011-04-07 15:56:38 [SEVERE] Could not pass event PLAYER_INTERACT to MultiVerse
        at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerInteract(MVPlayerListener.java:216)
        at org.bukkit.plugin.java.JavaPluginLoader$9.execute(JavaPluginLoader.java:217)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:255)
        at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:162)
        at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:133)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:661)
        at net.minecraft.server.Packet18ArmAnimation.a(SourceFile:35)
        at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    I never had this problem ever since the 1.4 update.
    I'm using the lastest version of bukkit (b617), permission 2.5.5, and multiverse 1.6.2

    I dont always get this error when using the wand. But the wand doesnt work in general. If I try to set a point it sets both 1st and 2nd point, then constantly sets the 2nd point no matter which button I click :/
  29. Offline


    /mvpt world2
  30. Offline


    What is the 'price' for in the worlds.yml file?
    I know there's a 'price' in the portals.yml file to charge currency for going through a portal, but what does the 'price' do in the worlds.yml file?
  31. Offline


    everytime i try to import an existing world it always loads a different much smaller world...

    EDIT: Issue was that my world folder was outdated, I loaded it as the default world so minecraft could convert it. now it works great

Share This Page