[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    Plugins that use Permissions (2.1+) can likely be configured to be per-world simply by not granting permission on some worlds. Obviously, this works only if the plugins provide permission nodes for everything you want to block.

    I made use of this to only allow General's /i to work on the creative world (and MultiInv to keep you from moving stuff between them).
  3. Offline


    How much more RAM do the extra worlds use? I'm starting to look into hosting my current personal stuff online and currently have 5 worlds with it but will probably be adding 2 or 3 more. So just wondering what options I should be looking at for RAM. The server will probably have 10 people as a maximum who'd have access.
  4. Offline


    I keep getting the same EXACT text when starting the server:
    16:41:14 [SEVERE] null; mapping values are not allowed here loading MultiVerse v
    1.5 (Permissions 2.1+) (Is it up to date?)
    mapping values are not allowed here
     in "<reader>", line 42, column 27:
        default: rrespawntodefault: false
            at org.yaml.snakeyaml.scanner.ScannerImpl.fetchValue(ScannerImpl.java:74
            at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.ja
            at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:18
            at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(Par
            at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
            at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
            at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
            at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:12
            at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
            at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
            at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
            at org.bukkit.util.config.Configuration.load(Configuration.java:73)
            at com.onarandombox.Rigby.MultiVerse.MultiVerse.onEnable(MultiVerse.java
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:83)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:61)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
            at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Everything else seems to work fine. And my default world is 'r', and I have quite a bit of plugins (16).
  5. Offline


    Ram use for additional worlds is fairly minimal. About the only thing that is kept in memory is the spawn area. Beyond that memory use scales per-player as normal (each player forces the chunks near them to stay in memory, regardless of world).
  6. Offline


    Man im just having nothing but problems now with this mod playing well with others

    I am trying to have a creative world with a RP type world with mcmmo, iconomy, towny and some others along side my standard creative build world...

    Every once in awhile now though as im testing the new world before opening it up to everyone(or telling them about it) i get stuck in my Rp world and every time i try to teleport back i get a internal error..looking at the log i get something like this

    Is this worldguard thats causing this issue? It pops up saying something similar for all my plugins...cant pass X to big brother, cant pass X to Auto Repair, cant pass X to mcmmo...

    *EDIT* Nope i removed worldguard still stuck in my RP world and i cant get out lol it just pops this error up for basically every mod i have installed that it cant pass PLAYER_COMMAND_PREPROCESS or it cant pass PLAYER_JOIN to bigbrother or mcmmo...

    Maybe worldEdit?

    Mods installed(theres alot)
    Minecart Mania

    Craftbukkit 531, all the latest versions of these mods that ALL support Build 531.

    All of these mods have played together 100% perfectly fine...but something isnt with Multiverse...the only way I know how to fix this is to kill my multiverse created world and make a new one...then i can TP too it and from it perfectly fine...but randomly something happens(or some command im issuing from another mod in the new world does something) and then im SOL and i cant get out without deleting the world no matter how many times i restart the server.

    The more time i spend messing im starting to think its Permissions 2.5.4 thats causing it? I cant even run permissions commands after this happens but ever other thing works...
  7. Offline

    Celtic Minstrel

    @FuzzeWuzze - You have tabs in your yml file, probably your Permissions one. Replace them with spaces.

    @Reed501 - I'm not too familiar with Multiverse's config file format; do you know what "default: rrespawntodefault: false" is supposedto mean? If not, I suggest pasting your Multiverse config (inside [ code ] tags) so that Rigby can look at it and see what's wrong.
  8. Offline


    @Rigby90 Bugreport. The "/mvtp world" if the player is in another world and use this command to teleport between worlds it takes that person to the world default spawn location even if you use /mvsetspawn. Making them have to use the command 2x to get to the /mvsetspawn location. But if people use portals they go to the /mvsetspawn location.

    If you need more of a example feel free to come to mc.mcdominion.net and I will show you what I mean.
  9. Offline


    was support ot be /mvpd p:[name]

    my bad.

    MultiVerse v 1.5
    CraftBukkit v556 Recommended Build

    Portal Destinations not working?

    When I make a portal, everything is fine. No errors and such. But then I make a portal to portal destination, it doesn't work.

    I used these 2 commands: /mvps YangSpawnPortal and /mvpd Yang

    I tried no destination as the quote says the destination will be place on the players cord's.

    BUT the server and client says nothing. There is no recognition of the command being typed. Am I doing something wrong?

    Portals to different worlds work fine.
  10. Offline

    John Kapsis

    Hey all, i was so thrilled about multiverse that i showed it to a friend of mine, he then got it around our college and everybody loved it BUT a few couldn't figure it out (i don't know what they are on) so i made a video covering the basics, it's not that great but it might help a nooby so... tell me what you think!

    check my vid, maybe it will help you...
    if there is something you still don't uderstand let me know, i'll be glad to help!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  11. Offline


    im having similar issues with multi world with world_move

    23:38:55 [SEVERE] Could not pass event PLAYER_MOVE to MultiVerse
    java.lang.IllegalStateException: Failed to add player. net.minecraft.server.Enti
    tyPlayer@10a0(mexicanjezus at -91.5,65.62000000476837,-12.5) already is in chunk
     -8, -3
            at net.minecraft.server.PlayerInstance.a(PlayerInstance.java:38)
            at net.minecraft.server.PlayerManager.a(PlayerManager.java:76)
            at org.bukkit.craftbukkit.entity.CraftPlayer.teleportTo(CraftPlayer.java
            at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerMove(MVPla
            at org.bukkit.plugin.java.JavaPluginLoader$7.execute(JavaPluginLoader.ja
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:124)
            at net.minecraft.server.Packet10Flying.a(SourceFile:126)
            at net.minecraft.server.NetworkManager.a(SourceFile:230)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:76)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    23:38:56 [SEVERE] java.lang.NullPointerException
    23:38:56 [SEVERE]       at uk.co.tggl.Pluckerpluck.MultiInv.MultiInv$1.run(Multi
    23:38:56 [SEVERE]       at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainT
    23:38:56 [SEVERE]       at net.minecraft.server.MinecraftServer.h(MinecraftServe
    23:38:56 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftSer
    23:38:56 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(Sour
    23:38:56 [SEVERE] Unexpected exception
            at uk.co.tggl.Pluckerpluck.MultiInv.MultiInv$1.run(MultiInv.java:85)
            at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(C
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:345)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
  12. Offline


    Well, that kind of helped, ty :D
  13. Offline

    John Kapsis

    Your welcome!!!
    nice to have helped!
  14. Offline


    Thank you I appreciate any help I can get atm, I'm currently in a situation where I don't have much time to get things done so having people do things like this as well as others like 'Celtic Minstrel' who are responding here trying to help people out is great.

    To everyone else, I'm just going to grab my lunch then try my best to respond to all of you who I've missed over the past couple of days.
    cengbrecht likes this.
  15. Offline


    Now it does work but it removes the prefix. Has this anything to do with it not able to pass things to ichat?
  16. Offline


    Any news on whether this is working for iConomy 4 yes with charging for portal usage?
  17. Offline

    John Kapsis

    Heres how i thought and did this:
    1)Thats so great i love it!!!
    2)Since i like it so much i should support it! (pay an x amount of $ that i can spare)
    3)I DON'T HAVE ANY MONEY!!! (recently fired and not gonna get a job any time soon... (DAMN MY LUCK))
    4)Well there must be something i can do, we will see.
    ---a few days later---
    5)(While reading posts about ppl not been able to get it right (wtf?))
    Hey!!! i could make a couple of tutorials!!!
    6)Made the first one!!!
  18. Offline


    What is the syntax for the white/blacklist ?
    And what is worldBlacklist?
  19. Offline


    Hi I would like help with this plugin :/
    I want to have the permissions the same for both worlds and when I put the name of the other world into:
            system: default
            copies: Planetoids
    It wont let me use the commands and says I dont have to permissions
    It works fine without multiworld tho
  20. Offline


    Can somebody tell excacly how to make these portlas, i don't understand this...

    I made it!! Thanks for this awesome plugin! :D
  21. Offline


  22. Offline


    i have a question... when i try the /mvpc [name] doesnt work... i mean it says i do not have permissions and i already put myself as admin and put my name under for all the
    - '*'
    - 'multiverse.portal.create'
    - 'multiverse.world.create'
    - 'multiverse.world.import'
    - 'multiverse.world.remove'
    - 'multiverse.tp'
    - 'multiverse.world.setspawn'
    - 'multiverse.world.spawn'
    - 'multiverse.list'
    - 'multiverse.portal.select'
    - 'multiverse.portal.destination'
    - 'multiverse.portal.remove'
    - 'multiverse.portal.list'
    so it looks like this:
    default: false
    prefix: ''
    suffix: ''
    build: true
    - '*'
    - 'multiverse.portal.create'
    - 'multiverse.world.create'
    - 'multiverse.world.import'
    - 'multiverse.world.remove'
    - 'multiverse.tp'
    - 'multiverse.world.setspawn'
    - 'multiverse.world.spawn'
    - 'multiverse.list'
    - 'multiverse.portal.select'
    - 'multiverse.portal.destination'
    - 'multiverse.portal.remove'
    - 'multiverse.portal.list'
    but idk if im doing anything wrong,... btw i put my name under admin in group and copied the permission commands again into my name... please help

    could someone make a tutorial on youtube about installing and editing permissions to make this work? i kinda am in need of this :) thank u

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  23. Offline


    Both permissions plugins clearly state that you DO NOT add anything if you've already got '*'. Also, use [ code ] tags so we can see your indentation.
  24. Offline

    Celtic Minstrel

    Though, I don't think they die if you do; they just ignore it. Feel free to correct me if I'm wrong.
  25. Offline


    How to fix so u can use 2 different inventorys in 2 worlds?
  26. Offline


  27. Offline


    Feature Request:

    On top of the permissions you already have to allow or disallow player-initiated portal creation... Could you add a fee to /mvpc that could be set in the config (with perhaps a ratio or cost increase per portal?)

    I.e. I'd like to allow users to create portals, but I'd like to make the so cost prohibitive that most people would never create one...

    Let's say 25000 money units for a single portal with the expectation that to most people 10000 in our economy at this time is a sizable amount of cash on hand.

    That way groups of people could pool together and build a portal to somewhere they'd like... but you would make it cost prohibitive for people to portal spam the world.

    The practical use that we're using the [Towny] mod on our server and that Nations or Capitols could link to smaller outlying cities to promote expansion or resource harvesting...

    The second part of my request being that to create your first portal it may cost 25000... your second portal may cost 35000 or 50000... in any case, it would cause people to really think about where they were putting portals.

    The alternative is having an op or admin create portals FOR people, but I'd rather see the money removed from the economy to help reduce inflation...

  28. Offline

    Ashik Dinani

    How do i set the coordinates, thank you!
  29. Offline


    Use a wooden pickaxe (or whatever you have set in your config). Left click and right click for positions 1 and 2.
  30. Offline


    How can I make it so people go back to the main world when they die? I've tried all the switches in MultiVerse.yml, but people respawn in the same world as they die.

    Basically, I'm trying to make a world that's impossible to leave without the person dying.
  31. Offline


    Hi. having some trouble creating a new nether map using the /mvcreate netherworld NETHER command. everything else works 100% fine apart from this. (I can create normal maps using the same command)
    here is pastebin:


    bukkit 544, latest multiverse. thanks alot.

Share This Page