[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    I think I just got the same error as Anubis Returns.

    Just in case, here's what I get:
    2011-03-07 20:32:03 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'mvpd
    ' in plugin MultiVerse v1.5 (Permissions 2.1+)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:21)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:77
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:1
            at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:638)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:601)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:595)
            at net.minecraft.server.Packet3Chat.a(SourceFile:24)
            at net.minecraft.server.NetworkManager.a(SourceFile:230)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:70)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:338)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:253)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.ArrayIndexOutOfBoundsException: 1
            at com.onarandombox.Rigby.MultiVerse.MVCommands.MVPDestination(MVCommand
            at com.onarandombox.Rigby.MultiVerse.MultiVerse.onCommand(MultiVerse.jav
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:19)
            ... 12 more
    this was just after I added a world called Netherworld to the server.

    Also, There's ghasts and whatnot in my Netherworld- is there any way to get rid of them? I've turned Spawn-monsters off, to no avail.
  3. Offline


    I'm kind of confused.. I have three worlds, world, mobs, nether. I want mobs not to have monsters and have set the mobs: false in the worlds.yml for "mobs" and it doesn't work. Monsters are still there.

    I'm running cb493, groupmanager, 1.4 mv

    EDIT NEVERMIND.. new ones weren't spawning, but the old ones were still there. It's working fine.. Thanks
  4. Offline


    just wanted to let you know i got my problem fixed. it turns out i had an extra space by one of my admins names in the permissions file. just goes to show how picky this new format is and how important detail is.

    if it helps. even if you don't know what your doing, read through the error reports and test all the pieces one by one to get it worked out for yourself.
  5. Offline


    People dying in the nether are spawning in the nether's spawn point instead of the default world.
    My worlds are named "world" and "nether". I used /mvcreate nether NETHER to create the nether. And portals are being created like in singleplayer.

    here's the end of my Multiverse.yml file.

    #SinglePlayer Styled Nether - You still have to "/mvimport" the World for Nether.
    #The settings below only affect the SPLike portals.
    #SPLike - True/False - Portals without a Destination or Sign will act like a SinglePlayer portal.
    #AutoBuild - True/False - AutoBuild a destination portal if none are found nearby?
    #Nether - Folder/WorldName of the Nether world.
    #Default - Folder/WorldName of the default world setup in server.properties.
    #RespawnToDefault - True/False - When a player dies do we respawn them back to the default world.
    splike: true
    autobuild: true
    nether: nether
    default: world
    respawntodefault: true
    Any thoughts?
  6. Offline


    I had the same problem, do you have essentials installed ? This seemed to conflict for me. Replaced it with CommandBook, and all good :)

    Just a wild stab in the dark, but is it case sensitive (as it's Java), so maybe RespawnToDefault instead of respawntodefault.

    I'm not anywhere near my server, so can't test it.
  7. Offline


    This plugin is getting rather difficult.

    I've now started with a completely clean server. Only permissions 2.5.2 and multiverse installed.
    With default everything, the plugin loads fine, it finds permissions and everything is good. But when I try to use any commands, it says I do not have access. Understandable.
    So I edit the permissions config file to include my name under the admins group, which has '*', acess to all commands. The plugin loads, but I still have no access to any commands.

    So far, my permissions file is as follows:

    So what I do is change it to this. This is all I change, I touch nothing else at all:

    I add '*' to my user, and all of a sudden this happens:
    21:09:53 [INFO] [MultiVerse] Commands are disabled unless Permissions is found.
    21:09:53 [INFO] [MultiVerse] - Version 1.5 (Permissions 2.1+) Enabled

    How am I supposed to use this plugin if I can't give myself access to the commands?
  8. Offline


    Chances are another plugin is interfering, I can't remember if I changed the priority level on the event in v1.4, can you list the other plugins you use?
    It works with the latest RECOMMENDED build, that's build #493...

    I'm not supporting higher than that publicly... I will be updating locally however, but I will not be officially supporting it and releasing it because it will just cause issues. The idea is to keep plugins working for the latest recommended build that way servers have something to go by.
    A clientside mod could possibly be made... however I'm not the person to go to for it :).
    Apologies I couldn't assist you further with it, however it comes as no surprise that Essentials was part of the cause... Chances are SpawnControl was fine as several other servers run it alongside MultiVerse... however Essentials has a tendency to piss over all other plugins.

    Again, glad you got it working and I hope the plugin suits your needs and doesn't cause any hassle :).
  9. Offline


    No worries fella, and thanks for the mod :)
  10. Offline


    The idea is, you select 2 coordiantes using both left click and right click with a Wooden Pickaxe. Then the area between those 2 coordinates can be turned into a portla using "/mvpc NAME", this means that if anyone comes in to contacts with this area they will be teleported.

    So if you wanted to turn a NetherPortal into a portal you would... as an example left click the bottom left obsidian block, and right click the top right obsidian block. Type the portal create command, assign it a destination and then whenever a user enters that area (So the portal blocks) they would be teleported to the destination.
    I can't remember if its possible to set the server.properties value to false and then multiverse settings to true... The idea behind it is to leave PVP and Mob spawn as true in the server.properties and then disable them within MultiVerse. However this doesn't allow the AutoHeal, but in the next version I have allowed the server to disable health per world as well, hopefully this will give you what you need.
    Have you restarted the server to check everything reloads correctly? Can you pastebin your server startup log and permission files? All I can think is its either not setup correctly or Permissions 2.5.3 has changed some things preventing it from working.
    Can you zip up your server without the world map and any sensitive files? Don't recall anything majro changing between 1.2 and such that would cause portals to break.
    Ok, will look into the error. Regarding the Ghasts that is a limitation in the current versions which has been sorted in the new version which I keep saying is coming out 'soon' but will have to see.

    Basically when the world is generated it adds animals/monsters to the world as well, all the MultiVerse option does is stop them from spawning... but if they've already spawned then theres nothing it can do.
    Ok looks like it's not handling the command correctly, will hopefully have this sorted for the next version.
    Will look into it, I'm splitting the plugins up anyways and there will be a seperate SPLike plugin which should hopefully ease things and enforce respawning to the default world etc.
    The issue is not with my plugin but with your Permissions Setup, you used a TAB infront of "- '*'", YAML hates tabs and such, use spaces instead of tabs and run your config through a YAML Parser to verify its formatting and such.
  11. Offline


    Wondering if a load screen could be on some future todo list? One of the only things my users have problems with is that it looks all wonky while waiting for chunks to load.

    I know you're currently in a rewrite-- simply wondering if it's even possible via bukkit.
  12. Offline


    I don't think it's physically possible, the fact that we can't even tell the client they're in a nether or normal world atm most likely means we cant force a loading screen or anything... However Mojang/Notch mentioned they wanted to allow GUI Hooks etc... so it maybe possible to display a form of loading bar or something to cover the screen whilst loading in.

    Will see in the future :), but I doubt it's anytime soon.
  13. Offline


    Im Very much New to this community and hope to help A LOT. In your position, What i did was i went to my Minecraft Sever Client (CMD,GUI) and Typed: op [PLAYERS NAME]
    Notice you get a message you are opped and now you can use those commands.
    How Do I get a Portal to transport me to another Portal?
    Portal 1: MLGor
    Portal 2: JsHouse
    I Selected my First Potral "/mvps MLGor"
    Then i tryed you choose its destination by using the command "/mvpd p:JsHouse"

    What am i doing wrong? or am i just not getting it? :p
  14. Offline


    Is there a way to configure this and runecraft so that only one world will have access to runecraft?
  15. Offline


    That would be up to Runecraft. If it uses Permissions, then you could grant permissions on one world and not the other. But there's nothing MV can really do to force the issue. Plugins are per-server, not per-world.
  16. Offline


    i believe you're plugin is looking for permissions.jar rather than Permissions.jar
    The difference being case sensetivity, the problem with that is... My files are case sensetive and as a result it causes problems :/

    Any chance you can fix that?
  17. Offline


    I ran my yml through a parser, and as far as I can tell it's all good, but I still do not have access to ANY command. Is there anything specific I have to give myself other than '*' or "multiverse.*'
  18. Offline


    Is there any way to rename a world?
  19. Offline


    http://dl.dropbox.com/u/199381/Bukkit 1.3.rar
    Above, thanks.
  20. Offline


    @Jaiden207 I'm not sure case is your issue. I'm on linux with "Permissions.jar" and everything is functional.

    @Alevyr Check your server log to see if MultiVerse is coming up at all. If you don't see anything, paste it for us in spoiler tags. (Just <spoiler></spoiler> with square brackets instead of angle brackets around your text).

    @gilros Yes, you can rename the folder and edit the corresponding entry in plugins/MultiVerse/Worlds.yml (While your server is down!)
  21. Offline


    Thanks for the quick response!
  22. Offline


    It doesn't look for any files in particular, it checks to make sure the Permissions plugin has been loaded into Bukkit. It checks to see if CB has loaded a plugin by the name Permissions, however this could be any plugin which has taken up the name 'Permissions' in its Plugin.yml file. So the file could be called 12345.jar and it will still find Permissions. However in your case it sounds as if it isn't finding it.

    Can you pastebin your server startup log.
    As I said before the line that gives you - '*' has a tab infront of it in the version you uploaded for me to download, therefore it's potentially erroring or ignoring the line full stop.

    Can you pastebin your server startup log instead then... Theres not much I can do regarding Permissions setup as it is not my plugin and not my area.
    The setup/commands you typed there was correct. However the plugin relies on the Permissions plugin and not whether a user has OP or not.
  23. Offline


    hey, recently i've been trying to use your mod but everytime i try to use a command i get totld i dont have permission :/ i asked theyeti and he said that the config for permission should be on here or something, can you help me out? :)
  24. Offline


    I know, I removed the tab and replaced it with spaces.

    This is my server start up log. As far as I can understand, it seems MultiVerse found permissions but returned an error about it's version, despite permissions being up to date, as I reinstalled it yesterday?

    Show Spoiler
    15:59:15 [INFO] Starting minecraft server version Beta 1.3
    15:59:15 [INFO] Loading properties
    15:59:15 [INFO] Starting Minecraft server on *:25565
    15:59:15 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-493-
    g8b5496e-b493jnks (MC: 1.3)
    15:59:15 [INFO] Preparing level "world"
    15:59:15 [INFO] Preparing start region
    15:59:16 [INFO] Preparing spawn area: 65%
    15:59:17 [INFO] [General-0.0] Loaded.
    15:59:17 [INFO] [Permissions] version [2.5.3] (Phoenix) was Initialized.
    15:59:17 [INFO] ChatBukkit v0.0.1 is enabled!
    15:59:17 [INFO] [General-3.1] [Codename: Wagner] Plugin successfully loaded! Usi
    ng [Basic (isOp)] permissions.
    15:59:17 [WARNING] [General-3.1] [Help] isn't detected. No /help support; instea
    d use /general help
    15:59:17 [INFO] [HeroicDeath] enabled.
    15:59:17 [INFO] Lockette version 1.2.2 is being enabled! Yay!
    15:59:17 [INFO] Lockette: Detected craftbukkit jenkins build [493] ok.
    15:59:17 [INFO] [Permissions] version [2.5.3] (Phoenix) loaded
    15:59:17 [INFO] Lockette: Linked to Nijikokun's Permissions plugin version 2.5.3

    15:59:17 [INFO] Lockette: Ready to protect your containers.
    15:59:17 [INFO] [MultiVerse] Permissions Found
    15:59:17 [INFO] [MultiVerse] - Version 1.5 (Permissions 2.1+) Enabled
    15:59:17 [SEVERE] while scanning for the next token; found character '\t' tha
    t cannot start any token loading MultiVerse v1.5 (Permissions 2.1+) (Is it up to
    while scanning for the next token
    found character '\t' that cannot start any token
    in "<reader>", line 13, column 1:


    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.ja
    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:18
    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(Par
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:12
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)

    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
    at org.bukkit.util.config.Configuration.load(Configuration.java:73)
    at com.onarandombox.Rigby.MultiVerse.MultiVerse.onEnable(MultiVerse.java
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:118)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:83)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:61)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    15:59:17 [INFO] Nether v1.1 enabled
    15:59:17 [INFO] [PlugMan] Starting Up! - Version: 1.2.2 by bekvon
    15:59:17 [INFO] [PlugMan] Found Permissions Plugin!
    15:59:17 [INFO] ScrapBukkit version 0.2.1 is enabled!
    15:59:17 [INFO] Warpz0r version 1.06 is enabled
    15:59:17 [INFO] [Tombstone] Using Permissions 2.5 (2.5.3) for permissions
    15:59:17 [INFO] WorldEdit 4.0-beta8 enabled.
    15:59:17 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin
    for permissions.
    15:59:17 [INFO] Done (0.228s)! For help, type "help" or "?"
  25. Offline


    Ok then looking at that it's showing that there is an error within the worlds.yml which seems to be a tab, your best using the in game commands to setup a world rather than manually editting the file as things like this can happen.

    Sounds like line 13 has a tab in it, run it through the parser to double check... Its finding the tab on startup which is causing an error so therefore its not finishing the rest of the setup and setting up Permissions etc.
    Theres no example permissions config for the plugin, all there is is a list of permission nodes in the original post.
  26. Offline


    Just a couple small questions:

    1. With the sign system, is it possible to name a portal?

    2. With the sign system, is it possible to link one portal to another?

    I didn't see anything in the documentation or the thread about either. Thanks in advance!
  27. Offline


    I've been TRYING to generate a world through in game commands, but It keeps saying I do not have access.

    What I just did, right now, was this;
    Download minecraft_server.jar from the minecraft website.
    Download craftbukkit from this page, http://wiki.bukkit.org/Main_Page the VERY LATEST version, the snapshot from 4 days ago. I also tried this with the latest reccomended build.
    I recreated my start.bat
    I redownloaded both permissions and multiverse
    I installed them. I touched NOTHING in any of the files.
    I started my server, and got this;

    Show Spoiler
    16:35:17 [INFO] Starting minecraft server version Beta 1.3
    16:35:17 [INFO] Loading properties
    16:35:17 [INFO] Starting Minecraft server on *:25565
    16:35:17 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-506-
    g4e9d448-b522jnks (MC: 1.3)
    16:35:17 [INFO] Preparing level "world"
    16:35:17 [INFO] Preparing start region
    16:35:19 [INFO] Preparing spawn area: 4%
    16:35:20 [INFO] Preparing spawn area: 8%
    16:35:21 [INFO] Preparing spawn area: 8%
    16:35:22 [INFO] Preparing spawn area: 12%
    16:35:23 [INFO] Preparing spawn area: 16%
    16:35:24 [INFO] Preparing spawn area: 16%
    16:35:25 [INFO] Preparing spawn area: 24%
    16:35:26 [INFO] Preparing spawn area: 28%
    16:35:27 [INFO] Preparing spawn area: 32%
    16:35:28 [INFO] Preparing spawn area: 32%
    16:35:29 [INFO] Preparing spawn area: 40%
    16:35:30 [INFO] Preparing spawn area: 44%
    16:35:31 [INFO] Preparing spawn area: 48%
    16:35:33 [INFO] Preparing spawn area: 53%
    16:35:34 [INFO] Preparing spawn area: 60%
    16:35:35 [INFO] Preparing spawn area: 65%
    16:35:36 [INFO] Preparing spawn area: 69%
    16:35:37 [INFO] Preparing spawn area: 69%
    16:35:38 [INFO] Preparing spawn area: 77%
    16:35:39 [INFO] Preparing spawn area: 81%
    16:35:40 [INFO] Preparing spawn area: 85%
    16:35:41 [INFO] Preparing spawn area: 89%
    16:35:42 [INFO] Preparing spawn area: 89%
    16:35:43 [INFO] Preparing spawn area: 93%
    16:35:44 [INFO] Preparing spawn area: 97%
    16:35:45 [INFO] Preparing spawn area: 97%
    16:35:45 [SEVERE] Could not load plugins\Permissions.jar in plugins: null
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:59)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
    ... 8 more
    Caused by: java.lang.NullPointerException
    at com.nijikokun.bukkit.Permissions.Permissions.<init>(Permissions.java:
    ... 13 more
    16:35:45 [INFO] [MultiVerse] Commands are disabled unless Permissions is found.
    16:35:45 [INFO] [MultiVerse] - Version 1.5 (Permissions 2.1+) Enabled
    16:35:45 [INFO] [MultiVerse] Loading World & Settings - 'world' - NORMAL
    16:35:45 [INFO] [MultiVerse] 1 - World(s) loaded.
    16:35:45 [INFO] [MultiVerse] Loading Portals
    16:35:45 [INFO] [MultiVerse] 0 - Portal(s) loaded.
    16:35:45 [INFO] Done (2.804s)! For help, type "help" or "?"

    All I've done is install the plugins, make the start.bat and run it. Nothing else. :\
  28. Offline


    Really nice plugin! Thanks!

    I just have a small feature request which is really simple and I think it shoudnt be so
    difficult to implement.

    The feature is that it should be possible for admins or ops to teleport other player to another world.
    For example you can extend the /mvtp command like this "/mvtp <player> <world>"
    Or just add a new command like "/mvtpp <player> <world>"

    Perhaps i will try to implement this myself and submitting a patch or something like that
    but i am not the best coder so dont't expect anything :D.
    EDIT: Oh forgot! MV isnt opensource... Just thought that it is.

    But otherwise a greate plugin! Keep on working!
  29. Offline


    What method are people using to backup their other world files? I'm using SimpleServer as a wrapper (ditching it soon) and it only backs up the main world folder. The Backup Plug-in for Bukkit only supports 1 world folder.
  30. Offline


    Will be working on a side plugin to go along with MultiVerse which will provide timed backups (possibly incremental) per world.
    Will just comment on this for now as I'm in uni for the next 20 or so minutes....

    Regarding the ability to teleport other players, this is being implemented as I see it as a necessity, regarding open source --

    The current versions arnt open source as such... there is a Github repo which was put up to allow someone to browse the code, however it is quite messy and such hense the rewrite... The rewrite is open source and on github... When the new version is out I will post the link but feel free to search for it till then :).
  31. Offline


    what is the title above the node? :)

Share This Page