[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    I definitely like the portal system - its very easy to use - my only worries is that it ports to the left (and sometime in the wall)
  3. Offline


    Would it be possible for this plugin to make it so you had different inventories for different worlds? That would be really nice, being able to have a building world and a survival world.
  4. Offline


    sorry about the newfaggotry, but i don't really understand. i have a world i want to use as well as my current one, isn't there a folder i can put it in? if i want to use a map in C:\Users\<name>\Documents, what command do i use?
  5. Offline


    I seem to be having problems setting a portal running Bukkit-0.0.0-450

    trying to select blocks using the default wand produces no visual effect (which may in fact be normal?). Subsequently, trying to name a portal produces this in the server logs--

    2011-03-06 18:05:08 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'mvpc' in plugin MultiVerse v1.5 (Permissions 2.1+)

    I next tried manually setting a portal, which also didn't work, although that gave more descriptive log output.

    Turns out, copying-and-pasting the Portals.yml was a bad idea. It either didn't like the commented-out default, or a line break I had between the comments and my portal definition. Deleting the file and letting the plugin create it on its own did the trick. Hope this helps someone in a similar situation.
  6. Offline


    I'm currently running the latest bukkit version and the recent Multiverse and MultiInv plugins with Permission v2.5. I am wondering if there's a way to add permissions per world. Say, I want to allow spawning items in World1, but disallow in World2, despite us being mods/admins, whatever. But this includes all permissions per world as well. Say, I would like to enable essentials.kit but disallow essentials.item, etc?
  7. Offline


    yes it works with permissions 2.1+ u must create a yml file for each world
  8. Offline


    It lacks the functionality atm however this will be added, until then theres a plugin called MultiInv which should do what you require :).
    --- merged: Mar 6, 2011 10:53 AM ---
    You need to copy the folder from where ever it is to the server folder, you cannot import a folder that is outside of the server directory.
  9. Offline


    Hey, I'm having trouble running this plugin. I have the latest Permissions working and installed, the latest craftbukkit and Multiverse installed. It all runs fine, but I can't create worlds or portals.

    Whenever I try to use /mvcreate to make a world, it says I do not have permission for this command, when I clearly have it set in my permissions file for "*", all commands, as well as "multiverse.*" just to make sure. Both on my group, and my user. Also, /mvpc returns "unknown command" in the console, and nothing in game.

    The plugin also fails to detect permission's config file when I add any lines to the default file. The default file works fine (from the permission download), and it works fine when I add myself to the admin group. But when I add another line to change something, Multiverse immediately stops detecting permissions plugin.

    I am extremely unhappy as there is no documentation on installing apart from "unzip to plugins directory" Thanks, really helpfully obvious. Now what do I do to actually make it work?
  10. Offline


    I'm also have permissions issues.

    Running Multiverse 1.5 with permission 2.5.2

    I've got a config file for each world, and in our test world, everything has all permissions, however when attempting to use a worldedit command I get "You don't have permissions

    Below is from the startup

    2011-03-06 09:50:54 [INFO] [MultiVerse] Permissions Found
    2011-03-06 09:50:54 [INFO] [MultiVerse] - Version 1.5 (Permissions 2.1+) Enabled
    2011-03-06 09:50:54 [INFO] [MultiVerse] Loading World & Settings - 'Gizmoo' - NORMAL
    2011-03-06 09:50:55 [INFO] [MultiVerse] Loading World & Settings - 'Wrights' - NORMAL
    2011-03-06 09:50:55 [INFO] [MultiVerse] Loading World & Settings - 'nether' - NETHER
    2011-03-06 09:50:56 [INFO] [MultiVerse] 3 - World(s) loaded.
    2011-03-06 09:50:56 [INFO] [MultiVerse] Loading Portals
    2011-03-06 09:50:56 [INFO] [MultiVerse] 4 - Portal(s) loaded.

    Thanks in advance
  11. Offline


    I'm sorry but the part you are struggling on is the permissions which is nothing to do with my plugin, also in some situations '/mvpc' does not send a message to the user I am aware of this and the issue has been resolved.

    There is a basic HowTo guide by a user of MultiVerse in the OP. Yes I admit there is a lack of documentation in the OP, however I can do one of two things... I can add to an already existing HowTo which will need replacing in a day or two because of a plugin rewrite... or I can finish rebuilding the plugin turning it into small modules to handle specific tasks and hopefully a lot more user friendly.

    What permissions plugin are you using? Can you pastebin your permissions file.... and pastebin your server startup log.

    I can't do anything to help you unless I have specifics on what versions of plugins etc you are using, and logs.
    The plugin doesnt 'detect' the permissions config itself... It detects the permissions plugin... so if you edit your permissions file and all of a sudden MV stops detecting it... then thats not a MV issue but a Permissions issue. Because all permissions are handled through the Permissions plugin.
    --- merged: Mar 6, 2011 11:55 AM ---
    In this case it is a Permissions or Worldedit issue and definitely not MultiVerse... All I can think is a mistake in the Permissions file and such? I see no reason for WorldEdit to allow a command in one world but not another unless Permissions is messed up.

    You can always Pastebin your permissions files for me to take a quick look, however seeing as it's not an MV issue I can't guarantee you my time at this moment in time.
  12. Offline


    Thanks for your quick response, however the worldedit command was just an example.

    I've taken a copy of my main world permissions, and renamed that to my test world, and given myself the Admin permission which should overwrite all the other commands.


    I've run it through the YAML parser and no errors come up.

    It seems the Admin permission doesn't work.
  13. Offline


    hmm thats strange, can you list all your plugins?

    Am I still right in saying that this is not a MultiVerse issue but a Permissions Multi World issue? In the sense that on non default worlds you don't seem to have any permissions even though it's setup to have the permissions.

    If so I'll get in contact with TheYeti on IRC as hes been using my plugin as a test to ensure that Multi World permissions do work correctly.
  14. Offline


    Cool, currently running the following
  15. Offline


    My plugins are
    World Edit

    and to fix the dieing thing, i had to give everyone god mode to everyon :(
    Plz, if its a plugin or anything i can do to fix this tell me
  16. Offline


    Still unsure as to why this is causing a disconnect error... I will say that in the next version I'm dropping the respawn event as it is no longer needed... However until then it is still a worry. Are you using the Essentials Spawn plugin or something that controls respawn/spawning ?
  17. Offline


    What do you have the config file saved as? test.yml or whatever the world name is? Also what is with the dropchestmaxradius: 10 in the Permissions config file? Another question, are you making sure to only use Permissions. I notice you have Essential stuff in there so is it possible your trying to use GroupManager as well?
  18. Offline


    gonna delete essentail spawn, see if that helps

    edit: does not work :( any tips?
  19. Offline

    Brennan Mathers

    Lol, there are clouds in the nether!
    Posible to fix?
  20. Offline


    hmm will have to keep an eye out then... however because I'm dropping the onRespawnEvent in the next update it should stop erroring on MV's behalf but not sure whats causing it in the first place.

    I guess it's safe to say you have /mvsetspawn at the area you wish to player to spawn/respawn at.
    --- merged: Mar 6, 2011 7:38 PM ---
    Nope :), it's a limitation with the Server/Client atm. Currently on login it sends you the default worlds Environment which most often than not is NORMAL... so clouds, sky etc... But apparently theres no way to resend that packet to say the player is now in a NETHER Environment.
  21. Offline


    I put MultiVerse 1.5 back into my server, CraftBukkit #450, and Towny .46.

    Last night, I received this:
    2011-03-06 02:53:53 [SEVERE] java.lang.OutOfMemoryError: Java heap space
    2011-03-06 02:53:53 [SEVERE]    at java.util.Arrays.copyOf(Arrays.java:2746)
    2011-03-06 02:53:53 [SEVERE]    at java.util.ArrayList.ensureCapacity(ArrayList.java:187)
    2011-03-06 02:53:53 [SEVERE]    at java.util.ArrayList.add(ArrayList.java:378)
    2011-03-06 02:53:53 [SEVERE]    at java.util.Collections$SynchronizedCollection.add(Collections.java:1593)
    2011-03-06 02:53:53 [SEVERE]    at net.minecraft.server.NetworkManager.a(SourceFile:108)
    2011-03-06 02:53:53 [SEVERE]    at net.minecraft.server.NetServerHandler.b(NetServerHandler.java:577)
    2011-03-06 02:53:53 [SEVERE]    at net.minecraft.server.EntityTrackerEntry.a(EntityTrackerEntry.java:135)
    2011-03-06 02:53:53 [SEVERE]    at net.minecraft.server.EntityTrackerEntry.a(EntityTrackerEntry.java:102)
    2011-03-06 02:53:53 [SEVERE]    at net.minecraft.server.EntityTracker.a(EntityTracker.java:109)
    2011-03-06 02:53:53 [SEVERE]    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:359)
    2011-03-06 02:53:53 [SEVERE]    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    2011-03-06 02:53:53 [SEVERE]    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    2011-03-06 02:53:53 [SEVERE] Unexpected exception
    java.lang.OutOfMemoryError: Java heap space
            at java.util.Arrays.copyOf(Arrays.java:2746)
            at java.util.ArrayList.ensureCapacity(ArrayList.java:187)
            at java.util.ArrayList.add(ArrayList.java:378)
            at java.util.Collections$SynchronizedCollection.add(Collections.java:1593)
            at net.minecraft.server.NetworkManager.a(SourceFile:108)
            at net.minecraft.server.NetServerHandler.b(NetServerHandler.java:577)
            at net.minecraft.server.EntityTrackerEntry.a(EntityTrackerEntry.java:135)
            at net.minecraft.server.EntityTrackerEntry.a(EntityTrackerEntry.java:102)
            at net.minecraft.server.EntityTracker.a(EntityTracker.java:109)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:359)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    I had disabled Towny from tracking the Nether.

    I cannot definitively point to MultiVerse causing the issue, as I just can't disable Towny to test. But I know when Towny and MultiVerse are running, the memory leak happens.
  22. Offline


    hmm have you tried running this with the latest recommended build of CraftBukkit? So build #493???


    Not sure if anything in there would have fixed it, will look into the Towny plugin more and check what its functionality is as well as what it does/performs code wise.
  23. Offline


    Have you tried the new recommended build 493?
  24. Offline


    Defo just permissions, not using the groupmanager

    the file is named correctly, Gizmoo.yml and nether.yml, both matching the names of the world

    As for the radius, this I believe is set up correctly based on the following, and works as expected.

    users: narrowtux: info: dropchestmaxradius: 1000

  25. Offline


    I have to say, I've been using MultiVerse for about a day now, and this has spawned a ton of great ideas between my server regulars and I, particularly when it comes to using the new 1.3 beta custom seeds ability.

    1] Design contests-- everyone starts off with a copy of the same seed, with the same permissions, and people rate both design an integration with the given environment at the end of a weekend. I'm definitely curious to see how a render like "Glaciers" would work with this.

    2] "Personal" worlds-- anti-build for everyone but a specified user. I'm working on a quick php script that will let my regulars upload a zip of their current seed (max 5mb-- has to be a largely untouched, newly seeded world).

    I'd love to get more advanced with that and have the script automatically update a portal with the location of the new world and send me an email to reboot the server, but I'm going to hold off until I see what this plugin rewrite brings. I'm all for user-friendliness, but if at all possible I'd love to see console commands stay in some capacity...scripting this stuff can have some great results.

    3] Cycling through maps-- great for PVP

    The only other question I've had after playing around with it a bit is...how the heck do I get nether to act like nether? I think the problem is that I'm starting Bukkit via McMyAdmin, and it has nether turned off. Since McMyAdmin doesn't have multiworld support, it's an all-or-nothing situation when it comes to actually seeing all that horrific lava and ghasts. Is there any way around this short of ditching McMyAdmin?
  26. Offline



    I was running wormhole xtreme but it was erroring out so I found this and it looks like it could be much more awesome. However I just installed it and set it up to provide default nether functionality. Havnt messed with any other worlds or anything yet and when I enter a portal I get the following:

    16:04:41 [SEVERE] Could not pass event PLAYER_MOVE to MultiVerse
            at com.onarandombox.Rigby.MultiVerse.MVTeleport.canTravelFromWorld(MVTel
            at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerMove(MVPla
            at org.bukkit.plugin.java.JavaPluginLoader$7.execute(JavaPluginLoader.ja
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:123)
            at net.minecraft.server.Packet10Flying.a(SourceFile:126)
            at net.minecraft.server.NetworkManager.a(SourceFile:230)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    I am running CB 493 and the following plugs (all latest versions):
    Essentials (Ban, God, Help, Home, Spawn, Tele, Warp)
    MineCart Mania

    Any thoughts?

    Thanks for your work and your assistance. :)
  27. Offline


    Can you pastebin your worlds.yml?
  28. Offline


    I'm having these too, and have been looking at all my plugins, this may help as it shows the one thing we have in common is Multiverse. Can the plugin author shed any light on this to aid us in finding out if this problem is caused by Multiverse? :( Please.
  29. Offline


    That was related to a threading issue which should be fixed in build #493. What build are you using?
  30. Offline


    Sure :)

    worlds.yml: http://pastebin.com/pX4Zf67R
    (dont think i've changed anything here) (it generated a "nether" world folder automatically after setting splike to true... But I see it didnt add it here. Do I need to do that manually?


    MultiVerse.yml: http://pastebin.com/5mH2jiiu
    Here you can see I set splike and respawntodefault.

  31. Offline


    hmm strange, will look into that... however can you type "/mvimport NAMEOFNETHER nether" This will import the world into the setting as the nether environment.

Share This Page