[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    Sorry for the bump but has anyone else reported this?
  3. Offline


    Yeh you hear explosions from opposite worlds etc, its just a bug which I don't think can be fixed by Bukkit.
  4. Offline


    Yeah Its pretty crazy to see the explosion and the see the blocks come back. Spawn protection applies across worlds too it seems.
  5. Offline


    The download link seems to be down.
  6. Offline



    If you mean MultiVerse then... the servers up, it's currently in use by me etc... May just be routing issues.
  7. Offline


    Yes I did, but it's just my computer, seems to not be able to get past 9 hops from my router.... just had someone send to me through skype after you said it's up.

    Thanks! :)
  8. Offline


    Update for the newest permissions????? PLEASE!!!!????[​IMG]
  9. Offline

    Rick Boss

    I apologize in advance if this has already been answered, but I do not intend to read through the last 5 pages of posts.
    Quick question: Are you planning on updating to support 2.4, 2.5, etc? The one by The Yeti? He's (officially?) taken over development, as he says it has been handed over to him by Niji herself. This plugin is keeping me up at night cause of requiring the older Permissions. Too much conflict between some mods wanting 2.0/2.1 and others wanting 2.4/2.5 and so on.
    I absolutely love this plugin, and do not mean in any way to disrespect. I'd love it if there was the option to use a built in permissions system, just for this plugins commands, so there wasn't this vital dependency on such an unstable plugin (Permissions).
  10. Offline


    This seems to cause conflicts with other plugins with permissions 2.5
  11. Offline



    Someone go slap all these Permission developers upside the head.

    I'll take a looksy in a second, the chances are I'll update to 2.5 Support and skip 2.4.
    --- merged: Mar 1, 2011 3:36 AM ---
    Ok just spoken to TheYeti who has taken over Permissions development... He said theres no change from 2.1-2.5 that would/could break the plugins and that they should be compatible. Not only that apparently he used MultiVerse as one of the plugins to test against and said it works fine.

    In that case, i'm not sure what's going on and which plugin is causing the issues.

    Can you provide http://pastebin.com links for your server logs?
  12. Offline


    you should move over to GroupManager....
  13. Offline


    Help! More new errors :(

    [SEVERE] Could not pass event PLAYER_MOVE to MultiVerse
    	at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerMove(MVPlayerListener.java:224)
    	at org.bukkit.plugin.java.JavaPluginLoader$8.execute(JavaPluginLoader.java:165)
    	at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    	at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:225)
    	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:115)
    	at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    	at net.minecraft.server.NetworkManager.a(SourceFile:230)
    	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:70)
    	at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:338)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:253)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)

    2011-03-01 03:38:13 [SEVERE] java.lang.IllegalStateException: Failed to remove player. net.minecraft.server.EntityPlayer@131d48 isn't in chunk -51, 120
    2011-03-01 03:38:13 [SEVERE] 	at net.minecraft.server.PlayerInstance.b(PlayerInstance.java:49)
    2011-03-01 03:38:13 [SEVERE] 	at net.minecraft.server.PlayerManager.b(PlayerManager.java:101)
    2011-03-01 03:38:13 [SEVERE] 	at net.minecraft.server.ServerConfigurationManager.c(ServerConfigurationManager.java:113)
    2011-03-01 03:38:13 [SEVERE] 	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:556)
    2011-03-01 03:38:13 [SEVERE] 	at net.minecraft.server.NetworkManager.a(SourceFile:234)
    2011-03-01 03:38:13 [SEVERE] 	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:70)
    2011-03-01 03:38:13 [SEVERE] 	at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-03-01 03:38:13 [SEVERE] 	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:338)
    2011-03-01 03:38:13 [SEVERE] 	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:253)
    We reverted to CB440, now this happens in huge spammy bursts that lag the server.
  14. Offline


    I did initially think that when Niji through his fit and quit... however TheYeti is doing a great job in keeping the plugin alive... the great thing with GroupManager is its FakePermissions plugin.... this allows for plugin devs to develop plugins against Permissions.... but for Server Admins to then use GroupManager.... win win situation...

    Atm it's just causing a split....
    --- merged: Mar 1, 2011 4:09 AM ---
    Yeh I've come across the error before... Did you by any chance /reload whilst people were either logging in or moving around? Basically theres a bug atm where if a player joins before MV is fully loaded they dont get assigned a PlayerSession so then they will constantly cause errors whilst moving.

    I have this fixed in the new moduled version though, only fix for it would be to get people to relog... or try not to /reload too often during peak times where people are constantly leaving and joining.

    Apologies for the issue :).
  15. Offline


    Did not reload (we've switched to commandbook so we can't even do that anymore), it was also causing the old problems that were occuring on 477.
  16. Offline


    I am having a problem where my default group members cannot build in the nether (my only other multiworld at the moment) The config says "true" to build, so i'm lost... I apologize if this is another plugins doing.

    I am on Permissions 2.3, as I hear from this thread there are possible issues with 2.4 (downgraded recently to try to fix that)

    Any information on this would be amazing, I'm completely lost as to what's going wrong!

    Note: CB: 432 Multiverse: 1.4
  17. Offline


    is there a way to get rid of [World] When people speak? thanks!
  18. Offline


    #Prefix Chat with World Name.
    prefix: true

    to #Prefix Chat with World Name.
    prefix: false
  19. Offline


    Thanks for the quick reply, but can you tell me what folder this is located in? Thanks lots!
    --- merged: Mar 1, 2011 4:40 AM ---
    ahh found it nevermind, the settings were all clumped up lol thanks
  20. Offline

    Tyler Ferm

    I just went with the recommended version and reinstalled the plugin and have no problems.
  21. Offline

    Six en Seven

    I keep getting 'You do not have permission to access this command.' no matter what I do to the config.yml for both world.yml or the other world I'm working on. I've tried everything, including reading every page of this thread. I love how dedicated you are to your plugin- frequently solving issues. Very frustrated with all of these plugin updates. :(
  22. Offline


    ok, please copy your permission file to pastebin.com, ill have a look at it
  23. Offline

    Six en Seven

    Alright, Here you go: http://pastebin.com/3nKmTqqw

    Hopefully you'll figure out the problem before I do.

    Also I realize how badly my permissions file is. I'm very recent to being an Administrator.
  24. Offline


    you only forgot an ' at the and of the last line
    and as admin you shouldnt have any other permssions after '*'
  25. Offline

    Six en Seven

    I realize both of those, but I thought I would give it a shot.
    The ' at the end was an error due to failed CTRL-C & V.

    Either way, Multiverse refuses to allow me access to the commands.. :(
  26. Offline


    ok, you are an admin? you only have the '*' in permissions for admins? you could use commands from other plugins? you get an error in the serverlog? your get an ingame "no permissions for..."?
  27. Offline


    I have the same problem as Six en Seven :(
    I have tried everything it just says: you dont have the rights to access this command.

    # System is no longer used, but may become used in the future
    # Copies is for multiple-world support
    # Put the name of the world you wish for it to be a clone of, otherwise leave it empty.
    # Does not work for the default world.
    system: default

    # Groups can contain inheritance.
    # To make a group inherit the permissions from another
    # group simply place the groups name in the "inheritance:" like so:
    # Example:
    # inheritance:
    # - Default
    # All permissions including the asterisks must be placed in single quotes.
    # like so:
    # - 'general.spawn'
    # Otherwise errors will happen!
    # Globalized Permission settings:
    # If a permission contains periods (.) you can denote a globalized parameter:
    # - 'general.*'
    # This will allow you to use all general commands.
    # Single Asterisk denotes all commands:
    # - '*'
    # To exempt a node use the - prefix like so:
    # - '-general.time'
    default: true
    build: false
    - 'general.spawn'
    - 'iConomy.payment'
    - 'iConomy.list'
    - 'iConomy.rank'
    default: false
    build: true
    - Default
    - 'general.time'
    - 'general.teleport'
    - 'general.teleport.here'
    - 'general.player-info'
    default: false
    build: true
    inheritance: Moderator
    - 'multiverse.world.create'
    - 'multiverse.world.import'
    - 'multiverse.world.remove'
    - 'multiverse.tp'
    - 'multiverse.world.setspawn'
    - 'multiverse.world.spawn'
    - 'multiverse.list'
    - 'multiverse.portal.create'
    - 'multiverse.portal.select'
    - 'multiverse.portal.destination'
    - 'multiverse.portal.remove'
    - 'multiverse.portal.list'
    - '*'
    # DarkGrave has control over all commands.
    group: Admin
    - '*'
  28. Offline


    please dont post it this way, put it to pastbin.com. but i the one mistake. u got an overload:
    u have double '*' + multiverse permissions. you only need this '*' one time. so delete '* in your own permission and all multivers things in the admin group
  29. Offline

    Six en Seven

    Yeah, there seems to be an issue at hand, either another plugin is making MV ineffective, or the Permissions aren't functioning correctly. Hmm..
  30. Offline


    still not working... i suck at this.
  31. Offline


    ok i dont know, wait for the developer to solve this...
    --- merged: Mar 1, 2011 11:56 AM ---
    ok, because of that u should post ur config to pastebin.com.
    and: to u rename the permssion file to your worldname?

Share This Page