[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline

    Robby Stolle

    just time will cause it to re see it? I did both fixes with permissions and still doesn't seem to work. Eh maybe i'm just burnt out I think ill play with it tomarrow lol
  3. Offline


    Glad to see you both got it working, and yeh Permissions is a pain at times... Can't wait for Bukkit Permissions.
  4. Offline


    so I lied. fixed the config files, getting the same issue, there something else I'm missing in the Permissions setup. Alternatively is there a currently-working permissions documentation you can point me to so I can quit bugging you?
  5. Offline


    Nope, never really looked at the documentation myself and the Google Cache has an old version of the Wiki which was going to be 2.1 before he reworked it.

    Feel free to zip up your server without the world and sensitive files and send it my way.
  6. Offline


    Works great with the Permissions 2.1 you've supplied. Thanks a lot for the speedy update!
  7. Offline


    won't be necessary. Rolled back to permissions 2.0 and just used your 2.0 version (thanks for keeping a backwards-compatible one) I'll upgrade once the permissions mess gets sorted out. Thanks for making such an awesome plugin btw !
  8. Offline

    Robby Stolle

    So magically it worked don't ask lol now I notice your issue with the nether being inside of you know a random block gasping for air but can I have per world rule. IE while in the nether it's ok to spawn back to the main world but on all others to set it up to go back to spawn?
  9. Offline


    Is Anti-build compatible? I have 2 worlds, and I want guests to be able to build in one and not in the other. I have separate 'worldname'.yml files and Build as false in one and true in the other but guests can not build in either.

    Edit: All other permissions are working and changing correctly.
  10. Offline


    I'm having some horrible trouble with permissions, I don't suppose someone could offer some assistance? No matter what I try, it seems that I never have the correct permissions to create a world.
  11. Offline


    - 'multiverse.*'

    That should give all MV commands.
  12. Offline

    Geoff Wilson

    Can't seem to get it working with Permissions 2.1, just says that Permissions isn't enabled/detected, tried the version posted above and still no dice, other things seem to work ok.
  13. Offline


    Yea, I'm having the same exact problem, Geoff.
  14. Offline


    Can you 2 post your Server Log to http://pastebin.com I need to find out in what order the plugins are enabling and such. Wierd how it's working for some but not the others.
  15. Offline


  16. Offline


    Tabs in the permissions file possibly?

    Edit: before "- 'multiverse.*'" make sure its only spaces.
  17. Offline

    Geoff Wilson

  18. Offline


    Permissions files are position sensitive?
  19. Offline

    Geoff Wilson

    you can't have tabs in permissions config, that is your error in the server log about \t
  20. Offline


    Not sure what that exactly means, but no tabs. I imagine its a delimitation issue....

    That one looks like mine before using the provided update above. Maybe delete and replace if you 'overwrote' before... maybe (thats what I had to do)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  21. Offline


    Could someone give me an example permissions file to work with? I'd appreciate it, as I think it's mostly the Permissions plugin that's driving me to madness.
  22. Offline


  23. Offline


    Yeh looking at the log you're still using the first version of 2.1 permissions which had some problems in... he reuploaded it.
  24. Offline

    Geoff Wilson

    stopped server, deleted JAR, uploaded the "fixed" JAR, still no dice, server log is identical to previous one.
  25. Offline


  26. Offline

    Geoff Wilson

  27. Offline


    Yeh my bad I didn't think to check if Permissions had somehow enabled itself before my Plugin, I was only checking if it enabled afterwards...

    Thanks for that :)
  28. Offline


    I'm still having issues, although it's an old one. It's now just saying I don't have the rights to use the command, rather than saying I don't have permissions enabled. I've enabled multiverse.* for the default group, so that should take care of that.
  29. Offline


    Ok two things for you to download :)


    http://bukkit.onarandombox.com/multiverse/v1.4 - Permissions 2.1/MultiVerse.jar

    I alterred MultiVerse as I missed a mistake and that Permissions jar is the one I made the plugin with... so it's the correct version etc.

    If that doesn't work then we'll have to start looking elsewhere.
  30. Offline


    You may be bumping against Permission's use of a seperate .yml file for each world.
  31. Offline


    Would it be possible to implement separate inventories between worlds? Like I wish to have a creative world where people will find unlimited supplies and I don't want them bringing it back to survival world.

Share This Page