[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    Is this going to be updated to 1.2.3?
    mattysamurai likes this.
  3. Offline


    when are you going to update to 1.2.3 pleaze i need it NOW!!!!
  4. Offline


    dude chill, i don't know much but it doesn't sound easy to fix a plugin.
    Marc-D likes this.
  5. Offline


    can we have some guide on how long we have to weight though
  6. Offline


    Hi! I love this plugin! It's very useful! :D
    But I've an issue on my server:
    in my default world, I have a gate (created with CreativeGates) that teleports me to another world created with Multiverse-Core. If I'm not opped, I can't go to that world with that gate, with a warp or in other ways!
    Multiverse says to me:
    Why do I receive this message? How can I solve this problem?
    I tried to add on Permissions 3.x YAML config files the node "multiverse.access.*" but it doesn't work!
    I use craftbukkit 1.1 R3 (build #1846).
    I solved this problem setting enforceaccess: 'false'
    Thanks anyway.
  7. Offline


    can u update to 1.2?
  8. Offline


    Guys, the dev builds although unstable work for me on 1.2.3 so try those out! I also want to report a bug. When using multiverse-portals with multiverse-adventure, when the adventure world is reset, the portals do not get reloaded so unless I restart the server I have no portals!
  9. Offline


    I'm having issues with portals.. It seems that sometimes it is impossible to create blocks in the portal area, other times it's possible, even for non-opped "default/guest" users, so they crap up the spawn with cobble/spawn trees.

    Why is it that sometimes the protection just disppears?
  10. Offline


    im having a problem I cant spawn anymobs at all... i used to be able to but now i cant all the sudden. You can't even spawn golem. PLEASE HELP MEH!
  11. Offline


    Enforceaccess: false just lets everyone go everywhere.
    What you're looking for is multiverse.portal.access.*
    You need both the access to the world and access to the portal.
    If you don't want to restrict any access to anyone to go anywhere, enforceaccess: false is fine.
  12. Offline


    My players keep getting "[mv] - Sorry you can't be in this world anymore!", what should I look into?
  13. Offline


    Hi. Thanks for your answer!
    I tried to add the multiverse.portal.access.* node, but I discovered that my server and all my plugins use the Op System and ignore Permissions! Infact, this node didn't work.
    How can I force Permissions 3.x use?
  14. Offline


    I have been having problems with not being able to spawn monsters any world even know they are enabled in the config file of MultiVerse. I can't even spawn mobs using commands or by making golems... but when i removed multiverse and it worked fine... I have The latest dev build of MV atm. PLEASE HELP MEH

    Bukkit: 2037
  15. Offline


    get the betabuild and not the latest build ^-^
  16. Offline


    Thanks for the reply man but that didnt help :( still cant spawn anything...If you need anything like my configs or list of plugins just ask. PLEASE HELP :oops: Thanks.

    Bukkit: Beta Build (2034)

    Ok I found out that this plugin conflicts with MobArena Some how. It doesnt let you spawn monsters or animals not even with commands!!! This is a HUGE problem! :oops:

    EDIT: Does anyone Know a solution for this?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  17. Multiverse does not work with Permissions 3. Permissions has been dead for around 8 months, there are many converters out there.

    I've heard rumors that people are trying to bring it back. If they do, tell them to make it compatible with the Bukkit SuperPerms API. This will render it useful again.

    Update please. This was a bug :)

    I don't recommend any user update to the latest builds of CraftBukkit for use with Multiverse until the RB of Craftbukkit is out. The Multiverse dev builds work great, but there are still some Multiworld bugs in bukkit.

    If you're brave and don't wish to heed my warning; http://ci.onarandombox.com

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  18. Offline


    I'm using Core b514 on 1.1-R6, and all seems to be working well :)
    Thanks for that!
  19. Offline


    I actually am :D I just say R6 since that's what everyone seems to know of/ask people to update plugins to. I had gotten the email from the mailing list after they made it
  20. Offline


    I'm still looking for some guidance on this issue, I hope you are able to help. If the issue is not in multiverse, does it contradict with any of the follow plugins?:

    Essentials (all)
  21. Offline


    I tried PermissionsBukkit and PermissionsEx, but it's the same: my server use Op System!
    What can I do?
  22. Offline


    Haha yeah I hate dealing with permissions on MC; between naming conflicts, constantly changing systems, counter-intuitive global settings, and lack of example files, I can never figure it out.

    That being said, I use the technically-dead GroupManager thru Essentials. If you use Essentials, it's great. If you don't, it seems kind of crazy to get it just for that.

    AFAIK PermissionsBukkit is not actually where you put the nodes but where you configure global settings for other perms? IDK. Good luck!
  23. Offline


    Thanks fo your quick reply.
    In 'plugins\PermissionsBukkit' folder there is only file: config.yml. I modified its contents in this way:
    # PermissionsBukkit configuration file
    # A permission node is a string like 'permissions.build', usually starting
    # with the name of the plugin. Refer to a plugin's documentation for what
    # permissions it cares about. Each node should be followed by true to grant
    # that permission or false to revoke it, as in 'permissions.build: true'.
    # Some plugins provide permission nodes that map to a group of permissions -
    # for example, PermissionsBukkit has 'permissions.*', which automatically
    # grants all admin permissions. You can also specify false for permissions
    # of this type.
    # Users inherit permissions from the groups they are a part of. If a user is
    # not specified here, or does not have a 'groups' node, they will be in the
    # group 'default'. Permissions for individual users may also be specified by
    # using a 'permissions' node with a list of permission nodes, which will
    # override their group permissions. World permissions may be assigned to
    # users with a 'worlds:' entry.
    # Groups can be assigned to players and all their permissions will also be
    # assigned to those players. Groups can also inherit permissions from other
    # groups. Like user permissions, groups may override the permissions of their
    # parent group(s). Unlike users, groups do NOT automatically inherit from
    # default. World permissions may be assigned to groups with a 'worlds:' entry.
    # The cannot-build message is configurable. If it is left blank, no message
    # will be displayed to the player if PermissionsBukkit prevents them from
    # building, digging, or interacting with a block. Use '&' characters to
    # signify color codes.
                permissions.example: true
            - Admins
                permissions.example: true
            - Admins
                permissions.example: true
            - Mod
                permissions.example: true
            - Admins
                permissions.example: true
            - Membro
                permissions.example: true
            - Membro
                permissions.build: false
                multiverse.access.*: true
                multiverse.portal.access.*: true
                creativegates.use: true
                essentials.spawn: true
                essentials.home: true
                essentials.delhome: true
                essentials.tpa: true
                essentials.tpaccept: true
                essentials.tpahere: true
                essentials.tpdeny: true
                essentials.balance: true
                essentials.pay: true
                essentials.sell: true
                permissions.*: true
            - user
                permissions.build: true
                warpplugin.warp: true
                econplugin.basic.*: true
                multiverse.access.*: true
                creativegates.use: true
                multiverse.portal.access.*: true
                    coolplugin.item: true
            - default
                permissions.build: true
                modplugin.ban: true
                modplugin.kick: true
                modplugin.unban: true
                multiverse.access.*: true
                creativegates.use: true
                multiverse.portal.access.*: true
                    coolplugin.item: true
            - default
        build: '&cNon hai i permessi per costruire qua!'
        home.basic.set: '&cNon hai i permessi per impostare una casa1'
    Is the YAML file correct? Should I try bPermissions or GroupManager?
  24. Offline


    When its coming the next version compatible with 1.1-R6 / 1.2.3?
    hockeychoas8195 likes this.
  25. Offline


    Is this plugin updated for 1.2.3? Just wondering...
  26. Offline


    Yeah wondering the about the same thing.
  27. Offline


    I imported three worlds into MV: Exploria, Exploria_nether and Exploria_the_end. When I go through a nether or end portal in Exploria, it doesn't take me anywhere, and there's no error in the console or in chat to tell me why. I'm running MV Core by itself, and I have the * permission.

    How can I fix this?
  28. Offline


    Yea... DOWNLOAD MV 2.4 HERE!!


    PS: Not my link, got it from the DEV BUKKIT page of the forum.

    EDIT: bigger font :D

    Maybe your Bukkit's configuration its not allowing the end/nether in your actual map. Go to "bukkit.yml" and open it with some Notepad-like program. Edit the "allow-end" option.
    For the nether, its in the config.yml, do the same, but with "allow-nether". Cya!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  29. Offline


    Have almost the same problem as SpeQzz but the nether works fine in the first world created with the normal bukkit.
    Changing allow-nether only works for the normal world "first". What to do?
  30. Offline


    Use multiverse to generate other Nether for other worlds, Bukkit will auto-get the users to the Nether corresponding to its world if its "allow-nether" in "yes".
    I mean if you make a portal in "World" it will get you to "World_nether" and if you make one in "first" it will get you to "first_nether"...
    Hope you inderstand me, Cya!

Share This Page