[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    I didn't think you could do it with just Core, thought you needed to have NetherPortals enabled too? I'll try it though.
  3. Offline


    I don't know what happened, but it appears I MAY have fixed the problem by removing the worlds from config, modifying the level.dat with NBTedit and importing the worlds. Here is my output - it still kinda scares me. I'll post again if I can confirm the issue is resolved.

    The seeds show up properly in the worlds.yml file and in the F3 menu in-game, but show 0 in a section of the startup. I have restarted the server twice.

    2011-12-08 00:36:57 [INFO] [Multiverse-Core] - Version RIP-JENKINS-001 (Somewhere around b-35X) (API v9) Enabled - By Rigby, fernferret, lithium3141 and mai$
    2011-12-08 00:36:57 [INFO] [AllPay] - Version 3.0 - hooked into iConomy 6 for Multiverse-Core vRIP-JENKINS-001 (Somewhere around b-35X)
    2011-12-08 00:36:57 [INFO] [Multiverse-Core] Loading World & Settings - 'world' - NORMAL with seed: 8225148791234223328
    2011-12-08 00:36:58 [INFO] [Multiverse-Core] Loading World & Settings - 'world_the_end' - THE_END with seed: 8225148791234223328
    2011-12-08 00:36:58 [INFO] [Multiverse-Core] Loading World & Settings - 'creative' - NORMAL with seed: 0
    2011-12-08 00:36:58 [INFO] Preparing start region for level 2 (Seed: -833083550)
    2011-12-08 00:36:58 [INFO] [Multiverse-Core] Loading World & Settings - 'survival' - NORMAL with seed: 0
    2011-12-08 00:36:58 [INFO] Preparing start region for level 3 (Seed: 1281139951)
    2011-12-08 00:36:59 [INFO] [Multiverse-Core] 4 - World(s) loaded.
  4. Offline


    Hi all

    I have got the multiverse core and portals (most recent versions) uploaded but am having problems importing my worlds. My worlds are called "World One" and "World One_nether" but when I type in the command: /mv import World One normal I get the error message "That is not a valid environment" and then the list of the 3 env types. I get this same error when trying to import the "World One_nether" world. I have tried just calling it "world" but I then (understandably) get the 'no folder exists' error message - so at least this tells me I am typing in my world name correctly.

    My other plugins are residence, permissions and vegetation. Nothing has been done with these as yet, but my friends have been building already in the "World One" world, so I don't want to have to start a new world for them...

    All ideas gratefully received.

    PS I am not getting any error messages on the Bukkit console.
  5. Offline


    So when are you guys going to update your dev links?
  6. Offline


    where can i find the build for 1.0? devbuild links dont work.
  7. Sorry all, we're working on it. Rigby and I are in different timezones so coordinating can get challanging. I know lithium3141 is working on a backup repo (for building it yourself) and Jenkins.

    Thanks for your patience. Sorry :(

    Dev builds are currently here. Please thank @lithium3141. He's awesome.

    /cc @Strebelschneck @darkcloud784


    /mv import "World One" normal

    Note the quotes. They're required when importing worlds that have spaces.


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  8. Offline


    This seems to have fixed my earlier problem for sure.
  9. Offline


    hey i cant set permissions, its not working.

    i will give the permission that players can warp to other worlds. but its not working, it says that there are not enough permissions.

                permissions.build: true
             multiverse.teleport.*: true
             multiverse.teleport.self.w: true
    is not working. what am i doing wrong?
  10. Offline


    is it possible if people go to the portal that the items go away of them so they can go from freebuild to normal without taking stuff with them
  11. Offline


    look up WorldInventories on Bukkit Dev.
  12. Hey all, I am using Multiverse with Multiverse-Portals. The portals I have setup work fine when Admins (who have all Permissions) use them, but when a member of the Default group tries to, nothing happens. I am wondering what Permission I am missing, since everyone has multiverse.access.*. I checked the Multiverse-Portal wiki for Permissions information, but it seems to have been deleted.

  13. Offline


    what is the permissions to use all all one portal?
  14. Offline


    Can't find it please send me how to do it
  15. Offline


  16. Offline


    RIGHT, would be a great pluging but im having problems with it and im not gonna scroll through 191 pages to see if its been answered.....

    Im running on permissions 3.1.5 (for ref) and i've checked the wiki and it states in the permissions section that opfallback must be disabled and its in the config.yml. well, no its not in any of the config.yml, not in the core, the portal, not in any, opfallback isnt anywhere, i cant find. cant this pluging run without having to op anyone for access, i just want my users to teleport to a new world without opping, im sure its simple enough as all the other pluging i use dont require opping users.....

    Can anyone help me with this? i dont wanna have to op a default or a member just so they can teleport to skylands, or if anyone can tell me where this supposed opfallback thing is located, would be great.
  17. Offline


    @pswayne You have to update your perms plugin that plugin isnt and hasnt been supported by most plugins for a while now.
  18. Offline


    Same issue here. I had this all set up before the DEV builds fully working. Now with the DEV build and PermissionsBukkit, I get "You do not have permissions to go there", when I try to /mvtp to worlds.
  19. Offline


    Will this still allow me to run old pre 1.0 worlds, like for easy salvaging purposes?

    Also, anyone know if it's safe to copy regions from pre-1.0 worlds into a 1.0 world?
  20. Offline


    Same issue here. Did you ever figure this out? I'm using PermissionsBukkit The Multiverse DEV builds, and Bukkit #1572
  21. Offline


    Check the config for both multiverse and multiverse portals and check the settings for enforce access.
  22. Offline


    Core config:

    worldnameprefix: true
    enforceaccess: true
    enforcegamemodes: true
    bedrespawn: true
    version: 2.2
    fakepvp: false
    messagecooldown: 5000
    disableautoheal: false
    opfallback: true
    debug: 0
    teleportcooldown: NOT SET
    Portals Config :

    wand: 286
    useonmove: true
    portalsdefaulttonether: false
    enforceportalaccess: true
    version: 1.1
    Not sure how this helps as I want it to enforce access based on permissions nodes. Also this worked fine on the exact same permissions with the non DEV build.
  23. Offline


    Not sure if you mentioned what perms plugin you're using, but he might have removed all legacy code for old perm plugins and might rely solely on superperms now.
  24. This is correct. You must be using a superperms capable perms plugin.

    Yep, however they'll have "edges" ie you'll see tears in the map from a high level view as the generators changed.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  25. Offline



    This works wonderfully as biomes such as snow and mushroom are rare regardless, and the server I have already started and have built on has none within its default map. Thanks to multiverse I can jump to worlds that are predominantly snow/mushroom biome through a linking chamber.

    My only thought of improvement would be so animals such as cows could walk through the teleporter. It would be great to get rare breeds such as the 'mooshrooms' into my default world in order to breed.

    Nevertheless a brilliant mod! Thanks allot :)
  26. So the reason I haven't done this (believe me, I've thought about it, I wanted creepers to be able to traverse worlds :)) is due to the fact that with the standard portals, you'd have to monitor onEntityMove, and that would murder servers faster than onPlayerMove. I have plenty of ideas, but I'm working on getting MV 2.2 stablized atm.


    PS: For those of you waiting patiently, Jenkins will be making a triumphant return shortly!
  27. Offline


    Thanks for the info!

    I only ask as I think I had seen it down with portalstick. The only other query I have is with permissions. I would like a default group (with no other permissions) to be able to be able to be transported using portals leading to another, but not anything else. So I tried adding the permissions for a default group and then put myself in the default group to test it. When I did, I could only go though the portals when I was an op.

    Is this a bug or have a missed a link somewhere explaining all the permissions? I also have the permission-enforcement in the config as true.
  28. We like to keep our plugin info in a Wiki format, where you, the users, can find our, the developer's, mistakes and fix them.

    With perms, I should note that MV2.2 requires a SuperPerms capable permission plugin. Basically all use it except Permissions3 which is long obsolete.

    Here are 2 pages that should be helpful re: permissions

  29. Offline



    I am now using Permissions-Bukkit. I hadn't done too much research into permissions prior and just assumed (not a good thing to do) that they were all the same. I am new to the bukkit experience, but am finding it a pleasing one with creations such as this ;)
  30. Offline


    Thnx Man

    I have a question my friends are playing in my server and they are non ops and if they want to teleport in a teleporter it's not working and i have already set permissions.... please help me and please send me the permission i need for it because i think it aren't the right ones

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  31. Offline


    I can't create Skylands on my server with CB #1572 :/

Share This Page