[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline

    Olof Larsson

  3. Offline


    Thanks for the update. Best multiworld plugin on bukkit !
    fernferret likes this.
  4. Offline


    Thanks was wondering if it was something I did. We also have hourly backups. I do recall this happening as soon as 1510 was installed and an auto restart happened. This happened to a world we have been using since the first 1.0.0 builds; which was created with (mvc world2 NORMAL -s xxxxxxx). After using one of the backups we haven't had a problem since.
  5. The Issue has been found!

    The issue is at least related to thunder and rain (maybe or, but thunder and rain definetly cause it).

    I've written a small python script that uses the nbt python lib.

    If you're a Mac/Linux user, check it out. We shouldn't need it for long, but until we get this figured out, as to why it's breaking in bukkit, this is a solution. I tried NEINedit, but it failed to save. So I wrote this.

    If you're a windows user, try opening your world with a NBT thingamajig. I've heard they're good on windows.

  6. Offline


    Im noticing when i use the /mvnp link end <from world> <to world> that it will initially link the end portals of the from world to the to world but when i reboot the server the link breaks and i have to redo the command again otherwise the end portals will take me to the nether instead. Other then that everything is working great. Keep up the great work!
  7. Yea sorry about that, I threw that feature together in a big rush (also why MV 2.2 isn't a release yet :) ) but if you could post it on https://github.com/Multiverse/Multi...tone=3&sort=created&direction=desc&state=open I'll actually remember to fix it before release :)

  8. Offline


    It's really not that big of a deal. Im really thankful that it's even implemented this early to be honest lol. You're doing a great job!
  9. Offline


    just amazing! thanks for make it so easy :D!
  10. @fffizzz edited the language out of your quote, since that post no longer exists. Deleted as "Offensive Spam"

    @gameplayer2014 Feel free to repost if you have an issue, would like help with it and keep the language clean.
  11. Offline


    Could anybody help me getting Multiverse working with Essentials GroupManager? I've read through all the tutorials I can find, and what seems like 10000 forum posts, and I still can't figure out what I'm doing wrong.

    In a nutshell, I have Essentials (full, 2.7.85) and Multiverse/Portals (2.2) installed on my server. Using groupmanager, I have set myself to Owner, and my son to Admin. I can use multiverse to create new worlds, teleport between them, and create working portals. The problem is that I'm the only one who can use the portals, or teleport between worlds. I tried using the following in my groups.yml:

        default: false
        - multiverse.access.*
        - multiverse.teleport.*
        - default
        - g:essentials_builder
    The admin group inherits permissions from the Moderator group, and the Moderator group inherits permissions from the Builder group. Or that's how it's supposed to work. When I save the changes to the groups.yml file and reload, none of the commands work at all. I can't even use the /who command. When I take the changes back out, and reload again, my access (as well as his) is restored.

    I've also tried putting in each individual command (without using the *), and I have also tried putting each command (both with the * and without) in ' '.

    I'm lost...

    If this has already been answered in another post, then I apologize for the duplication. Please post the link to it, so I can go there.
  12. Offline


    it really really laggs when i go the the new world! pls help me!
  13. Well I'm not really an essentials fan, but someone was having this issue the other day. I'd go check out their multi-world permissions, as this is most likely the issue. I do have experience (and can help) with PermissionsBukkit, PEX, and i've seen bPerms and it looks neat, so I may go play with it, but in my experience essentials can cause a lot of issues with smaller plugins as it defaults a lot of features on (understandably).


    Rule #1 of Multiverse. It doesn't actually do anything. Maybe your server doesn't have enough ram? Any more details?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  14. Offline


    I had considered PermissionsBukkit, but I didn't see an update that was compatible with MC 1.0.0, and I read a lot of forum posts complaining about PEX breaking things, so I didn't go with either of those. However, that being said, I really have no idea what I'm doing with any of this. I just recently started trying to configure the server for my son and his school friends to play on, and although I am fairly competent, and a quick study, sifting through tens of thousands of posts actually seems like more work than beating my head against the issue until it goes away. :p

    any suggestions on something to use instead of Essentials?
  15. This is a psudo-trick question :)

    What features from essentials do you use? This is my biggest problem with the plugin (not you at all! :)) is that they provide so much, most users don't even know if they need or want it all.

    - Teleports?
    - Warps?
    - Godmode
    - etc.

    For a good "bare-bone commands" plugin try CommandBook. That's what I test MV with. They have a really nice web app that lets you choose what you want:

    As for PermissionsBukkit, it works fine with 1.0.0. This is what I test MV with.

    Let me know if you want some more. I'm also always in #multiverse on esper.net.
  16. Offline


    use bPermissions :)
  17. Offline


    Actually...CommandBook looks like it would have what i need to start with, including tp and warps. Would you suggest I try CB along side of PermissionsBukkit? If so, (and this is going to sound like a complete "n00btard" question), would I be able to use PB to set permission levels for specific commands from CB? I assume the answer is yes, but it never hurts to ask (aside from my pride)...
  18. Not really sure what you mean, elaborate?
  19. Offline


    see...i knew is was a beginners question :p

    Do I use PermissionsBukkit to set my permissions up with four levels (1. player, 2. moderator, 3. admin, 4. owner) and then use those permissions with CommandBook to set the broadcast command for levels 2-4, set the teleport command for levels 3&4, and set the unban command to level 4 only? Or are the permission levels set with CommandBook.

    I guess an easier way to ask is, do I need both CommandBook and PermissionsBukkit, or do I just need CommandBook?
  20. Offline


    Okay I understand that there isn't an AB/RB for the latest version of Minecraft... but can you please try and explain to me why my world isn't being loaded? I have a 1.7.3 generated world named "oldworld" and every time I try to load the world, it returns with an error. When I look at the debug log, it tells me that the "world has errors" and to try using Chunkster. I used Chunkster. No errors were apparent. PLUS I have tried running this world in the vanilla minecraft 1.0.0 and it loads just fine. (I don't think it is an error with the world file)
  21. Offline


    @GetGoodKid there was a bug in versions before 1538 bukkit that would fail to load some worlds, update bukkit, or try the fix fernferret posted on the last page.
  22. Offline


    Actually I am on the latest version of dev bukkit and I am still receiving the same error

    Does anyone know why I can't load my 1.7.3 generated world? I type "/mv load oldworld normal" and it returns saying there is an error trying to load that world.

    When I try to import it... it says it "completed" but I do "/mv list" and it does not show up on the list.

    The world works/loads just fine on vanilla minecraft 1.0.0 so it is NOT a corrupted world.

    If it helps... I am running the latest dev craftbukkit build and the latest dev builds for multiverse.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  23. Offline


    1042 mb ram enough?
  24. Offline


    From what I've seen, if you are running Windows/Mac/Graphical mode Linux, it will take about 512MB for general operation. If you are running Linux in text mode, you will be using about 200MB. Everything I've seen for single-world Minecraft has a minimum of 512MB. I seem to recall suggestions for setting up a server having you take the minimum memory requirement for the server (512MB) and add 32MB per player that will be on simultaneously, and about 256MB per world after the first, assuming you are keeping the worlds small.

    Basically, the above paragraph says you probably don't have enough RAM to be smoothly handling multiple worlds.
  25. Offline


    i use nitrado. does that change anything?
  26. Offline


    Is there a possibility in multiverse or another plugin to save the positions when teleporting between worlds?
    I want to allow my users to always change between our survival and creative world, but they shouldn't have to walk from spawn to their last location.
  27. Offline


    Nitrado is a service, and not an operating system. It is most likely running Linux on the back end. You still probably do not have enough RAM for what you are trying to do, and depending on what level of service you have, you may not have enough processing power, although I am not sure on that count. To handle a smooth multi-world server, you may need to upgrade your service.

    Based on the numbers I provided above, you have about enough memory for 2 simultaneous players on a two-world server, assuming a text-mode Linux installation.

    Edit 2:
    canihostaminecraftserver.com will give some bandwidth and memory checking for a VANILLA (Mojang, not Bukkit w/ plugins) Minecraft server. The more plugins you use, the more memory you will need, and extra worlds can be considered very large plugins, for the purpose above.

    From the Bukkit Wiki:
    When choosing RAM amounts, it is HIGHLY recommended to run a Craftbukkit Server 1024MB (1GB) of RAM per 10 Player Slots. If your player slot amount is below 10, we recommend a 768MB Plan at minimum. Due to the high memory consumption of the server and plugins you can never have enough RAM.

  28. Offline


    So it seems that my users can't teleport to other worlds. They have, as far as I know, the correct permissions. I even logged in as a default user to test it out myself, and everyone gets the same error, "It looks like you're not allowed to go there."

    I'm 99% sure that it's a permission problem as my account, admin, has all multiverse permissions set to true, but since my users/default only has multiverse.teleport.self.*, multiverse.teleport.self, multiverse.teleport.self.w all set to true (Hey, can't hurt to make damn sure that you have all of them set to true...) as well as things like the /mv info node enabled... Though I'd assume that you wouldn't need to have a different set of permissions to be enabled to use teleport.
  29. Offline


    Darn, devsite is down. Can't get the latest update! :( Shame, needed this too for the amazing teleporting api.
  30. Offline


    Does anyone know why I can't load my 1.7.3 generated world? I type "/mv load oldworld normal" and it returns saying there is an error trying to load that world.

    When I try to import it... it says it "completed" but I do "/mv list" and it does not show up on the list.

    The world works/loads just fine on vanilla minecraft 1.0.0 so it is NOT a corrupted world.

    If it helps... I am running the latest dev craftbukkit build and the latest dev builds for multiverse.
  31. From IRC just now:
    @krinsdeath has made TeleportSuite that provides this function! It works great with MV2.


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016

Share This Page