[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. "
    Error 199.
    Happens about once per forum page
    Don't worry about it.
    It's fixed in 2.

    Those are my usual responses... Note to future people, please use google... that's what it's there for:
  3. Offline


    is there a way to get just new users to spawn at multiverse spawn?
  4. Offline


    I'd say disable MV handling spawning and use another plugin to for handling it - I know there are some which do what you want.
  5. dunno about MV1, but MV2 sets the world spawns for bukkit.
  6. Offline

    Richard Scheide

    Hello, First of all. This mod is great. Can't thank you enough for it and the best cheatsheet i've ever seen.

    I have created several new worlds but what I would like to do is take my original "world" map and move it to another map named oldworld. Can I do this or should I just change the level name in the config file to a new name a let server create a new started world?
  7. If I understand you correctly, either option should be fine. Now, if you thought the cheatsheet was good (and it only is because of @AkiTensai ) You should check out the wiki for Multiverse 2 (which is currently in final testing) example page: https://github.com/Herocraft/Multiverse-Core/wiki/Basic-multiverse-tutorial
  8. Offline


    When I try to import a World I get this error.

    09:40:40 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'mvimport' in plugin MultiVerse v1.7.2
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:320)
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:713)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
            at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NullPointerException
            at com.onarandombox.Rigby.MultiVerse.MVCommands.worldCreateImport(MVCommands.java:230)
            at com.onarandombox.Rigby.MultiVerse.MVCommands.MVImport(MVCommands.java:47)
            at com.onarandombox.Rigby.MultiVerse.MultiVerse.onCommand(MultiVerse.java:176)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
            ... 12 more
    Fixed it by setting the World to the default world, but now I can only mvtp to the world I am currently in

    my Worlds.yml
            animals: true
            pvp: true
            alias: ''
            blockBlacklist: ''
            worldBlacklist: ''
            spawn: -127:64:-49:0.0:0.0
            mobs: true
            price: 0.0
            environment: NETHER
            editWhitelist: ''
            playerBlacklist: ''
            playerWhitelist: ''
            editBlacklist: ''
            animals: true
            pvp: true
            alias: Normal
            blockBlacklist: ''
            worldBlacklist: ''
            spawn: 4184:60:28:0.0:0.0
            mobs: true
            price: 0.0
            environment: NORMAL
            editWhitelist: ''
            playerBlacklist: ''
            playerWhitelist: ''
            editBlacklist: ''
            animals: true
            pvp: true
            alias: ''
            blockBlacklist: ''
            worldBlacklist: ''
            spawn: -494:70:3654:0.0:0.0
            mobs: true
            price: 0.0
            environment: NORMAL
            editWhitelist: ''
            playerBlacklist: ''
            playerWhitelist: ''
            editBlacklist: ''
            animals: true
            pvp: true
            alias: ''
            blockBlacklist: ''
            worldBlacklist: ''
            spawn: -12:64:51:0.0:0.0
            mobs: true
            price: 0.0
            environment: NETHER
            editWhitelist: ''
            playerBlacklist: ''
            playerWhitelist: ''
            editBlacklist: ''
  9. Could you post your startup log on pastebin.org?
  10. Offline


    Hello! While trying to use MV2 BETA I get this error whenever a user tries to join the server, they can join sucessfully and the server stays up but I cannot use MV. Thanks!

  11. Offline


    hi i have a problem,when me and my friend is teleported to the other world we can break and place block!why?
  12. You came in irc, but left. I was at work. That should have been very obvious by my nick(s) in IRC: fernferret|away AND fernferret|work. If you stay in there, we WILL help you out. We can't help when you leave... For example, this is a new error, and I need more info to find out about it.

    Come back in IRC and If I or someone else does not answer, don't ragequit, just be patient.

    Please reword your question. From what you said, i'd say that is completely expected. Here is what I got out of it:

    Hello, I have a problem. When my friend and I teleport to a different world, we can place and break blocks. Why?

    If you are saying you CANNOT place or break blocks, then you have a permissions issue. If someone else here wants to help with it, please take over. I will assist if AND only if you are using PermissionsBukkit. To get my assistance, come in our IRC channel.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  13. Offline


    oops...we CANNOT sorry XD
  14. MV2 Status:

    We're ready. The time has come. But we can't release :(

    Wether you like it or not, we're using Bukkit's built in Permissions WITH mutability. What this means is that you will need 1024+ to run Multiverse 2.0. If you wanna go grab it now: Start here. Even if you want to wait, it wouldn't hurt to checkout our brand new Wiki! There are still a few areas in need of work, but overall it's pretty slick. A huge thanks go out to @AkiTensai @lithium3141 @Elizacat for their assistance with the ongoing documentation process.

    Full credits will be released on offical release. This will happen the day the next RB comes out. Which I don't know when that will be, so don't ask.

    We'd love for you to try out MV2 before the official release to catch any last minute bugs for the 2.0 release!
  15. Offline


  16. You lie. You changed a config. A config is a setting. Your permissions yaml is messed up. Go ask those guys.
  17. Offline


    I dont know what happened, honestly didnt change anything with multiverse/permissions. i fixed be removing ALL ' from groups.yml in all worlds.
  18. Offline


    (CB 1000, and the MultiVerse in the OP.)

    When I try and move between worlds, the server resets itself. When I come back to the server, and I'm in the world that I "teleported" to.

    Here's the log:
    2011-08-02 12:06:43 [WARNING] nilxchaos moved too quickly! Elapsed ticks: 33, Di
    stance change: 210176.0
    2011-08-02 12:06:43 [INFO] nilxchaos lost connection: user was kicked.
    2011-08-02 12:06:43 [WARNING] nilxchaos moved too quickly! Elapsed ticks: 35, Di
    stance change: 210178.51494660907
    2011-08-02 12:06:43 [INFO] nilxchaos lost connection: user was kicked.
    2011-08-02 12:06:43 [SEVERE] Could not pass event PLAYER_KICK to PermissionsBukk
    Error:  Minecraft server error. Server will be restarted.
    java.lang.IllegalArgumentException: Attachment cannot be null
    2011-08-02 12:06:43 [WARNING] nilxchaos moved too quickly! Elapsed ticks: 36, Di
    stance change: 210183.5308081076
    2011-08-02 12:06:43 [INFO] nilxchaos lost connection: user was kicked.
    2011-08-02 12:06:43 [SEVERE] Could not pass event PLAYER_KICK to PermissionsBukk
    java.lang.IllegalArgumentException: Attachment cannot be null
    2011-08-02 12:06:43 [INFO] Sciathz lost connection: user was kicked.
    2011-08-02 12:06:43 [SEVERE] Could not pass event PLAYER_QUIT to PermissionsBukk
    java.lang.IllegalArgumentException: Attachment cannot be null
    2011-08-02 12:06:43 [INFO] [CONSOLE] Server is restarting. World is being saved.
    I think it's a memory issue, but I'm not sure. As you can see, I'm running the Bukkit Permissions.

    Here's a list of all of my Plugins:
    Show Spoiler
  19. Offline


    MV2 prefix is working fine(now that I removed ichat)
    Keep up the awesome work, hopefully we will see a RB soon for bukkit.
  20. Offline


    That seemed to work, even though I had tried it before. I'm not complaining, though, I love it when problems solve themselves :) Great plugin btw, and thanks very much.
  21. Offline


    Nice! :)
    Is the 1024-Bukkit-Version under development?
    Or must we wait a long time? :eek:

  22. Offline

    Celtic Minstrel

    No you don't. Other plugin developers have released plugins that require a build later than the recommended; just put 1024 in the topic.

    I believe lacking the day/night cycle was intentional. As for weather, Skyland already has that; it's just that it's the weather of deserts, which means everything just gets darker and no rain or snow falls.

    @Yurameki – Go to the beginning of the line above "prefix: true" and press backspace. Do the same at the line above "globalrespawn: false". Save, and it'll probably be fixed.

    @Trenny – It's available right now; you can get it from the Bukkit Jenkins, which is the same place you get CraftBukkit normally, but just a little less conveniently located.
  23. I'm going to put up a little blurb on how other chat plugins can support multiverse's Aliases and Colors. Oh yea, you can color your world names now :p
  24. Offline


    I have a few questions:
    1. My PREFIX does not work. I have it set to true, but it does not ass a prefix into it. Does it require IChat? I use HeroChat and the prefixes I set in Permissions work fine.
    2. MV2 is supposed to need 1024+. I thought the latest build available was 1000. Is there a later version out already? I Googled and found 1038. Will this work? If so, I forgot how to update. Do you only have to replace the SNAPSHOT file?
    3. Will I have to go through and redo all the Permissions commands as well? I only just got done putting them in for MV1.
  25. 1. If you use a seperate chat plugin, it will most likely override the prefix MV tries to put in. We're not a chat plugin so our priority on that chain is pretty low...
    2. It will. Yes.
    3. Some, yes, and we're sorry about this. but it's for the best in the long run. The good news is that the new perms are A LOT better documented here: https://github.com/Herocraft/Multiverse-Core/wiki/Command-Reference
  26. Offline


    Thanks for the quick reply. Glad I caught you online. Do you know what I should do to be able to use both my Permissions Group Prefixes and my World Prefixes?
  27. See this: (2 posts above yours :))
  28. When so i set up portals
    /mvpc test
    go to my destination
    /mvps test

    then when i go and walk into my portal i dont get teled to the my destination?

    EDIT: o i see now i was hoping i could use this plugin to tp me to other parts of my world :(
  29. "/mvpd here" will set the portal's destination to where you're standing.
  30. Offline


    Could not pass player_movement on multiverse.
    Caused when i used commandbook to rocket someone, they got kicked, and caused this.

Share This Page