[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    im sry if this has already been asked, i did my best to skim through the massive ammount of pages, heres my problem, everything was working great, ive been running a server with me and 2 other friends, gave everyone admin privilages, and now i decided i want to make a legit world where no one can give themselves anything and we have to really play the game n not just build. i created the world, made a portal to it, then set up permissions, everything seemed fine, but as soon as i deop'ed myself, i could no longer build in the new world. the only way you can build there is if your OP. ive spent hours messing with permissions, and unless im overlooking something, its just not making sense.
  3. I agree entirely. Which is why we have a VERY nice wiki for MV2. (https://github.com/Herocraft/Multiverse-Core/wiki)
  4. Offline

    Emiya Shirou

    Any way to set it Op only? Permissions are little useless on my server.
  5. Offline


    I need help setting up my portals is there anyone who could come to my server and set them up?
  6. Offline

    Celtic Minstrel

    If you don't use portals to arbitrary destinations, download MultiVerse 2.
  7. Offline

    Emiya Shirou

    umm link please? Btw. what are those portals to Arbitrary destinations? We only use runecraft and it's teleporting system, and have nether enabled.
  8. Offline


  9. Those work in MV2 now :p so do vehicles :p
  10. Offline

    Emiya Shirou

    But where is this MV2 >,< ? Everywhere is 1.7.2 =_= And i don't see any other multi world plugin without permission that i can use for the generator i have...
  11. Offline

    Celtic Minstrel

    So, MultiVerse-Portals is done?
  12. MV-Core and Portals are both missing the Economy aspect. But all that is needed now is a bunch of bugtesting, then release! (also need to write a portal migrator)


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  13. Offline


    for MV2 do you have to have permissions? or any other plugins?
  14. Offline


    I have a question. Does memory usage increase significantly with more worlds? Or does it increase normally as it would when a player explores a world?
  15. Offline


    Just wondering, do the pages on bukkit.onarandombox.com link directly to the newest builds on ci.onarandombox.com, or do they link to the recommended builds?

    Also, are there any nearly-functional builds of Multiverse-Portals? I used a few from a few days ago and they failed entirely on me...
  16. Uh I have no idea actually, I'll have to ask @Rigby90. Seeing as it's still in Beta, the newer builds of Core (110+) require Bukkit 1024+ And the newer versions of Portals require the Core they were built with.

    Also, I don't support old versions of the Beta. so to (unfortunately) say this as an official statement:

    The Bad News: MV2 Will NOT be official until bukkit's RB is increased past 1024.

    The Good News: MV2 Should be ready when the next bukkit RB comes!

    EDIT: Looks like I failed to answer your question. Yes. I consider Portals 77+ to be in pretty good working order.

    Uh I don't think the server keeps all chunks in memory (at least I hope not), This is another for:


    You don't need anything, but All commands would then require OP.

    I highly recommend PermissionsBukkit (The implementation of Bukkit Perms), it's very easy to setup and use, unlike P2 or P3 or GM.

    MV2 works with P2, P3, GM w/ FP AND Built In Bukkit Permissions.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  17. Offline


    Ah, thank you. That would be why it kept failing for me, I figured it was compiling against 1K, not past that. I'll test soon on 1024, or maybe just wait for the RB. Not sure yet.

    Also, thanks for keeping active on the forums throughout your shift to MV2. That's a cool thing to do, especially since it took so long to make.
    fernferret likes this.
  18. Offline


    This is probably a dumb question that was obviously stated somewhere in the infologs and I just missed it, but... Is there a way to make it so that items don't transfer between worlds?
  19. Offline

    Celtic Minstrel

    Sounds like this is the only thing I still need before I can update. Let me know when it's done?
    You know, it's not actually required that released plugins require a recommended build. Some get along just fine requiring a greater-than-recommended build. I myself will probably do that with General once I get around to making the world-based permissions dynamic.
  20. Offline


    thought i'd give 2.0 a try and getting this on startup:
    2011-07-25 06:03:58 [INFO] [Multiverse-Core] - Version 2.0-b150 Enabled - By Rigby and fernferret
    2011-07-25 06:03:58 [INFO] [Multiverse-Core] - Attached to Permissions
    2011-07-25 06:03:58 [INFO] [AllPay] - Version .5.1 - using only an item based economy for Multiverse-Core v2.0-b150
    2011-07-25 06:03:58 [SEVERE] Error occurred while enabling Multiverse-Core v2.0-b150 (Is it up to date?): org.bukkit.plugin.PluginManager.recalculatePermissionDefaults(Lorg/bukkit/permissions/Permission;)V
    java.lang.NoSuchMethodError: org.bukkit.plugin.PluginManager.recalculatePermissionDefaults(Lorg/bukkit/permissions/Permission;)V
        at com.pneumaticraft.commandhandler.Command.addToParentPerms(Command.java:108)
        at com.pneumaticraft.commandhandler.Command.setPermission(Command.java:91)
        at com.pneumaticraft.commandhandler.Command.setPermission(Command.java:83)
        at com.onarandombox.MultiverseCore.commands.VersionCommand.<init>(VersionCommand.java:22)
        at com.onarandombox.MultiverseCore.MultiverseCore.registerCommands(MultiverseCore.java:222)
        at com.onarandombox.MultiverseCore.MultiverseCore.onEnable(MultiverseCore.java:138)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:878)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:272)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-07-25 06:03:58 [INFO] [PermissionsEx] Modifyworld is disabled. To enable set "permissions.modifyworld.enable" to "true" in config.yml
    2011-07-25 06:03:58 [INFO] [PermissionsEx] v1.12 enabled
    2011-07-25 06:03:58 [INFO] [PermissionsCompat] Compatibility layer enabled.
    2011-07-25 06:03:58 [INFO] [Multiverse-Core] - Attached to Permissions
  21. Offline


    did you use CB1024 or higher? your sig says you're using build 1k
  22. Offline


    ah, I need 1024+. ok thanks
  23. Offline


    I just installed MultiVerse and it seems to have installed correctly, but for some reason any command I enter will return an "internal error". I've made sure the version of Permissions we're using was current, and even tried using 2.7.4 for good measure, but I just can't nail down the issue. The only other mods on the server are those included in Bukkit Essentials, so I can't imagine it's a mod conflict in action here. Here's what happens when I try to create a new world via /mvcreate.

    2011-07-25 04:01:23 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'mvcreate' in plugin MultiVerse v1.7.2
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:320)
        at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:713)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
        at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NullPointerException
        at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:241)
        at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:224)
        at com.onarandombox.Rigby.MultiVerse.MultiVerse.onCommand(MultiVerse.java:163)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
        ... 12 more
  24. Offline


    I posted earlier that as soon we try to /mvtp to skyworld the server hangs, people get disconnected and needs to be force restarted.

    No error messages etc apart from what I stated previously which happens clientside.

    I can /mvcreate skyworld fine but cannot enter it on build 1029 was fine before 1.7.

    We have a development system we are trying to get going if it wasn't for permissions and this we would be nearly ready.

    Update: Multiverse 2 core fixed it.
  25. Offline


  26. Offline


    That means the actual version I found here has no support for portals because it's the old version from Jul-20-11? And you will upload the bugtested version with portal migrator tomorrow/or this week? Sounds good. :) Or is the date wrong and that's the newest version about which you were talking?
  27. Offline


    When I'm in another world which Isn't my default, I cannot perform any commands. It just come up with this "An internal error occurred while trying to perform this command"
  28. Offline


    Briggy try type the /reload command.
  29. Offline


    When I set the world to just spawn animals but no mobs, then the world would continue spawning mobs. BUT, your health would regen after time. Am I doing something wrong?
  30. Offline


    Config problem!
    I don't know if it is just me or some plugins but it happens to this plugin more. My configs arn't vertical format instead some kind of sideways but the plugin manages to read it.
    I would post it in the code but it shows up normal what is happening?

    Config problem!
    I don't know if it is just me or some plugins but it happens to this plugin more. My configs arn't vertical format instead some kind of sideways but the plugin manages to read it.
    I would post it in the code but it shows up normal what is happening?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  31. Offline


    @rockxz2135 what's the error you're getting? also, it sounds like you're using notepad. try reading your config files in notepad++ (free download) and also posting any errors you may have from your server.log (or explain in detail what's not working)

Share This Page