[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    Hey, this looks like exactly what I'd want, but I have a question;
    I'm looking to host a creative and survival map on the same server, and while I'd allow moving freely between the two worlds, I would like the inventory to be emptied when you go to and from the survival server. Simply because moving to the creative server, spawning a ton of blocks and moving back would be cheating the fun of a survival server.

    Does the mod support this? Alternatively; any mod that does this?

    EDIT: Never mind, I'm just an impatient douchebag for asking before searching. I found what I was looking for in MultiInv.
  3. Offline



    1. There needs to be some method of portal protection. I suggest every portal created has a record of who made it. Then, you add one extra permission '- multiverse.portal.override' for any group you want to allow the renaming, deleting, and otherwise changing of other users portals. This way you can have a fun world where users can build portals freely without worrying about your other worlds portals being manipulated. For legacy builds just set all previous portals to "admin" or something.
    2. There should also be a permission setting to allow portals to connect outside of the current world. For example, '- multiverse.portal.wide' would allow a group to build a portal with a connection outside the world they are currently in. This way if you want a tightly kept sandbox world it will be maintained that way.
  4. Offline


    So long as A) the server.properties nether is off B) splike is turned off and C) No other plugins such as AncientGates are using the portal blocks then it will make a funky light and give an area some sound effects, beyond that they won't do anything
  5. Offline


    I will turn the server.properties nether off, and I have no other plugins like AncientGates. what is splike and how do I ensure its turned off?
  6. Offline


    There should be an option to turn it off in the Multiverse config
  7. Offline

    Kaydin Smtih

    When I /mvtp to any of my worlds it doesn't take me to that worlds spawn. I have to /mvtp and then /mvspawn to get to the worlds spawn. Is there something I am doing wrong? Can I fix this? because it is very annoying.
  8. Offline


    Bukkit 820+
  9. Offline

    Kaydin Smtih

    Damn, I was worried about that. I rent a server from Multiplay so I guess I just have to wait. :(
  10. Offline


    12:00:21 [INFO] [MultiVerse] Loading World & Settings - 'ApertureScience' - NORM
    12:00:21 [INFO] Attempted to place a tile entity where there was no entity tile!
    12:00:21 [INFO] Attempted to place a tile entity where there was no entity tile!
    12:00:21 [INFO] Attempted to place a tile entity where there was no entity tile!
    12:00:22 [INFO] Attempted to place a tile entity where there was no entity tile!
    12:00:22 [INFO] Attempted to place a tile entity where there was no entity tile!
    12:00:22 [INFO] Attempted to place a tile entity where there was no entity tile!
    12:00:22 [INFO] Attempted to place a tile entity where there was no entity tile!
    12:00:22 [INFO] Attempted to place a tile entity where there was no entity tile!
    I have a little error with one of my maps have no idea whats going on maybe you can help out?
  11. Offline


    Is anyone else having issues with players dying and getting set to the 'main world's default spawn, regardless of what world theyre in?
    I'm using 820, so I'm not sure if this is another plug-in thats causing this or not
  12. I've noticed this in test for both MV 1.X and 2.X. I've heard that this has been fixed in later bukkit builds, like 840+ or something.
  13. Offline


    Ah, appreciate it. I'm just gonna take a risk and put a later build on my server then, I suppose. It's somewhat crucial that players dont spawn OUT of the tutorial containment area if they die. :x
  14. Offline


    There should be an option for group whitelisting/blacklisting for worlds.
    Or is there?
    Edit: Do I just add g:{group} into the player area?
    ElgarL likes this.
  15. Offline


    Could anyone tell me what the whitelist format is? The reference skips it and I'm only finding people not knowing how to use it in the previous pages, no answers. It says that it's been fixed before, so it must work, however nothing is working no matter how many different ways I try to type it..
  16. Offline


    you need to give yourself permission for multiverse with a permissons plugin. then you use a woodenpickaxe to set two given points in minecraft and say /mvpc name1 p:name2. this would create a portal called "name1" that is in-between the the points selected with the woodenpickaxe and will take you to a portal called "name2". you have to create the "name2" portal the same way. you would select two new points say /mvpc name2 w:world and that portal would take you to the spawn of the world named world. the portals are invisible you must outline them if u wanna know where they are. you could just make a hole in the ground that takes you anywhere you want.

    i think the easiest way is to just download the permissions 3.1.4 JAR. start, save, and stop the server. then edit globalgroups.yml and every groups.yml inside every wolrd folder to look like:


    then delete globaluser.yml and every user.yml in every world folder and start the server it should now make a user in group "default" when someone joins. i edited the globaluser.yml to make myself admin in every world. when i tried to edit just globalgroups to apply the same group settings on everyworld it didnt work for me but you could try that.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  17. Offline


    It's maybe a known problem but :

    In the "server.properties" file, "spawn-monsters=false" but Player isn't able to regains health over time in other worlds than the default one. It's like only the default one is in Peaceful, but in the "Worlds.yml" file, "mobs: false" for all worlds...
  18. Offline


    i want to separate item between world and world2
    but i try enter world from world 2
    still preserved ....
    In short world1 world2
    go world2 and delete world1 item
    again go world1 appear item once and delete world2 item
    please tell me what will i do?
  19. Offline


    Get MultiInv
  20. Offline


    i am sorry
    i have a problem too
    if i make world2, i don't command /list
    when i try /list this is error

    2011-06-10 23:46:29 [SEVERE] java.lang.NoSuchMethodException: no such method: who
    2011-06-10 23:46:29 [SEVERE] at com.sun.script.javascript.RhinoScriptEngine.invoke(Unknown Source)
    2011-06-10 23:46:29 [SEVERE] at com.sun.script.javascript.RhinoScriptEngine.invokeFunction(Unknown Source)
    2011-06-10 23:46:29 [SEVERE] at nickguletskii200.SpyerAdmin.CustomHandling.who(Unknown Source)
    2011-06-10 23:46:29 [SEVERE] at nickguletskii200.SpyerAdmin.SpyerAdmin.onCommand(Unknown Source)
    2011-06-10 23:46:29 [SEVERE] at com.earth2me.essentials.Essentials.onCommandEssentials(Essentials.java:395)
    2011-06-10 23:46:29 [SEVERE] at com.earth2me.essentials.Essentials.onCommand(Essentials.java:343)
    2011-06-10 23:46:29 [SEVERE] at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-06-10 23:46:29 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:128)
    2011-06-10 23:46:29 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:273)
    2011-06-10 23:46:29 [SEVERE] at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:430)
    2011-06-10 23:46:29 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:415)
    2011-06-10 23:46:29 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:311)
    2011-06-10 23:46:29 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-06-10 23:47:01 [INFO] Essential [/] logged in with entity id 53886 at (517.1392142218708, 71.0, 507.26346015020124)
    2011-06-10 23:47:05 [SEVERE] java.lang.NoSuchMethodException: no such method: who
    2011-06-10 23:47:05 [SEVERE] at com.sun.script.javascript.RhinoScriptEngine.invoke(Unknown Source)
    2011-06-10 23:47:05 [SEVERE] at com.sun.script.javascript.RhinoScriptEngine.invokeFunction(Unknown Source)
    2011-06-10 23:47:05 [SEVERE] at nickguletskii200.SpyerAdmin.CustomHandling.who(Unknown Source)
    2011-06-10 23:47:05 [SEVERE] at nickguletskii200.SpyerAdmin.SpyerAdmin.onCommand(Unknown Source)
    2011-06-10 23:47:05 [SEVERE] at com.earth2me.essentials.Essentials.onCommandEssentials(Essentials.java:395)
    2011-06-10 23:47:05 [SEVERE] at com.earth2me.essentials.Essentials.onCommand(Essentials.java:343)
    2011-06-10 23:47:05 [SEVERE] at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-06-10 23:47:05 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:128)
    2011-06-10 23:47:05 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:281)
    2011-06-10 23:47:05 [SEVERE] at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:718)
    2011-06-10 23:47:05 [SEVERE] at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:684)
    2011-06-10 23:47:05 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:677)
    2011-06-10 23:47:05 [SEVERE] at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    2011-06-10 23:47:05 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:217)
    2011-06-10 23:47:05 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    2011-06-10 23:47:05 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    2011-06-10 23:47:05 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:401)
    2011-06-10 23:47:05 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:311)
    2011-06-10 23:47:05 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  21. Offline


    That isn't multiverse
    Post it for SpyerAdmin and Essentials
  22. Offline


    i am so sorry oh my god
    i felt very very sorry
    i have a problem too....
    i want to separate Group and permissions between world and world2
    still preserved ....
    In short world1 world2
    go world2 and delete world1 Group and permissions
    again go world1 appearGroup and permissions once and delete world2 Group and permissions
    please tell me what will i do?

    please tell me n-n
    i'm sorry
    Be happy life

    what is name plugin ???
    Doesn't GroupManager use multi world ???

    i realy realy realy need please how can i do?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  23. Offline


    Hi, I created my server so I am the admin and controls who can change what people can do... I use the /mvtp (world name goes here) and it says "You do not have the rights to this command" I am an admin and set it to so that I have every command? I don't know why its doing this? I am using CB 820 like you said and I am using Permissions 2.7.4? Any help would be nice
  24. Offline


    Up until 3.1.4 permissions isn't working well with global settings, if at all. Something might have changed with 3.1.5, but I can't find anything stating it. To make Permissions 3x work, you must have both the groups.yml and users.yml copied for each world.
  25. Offline


    yea i got the same problem i have added myself to admin on everything i could and it says you do not have rights to this command
  26. Offline


    I am interested in using this plugin, but I am having a really hard time with it. Everytime I start my server with this Jar File in the plugins directory, Permisions dies with the following errors in my console:
    2011-06-10 23:58:09 [SEVERE] java.lang.IllegalAccessError: tried to access class com.nijiko.permissions.ModularControl$RefreshTask from class com.nijiko.permissions.ModularControl
    2011-06-10 23:58:09 [SEVERE]     at com.nijiko.permissions.ModularControl.<clinit>(ModularControl.java:45)
    2011-06-10 23:58:09 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(Permissions.java:184)
    2011-06-10 23:58:09 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.onLoad(Permissions.java:139)
    2011-06-10 23:58:09 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:112)
    2011-06-10 23:58:09 [SEVERE]     at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
    2011-06-10 23:58:09 [SEVERE]     at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
    2011-06-10 23:58:09 [SEVERE]     at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
    2011-06-10 23:58:09 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    2011-06-10 23:58:09 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-06-10 23:58:09 [SEVERE] [Permissions] Unable to load permission data.
    2011-06-10 23:58:09 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    I have Permissions 3.1.5b and I tried Craftbukkit versions 820, 830, 840, and 857 (most recent as of this posting).
    Other plugins are as follows:
    iChat 2.3.0
    MagicCarpet 1.5.5
    MyWarp 1.10.7
    Performance Tweaks 0.08
    Tele++ 1.3.4
    WorldEdit 4.4
    WorldGuard 5.0-alpha10
    General 2.2.9 (Chernobyl)
    When I pull the Multiverse.jar file out, everything works great.
    Thanks in advance for the assistance.
  27. Offline


    Try renaming Permissions.jar to zPermissions.jar.
  28. Offline


    @zenith501st and Yelnuts71

    Not positive, but try adding multiverse.tp permission to yourself anyways. I updated to CB857 and added the permission and the problem went away. Hopefully this helps because I didn't troubleshoot it very thoroughly myself :\

    If I think of anything else I may have done to fix it I'll be sure to post

    *This was only happening to me when not in the default world. I could do anything in that world but once I left it I was powerless. This is no longer the case and I don't have world-specific permissions set, only global. This seems to confuse the problem further, but it may as well be mentioned.
  29. Offline


    Ugghhh Is there a way to make it so that every time I add an OP, it adds a permission for them? I know this is more of a question for the Permissions page, but, as this is the only one that REQUIRES permissions, I am postiung it here. I want this plugin SO BAD it's not even funny. If I could use the ops for everything else, and permissios for this, that would be great. Or have a way so I didn't need permissions. This is the only good plugin I can find for Multiverse.

    Is there a way to make all of the OPs have permissions for everything? I am asking this here because it is the only plugin I have that REQUIRES permissions. This is the only multi-world plugin I can find that is good.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  30. Offline



    I'm no expert, however your first request seems as if it'd be a plugin of it's own, or need to be manually done.

    As for your second question, simply add * to the permissions of your OP in the permissions file.

    Your easiest solution is to create a group called OP in the globalGroups.yml like this:

            system: default
            default: true
                build: false
                - 'plugin.lamecommand'
            default: false
                build: true
                - Guest
                - 'plugin.bettercommand'
            default: false
                build: true
                - '*'

    Then in the globalUsers.yml simply enter your OP's names like this:

                - OP
                - OP
    Both of these files are found under \plugins\Permissions

    And also next time, even though this is the only plugin you use Permissions with, you will find more help at the Permissions thread. This thread should be used to discuss this plugin.
  31. Offline


    I found my error. I missed an old plugin, Delrad, and once I removed that, everything worked great.

Share This Page