[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    My problem is that if i warp from world1 to world2 i get up some wierd places in world2. and then i need to warpm again to get where i should go. Dont know if it is a bukkit bug.
  3. Offline


    same problem
    when i going trough a portal i get a wierd place
    but when i say /mvspawn i get the right place

    sorry for my english^^ i'm german
  4. Offline


    If your using Worldguard just type in:
  5. And Me!!!
  6. Offline

    Hudson Diesing

    And me =/ so annoying, just that is going wrong. Good luck fixing it =]
  7. Offline


    I also have that. At first I thought that it was MyWarp's problem because I would warp in between worlds(with MyWarp's warp, not Muliverse's warp) and it would warp me to a location that I have never seen before. I also tried using Multiverse's /mvtp command and it did the same so I don't know who's problem it is. Any one have this problem and have fixed it? Maybe its something that the dev has to fix?

    EDIT: I think I remember this morning when I didn't have Multiverese, I could warp all over my first world without any issues.
  8. Offline

    Hudson Diesing

    I think what it is, when using /mvtp or /warp to a different world than the one you are currently in it tp's you to a new or different spawn location, previously using /mvsetspawn or (with a different plugin)/setspawn would take somewhere to the new set location, but it still doesn't =/

    Hopefully this problem will be fixed soon =]
  9. Offline


    I've got this same issue. I know I fixed this before, but now I am stumped.
  10. Offline


    I may have not set up Permissions correctly, but when I try it on my server, it says I do not have the right to use the command....
  11. Offline


    I have the same issue on CB818 and MV 1.7
  12. If you suspect that you didn't set up permissions correctly, why not post your configuration instead of just stating that it's not set up right? We can't help you if you don't provide details.
  13. Offline


    Ok, so, I am new to Bukkit so bear with me here.

    I did what the readme said, I renamed the config file as my world's name. Then, I typed my username in the "users" file. That's where I think I went wrong, the notepad file is blank except for my name. Then I go on, and I don't have the right to use Multiverse commands.
  14. Offline


    People with teleportation issues, hope is on the horizon. I think I fixed it, we just need to wait until Bukkit vets my changes or finds bugs or implements their own version.

    Changes are here (github) for the curious.
    Tux2 likes this.
  15. Offline


    Here's my groups and users config files as examples to help you.
  16. Offline


    i tried just standalone craftbukkit 818 and permissions 3.1 and the new minecraft maps work just fine but when i add multiverse 1.7 the one i made before still works until i import and teleport to the new world then no maps work ever again.
  17. Offline


    I figured out where it takes you when you /mvtp between different worlds. No matter where you set the spawn for each world, /mvtp will always place you in the exact same coordinates you are standing in. Figured it out with a combination of dynmap and /mvtping from a high platform in the MainWorld to our second world. I was in the exact same coordinate location according to F3 and the dynmap and really high in the air.
  18. Offline

    Hudson Diesing

    Yay, hopefully everything gets worked out soon. =]
  19. Offline


  20. Offline


    Look at the bottom of the groups.yml file, I made a special group for select users. Just copy those permissions and place them under the Permissions area just like the groups.
  21. Offline


    u just have to try again the first tp puts u in the world and stops the second time should take u to the mv spawn
  22. Offline


    Ah, thank you much! I'm starting to understand this! :p
    Now, though, it has taken away my permissions from other plugins (including just building anything), so how do I do that?

    Sorry for the trouble! But thanks!

    Ok, so I set up my groups like this:

    default: false
    prefix: Admin
    build: true
    - 'multiverse.portal.create'
    - 'multiverse.portal.remove'
    - 'multiverse.portal.select'
    - 'multiverse.portal.destination'
    - 'multiverse.portal.rename'
    - 'multiverse.portal.list'
    - 'multiverse.list'
    - 'multiverse.world.spawn'
    - 'multiverse.tp'

    And my user like this.

    - Admins
    permissions: null

    What am I doing wrong? :p

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  23. Offline


    i tried just standalone craftbukkit 818 and permissions 3.1 and the new minecraft maps work just fine but when i add multiverse 1.7 the one i made before still works until i import and teleport to the new world then no maps work ever again.
    I also got this error when i tpd to the newly created world
    Show Spoiler
    2011-06-01 18:14:49 [SEVERE] java.lang.Exception: Error creating user wardevour in world pi due to storage problems!
    2011-06-01 18:14:49 [SEVERE] at com.nijiko.permissions.ModularControl.safeGetUser(ModularControl.java:489)
    2011-06-01 18:14:49 [SEVERE] at com.nijikokun.bukkit.Permissions.Listener.onBlockPlace(Listener.java:44)
    2011-06-01 18:14:49 [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader$26.execute(JavaPluginLoader.java:419)
    2011-06-01 18:14:49 [SEVERE] at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    2011-06-01 18:14:49 [SEVERE] at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:310)
    2011-06-01 18:14:49 [SEVERE] at org.bukkit.craftbukkit.event.CraftEventFactory.callBlockPlaceEvent(CraftEventFactory.java:84)
    2011-06-01 18:14:49 [SEVERE] at org.bukkit.craftbukkit.event.CraftEventFactory.callBlockPlaceEvent(CraftEventFactory.java:68)
    2011-06-01 18:14:49 [SEVERE] at net.minecraft.server.ItemBlock.a(ItemBlock.java:76)
    2011-06-01 18:14:49 [SEVERE] at net.minecraft.server.ItemStack.placeItem(ItemStack.java:56)
    2011-06-01 18:14:49 [SEVERE] at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:219)
    2011-06-01 18:14:49 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:556)
    2011-06-01 18:14:49 [SEVERE] at net.minecraft.server.Packet15Place.a(SourceFile:57)
    2011-06-01 18:14:49 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:217)
    2011-06-01 18:14:49 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    2011-06-01 18:14:49 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    2011-06-01 18:14:49 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:401)
    2011-06-01 18:14:49 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:311)
    2011-06-01 18:14:49 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-06-01 18:14:49 [SEVERE] Caused by: java.io.IOException: Unable to create directory structure for world 'pi'.
    2011-06-01 18:14:49 [SEVERE] at com.nijiko.data.StorageFactory.getUserStorage(StorageFactory.java:79)
    2011-06-01 18:14:49 [SEVERE] at com.nijiko.permissions.ModularControl.forceLoadWorld(ModularControl.java:89)
    2011-06-01 18:14:49 [SEVERE] at com.nijiko.permissions.ModularControl.loadWorld(ModularControl.java:81)
    2011-06-01 18:14:49 [SEVERE] at com.nijiko.permissions.ModularControl.safeGetUser(ModularControl.java:487)
    2011-06-01 18:14:49 [SEVERE] ... 17 more

    Attached Files:

  24. Offline


    I realize that, I'm just saying that's what it's doing. So everyone's not all "Its taking me to a completely random spot and i have no idea whats going on..."

    Trying to contribute here...
  25. Offline


    Getting these NPEs:

    2011-06-01 16:19:41 [SEVERE] Could not pass event PLAYER_CHAT to MultiVerse
    at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerChat(MVPlayerListener.java:173)
    at org.bukkit.plugin.java.JavaPluginLoader$6.execute(JavaPluginLoader.java:278)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:310)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:689)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:677)
    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:217)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:401)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:311)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  26. Offline


    Apologies been out all day dealing with stuff...

    As some of you are probably aware the Teleportation issue is an issue with Bukkit itself and not the plugin so you can keep ahold of 1.7 and keep an eye out for a new CraftBukkit RB soonish which will resolve the issues.

    Those of you with other issues I'll be taking a look at them shortly once I catch up on the day I've missed, expect 1.7.1 sometime tonight or tomorrow to fix the Environment/Biome issue and to remove the Alphanumeric restriction on Portals and Worlds.

    Ok I know what is causing that... and surprisingly I'm not sure why it hasn't popped up before now...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  27. Offline


    is there a way to set up individual world pvp or creative? I didnt see anything but im sure i missed it

    im dumb :D i found it!
  28. Offline


    Hey the portals just teleport me to some random spot on the other world, not the portal I set it to teleport me to.
  29. Craftbukkit 819 should fix this.
  30. Offline


    You're going to have to allow mvimport to use the name "world_nether"
    because at the moment, it won't support the underscore.
  31. Offline


    /mvimport sphere skylands or /mvimport sphere skyland does not work. I dunno what's wrong. Updated to 1.7 (MultiVerse) + I am using Bukkit #818 and sphere is in the right folder.

Share This Page