[EDIT/FUN/SEC] VoxelSniper v5.019 - Flexible Long-Range In-Game Map Editor [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Voxel Box, Jan 23, 2011.

  1. Offline

    Voxel Box

  2. Offline


    Did you add the people you want to use voxelsniper in the sniper.txt file? if not go to your plugin folder then click on sniper.txt and for each line put a name that you want to use the plugin
    this is like what przerwap but a bit more info
  3. Offline


    Great Plugin, A real time saver....

    Got a quick question. How do you change running water into still water? I tried /v 09, equipped an arrow, pointed it at the running water, right clicked and nothing happens.

  4. Offline


    has this fixed the /b conflict with essentials?
  5. Offline


    /b id
    /vi 0

    The state of water is its data value; so changing its data value to still water ( 0 ) is the best way.
  6. Offline


    Thanks for the info, worked perfectly.....
  7. Offline


    i did and none of this still works
    --- merged: Feb 11, 2011 8:44 PM ---
    i was the only one on server at time
  8. Offline


    I got the mods on to my server successfully, i have my account set as a sniper and all the commands work but when i try clearing land or filling nothing happens and i dont know what i am doing wrong.. ? any help?[​IMG]
  9. Offline


    Well, are you getting any exceptions?
  10. Offline


    what do you mean by that ?
  11. Offline


    i got it to work by just reinstalling it but everytime i snipe something and error shows up in cmd
  12. Offline


    yea the same thing happens to me and i have no idea what im doing wrong
    --- merged: Feb 12, 2011 6:36 PM ---
    Ok thank you for the advice i got it to work :D
  13. Offline


    Amazing tool, thank you!
  14. Offline


    A little bug: If you shoot away the bedrock, and try to shoot again into the blue, the effect of the brush is applied to the top area at the same XY coordinates. Totally ruined my future flying island, and I didn't notice before i had done huge damage.
  15. Offline


    Help me. I added my name to the snipers.txt but I don't know what is going on.

    2011-02-16 18:25:38 [WARNING] [VoxelSniper] Error while loading snipers.txt

    2011-02-16 18:25:38 [WARNING] [VoxelSniper] Error while loading snipers.txt
    2011-02-16 18:25:38 [INFO] VoxelSniper version 2.7 is enabled! Snipe away.

    SEVERE: Could not pass event PLAYER_COMMAND to VoxelSniper
    at com.thevoxelbox.VoxelSniper.VoxelSniperListener.onCommand(VoxelSniper
    at com.thevoxelbox.VoxelSniper.VoxelSniperListener.onPlayerCommand(Voxel
    at org.bukkit.plugin.java.JavaPluginLoader$5.execute(JavaPluginLoader.ja
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:616)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:589)
    at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    at net.minecraft.server.NetworkManager.a(SourceFile:232)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:104)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:317)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:232)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
    2011-02-16 18:26:57 [INFO] johno323 issued server command: v 41
    2011-02-16 18:26:57 [INFO] Unknown console command. Type "help" for help.
  16. Offline


    I really have to thank the creator. I couldn't have built my huge pyramid without it. This was created by setting /v to 24. /b to s. And getting a piece of sulpher and just spamming the right click button until each side was done. Again THANKS for creating this plugin. Also, in your road tutorial you talked about importing a structure from one map into your current map. Say I want to import this pyramid to another map. How do I do that?[​IMG]
  17. Offline

    Voxel Box

    New tutorial today, folks:

    VoxelSniper for Advanced Users: Terraforming Oceanated Edges
  18. Offline


    Tx, really needed the last tutorial :D

    amazing tool
  19. Offline

    Voxel Box

    Exciting stuff ahead in future releases of VoxelSniper!

  20. Offline


    edit : bug gone with bukkit update!
  21. Offline


    Hm, I was sure I already changed that before ... hmmm...
  22. Offline


    Oh wow! That Clone Stamp brush is amazing. Any ETA as to when it will be out?
  23. Offline


    I redownloaded and upgraded server to build 405 = works
    sorta.. some of the /b commands are either changed or having issues..

    /b b = error was the ball cmd removed ?
    other edit plugins i currently have


    Edit : If you want, i can add your username to the "sniper.txt" and you can login and test
    issues yourself, no griefing ;) issue with cmd's not working. Just Pm me the username.
  24. Offline


    im having trouble getting this mod to work, i did what it says, but i think im messing up with the sniper.txt part. i put my username in but it wont work. also macosk folder with a sniper.txt and i dont know if thats the one i should be using.
    --- merged: Feb 22, 2011 4:08 PM ---
    never mind i figured it out
  25. Offline

    Voxel Box

    Make sure you are using "snipers.txt"
    with an "s" at the end
  26. Offline


    2011-02-22 20:07:21 [WARNING] Using the stupidly long constructor com.thevoxelbox.VoxelSniper.VoxelSniper(PluginLoader, Server
    , PluginDescriptionFile, File, File, ClassLoader) is no longer recommended. Go nag the plugin author of VoxelSniper to remove
    it! (Nothing is broken, we just like to keep code clean.)

    So, here I am .. nagging the author. Using build 416.

  27. Offline


    I know, I know. It is already changed to the new format. Will come out with Clone-Stamp brush
  28. Offline


    I think i narrows my issues down to be a conflict with Worldedit 4.x+
    When i type

    /b ?
    i get this listet
    /b sphere/cyl....

    Now i found this on the We upgrade changes..

    • /brush sphere [-h] <block> <radius>
    • /brush cylinder [-h] <block> <radius> [height]
    • /brush clipboard
    • /brush smooth [size] [iterations]
    Looks wery fammiliar with the issues i have..
    gonna test with next 1.3 compatable bukkit build.
  29. Offline


    I can confirm the issue with WorldEdit, pretty dumb if you ask me :/
    We need a plugin that is able to disable certain commands on a per plugin basis so we can avoid those problems, right now I cant use Voxel because of WorldEdit ;(
  30. Offline


    Same here.
  31. Offline


    did some extensive testing now its all back..

    Voxelsniper works fine alone
    World edit works fine alone.

    Mixed together Worldedit overrides Voxelsnipers commands. :(

    Kinda use both.

Share This Page