[EDIT/FUN/SEC] VoxelSniper v5.019 - Flexible Long-Range In-Game Map Editor [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Voxel Box, Jan 23, 2011.

  1. Offline

    Voxel Box

  2. Offline


    Sure. Here is the changelog if you're interested:

    changelog (open)

    [5.092] -- Added multi-command functionality - prz
    [5.093] -- Underlay was added to liteBrushes enum. Also first commit to SVN - prz
    [5.094] -- Changed "/vupdate" to "/vchunk" for compatibility with VoxelUpdate - psa
    [5.095] -- Changed the mechanics of Disc.java to fix undo problems - prz
    [5.096] -- Fixed minor typo in copypasta (silly minus signs) - giltwist
    [5.097] -- Updated some undo code - prz
    [5.098] -- Added Comet brush for the new blaze small fireball, pw protected at Ridge's request - Giltwist
    [5.099] -- Allowed OP's to /addsniper - prz
    [5.100] -- Typo - prz

    Check out VoxelUpdate if you would like to be able to update or install any of the VoxelPlugins straight from ingame!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  3. Offline


    Big problem.

    I set my brush to disc
    I set my size to 5
    I pick gunpowder
    Change my /v to 31 (long grass)

    Instead of giving me tall grass, it gives me a bunch of dead shrubs? How do I fix this?
  4. Offline


    Try the 'mu' performer. Also try re-logging.
  5. Offline


    I type /b d mu and it is still placing dead shrub. Re logging has no effect
  6. Offline


    That would mean that data value 0 is not what you want.
  7. Offline


    I have tried /vi 1 and 2 and it still doesnt work.

    I take it there is no solution to this issue?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  8. Offline


    Wait, do you mean 'mi' performer? I didn't think there was a 'mu' performer... I believe it should be /b d mi, /v 31, and /vi 1 to place tall grass.
  9. Offline

    Voxel Box

  10. Offline


    Dumb question, but I need to know, since googling my brains out didn't work --- does VoxelSniper work for 1.5_01 Beta? Because that's what I'm using. Oh, and the server is:
    git-Bukkit-0.0.0-706-gf53e007-b740jnks (MC: 1.5_02)

    I added my name to snipers.txt, but I get errors:

    [WARNING] [VoxelSniper] Error while loading SniperConfig.txt
    [SEVERE] java.lang.ArrayIndexOutOfBoundsException: 1
    [SEVERE] at com.thevoxelbox.VoxelSniperListener.loadConfig(VoxelSniperListener.java:961)
    [SEVERE] at com.thevoxelbox.VoxelSniperListener.initSnipers(VoxelSniperListener.java:58)
    [SEVERE] at com.thevoxelbox.VoxelSniper.onEnable(VoxelSniper.java:41)
    [SEVERE] at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
    [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:632)
    [SEVERE] at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:218)
    [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:116)
    [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:94)
    [SEVERE] at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:217)
    [SEVERE] at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:204)
    [SEVERE] at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:144)
    [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:259)
    [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)

    Thanks :)
  11. Offline


    For the item id for grass there are 3 kinds. Dead shrub= 31:0 tall grass = 31:1 fern = 31:2
    Dead shrub is the default. You could try typing in /v 31:1 but I think voxelsniper only supports the default id. You can't do colored wool either.
  12. Offline


    You are kidding me. If we didn't support data values how the hell would VoxelSniper be the first tool to use multi-level snow tiles?
  13. try
    /b s c
    /v 31
    /vi 1

    it's your brush, not the data value.
  14. Offline


    Might sound stupid. But where to heck to i get the gunpowder tool?
  15. kill a creeper.
    or, open your inventory in creative mode.
  16. Offline


    This might be a stupid question but.
    my /v command doesn't work.
    every other command does.
    When i type /v 17 (or any other number) and press enter again nothing happens (i don't even get an error on the server or in my server log).
    does anybody know how to fix this. so i can use my /v command. cause without it you can't do anything.
  17. Offline


    I downloaded this plugin everything went well until i started the server and tried using the voxelsniper and i tried to use it but all it said was "unknown command try "help" and look i did everything right but are u sure its suposed to be voxelupdate?
  18. Offline


    Well it's not that bad.. but i still think you should make a command like ./b help that shows all the brush commands :D
  19. Offline


    /vs brushes & /vs brusheslong ?
  20. Offline


    Why is there no Recommended Build in the title? :p That's required for a thread, well, a Plugin Submission thread anyway, not too sure if there's an exception for already-released plugins.
  21. Offline


    Maybe because it always works .. iunno ... just a thought.

    Either way, this thread is not supported 'nymore.. afaik the PR guys decided to use DevBukkit
  22. Offline


    When an RB comes out, so will an update. That is .. if the RB actually breaks anything.. otherwise no point in update eh?
  23. Offline


    I did not request an update. I was giving you a heads-up in the unlikely event that it saves you some time when the RB comes out, showing you where you may want to look, eh?
  24. Offline


    Maybe. Either way, VoxelUpdate will take care of all your up-to-date-plugin needs.
  25. Offline


    They may want to check the comments on the doop page. There's a month of help requests in the comments that haven't been responded to.
  26. Offline


    Doop page?
  27. Offline


  28. Offline


    I flipping HATE curse. Bunch of attention seeking bananas who can't do poop. I receive notifications just fine on the well programmed bukkit forums, but nooooo ... on the Curse-controlled poop it must be some kind of privelage to receive a notification...

    *Sigh* time to get reading.

    Edited by NinjaGrinch: Be civil, Curse workers are people too! It takes time to add features and cannot be done within a few seconds or just by pressing an "Add Feature" button.
  29. Offline


    Is there a box shaped clone tool in vs? Been using it awhile but haven't really looked up any recent additions (or old ones I missed). Looking for something like the /b set brush that just lets me copy a zone. /b setvox or something, add a 90 to rotate it on paste. Meh, just asking.
  30. Offline


    Is this updated for 1.1? If not, please update it. I love this plugin :)
  31. Offline



    Im looking for an easy way to fix water...
    either when it is not smooth or when there is flowing water in the middle of an ocean after you built something and then removed it.

    Is there a way with voxel to do this?

    well i can not change the drain brush from a ball to disc.
    ive tried /b drain d but it is invalid
    only works to do /b drain

    and /b drain is a ball that removes all water..
    so it does not transfoorm flowing water into still water

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016

Share This Page