[EDIT/FUN/SEC] VoxelSniper v5.019 - Flexible Long-Range In-Game Map Editor [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Voxel Box, Jan 23, 2011.

  1. Offline

    Voxel Box

  2. Offline


    So is it safe to say that Voxel Sniper works on all build 1337+?
  3. Offline


    It has worked for me from 1060 through all builds, so I would say it works on all 1337+...
  4. Offline

    colin shepherd

    It says the 404 was not found under the download link...HELP!!!
  5. i dont know if it's safe, but it's seems to work for now, anyway.
  6. Offline


    Download link is a 404. Please fix.

    In fact, the Github is a 404 too. Please, fix it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  7. Offline


    Not that I disagree, but I have to wonder if the lack of namespacing between bukkit commands will eventually be problematic. The user should be allowed to use any command without prefixing, but in the case of conflict, a /switchplugin <name> could/should/would cause the server to first consider that plugin's list of commands over others that are installed.

    Not that I think you are responsible for implementing this in any way-- just ruminating on what will presumably become a larger problem for mods.
  8. Offline


    I saw in the wiki under "VoxelSniperDev" you said that a brush that fixes water would not be accepted as an idea because it already existed? I was just wondering how you would fix water currents with the current sniper, since I haven't found a way to do this, and I have tried for quite a while to make it work.

  9. Offline

    Voxel Box

    /b b i
    /vi 0

    PhoenixRising likes this.
  10. Offline

    Lunar Delta

    The /b fd brush is also awesome for this task. Use that with /v 9 and /b 15 and bam! You can then use /b d i with /vi 0 to fix the flows afterward.
  11. Offline


    Unrelated, but the next Version of VoxelSniper to be released will include a special feature! This feature will allow you to use multiple commands in one message!

    For example:

    Say you are derping around and some annoying griefer shows up, right? So you're all like "Ah, MEH! Another damn griefer... I must ban him and clean up his shit now :/"
    And than you ...

    Simple right?
  12. Offline


    So, since RB is released are you going to update this?
  13. Offline


    It is updated, check the Wiki. But in all seriousness VoxelSniper works even without the need of updating.
  14. Offline


    The Submission Guidelines require you to test your plugin to make sure it's still compatible with the latest RB as well as keep your thread up to date, otherwise it is marked inactive. The thread reports build 1060 and your wiki reports 1337.
  15. Offline


    Last I checked we moved that that Bukkit Dev stuff, and I wouldn't be saying that it works if I didn't test it. Although I really had no need to test anything..
    iMattxC and PhoenixRising like this.
  16. Offline


    VoxelSniper simply isnt just for anyone ;)
  17. Offline


  18. Offline


    Thanks, I didn't realize water streams used ink values... :confused: Anyway, I will use this a lot, so thanks for the prompt reply!
  19. Offline


    The download link from the wiki is empty. It gives me a 0 bit jar.
    EDIT - works now. Must have been the upload to dropbox
  20. Offline


    Works just fine for me
  21. Offline


    Will there be a per-world disable of sniper? I think this would be a fairly easy thing to implement, with just a text document with a list of worlds that sniper is disabled on. It would also be easier than permissions, and would really help out any servers using sniper with a survival world...

    Thanks! :)
    Jay101 likes this.
  22. i support that.
    Potatoboy2 likes this.
  23. Offline


    I hate having to ask but I'm stumped here. I've read the wiki and searched through google for a while now. Before I thought maybe it was just broken because it wasn't for RB, but now that it is I downloaded it to test it out to see if it works now. I still cant get it to work. The thing I cant get to work is Inks. I cannot place colored wool at all. I can do everything else fine (its just /vi that isnt working apparently, for me) just cant figure this out. Am I doing it wrong, am I making some kind of newbie mistake? I have the /v set to wool, and it places it fine. It even works for everything else. But when I use /vi number, it says "data variable set to 11" but the wool it places is still white.

    Since I couldn't find any other mention of this being a problem on google, I'm hoping that I'm just misunderstanding something and no entering something right. Can anyone help with this?
  24. Offline


    You need to use a performer that uses ink:


    Read up on this and you should be fine ;)
  25. Offline


    Thank you Przerwap. Turns what the command I was looking for was
    /b b i
    /vi <color>
    /b 0

    After that I imagine its more simple, as I'd just have to change the /vi again to change wool color, as apposed to going through all that for each color change. I'll play with that later but at least I finally got somewhere. Thanks for the assistance.
  26. Offline

    Lunar Delta

    If you actually want to *place* colored wool, the "c" performer is the proper choice.
  27. Offline


    Are you guys updating this for 1.0.1 R1? I would love to use it in my server. Thanks!
  28. Offline


    It works.
  29. Offline


    Any comment on what I said earlier, as to if you would maybe implement a per-world disable of sniper in some future release?
  30. Offline


    I'll think about it.
  31. Offline


    Thanks, I'm just glad you're actually considering it... :D

Share This Page