[EDIT/FUN/SEC] VoxelSniper v5.019 - Flexible Long-Range In-Game Map Editor [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Voxel Box, Jan 23, 2011.

  1. Offline

    Voxel Box

  2. Offline

    Voxel Box

    We primarily use our own permissions system (VoxelPermissions) built into each plugin. We may support Bukkit's permissions system in the future.
  3. Offline


    Hello I was wondering weather this mod can change the minecraft building limit.

    I want to build very tall buildings but its getting very annoying.

    There is a client mod for extending the building limit but its very buggy and for 1.7.3 not 1.8.1

  4. Offline


    I can't seem to use the ball-replace brush. When i type /b br it says 'No such brush'.
    I remember it doing this to me last time i had VoxelSniper but i can't remember how i fixed it, thanks.
  5. Offline

    Voxel Box

    This is not a mod, and it does not extend the minecraft height limit.
    It is quite simple. The page that you are required to go to so you understand the tool also has a nifty infobox with a download link on the right side of the page.
    This is because the ball replace brush is indeed not a brush anymore.

    We have switched to a performer system. Ball replace is now /b b mm (ball brush, material-material performer). For the full information on this new system, please check out the VoxelSniper documentation at VoxelWiki.com
  6. Offline


    i cant seem to get the erosion tool to work for my 1.8.1 server. it sais no such brush exists when i type /b e
    please help, im trying to make a beautiful river :)
  7. Offline

    Voxel Box

    Four things:

    1) We have not yet released a version that is advertised as capable with 1.8.1, as there is not yet an RB. Things might not work as advertised until then.
    2) Try typing /b e fill or one of the other erosion presets.
    3) If step 2 fails, type /vs brushes and make sure the e is on the brush list. It's possible that you may have an outdated version of VoxelSniper, which you can check by typing /version VoxelSniper
    4) I don't believe the erosion brush is available to LiteSnipers by default. Are you a full Sniper?
  8. Offline


    im a a full sniper, and no it is not on the list... any idea when it will be updated to 1.8? i made my river but BOY was it a pain in the ass :p
  9. Offline

    Voxel Box

    Are you using the latest release? /version VoxelSniper should read 5.019. Have you tried reinstalling?
  10. Offline


    i get the voxelsniper is enabled, but it doesnt create any sniper.txt :( using latest version in OP
  11. Offline


    Same here...

    org.bukkit.command.CommandException: Unhandled exception executing command 'u' in plugin VoxelSniper v5.019
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:352)
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:737)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:701)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:694)
            at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:89)
            at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:478)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:454)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NullPointerException
            at com.thevoxelbox.vSniper.doUndo(vSniper.java:310)
            at com.thevoxelbox.VoxelSniperListener.onCommand(VoxelSniperListener.java:299)
            at com.thevoxelbox.VoxelSniper.onCommand(VoxelSniper.java:67)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    I don't found a answer from the developer to your issue. You found a way to fix it? This is really annoying... and i only tryed to undo the first steps from the documentation.
  12. Offline

    Voxel Box

    Check in the VoxelSniper folder & in the /plugins folder for it.
  13. Offline


    @t VoxelBox: Do you understand how my error message can be appear? It's another Plugin fault? I followed your instructions in the documentation.
  14. Offline


    Is there a way with Voxel Sniper 5 to do a replace on several materials at once? I have seen in the old videos a replace brush being created that converted log and leaves to air at the same time, although I was unable to see how exactly. Is this possible with the new Voxel Sniper and if so, how? It would be a MASSIVE time saver.
  15. Offline


    How i can replace material with bigger brushes?

    At the moment i try to brush the different materials under water to SAND (12) but, only the Sniper (1x1 Block) a really replacing stuff. If i try to use another shape (like ball, disk and so on) the create complete shapes. I thought, the arrow is for replacing, and gunpowder for creating. Why the Arrow creating now the shapes?

    I only want to paint all the different materials under water to 12, and make a naturally look. (moved City Island)

    /b s m
    /v 12
    Replacing materials (with Arrow)

    /b d m
    /v 12
    Creates materials (with Arrow) <- I don't want this i only want to replace more blogs. Bigger Brush as 1x1 (sniper block)

    /b <sizevalue> don't affect in sniper mode.
  16. Offline

    Voxel Box

    I'm not actually a developer for the plugins (just painfully knowledgeable about them), but I see "spout" mixed in there. Could that have to do with something?
    Not yet, but it may be coming soon!
    I would highly recommend re-reading our documentation for VoxelSniper. We're using a system which allows virtually any brush to either set, replace, ink, ink replace, and on and on! This is the performer system, which is beautifully described on the VoxelWiki:

  17. Offline


    I don't know... yesterday (one day after my issue post) i used your plugin again and no problems appeard. I think it is possible that the step count created the error: /u <steps> (expample: /u 3)

    At the moment it works.

    Any Infos about 1185 compatiblity? We want to switch to the new bukkit version.
  18. Offline


    can you make a version for 1185 sry for my bad english i come from germany
  19. Offline


    I've tried to read over the new commands, but I just do not get it. Here's what I want to do:

    I want to replace water & stationary water (8 and 9) with air. I used to be able to do this with something like

    /b dr
    /vr 8
    /b dr 9

    but now I cannot for the life of me figure out how to replace two materials simultaneously with one different material.
  20. Um your download button is also linked 2 the wiki instead of downloading. :confused:
  21. Offline


    No, that's correct (but definitely misleading)...the actual download link is on the right side of that wiki page, under the VoxelSniper logo.
  22. Thanks I didn't see that button.
  23. Offline

    Voxel Box

    A release will be sent out for Build 1185 once we playtest it. 1.8 changes a bunch of stuff.
    Again, a release will be sent out for Build 1185 once we playtest it. 1.8 changes a bunch of stuff.
    It's generally updated on the wiki for most commands, but I don't believe multiple-replace has been released yet. Coming soon (hopefully)!

    (to do normal replaces do /b b mm /vr 8 /v 1)
    Yep. You need to read the wiki before you download it anyway. VoxelSniper isn't just "plug and play" type of thing.
    It may seem misleading, but our documentation must be read by anyone using VoxelSniper.

    Think about surviving your first night of Minecraft without knowing at ALL how to play the game -- that is what it would be like if you downloaded VoxelSniper without reading the documentation.
  24. Offline


    Great news! Looking forward to that one, as water cleanup is a bit tricky when 8 turns into 9 which turns into 8. Same with lava but not quite as bad.
    Yeah, that makes perfect sense, however that tiny download link is a bit like a scavenger hunt every time I pop in for a new version and always forget where it actually is. Also, where can I get links to legacy versions?
  25. Offline


    Drain brush?

    And what do you mean Legacy versions

    Who told you that it doesn't work ?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  26. Offline


    v5.019 confirmed working in 1185. In fact, until recently I was using an even older version with no errors. Check your other plugins and configuration settings.

    I'm even able to set my material to the new blocks by aiming and /v or shift click, just not by name or ID number.
  27. Offline


    If you add them to the items.txt you will be able to select them by name or ID, but the next release will update it for you
  28. Offline


    Hello i want to be a able to limit VoxeSniper to certain worlds and if possible certain WG regions that would be great but mostly the Worlds are important for me!
  29. Offline


    Is the site down at the moment? 'Cause I get an error when I try to enter it :p
  30. Offline


    I'll have to give that brush a try...sounds like just what I need. I am still interested to see the ability to add multiple types to /vr in the future though, as it comes in handy very often.

    I mean links to 4.x versions.
  31. Offline

    Voxel Box

    World permissions probably won't be in a future update (sorry), and I know that this plugin, or any VoxelPlugin, will not depend on other plugins to function (ESPECIALLY not WorldEdit).
    Workin' fine.
    Why would you need a 4.x version?

Share This Page