Inactive [EDIT/FUN] BlastPick - Clear your path. [1.1-RB]

Discussion in 'Inactive/Unsupported Plugins' started by gnftoxic, Mar 3, 2011.

  1. Offline


    Clear Your Path!
    Version 2.0.0

    Live Chat @ #bukkit

    BlastPick allows you to clear griefers messes, big areas, etc. with a simple right click. Based on ho0ber's mod, BlastPick allows you to control who has access via PermissionsBukkit, based on assigning to groups, users, or both.
    Default Configuration (plugins/BlastPick/config.yml):​
        # group name
            # maximum distance
            max: 100
            # default distance
            default: 10
        # maximum / standard length of the blastpick.
        length: 10
        # tool to use for blastpicking
        tool: DIAMOND_PICKAXE
    - CHEST

    Groups can be used in your PermissionsBukkit config.yml pretty easily. Simply add the node "blastpick.groups.groupName" to your player or group. For example, I would add "blastpick.groups.admin" to my Admin class. This will not work without blastpick.use permission node.

    /bp [size] (blastpick.use)

    • 2.0
      • Updated to new Event handling system.
      • Removed Permissions support and updated to PermissionsBukkit
      • "Length Groups" that allow you to set maximum lengths per user or per group in PermissionsBukkit.
      • Maximum length configuration value.
      • Blacklist of blocks to prevent blastpicking.
      • Configurable tool
    • 1.3.1
      • Fixes bedrock protection below level 8
    • 1.3
      • Code cleanup
      • Takes region protection into consideration (by checking if BlockBreakEvent is cancelled)
    • 1.2-AE
      • Adds BlockBreakEvent calls
      • Disabled removal of dispensers
      • Bug fixes
      • Only removes bedrock above level 8.
      • Fixed north/south issue
    • 1.0
      • Initial release
    Special thanks to:
    @ArmEagle for helping / developing while I was gone & implementing block break events :)
  2. Offline


    Sweeet i used to have this and been wanting this for ages for bukkit :)
    Thanks man !
  3. Offline


    Please test your plugin with the latest Recommended Build (493) and update your release post accordingly as it is now a requirement of the submissions process, since the newest RB contains breakages.
  4. Offline


    Apologies, deleted my posts as I thought it said 492, but retested on 493, works perfectly.
  5. so.. .this works with any kind of pick then ? any way to make it only work with a stick ?
  6. Offline


    It only works with 278, diamond pick. I do not have that as a configurable option, sorry. I don't quite understand why it makes a difference.
  7. Offline


    i cant seem to get blastpick to work. When i type /bp 10, it says set bp to 10 in green
    but when i try to break something, nothing happens. it only breaks the 1 block. ive tried a diamond and stone pick. help plz?
  8. Offline


    You right click. Not left click.
  9. Offline


    Thanks, was waiting for this plugin to be ported :)
  10. Offline


    I cant seem to get it to work, i dont know what tool i should use :)
    Maybe ad a config file with a configurable tool :)
  11. Offline


    It works perfectly along the Y and Z axis, but if I try it on the X-axis it only breaks one block (still instantly though). Is this just me?

    Edit: Correction; along the X axis it mines 1 block in front of me, and the rest backwards. So if /bp is set to 20 it mines 1 forwards and 19 backwards...

    Where did you learn to read?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  12. Offline


    Hey I installed Blast pick but it didn't work, kept saying I'm not allowed to use that command. I don't have permissions installed and I am an op. Please help.
  13. Offline


    It's working here, what version of Bukkit are you using? Working for me using 531.
  14. Offline


    It may not work properly with newer builds, I will double check soon. I'm currently in the middle of something right now, sorry.

    Are you still experiencing this issue? I just tested this on #556 and I cannot duplicate this.
    It's working for me - as dark_hunter said, I need to know what version of craftbukkit you're running.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
    dark_hunter likes this.
  15. Offline


    I'm using this one.
  16. Offline


    That could be several different versions, depending on when you last updated. Could you type "version" into your console and return the output?
  17. Offline


    "This server is running Craftbukkit version git-Bukkit-o.o.o-516-gdf87bb3-b531jnks <MC: 1.3>"
  18. Offline


    I just updated bukkit, still same error, still not running permissions, still an op. =(
  19. Offline


    Hey there, I'm running the newest version of permissions and craftbukkit 559. As an op it is possible for me to use blastpick. However, even though I stated - 'blastpick.usepick' in the config file of permissions, for my users, they are not able to use the command as permissions tells them they are not allowed to. Is there something I could do?
    I'm quite sure about the correctness of the config file..

  20. Offline


    I will have to look into permissions on #559 - I've tested it on 531 last, and whatever build I'm running my servers on.
    Which distribution of Permissions are you guys using? 2.5.4 Pheonix or whatever?
  21. Offline


    Yeah the last one, pheonix 2.5.4. Thanks!
  22. Offline

    Steve Cole

    i cant get blastpick to work with my groupmanager groups
    only people in the op.txt file can use it
  23. Offline


    You are a complete failure.
  24. Offline

    Steve Cole

    by that i will assume that permissions and groupmanager are not as interchangable as I thought.
    so allow me to rephrase
    do you have any plans on adding groupmanager support?
  25. Offline


    How come at the start of your topic you say it can work with permissions, then at the end of your topic the FAQ, it you say it can't work with permissions?
  26. Offline


    Please use common sense, it's for people whom don't read the damn topic.
  27. Offline


    Can you make it toggleable? Or can i just set /bp 0 and it will disable it? Because, I am also currently using my diamond pick for other rightclicking functions from worldguard.

    Also, any chance of allowing us to choose which tool?
    pyromanic and gnftoxic like this.
  28. Offline


    If you do /bp, it'll turn on BlastPick, if you do /bp again, it will disable it.
    I may or may not create a configuration for selecting what item it uses.
  29. Offline


    Thanks ^^

    -installed and played around with it- (mostly for clearing annoying floating trees)
  30. Offline


    Using CB 556 and Permissions 2.5.4 here. BlastPick works for ops, although something is printing a few extra lines in the client when you enable/disable it:

    BlastPick length set to 1o
    Unknown console command. Type "help" for help.
    Unknown console command. Type "help" for help.

    But with - 'blastpick.usepick' added correctly to the permissions file, non-ops are getting this:

    You cannot use this command.

Share This Page