Inactive [ECON/RPG/FUN] TreasureHunt 0.8.2 - Randomly-placed treasure goodness! [1.2.4-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by Taien, Sep 27, 2011.

  1. Offline


    Any ETA on when the fixes will come?
    I just started a new PVP server and would love to use this plugin (but config files are messed up).

    Also if possible it would be extremely awesome to make an option for minimum amount of players for it to generate chests? (I want at least 2 or 3 people online in order to start any treasure hunts).
  2. Offline


    Hey, is it just me or does the '/starthunt here value command not work?
  3. Offline


    You need to configure your plugin so Permissions 3.x will work.
  4. Offline


    Hi there,

    i really want to like this plugin, but i have a problem:
    This plugin needs about 30 percent of the CPU performance when i activate it. And after some time i always get the following error:

    2012-01-13 13:36:16 [WARNING] Task of 'TreasureHunt' generated an exception
    java.lang.OutOfMemoryError: Java heap space
        at net.minecraft.server.ChunkProviderGenerate.getOrCreateChunk(SourceFile:218)
        at org.bukkit.craftbukkit.generator.NormalChunkGenerator.getOrCreateChunk(
        at net.minecraft.server.ChunkProviderServer.getChunkAt(
        at org.bukkit.craftbukkit.CraftWorld.getChunkAt(
        at org.bukkit.craftbukkit.CraftWorld.getBlockAt(
        at me.taien.THHunt.<init>(
        at me.taien.TreasureHunt.startRandomHunt(
        at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
        at net.minecraft.server.MinecraftServer.w(
    2012-01-13 13:36:22 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2012-01-13 13:36:49 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2012-01-13 13:36:58 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2012-01-13 13:37:15 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2012-01-13 13:37:29 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2012-01-13 13:37:56 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2012-01-13 13:38:15 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2012-01-13 13:38:31 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2012-01-13 13:40:03 [SEVERE] Exception in thread "File IO Thread"
    2012-01-13 13:40:03 [SEVERE] java.lang.OutOfMemoryError: Java heap space
    2012-01-13 13:40:03 [SEVERE]     at java.lang.StringCoding$StringEncoder.encode(Unknown Source)
    2012-01-13 13:40:03 [SEVERE]     at java.lang.StringCoding.encode(Unknown Source)
    2012-01-13 13:40:03 [SEVERE]     at java.lang.String.getBytes(Unknown Source)
    2012-01-13 13:40:05 [SEVERE]     at Method)
    2012-01-13 13:40:05 [SEVERE]     at Source)
    2012-01-13 13:40:06 [SEVERE]     at Source)
    2012-01-13 13:40:06 [SEVERE]     at net.minecraft.server.RegionFile.<init>(SourceFile:94)
    2012-01-13 13:40:08 [SEVERE]     at net.minecraft.server.RegionFileCache.a(SourceFile:63)
    2012-01-13 13:40:08 [SEVERE]     at net.minecraft.server.RegionFileCache.c(SourceFile:93)
    2012-01-13 13:40:09 [SEVERE]     at net.minecraft.server.ChunkRegionLoader.a(SourceFile:131)
    2012-01-13 13:40:09 [SEVERE]     at net.minecraft.server.ChunkRegionLoader.c(SourceFile:121)
    2012-01-13 13:40:11 [SEVERE]     at net.minecraft.server.FileIOThread.b(SourceFile:29)
    2012-01-13 13:40:11 [SEVERE]     at
    2012-01-13 13:40:12 [SEVERE]     at Source)
    2012-01-13 13:40:12 [SEVERE] java.lang.OutOfMemoryError: Java heap space
    2012-01-13 13:40:14 [SEVERE]     at net.minecraft.server.NBTTagCompound.setShort(SourceFile:49)
    2012-01-13 13:40:14 [SEVERE]     at net.minecraft.server.ItemStack.b(
    2012-01-13 13:40:15 [SEVERE]     at net.minecraft.server.EntityItem.b(
    2012-01-13 13:40:15 [SEVERE]     at net.minecraft.server.Entity.d(
    2012-01-13 13:40:16 [SEVERE]     at net.minecraft.server.Entity.c(
    2012-01-13 13:40:16 [SEVERE]     at net.minecraft.server.ChunkLoader.a(SourceFile:125)
    2012-01-13 13:40:16 [SEVERE]     at net.minecraft.server.ChunkRegionLoader.a(SourceFile:84)
    2012-01-13 13:40:17 [SEVERE]     at net.minecraft.server.ChunkProviderServer.saveChunk(
    2012-01-13 13:40:18 [SEVERE]     at net.minecraft.server.ChunkProviderServer.saveChunks(
    2012-01-13 13:40:19 [SEVERE]     at
    2012-01-13 13:40:19 [SEVERE]     at net.minecraft.server.World.doTick(
    2012-01-13 13:40:20 [SEVERE]     at net.minecraft.server.MinecraftServer.w(
    2012-01-13 13:40:22 [SEVERE]     at
    2012-01-13 13:40:22 [SEVERE]     at
    2012-01-13 13:40:22 [SEVERE] Unexpected exception
    java.lang.OutOfMemoryError: Java heap space
        at net.minecraft.server.NBTTagCompound.setShort(SourceFile:49)
        at net.minecraft.server.ItemStack.b(
        at net.minecraft.server.EntityItem.b(
        at net.minecraft.server.Entity.d(
        at net.minecraft.server.Entity.c(
        at net.minecraft.server.ChunkLoader.a(SourceFile:125)
        at net.minecraft.server.ChunkRegionLoader.a(SourceFile:84)
        at net.minecraft.server.ChunkProviderServer.saveChunk(
        at net.minecraft.server.ChunkProviderServer.saveChunks(
        at net.minecraft.server.World.doTick(
        at net.minecraft.server.MinecraftServer.w(
    I am also getting the
    [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    every few seconds or minutes when the plugin is running.
    Any idea how to solve this problem?
    If you need more information just ask.

    Thanks for your help!
  5. Or... You should switch to an permissions plugin that actually are supported and not inactive. More and more plugins stop supporting Permissions 3 so you would only do yourself a favor to switch to one that is active.

    One thought about this plugin. I'm running a private server for me and a couple of friends. Since we're not many people playing (20 at most) and the map is quite big. Running around with rotten food is ok, but is it possible to make the plugin mark the spot on dynmap?

    Since the console prints out the exact coords when a new treasure is generated, it seems like it would be possible to make it use dymaps dmarker to mark it on the map. This way we on the server would actually compete to reach it first. :)


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 20, 2016
  6. Offline



    P.S. Your Avatar is scary... D:
  7. My avatar is me, so I'm scary.

    If you're not going to switch permission you are going to have to live with a lot of plugins not working since your permissions plugin isn't updated any more. I've used permissionsBukkit and PEX and both works fine.

    But it's your choice. I don't think anyone making plugins will put down extra time to make them compatible with something that's inactive thought...

    EDIT: Just for you I changed my Avatar. Happy? :) (Still me thought)
  8. Offline


    Thanks for your comments and ideas.

    First off, I might be able to add some dynmap stuff down the line, but for now it's not a priority since there are still issues with the plugin itself. But yes, it does seem as if it would be extremely easy to make it mark it :)

    On an upnote...
    Version 0.7 has been released. See changelog for details. I've basically moved to Vault for supporting various permissions and economy plugins. I'm sorry if some of you don't like Vault for whatever reason, but I've found it to be extremely efficient on my server and very helpful as a plugin coder. It basically allows me to support any permission/economy plugin without having to code huge subsections of code to handle that stuff. I highly recommend downloading it.
  9. Offline


    I'm going to try 0.7, if more errors appear I'll post here :p
  10. Offline


    Yes, the avatar is better, and I was able to get PEX to work after 2 hours of messing around with it.
    Sketaful likes this.
  11. Offline


    Thanks. Great plugin!
    • Is it possible to add some kind of SetCompass command (and permission)? I'm thinking that there would be some central starting place (HQ) that players would know about. Then when the hunt begins, they head to HQ where a CommandSign/ServerSign could set compass (for users that have a compass) to the location of the Treasure (or the Surface Location).
    • Also, is it possible to put a Min Player parameter in the configuration so the Hunt doesn't get triggered when there are too few players connected to the server.
    Do you prefer comments here or the BukkitDev thread?
  12. Offline


    I might just be missing it somewhere, but what do the values in the config file represent?
    I do not want people getting a stack of 20 'water' in the chests, and one chest had 5 stacks of feathers..
    Is there a way to set this config to regulate it some how ?
  13. Offline


    i get a horrible 5 second lagspike, spamming with CANT KEEP UP, right before the chest generates... any way to fix that ?
  14. Offline


    When my players type /hunt it returns the message /hunt.

    Any Ideas To Fix It?
  15. Offline


    Unfortunately, the chest generation can be taxing on weaker servers. It also could be caused by having too tight of requirements for the chest location (like light levels, distance, etc). What it does is basically picks a random location within the distance you specify, and then checks if that location meets the requirements. If it doesn't, it picks another spot and checks, repeat repeat repeat until it finds a spot.

    I plan to add a MaxChestGenRuns option for you to specify how many times it can attempt to find a spot before it gives up, thus saving your server from that lag. If you have a weaker server, you could set it to like 100 or something and you probably wouldn't notice any lag. I've had chest generation runs in the thousands of attempts on my server and it only lags a second or two even at that amount. So adding that option will be the best I can do in that regard. :) Or maybe I can find a way to have it space out its attempts over time.

    It's probably a permission issue. If you have a permissions plugin installed and the th.hunt permission isn't set to your players, they won't be able to use it. If you're not using a perms plugin or Vault at all, it will default to allowing people to use the command. So I think it's probably a perms issue.

    When a chest is generated the plugin picks a total value for the chest, between 0-5000, and may also draw a few more times if you have the DrawWeight set above 1. It will take the lowest value of the randomly picked numbers, and use that as the base value for the chest. The values in the config file for each item represent how much of that total value each item of that type takes up. The chest will populate with items until it hits or exceeds slightly the total value. So if you want less items in chests, set their values higher.

    Soon, you'll be able to set different sets of items to appear in each level of chest. Also, I'm adding multiworld support soon as well.

    Keep watching the bukkitdev section for this plugin. I may have it updated tomorrow. (Sorry, I've been working 50 hour weeks lately plus running my own server and programming for it, so I have neglected this plugin slightly, and I apologize for that). I have a r3 build working on my server which fixes some of the bugs in the ticket section, but I need to add those features I just mentioned in the previous paragraph before I release it. It won't take long. I'm getting pretty decent at this. :p

    As for the efficiency of the plugin...I'll probably go through and rewrite sections of it soon as well. This plugin was initially created when I was at more of a 3 or 4/10 level on minecraft plugin coding, and I'd say I'm up to about a 7 or 8/10 now. :p
  16. Offline

    Dan Schu

    How can I resolve this problem? I don't have an economy installed, if that's whats being problematic. The code below is what I have been getting when I try to start the server.
    18:45:23 [SEVERE] Error occurred while enabling TreasureHunt v0.7 (Is it up to date?): net/milkbowl/vault/economy/Economy
    java.lang.NoClassDefFoundError: net/milkbowl/vault/economy/Economy
        at me.taien.TreasureHunt.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(
        at net.minecraft.server.MinecraftServer.t(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
    Caused by: java.lang.ClassNotFoundException: net.milkbowl.vault.economy.Economy
        at Method)
        at java.lang.ClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
        ... 11 more
    I tried setting the money multipliers (money in the config.yml) to 0, and that didn't help.
  17. Offline


    I assume you don't have Vault installed either then right?

    I'll look into the code and make sure it's properly handling the case when Vault isn't around.
  18. Offline


    Couple of suggestions:

    1) The /starthunt command should start a hunt immediately without requiring any additional parameters. There could be a 'default setting' set up in the config to make this work nice. It's a nice easy and quick way for an admin to start a hunt without having to think. (I have so many plug-in's on my server, it's a real chore to remember commands. Heck, I couldn't even remember /hunt ... I had to lookup the plug-in to remember how to access the help).

    2) IF a hunt is already started, does a player get notified of this if they log in to the server after the fact? I haven't tried this, but, if this isn't the case, then I would like to suggest that when a player logs in to the server and there is already a hunt underway, that the play is notified of the hunt.

    Still testing the plug-in. I like the concept. Keep up the great work.
  19. Offline


    Fairly sure you can already /starthunt without parameters. If not, I can add it with the next version.

    Version 0.8 released! See BukkitDev for the download.

    The file will be available as soon as it is approved, or you can click the download link in the description for the project as well to download it from MediaFire. It is made for version 1.1-R4. See BukkitDev for all other information :) Thanks for your interest in my plugin, people.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 20, 2016
  20. Offline


    Idek how to make a hunt! Plz tell me, someone!
  21. Offline


    Is there a way for permissions I can use a two-word world name? The world is called "Stack-n-Craft World" So how would i write that in permissions?
  22. Offline


    That's a good question. I'm pretty sure world names like that are impossible, so you must be talking about a MultiVerse alias. Currently the plugin doesn't handle those, so it should instead have the folder name of your world (usually 'world'). In the case of multiple worlds, it's always the folder name of the world.

    Version 0.8.1 released!
    See bukkitdev thread for details and downloads :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 20, 2016
  23. Offline


    Actually, I just noticed that now. Apparently our host allows two-word worlds. But Apparently just "Stack-n-Craft World" in quotations works fine for treasurehunt. Its not a multiverse world either, its the main world. I didnt mean to name the world in two words, but I just didnt think before I did it lol... It makes using alot of plugins complicated.
  24. Just rename it then?
  25. hi,

    i configured all /hunt parameters good but when i try to /starthunt 4000 an internal error appears,

    Any idea?
  26. Offline


    Can you post the error (with line number) that you get in console?

    New version 0.8.2 released! See bukkitdev for details :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 20, 2016
  27. Offline


    MMMMMMMMMMMM, I must look in to this


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 20, 2016
  28. i installed now the new version, but the error persist. When y make /starthunt, this error appears in console:

    CONSOLE: Placed stronghold in INVALID biome at (52, -23)
    TreasureHunt: Location selection took 136 runs.
    TreasureHunt: Location selection took 53 runs.
    and "internar error ocured" appears in game
    any idea? i want this plugin :(
  29. Offline


    How do I force the chests to fade away? Instead of waiting out the time for it to fade?
  30. pelase, can confirm if this plugins needs vault to run?

Share This Page