Inactive [ECON/ADMN] DuckShop v30 - Create shops by placing signs [1185]

Discussion in 'Inactive/Unsupported Plugins' started by _ralts, Jul 15, 2011.

  1. Offline


    crazycrafter, iFooZy and Rellac like this.
  2. Offline


    I just started getting this error:
    07:40:20 [INFO] [DuckShop] Loaded 0 chest link(s).
    07:40:20 [INFO] [DuckShop] Permissions plugin detected!
    07:40:20 [INFO] [DuckShop] Using TheYeti for permissions.
    07:40:20 [INFO] [DuckShop] Using LWC for chest protection.
    07:40:20 [INFO] [DuckShop] Version 21 enabled. No viruses, honest!
    07:40:20 [INFO] [iConomy] Logging is currently disabled.
    07:40:20 [INFO] [iConomy] v5.01 (Eruanna) loaded.
    07:40:20 [INFO] [iConomy] Developed by: [Nijikokun]
    07:40:20 [INFO] Register: Payment method found (iConomy version: 5.01)
    07:40:20 [INFO] [DuckShop] Hooked into iConomy version 5.
    07:40:20 [SEVERE] Error occurred (in the plugin loader) while enabling DuckShop
    v21 (Is it up to date?): null
            at java.util.TreeMap$PrivateEntryIterator.nextEntry(Unknown Source)
            at java.util.TreeMap$ Source)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.init(
    I was wondering if it conflicts with commandsigns or annotate, or if this is something else? All functionality seems to still be intact; the signs still work and they credit/debit the iconomy accounts.
  3. Offline


    _ralts help me :( i dont know where or how to put the permissions i tried ingame i downloaded Permissions but i couldnt understand it also i tried writing the permissions in the console... please can you give me example of where and how should i type them... PLEASE! :(
  4. Offline


    great plugin thank you :)
  5. Offline


    how did u wrote the permissions and where PLS HELP! :(


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  6. Offline


    I need to download permissions, wich permissions ? please help.
  7. Offline


    um is it just me or are some of the items working and some are not like white wool im typing
    64 whitewool
  8. Offline


    any way to make it not require permissions for others to make/buy from signs?
  9. Offline


    I think it's a bug in CraftBukkit -- I have no idea what it's about. If it still works, I wouldn't worry about it.


    I admit "soul sand" would be a better name, so I'll probably change it in a later version.

    As for your comment on gold:
    But to be honest, now that you mention it, I might try that too. I'm currently being bothered by other projects, so don't expect anything soon.

    And no, there aren't any config files :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  10. Offline


    Ok I'm having a bit of a problem when i try to sell slime balls to ppl it says "Oh Noes! Cannot Trade". i put the right name on the sign. i have linked it with a chest. I've tried "slime" "slimeball" and "341" (the idem id). and it always puts it as "slime". But when I type "[Global]" on the first line instead of my name it works just fine. Any help plz. Thanks.
    • Your version of CraftBukkit and DuckShop- craftbukkit #1000, Duckshop version 21
    • Any other plugins you use and their versions- iConomy 5.0.1
    • What permissions nodes you have- I'm admin no nodes needed
  11. Offline


    Just want to say I love this plugin, so simple and easy to use, but since I use PermissionsBukkit (since its compatible with 1000) the plugin uses op only permissions :/. Could you make it compatible with PermissionsBukkit?
    Thanks ahead of time
  12. Offline


    What did you write on the sign? Are there slime balls in the chest?

    I'll think about it :)
  13. Offline


    good plugin :)
  14. Offline


    There seems to be an issue for me, when I try to set up a global shop selling or buying from my mall [Global] psapling $100 and [Global] $50 psapling , make the item turn to null?

    Also, nrack seems to not be working, it shows up correctly once typed into the sign, but when you click it nothing happens?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  15. Offline


    FYI, it conflicts with CommandSigns. I removed Annotate, restarted, replaced, removed CommandSigns, restarted, no error. Apparently CS doesn't inhibit functionality of DuckShop, but DS prevents proper enabling of CS signs somehow.
  16. Offline


    Thanks for pointing that out -- I'll put it up once @XA21X fixes the build server :p
  17. Offline


    so if i dont have a money plugin like iconomy, i can make shops like selling one diamond sword for 5 gold ingots for example?
  18. Offline


  19. Offline


    that's perfect! thank you for this amazing plug in :D
  20. Keeps saying "Oh noes Cannot Trade" When i did everything right, but it refuses to work with my food chest, but works with the others...

    If you're confident it's a bug, make sure you tell me these things:

    • CB 1060 DS 21
    • What you wrote on the sign:
      16 cookie
    • 1 coal
    • What you put in the chest
      food item, like apples cookies, etc.. all fail
    • What you wanted it to do
      give 16 cookies for 1 coal
    • What actually happened
      Oh noes! Cannot Trade!
  21. Offline


    Hello. I just installed the mod and we have iConomy5 installed as well. I created the sign and successfully connected it to a chest filled with dirt. I followed your instructions exactly, I swear. I setup permissions correctly as well. But whenever anyone clicks on a sign, it simply says "Oh noes! Cannot Trade!" I've tested it multiple times with varying members; no dice.

    Edit: My apologies; I didn't understand the difference between the second and third line on the sign. Fantastic plugin!

    Second edit: Wow! I tried using the plugin to bypass Lockette (sign set to diamonds and free) and it denied the user access. I was fearing this would be an oversight on your part, but nope! Excellent work!
  22. Offline


    It looks okay. Is there enough space in your inventory to hold 16 cookies? Does the chest have 16 cookies in it?
    Other than that, I have no idea.

    What did you write on the sign?

    Try putting the word "for" in the middle. 1 dirt for free. nothing for 64 diamonds.
  23. Yes, and yes. I guess we both have no idea what the problem is.
  24. Offline


    is it possible to link more than one sign to a chest? and why does it say "the owner of the sign doesn't have 1 cobble or whatever" when i go to trade?
    I am the owner of that sign and there is 1 cobble in the chest and 1 in my inv
  25. Offline



    What did you write on the sign?
  26. Offline


    <1 cobble>
    <2 dirt>
    <blank line>
  27. Offline


    It looks good. Is it in a double chest? DuckShop doesn't handle double chests well :(
  28. Offline


    yea its a double chest, i realised sometimes it works and sometimes it doesnt when you're making them
  29. Offline


    No no, you misunderstand. I'm saying I quickly resolved the issue. :)

    Oh, but I do have a minor suggestion, and I do apologize again if perhaps I missed it; Can there be an 'Anything' variable? I mean... can I have users donate anything they want to a chest, or as long as they give something they get whatever is being sold. If I'm not clear, here:


    ^ That would essentially be a donations sign, where they can give up anything.
  30. Offline


    So my documentation isn't that bad! :D

    Sorry, but I have no idea how that would work. How would players choose what to give?
  31. Offline


    Whatever is in their right hand, I figured. I'm not sure how difficult that would be. Default it to one item at a time to avoid counting issues as well.

Share This Page