Solved Disable Hunger Auto-Refill?

Discussion in 'Plugin Help/Development/Requests' started by UNC00KED, Oct 14, 2015.

Thread Status:
Not open for further replies.
  1. For some reason I can not get auto heal to disable in my Factions world on my server. It is really bugging me because I thought I set up everything correctly.

    Here is what's happening:

    I have tried using the following commands to disable auto heal, and none have worked:
    /mvm set hunger true
    /mvm set autoheal false
    /gamerule doNaturalRegen false
    /gamerule naturalRegeneration false

    Monster spawning in is set to 'true'.

    List of plugins: LinksOnSigns, GroupManager, Buycraft, VoxelSniper, WorldEdit, CustomEnderChest, Essentials, ClearLag, WorldBorder, NoCheatPlus, SignEdit, AsyncWorldEdit, WeatherLock, EssentialsChat, mcMMO, Vault, MassiveCore, PlotSquared, WorldGuard, Factions, EssentialsXMPP, EssentialsGeoIP, RandomLocation, Commandspy, CombatLog, SilkSpawners, Multiverse-Core, VanishNoPacket, Multiverse-Portals, FactionsChat, HolographicDisplays, SilkSpawnersShopAddon, Multiverse-Inventories, Multiverse-SignPortals

    Would appreciate any help, thanks!
  2. Offline


    try /gamerule naturalRegeneration false
  3. Offline


  4. Offline


    Is it possibly a WorldGuard flag?

    To figure out which plugin is causing the problem you should use this plugin troubleshooting video. It shows you how to quickly and efficiently troubleshoot your plugins.
  5. Thanks for the suggestions guys, have no clue what the issue was before, but I literally didn't do anything to fix it, and I hopped on today, and it was working fine... some sorta glitch I guess. Now the problem I'm having is getting players to regen health when they have a full saturation bar. Trying a server restart...

    Nevermind, the issue is not fixed. Now hunger gets auto-filled like it was before and even when I do have full hunger, my health does not replete. This is starting to really bug me now. Have no clue what to do.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 29, 2015
  6. Offline


  7. I am hesitant to do this because its easier said than done. This is gonna take a bunch of time and simply a hassle to do. I am worried that if I delete all the jars then the configs will reset on all the plugins.
  8. Offline


    @UNC00KED The configs won't reset. Without the jars the configs and plugin files will simply be unused. First, backup your jars to a safe place so that you won't loose them. It'll take less than half an hour to troubleshoot if your server starts up at a reasonable pace. The video provides a good example on how to do it, and it's a lot faster than testing one at a time. You don't have to follow the video if you don't want to though.
  9. Yep, the issue is Multiverse. Removed the plugin and health regenerating worked fine. Re-installed Multiverse, issue came back. Now that I have found out that the issue is Multiverse, how do I fix it? @oceantheskatr

    Doing a complete re-install of Multiverse didn't solve the issue. I am completely out of ideas. Can't believe I am having this problem. Ugh

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 29, 2015
  10. Offline


    If your difficulty is set to peaceful, by default, players will regain health. If you do not want them to, simply set this variable to false. This setting has no effect on worlds with adifficulty greater than peaceful or 0.

    Type: Boolean

    Example: autoheal: true

    In Game Usage: mvm set autoheal true mvm set autoheal false

    I know u said u tried it but read above what it says
  11. Offline


    @UNC00KED Sorry I didn't get back to you sooner, however I'm glad to hear you found the plugin causing it. Give what Scorpionvssub a try and see if that helps.
  12. Thanks for the suggestions guys @Scorpionvssub @oceantheskatr. So yea, skimmed the Multiverse wiki and kept on trying to use the /mvm set autoheal <true/false> until I actually read it and noticed that the command has no effect on worlds with a difficulty greater than 0, and my world is set to 'hard'. Tried a combination of '/mvm set hunger true' (supposedly enables hunger depletion) and '/gamerule naturalRegeneration true' and I'm back to square 1. When I have full saturation, I heal back up, but my hunger is still glitching to where when it goes below full, it automatically refills.

    Turned out to be the global WorldGuard region with the flag 'feed-delay:0'. I am an idiot. Thanks for the help guys, I really do appreciate it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 29, 2015
  13. Offline


    Lol! Glad you figured it out! :)
  14. Nevermind. That seemed to work only for a little bit. So again, am back to square one.
  15. Offline


  16. I assume you mean my *Multiverse worlds.yml because WorldGuard does not have a file named worlds.yml. If so, here it is:
  17. Offline


    My bad, I meant WorldGuard>worlds>(affected world)>config.yml
  18. Well the config of the factions world is empty:
    # WorldGuard's world configuration file
    # This is a world configuration file. Anything placed into here will only
    # affect this world. If you don't put anything in this file, then the
    # settings will be inherited from the main configuration file.
    # If you see {} below, that means that there are NO entries in this file.
    # Remove the {} and add your own entries.
    So my regions.yml of the factions world is:
  19. Offline


    Lol I haven't used WorldGuard in a little while, yes I meant the regions.yml, thanks. I wanted to make sure you didn't have any wonky flags. I'm not exactly sure what to do to fix this, but since you know that it's something to do with Multiverse that will help.
  20. Doing the command
    /mvm set difficulty hard factions
    then restarting my server somehow worked... read online somewhere that doing that worked.

    I feel like this issue may pop back up in a week or two, let's hope not. Thanks guys.
  21. Offline


    @UNC00KED If you add region flags to the specific folders those count on that world but i think additional main settings in the global 1 that arent specified per world will still be active for those worlds as "global flags" not shown via /rg info as they are server global not world global, also make sure to do commands such as "rg flag __global__ blocked-cmds /?, bukkit:help etc. if u dont have commands override...just a quick tip
Thread Status:
Not open for further replies.

Share This Page