Inactive [DEV] SpoutPlugin - Unleash the flow of endless possibilities [1.0-1.3.2]

Discussion in 'Inactive/Unsupported Plugins' started by SpoutDev, Aug 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    In order to centralize support of our legacy projects, we will no longer be providing support on Bukkit. Please use for support with our projects going forward.
  2. Offline


    Not true. Go into the logblock's config and set chest logging to false.
  3. Offline

    Lunar Delta

    Excellent. Now I just hope the issue is fixed soon so I can re-enable spout. People are gonna be upset about not having their custom stuff.
  4. Offline


    I know right? But for now lets adopt to the changes for now. The guys behind Spout have truly made a great plugin here and are flat of there feet.

    Your welcome mate.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  5. Offline


    Hello, i'm french (so I've got a bad english) and I've got problems when i pass my serveur on spout.
    I can read on my cmd this :
    151 recipes
    16 achievements
    12:32:45 [INFO] Starting minecraft server version Beta 1.7.3
    12:32:45 [INFO] Loading properties
    12:32:45 [INFO] Starting Minecraft server on *:25565
    12:32:45 [ATTENTION] The server will make no attempt to authenticate usernames.
    12:32:45 [ATTENTION] While this makes the game possible to play without internet
     access, it also opens up the ability for hackers to connect with any username t
    hey choose.
    12:32:45 [ATTENTION] To change this, set "online-mode" to "true" in the server.s
    ettings file.
    12:32:45 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-945-
    g73697a4-b1000jnks (MC: 1.7.3)
    12:32:46 [INFO] DataSourcePool [iConomyChestShop] autoCommit[false] transIsolati
    on[SERIALIZABLE] min[2] max[20]
    12:32:46 [INFO] SubClassFactory parent ClassLoader [
    12:32:46 [INFO] Entities enhanced[0] subclassed[1]
    12:32:46 [INFO] [Permissions] (Phoenix) was Initialized.
    12:32:46 [INFO] LWC: Loading shared objects
    12:32:46 [INFO] LWC: Protection cache: 0/10000
    12:32:46 [INFO] LWC: Native library: plugins/LWC/lib/native/Windows/x86/sqlitejd
    12:32:46 [INFO] Preparing level "Remember Okidama"
    12:32:47 [INFO] Preparing start region for level 0 (Seed: -26758189575608007)
    12:32:48 [INFO] Backup v1.6 was sucessfully loaded!
    12:32:48 [INFO] [BackupPlugin]  BackupPlugin version 0.8.8 is enabled!
    12:32:48 [INFO] [BackupPlugin]  Permissions plugin found, using Permission confi
    12:32:48 [ATTENTION] [BackupPlugin]  Disabled MapperUnit, mapper_path invalid: m
    12:32:48 [INFO] [BBROTHER] ------------------------------------
    12:32:48 [INFO] [BBROTHER] Hello, and thank you for using the TESTING version of
    12:32:48 [INFO] [BBROTHER] Please note that, since this is far from complete, th
    ere will be many bugs.
    12:32:48 [INFO] [BBROTHER] Please stay tuned in #bigbrother for up
    dates and build notifications.
    12:32:48 [INFO] [BBROTHER] ------------------------------------
    12:32:50 [INFO] [BBROTHER] Building `bbdata` table...
    12:32:50 [INFO] [BBROTHER] BBData H2 Driver r1 loaded!
    12:32:50 [INFO] [BBROTHER] Building `bbworlds` table...
    12:32:50 [INFO] [BBROTHER] Building `bbusers` table...
    12:32:50 [INFO] [BBROTHER] Permissions plugin found but disabled. Enabling 'Perm
    issions' (v2.7.4).
    12:32:50 [INFO] [Permissions] version [2.7.4] (Phoenix)  loaded
    12:32:50 [INFO] [BBROTHER] Permissions enabled using: Permissions v2.7.4
    12:32:50 [ATTENTION] [BBROTHER] 'Help' isn't detected. No /help support
    12:32:50 [INFO] [BBROTHER] BigBrother 1.9-SNAPSHOT (build #569) enabled!
    12:32:50 [INFO] ChargÚ Essentials version 2.4.1 par Zenexer, ementalo, Aelux, Br
    ettflan, KimKandor, snowleo, ceulemans and Xeology
    12:32:50 [INFO] [Essentials] Payment method found (iConomy version: 5)
    12:32:50 [INFO] ChargÚ EssentialsGeoIP version 2.4.1 par Zenexer, ementalo, Aelu
    x, Brettflan, KimKandor, snowleo, ceulemans and Xeology
    12:32:50 [INFO] This product includes GeoLite data created by MaxMind, available
    12:32:50 [INFO] ChargÚ EssentialsSpawn version 2.4.1 par Zenexer, ementalo, Aelu
    x, Brettflan, KimKandor, snowleo, ceulemans and Xeology
    12:32:51 [INFO] [FeaturePack] Using Spout version
    12:32:51 [INFO] [FeaturePack] Using Permissions version 2.7.4
    12:32:51 [INFO] [FeaturePack] Using iConomy version 5
    12:32:52 [INFO] [FeaturePack] Plugin enabled! version 2.7.2
    12:32:52 [INFO] Found Diamonds STARTED
    12:32:52 [INFO] [HeroChat] HeroChat version 4.10.3 enabled.
    12:32:52 [INFO] [HeroChat] Permissions 2.7.4 found.
    12:32:52 [INFO] [iConomy] Logging is currently disabled.
    12:32:52 [INFO] [iConomy] v5.01 (Eruanna) loaded.
    12:32:52 [INFO] [iConomy] Developed by: [Nijikokun]
    12:32:52 [INFO] [iConomy] hooked into Permissions.
    12:32:52 [INFO] [iConomyChestShop] version 2.75 initialized!
    12:32:52 [INFO] [iConomyChestShop] iConomy version 5 loaded.
    12:32:52 [INFO] [iConomyChestShop] Permissions version 2.7.4 loaded.
    12:32:52 [INFO] [iConomyChestShop] LWC version 3.21 loaded.
    12:32:52 [INFO] [InstaBreak] Starting! (version 1.9.1 by R3ality)
    12:32:52 [INFO] [InstaBreak] Found a permission system, using it!
    12:32:52 [SEVERE] [LagMeter 0.4.1] Old permissions system detected.  Using it.
    12:32:52 [INFO] [LagMeter 0.4.1] Enabled!  Polling every 40 server ticks.  Loggi
    ng to C:\Users\Famille\Desktop\mon_serveur\plugins\LagMeter\lag.log
    12:32:52 [INFO] [MagicCarpet] MagicCarpet version 1.5.5 is enabled!
    12:32:52 [INFO] [MagicCarpet] Take yourself wonder by wonder, using /magiccarpet
     or /mc.
    12:32:52 [INFO] [MagicCarpet] Using Permissions.
    12:32:52 [INFO] mobchange 0.1 by Edfake is enabled
    12:32:52 [INFO] MonsterBox version 0.2 is enabled!
    12:32:52 [INFO] [MonsterHunt] MonsterHunt Loaded!
    12:32:52 [INFO] [MYHOME]: 0 homes loaded
    12:32:52 [INFO] [MYHOME] Permissions enabled using: Permissions v2.7.4
    12:32:52 [WARNING] [MYHOME] 'Help' isn't detected. No /help support.
    12:32:52 [INFO] [MYHOME] MyHome 1.9.5 enabled
    12:32:52 [INFO] [MYWARP] [MYWARP]: 0 warps loaded
    12:32:52 [INFO] [MYWARP] Permissions enabled using: Permissions v2.7.4
    12:32:52 [WARNING] [MYWARP] Help plugin not detected. Only providing help via /w
    arp help.
    12:32:52 [INFO] [MYWARP] MyWarp 2.0 enabled
    12:32:52 [INFO] NaturalGiants version 1.3 is enabled!
    12:32:52 [INFO] [PetCreeper] version 0.32 is enabled!
    12:32:52 [INFO] PetCreeper is using Permissions.
    12:32:52 [SEVERE] [ResidenceSigns 2.0] Residence NOT Installed, DISABLED!
    12:32:52 [INFO] PetCreeper main loop running.
    12:32:52 [INFO] [ResidenceSigns 2.0] Disabled
    12:32:52 [INFO] Spout has been initialized
    12:32:52 [INFO] [VanishNoPickup] 1.9.9 enabled.
    12:32:52 [INFO] WorldEdit 4.6 enabled.
    12:32:52 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin
     for permissions.
    12:32:52 [INFO] [BCMusic] Version 3.1 Permissions system detected!
    12:32:52 [INFO] [BCMusic] Version 3.1 by IC3D enabled
    12:32:52 [INFO] [Herobrine] 1.0_5 is enabling.
    12:32:52 [INFO] [Herobrine] Found Spout.
    12:32:52 [INFO] [Herobrine] Loading configuration.
    12:32:52 [INFO] [Herobrine] 1.0_5 was enabled.
    12:32:52 [INFO] LWC: Loaded 133 locale strings (0 overrides)
    12:32:52 [INFO] Using Permissions API
    12:32:52 [INFO] LWC: Loading SQLite
    12:32:52 [INFO] LWC: Using: Native
    12:32:52 [INFO] LWC: Precached 303 protections.
    12:32:52 [INFO] LWC: At version: 3.21-git-LWC-2936c58564bf9d84e97a9a024af1644c8f
    12:32:52 [INFO] Server permissions file permissions.yml is empty, ignoring it
    12:32:52 [INFO] Done (0.589s)! For help, type "help" or "?"
    12:32:55 [INFO] [BBROTHER] Removed 0 old records because of age in 0h00m00s.
    12:32:56 [INFO] Yaul [/] logged in with entity id 119 at ([Rememb
    er Okidama] -231.32823702674662, 68.0, 158.5281839585873)
    12:32:56 [INFO] Loaded world: remember okidama
    12:32:56 [INFO] [Spout] Successfully authenticated Yaul's Spoutcraft client. Run
    ning client version: 102
    12:32:56 [SEVERE] Exception in thread "Thread-20"
    12:32:56 [SEVERE] java.lang.NoSuchFieldError: rawData
    12:32:56 [SEVERE]       at org.getspout.spout.MapChunkThread.handleMapChunk(MapC
    12:32:56 [SEVERE]       at org.getspout.spout.MapChunkThread.handle(MapChunkThre
    12:32:56 [SEVERE]       at
    12:32:56 [SEVERE]       at Source)
    12:32:56 [INFO] [BBROTHER] Building `ownership` table...
    12:33:01 [INFO] º9[PLAYER_COMMAND] Yaul: /time day*
    12:33:11 [INFO] º9[PLAYER_COMMAND] Yaul: /time DAY
    12:33:16 [INFO] º9[PLAYER_COMMAND] Yaul: /weather sun
    12:34:56 [INFO] Yaul lost connection: disconnect.quitting
    12:34:56 [INFO] Connection reset
    12:34:56 [INFO] [BACKUP] Initiate a last backup because the last player left. It
     will start to backup in 15 minutes when no player will have connected in this t
    I've got a minecraft premium account, but I can't connect myself when online-mode is true (connection reset: connect). When I put a block on the map, he appear, disappear, appear, etc ...
    When I break it, The little block go on my inventory but the block on the map didn't disappear.
    So .... need help !
    I wish you can understand this message ! ^^'
    And one more time sorry for my bad english !
    (that's my serveur launcher:
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xincgc -Xmx1G -jar craftbukkit-0.0.1-SNAPSHOT.jar
    P.S. 1 I forgot to write this, the signs are clean
  6. Offline


    I had a sort of same error, I fixed it by updating to Craftbukkit 1060 and updating spout to 1.0.2.
  7. Offline


    Hi.. After this update it doesnt load any new chucks.. here a picture :
    Only when I type /reload. ;(

    (Theres a bug in Spout.jar. Because minecraft.exe has the same bug.)

    Edit: You cannot destroy blocks, too.
  8. Offline


    I have heavy Chunk laggs with this plugin
  9. Offline


    Works perfectly ! thanks !!!!
  10. Offline


    It's a very great plugin but i have a problem beacause on my server i use Itemcraft and i would like, spoutcraft stop updating. That is to say an option to have no automatic update.
  11. Offline


    ooops, I've said no problem but I've got one new, the map ad some bugs (sometimes the builds are double, a part of a build is near the bluid, so, strange ... and I've got this error with herobrine

    13:32:09 [WARNING] Task of 'Herobrine' generated an exception
    java.lang.NoSuchMethodError: org.getspout.spoutapi.player.SpoutPlayer.getRenderD
    at net.minedev.herobrine.spout.SpoutHelper.setFog(
    at net.minedev.herobrine.HerobrineNPC.spawn(
    at net.minedev.herobrine.ScheduleHandlerMutual$
    at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(C
    at net.minecraft.server.MinecraftServer.h(
    Need one more time help, sorry !

    Attached Files:

  12. Offline


    Why i get Chunkerrors? -.-
    If i break a block.. after 2 seconds it is back....
  13. Offline


    need help (page 92)
  14. In some reason, I cant use Spoutcraft (Client).
    When I loging it using the launcher, its keep updating and i wont be able to logon.

    Already tried it several time but its keep updating :(
  15. Offline


    Disable chunk caching in the config file for Spout.

    Disable chunk caching in Spout's config on the server.

    Did you disable chunk caching for Spout in it's config on the server?
    What version of Spout are you using and is Herobrine updated for it?

    What part is it getting stuck on?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 13, 2016
  16. Offline


    Is it possible to add a newline in tooltips?
  17. Offline


    I noticed by watching the memory ingame that it seems to start leaking terribly when it's raining. If you stay deep underground it seems to have no problems.
  18. Offline


    Can you come in my mumble by any chance and try to help me figure out what one of my plugins or something is downloading bukkitcontrib, its much easier and faster to do it that way.
  19. Offline


    i have disable it and reload.

    And its still the same error... :(
  20. Offline


    Now it's work nicely whitout the datacache, thanks lot !
  21. Offline



    First of all thanks to this team for an amazing product that I cant live with out!

    I would like to know where I can find the option to disable chunk caching as my server is repeating chunks as many others have seen.

    In my servers plugin list I have a spout folder with a config.yml with the following options:


    I cant find the option to disable chunk updates in this file and I cant find any other config for Spout. I hope I"m not overlooking something obvious.

    Thankyou for your time.

  22. Offline


    This is my Config File.

    ForceSinglePlayerClientKickMessage: This server requires Spoutcraft!
    ForceSinglePlayerClient: false
    AllowVisualCheats: false
    ChunkDataCache: false
    AuthenticateTicks: 200
    AutoUpdate: false

    I have only Problems with 1.0.2.
  23. I all of a sudden get this error message when trying to connect to a server:

  24. Offline



    Thanks for the quick reply. I tried removing my config to see if it would generate a new one like yours. It did not. I removed my spout folder and spout.jar from my pluggins directory. Then I downloaded the latest reccomeded build. It generated the proper config. Testing now.

    Works perfectly!!!!



  25. Offline


    chunkdatacache: false

    And i get still chunkerrors ._.
  26. Offline


    Spout 1.01 is cool, but the version 1.02 disappoint me.
    You have removed compatibility with modload, just because it is useless for you.

    Personally, I use on my client a mod that allows items, fly, ... on his server, because I do not like typing commands all the time.

    You say you do the plugin that will significantly increase the functionality, so why not integrate ... ?

    Mod loader may be useless for you, but it's the only one able to run some Mods

    But you do not care does not it?

    Ps: Excuse my English, I am French.
  27. Offline


    I understand your frustration, because i can't use worldeditCUI any longer.
    However, I do get why thay had to say no to it and develop beyond limitations.
    I just wish lahwran could make WorldEditCUI stand alone and not need modloader.
  28. Offline


    Your frustration is understandable. Myself, I use Zombe's Modpack on my own server (I use NoCheat to make sure noone else does), but I love seeing all the cool extra stuff Spout brings to the Minecraft experience! It's difficult to choose between them.
  29. Offline


    Can you install spout on cracked minecraft ? without the launcher... My friend has mine copy of minecraft.
  30. Offline


    I use CJB, worldeditCUI, Dynamic Light, and many others, who all work in Multi normally.
    So many opportunities are being lost.

    That's why this update disappoint me.

    And it is true that it is dificil to choose either one or the other.

    That's why I asked whether it was possible to integrate Modloader directly into Spout, despite your misgivings.
  31. Offline


    kicks me for not having spout, i use the client mod though, worked yesterday

    plugins are:
    archers b10
    bukkitcontrib??? is this the problem
    narrowtuxlib? does that go in the lib folder?
    retractable bridge
    i have also tried 2 permissions plugins and neither worked
    permissionsbukkit w/ superperms bridge

    then after 3 secs it kicks me for not having spout.
Thread Status:
Not open for further replies.

Share This Page