Inactive [DEV] SpoutPlugin - Unleash the flow of endless possibilities [1.0-1.3.2]

Discussion in 'Inactive/Unsupported Plugins' started by SpoutDev, Aug 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    In order to centralize support of our legacy projects, we will no longer be providing support on Bukkit. Please use for support with our projects going forward.
  2. Offline


    Is there a way in spout to set the sky cap server wide above 128? and then force the change done to the clients?
  3. Offline


    from Shakespeare's "Macbeth":
    Confusion now hath made his masterpiece :p
  4. Offline


    By the way... the player count, MoTD/description, and server ping features from Notch's favorites list have been added to our server pages in the latest dev builds now...
  5. Offline


  6. Offline


  7. Offline


    I am not sure. Maybe the essentials one, or SpoutSky or something. I actually don't keep up on plugins at all. It's possible though.
  8. Offline


    Name of project: Spoutcraft Launcher
    Project version/build: 1.0.6
    Description of issue: I start up spoutcraft, enter my info and press login. Screen goes completely white and doesn't change.
    Steps to reproduce: I double clicked the spoutcraft.jar type in my info and press login.
    Link to error log: i dont get any

    Also, two windows of spoutcraft are open when its the whitescreen, the launcher and the actually spout craft(white screen one)

  9. Offline


    I would download the latest stable version of Spout, and then I would delete the ".SpoutCraft" directory and then download latest stable version of SpoutCraft and reinstall it.
  10. Offline


    I'm having an issue with logging into my server. I am using the RB of both the Spout plugin and the launcher (403, 449), as well as CB 1240.

    My server is also stuck in an endless reboot loop. I'm not sure if it's my server host or Spout, though.
    EDIT 2: I managed to log in and; BAM restart. While no one was logged in it did not restart.

    This error does not occur if I use the official launcher.

    Any ideas?

    EDIT: I'm also getting a a cut-off error.
    "Internal exception: Received string length longer than maximum allowed (205 > (here it cuts off)
  11. i know its possible for plugins to disable/enable the sky/cloud/time..options, but is it possible for other graphical option (advanced opengl) ? because we use spout and force texture pack to ensure hack like xray mod on our serveur but with opengl the players can see like xray at the connexion

  12. Offline


    CB 1303 - Spout 435
    2011-10-09 05:44:04 [SEVERE] Could not pass event CHUNK_LOAD to Spout
     at org.getspout.spout.block.SpoutCraftChunk.replaceBukkitChunk(
     at org.getspout.spout.SpoutWorldListener.onChunkLoad(
     at org.bukkit.plugin.RegisteredListener.callEvent(
     at org.bukkit.plugin.SimplePluginManager.callEvent(
     at net.minecraft.server.ChunkProviderServer.getChunkAt(
     at org.bukkit.craftbukkit.CraftWorld.getChunkAt(
     at org.bukkit.craftbukkit.CraftWorld.getBlockAt(
     at org.bukkit.craftbukkit.block.CraftBlock.getRelative(
     at org.getspout.spout.block.SpoutCraftBlock.getRelative(
     at org.getspout.spout.block.SpoutCraftBlock.getRelative(
     at org.bukkit.event.block.BlockFromToEvent.getToBlock(
     at com.sk89q.worldguard.bukkit.WorldGuardBlockListener.onBlockFromTo(
     at org.bukkit.plugin.RegisteredListener.callEvent(
     at org.bukkit.plugin.SimplePluginManager.callEvent(
     at net.minecraft.server.BlockFlowing.a(
     at org.getspout.spout.block.mcblock.CustomBlock.a(
     at net.minecraft.server.World.i(
     at net.minecraft.server.World.doTick(
     at net.minecraft.server.MinecraftServer.h(
  13. Hmm, I didn't find this... but is it possible to change monster and animal skins ?
  14. Code:
    15:42:46 [SEVERE] Could not pass event CHUNK_LOAD to Spout
    at java.util.ArrayList$Itr.checkForComodification(Unknown Source)
    at java.util.ArrayList$ Source)
    at org.bukkit.craftbukkit.CraftWorld.getPlayers(
    at org.getspout.spout.SpoutWorldListener.onChunkLoad(
    at org.bukkit.plugin.RegisteredListener.callEvent(
    at org.bukkit.plugin.SimplePluginManager.callEvent(
    at net.minecraft.server.ChunkProviderServer.getChunkAt(
    at net.minecraft.server.PlayerInstance.<init>(
    at net.minecraft.server.PlayerManager.a(
    at net.minecraft.server.PlayerManager.addPlayer(
    at net.minecraft.server.ServerConfigurationManager.moveToWorld(
    at org.bukkit.craftbukkit.entity.CraftPlayer.teleport(
    at be.Balor.Manager.Commands.Home.Home.execute(
    at be.Balor.Manager.Commands.ACCommandContainer.execute(
    at be.Balor.Manager.CommandManager$
  15. Offline


    What version of CraftBukkit and Spout are you using? This (as stated in the stack trace) is a Concurrent Modification Exception, meaning one variable is being accessed by two threads at the same time. The error is probably caused by using the wrong versions of Spout and CraftBukkit together. On a side note, this is more of a Bukkit problem then a Spout (Bukkit not being thread safe), but from what I've read, it doesn't seem like Bukkit is going to being taking steps to become thread safe any time soon.
    Edit: I didn't notice the bottom part of the stack trace, this is all from a command a plugin you are using. The plugin has created a separate thread for executing commands and dispatched it incorrectly. (s)he needs to use:
    plugin.getServer().getScheduler().scheduleSyncDelayedTask(plugin, <runnable>, <delay>L);
    to properly start a thread that will interface with bukkit methods. This is not actually an issue with Spout, or CraftBukkit.
  16. Offline


    I know @narrowtux was tinkering with this at one time. I think you can, but you might want to check with him to make sure.
  17. Offline


    my chunks were not loaded. And the lightning doesn't work correct. If i put a torch on a wall, the light works not correctly too.


    sc rec. and dev -> the same and spout rec and latest the same
    win 7 x64
    jre 7 x64
    (kaspersky internet Sec. 2k12)
  18. Using build 1240 and Spout is set to auto update
  19. Offline


    The problem here isn't with Spout, it's with the plugin you are using (balor commands? It's the one you are using for the home command). It isn't managing it's threads properly, you should contact it's dev for additional help.
  20. Im using home from AdminCmd
  21. Offline


    I've never used AdminCmd, so I can't help you too much. You should probably post your problem at the AdminCmd page, since that is whats causing the error. :/
  22. Offline


    I believe AdminCmd has some known issues. I've heard people having problems with it and Spout before.
  23. Oh rly? I'll change to CommandBook then
  24. Offline


    This bug came back today. It was fixed in build: 529[​IMG]

    This was from build 549 btw.
  25. Offline


    When you play a sound in spout, does the client download the sound and then play it, or stream it directly from the source?
  26. Offline


    downloads, then plays. It saves the sound file locally, so it is only downloaded once.
  27. Offline


    I love this plugin!!! keep it up!
  28. Offline


    having issues with sound still

    tried everything anyone else has said any idea's?

    windows 7, soundblaster sound card, normal minecraft works just not spoutcraft

  29. Offline


    when does sound mess up?
  30. Offline


    When you open the launcher open, before you login, open the options menu, and increase your RAM to 1gb,
  31. Offline


    did that, didn't change anything, tried turning it up, turning it down, everything I could think of from running as admin to re-downloading multiple times

    The sound doesn't start up at all for some reason, i even copies the resource folder from the original minecraft because it was empty
Thread Status:
Not open for further replies.

Share This Page