Inactive [DEV] SpoutPlugin - Unleash the flow of endless possibilities [1.0-1.3.2]

Discussion in 'Inactive/Unsupported Plugins' started by SpoutDev, Aug 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    In order to centralize support of our legacy projects, we will no longer be providing support on Bukkit. Please use for support with our projects going forward.
  2. Offline


    It may behoove you try out a dev build of the client since the server is on a dev build. In your launcher tick Use dev build. May or may not work any better, just to warn you. :)
  3. Offline


    Please forgive my ignorance based on the following question.

    When we have the ability to add blocks into the game via Spout, how easy is it going to be? Will I still need a years java experience?
  4. Offline


    You will need roughly as much Java experience as you need for other Bukkit plugins. It's fairly simple, but this is coming from me, and I actually put together the API for it so it's hard to really judge.
  5. Offline


    Not sure how to replicate this and it doesn't effect everyone, but lately people who are running spout seem to occasionally get stuck on "downloading terrain" when they try to join. Wiping player data seemed to fix this for a time, but the problem reoccurs (lately within minutes of them being able to get back on..). Worse, when one of these people attempts to rejoin multiple times it causes mass server lag or even freezes up the server completely.

    Running latest recommended build of spout + craftbukkit 1190. Everything was working fine up until sometime 5 or 6 days ago as far as I know.
  6. Offline


    Are they using dev builds of Spoutcraft?
  7. I can't understand his reasoning for saying no.
  8. The multiplayer menu looks better as the default one! can you change it back?
  9. Offline


    I shall do so and let you know how it turns out. :)


    edit: I originally didn't get java 7 as it isn't the current recommended version. I'll get it now, at any rate.

    From my experience, servers running spout get a communication with the default server browser, which kind of defeats the purpose of using it for spout.
  10. Offline


    Hello I've got a problem with spout... if I don't use it. My server can be reload with the command /reload. With spout, it crash. Did I made something wrong ?
    I use version 403
    Thank's for your help :)
  11. Offline


    Well im not really sure what you mean, but this might help you:
    Here's what I'm doing =

    1. Downloading the
    2. on my desktop, something appears called
    3. i double click it, and then the spout app appears on my desktop (the little logo with the tap and water)
    4. i double click it, and it says "Spoutcraft" is an appplication which was downloaded from the internet. are you sure you want to open it?
    5. i click open, the spout thing bounces but nothing happens
    6. I try clicking it again, and the popup about it being downloaded from the internet doesnt open, nothing does actually.
  12. Offline


    got a recent problem when deleting my whole .spoutcraft folder and doing a clean install of spout launcher. it doewnloads all the files and when it comes to extracting them it tells me download interrupted... any ideas on whats cauaing this ?? :(
  13. Offline


    No. We will be adding the ping, player count, etc, to our own. The "default" doesn't include the server list, only a favorites list.

    What CraftBukkit build are you using and what errors do you get?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 13, 2016
  14. Offline


    Do you have an error log?
  15. Offline


    I've been having a weird problem. Sometimes, some plugins will randomly start to... not work. The bukkit console then gives some errors about Spout. I restart the server, and still the same error, and no one can connect. I delete the Spout folder, still the same. I replace my Spout.jar with a backup copy, and suddenly, it starts working again! As if the Java archive just randomly corrupts.

    I've opened it after a corruption and everything seems normal. Why would it want to write to Spout.jar anyway?


    Are you, by any chance, using AdminCMD? I had the same problem until I disabled Admincmd's reload to use bukkit's reload command instead.
  16. Offline


    Error logs would be useful.
  17. Offline


    I'll try to reproduce the corruption, then. Might take a while.
  18. Offline


    Haha love you dude ! :D IT's exactly my case :) I'll have a look on how to disable admincmd's reload ;) thank you very much !

    EDIT : I confirm it works now I just had to disable "reload" on admincmd. Thank you very much !
  19. Offline


    I had a similar problem at first. The way I got it working was to download the .jar launcher. After running the .jar launcher and downloading the files, the .app one workedHopefully this will work for you. :)
  20. Offline


    Update: Error: Download Interrupted
    If i ignore, Spout starts...

    New installation: Error: Download Interrupted
    Log Content: 6Exiting the Spoutcraft Launcher
    No Possibility to start (Failed to Launch)

    Newest Version... Same Result in EXE and JAR
    Solution: Manual Patch
  21. Offline


    You should report that to the admincmd devs. ;)

    I've been messing with the mirrors all afternoon, so might need to clear out your temp and bin folder and retry.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 13, 2016
  22. Offline


    What class/method calls InGameScreen.clearPopup()? I'm working on a small problem I'm having and this method seems to be the source.
  23. Offline


    I tried this tonight, prefer the original server list and would like to be able to use the proper version of Optifine, this seems to use a modified version that doesn't have all the same options. Would it be possible to have the client side stuff in a build that would let us still install Optifine ourselves as normal?
  24. Offline


    If you can give us an example of what is missing, we can look and see what the case may be. We are not using the latest OptiFine and we will be adding the original favorites list features to our own list. We are already planning on adding the ping, player count, and server description info onto our list.

    No, there is too much involved to have OptiFine separate. It's not a simple drag-drap to make things work...
    ssechaud likes this.
  25. Offline


    Is it possible to create a plugin that adds certain animations ingame? For example, When a person levels up they have the gold flash around them that is similar to in WoW? That would be a definite plus.
  26. Offline


  27. Offline


    So I have had this problem off and on with spout craft crashing on me and after alot of testing and confirming it with other players onthe server we determined the problem. When a player on my server is using spout and is at the bed rock lvl a memory leak begins to occur if lil lock ups increasing with time till a players client crashes.
  28. Offline


    There is a zoom function in Optifine that I didn't see in Spout. Apart from that it all looked similar, I just seen less options I didn't note them all.
  29. Offline


    Like I said, we aren't using the latest version of it right now. We'll be adding the newer parts of it when we have time.

    I believe this was fixed in a dev build, but hasn't been marked as a recommended build yet.

    Any of the latest builds should work fine with it.
    You can update Spoutcraft to dev builds through the launcher or download manually.
    All the links are on the dev.bukkit page.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 10, 2018
  30. Offline


    Checking references in workspace with eclipse, nothing at all appears to call it, and in fact it is not in the interface InGameHUD and I don't know what its purpose is of it's meant to be called. But if something is calling it on you, it is likely that a plugin is doing it, because I searched all of Spout, SpoutAPI (for the server) and Spoutcraft, and SpoutCraftAPI for calls of it. (The method exists in both SpoutAPI and SpoutcraftAPI)
Thread Status:
Not open for further replies.

Share This Page