Inactive [DEV] BukkitContrib Alpha 0.1.7 [1000]

Discussion in 'Inactive/Unsupported Plugins' started by Afforess, May 21, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    BukkitContrib is superseded by Spout, the new Bukkit/Client framework.
  2. Offline


    If I may ask, Why remove the coordinates in the first place? I've gotten a bit of grief from some of the players on my server for removing one of their favorite exact-o-tools. Lol

    I haven't tested it, but when I have the server plugin installed, does the coordinates still show up for those who don't have the client mod installed? I haven't tested this yet to be honest.

    Great work so far! Keep it up! :D
  3. Offline


    If you don't have client mod then there is nothing that can remove coordinates.
  4. Offline


    I figured so, I just thought that there might be the off chance that the client see X 0, Y 0, Z 0.
  5. Offline


    Because it's cheating. Even Notch said so... I forget where the quote is.
  6. Offline


    I know that with essentials there is a /getpos command, one just has to give their players the node and tell them about it.
  7. Offline


    I think some of my problem too, is that i'm still using b953.. which is technically 1.7.2.
    0.1.3 and up are clearly stated in the OP to be used with 1.7.3.
    Is this correct?
    I think the first build for 1.7.3 was... 960 something... or 970. No matter :p
    i'm not planning on upgrading the server until i see a recommended build for bukkit though.. unless one is out right now and i didnt see it. :p. i haven't looked for a day or so.
    *goes and looks now*
  8. Offline


    Yep, RB 1000 have just been released.
  9. Offline


    Next release, in an hour or so, will support it.

    0.1.3 and up are 1.7.3, correct.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 15, 2016
  10. Offline



    While Not 100% ready for pull request yet, my code is working on client side. The issue I'm experiencing now is likely some anti-hack code by notch. Even though the client digs with the new set speeds, the server refuses to believe the player dug in that time (as expected)

    Any thoughts on how to circumvent this without opening the path to instant-digging clients again?
  11. Offline


    Not super familiar with it, but I'm fairly certain the NSH handles it somewhere around here:

    Good news is that BukkitContrib has control of the NSH. See the ContribNetServerHandler.
  12. Offline


    Hey Afforess
    I found a bug! Sometimes the plugin: BCMusic, show me the plugin "BukkitContrib" isn't installed!
    But if I remove the Permission Plugin then the problem is fixed! D= But i need the Permission Plugin.

    Before Remove Permission Plugin!

    But the Console show me the Plugin BukkitContrib is initialized

    After remove Permission, the plugin works normal
    I have add the "Perm: BCM.*" to permission but it doesn't help

    Pls help me D=
  13. Offline


    Good point out. The two ways I can see this being done are either editing Block.strength (both protected AND altering minecraft server code? eep) or altering the a() packet handler and just assuming people who have registered as contrib user to be truthful about breaking blocks...

    Ones a huge security assumption, the other will take some altering of Bukkit...

    Also It's 2am so I'm going to call it a night, and catch your reply after work tomorow!
  14. Offline


  15. Offline


    :mad: Still can't access dev site for bukkitcontrib.
  16. Offline


    It's down. An official release is in the final testing phases.
  17. Offline


    I see. Your github says 0.1.6 is done, can't wait! Postponing my server update until 0.1.6 is out, still miss the dev updates though :(
  18. Offline


    It's only protected? Than that's easy. Use reflection and edit the field. Private/Protected are no barrier.

    plugin is, testing the client. ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 15, 2016
  19. Offline


    Any eta? :p
  20. Offline


    Is now soon enough?

    Alpha 0.1.6 is out!

    • Fixed connection issues when 0.1.3 or earlier users connected to a newer server
    • Fixed authentification issues
    • Completely solved performance issues
    • Custom Item names for new item datas (Thanks @narrowtux!)
    • General bug fixes
    • Clients with BukkitContrib are given correct world seed when switching worlds

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 15, 2016
  21. Offline


    Thanks ^_^, still no ETA on dev site though?
  22. Offline


    I don't run it, it's courtesy of @Wulfspider
  23. Offline


    It's being worked on. The VPS provider is having ... issues. I've been trying to beat them into fixing it, but no progress so far. :p
  24. Offline


    You are Da Flash!:D

    I know you don't like it but may I ask you what am I missing by replacing your id.class for the one that comes with TMI? :rolleyes:

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 15, 2016
  25. Offline


    Custom item names.
  26. Offline


    Thanks for your fast reply.
    I'm gonna ask TMI's author Marglyph for this one.
  27. Offline


    Thank you, thank you, thank you!!!
  28. Offline


    Not meaning to pester you about the same Coordinates question, the players on my server want to know why/how the coordinates were cheating.
  29. Offline


    If I try and scroll up in chat with bukkitcontrib client mod, minecraft crashes to a black screen.
  30. Offline


    By the way, what is the command BukkitContrib does on server join? It gives us "Unknown command" on login and I'd like to whitelist it.
  31. Offline


    I believe this plugin auto-updated and broke...
    Here is the error I get when people join:
    It hasn't done anything negative i've seen, except be annoying. Any ideas?
    EDIT: I changed my mind. Attempting to use a command I cannot while BukkitContrib is activated crashes the server. The error that comes up relates to Permissions but once I remove the BukkitContrib plugin and restart the server the issue disappears. I am running Permissions 3.1.6
Thread Status:
Not open for further replies.

Share This Page