[DEAD] Spells v0.996

Discussion in 'Inactive/Unsupported Plugins' started by NathanWolf, Jan 16, 2011.

  1. Offline


    none of your commands except for /wand work in world, instead i have to type them into the console to get them to work,. and /cast blink /cast fireball, cast anything all say that persistance cant find callback or something like that
  2. Offline


    Yikes! The cycling part ruined my day, I had a wolf, then all of a sudden he was trying to EAT me! Bad wolf! I had to kill him and that made me sad! (the last function, calming, doesn't seem to work). I can't tell my 6 year old about the spell for fear he'll cycle through to aggressive and start crying when his wolf attacks him. I'm 32 and it upset me!

    Could you instead make it so that every click just brings another wolf, or at least does nothing at all if a wolf already exists? We can handle gathering up bones and taming the wolves on our own, no need to cycle.
  3. Offline


    Ahh it all makes sense now probably since reading back a few post you already mentioned this:p

    This is an excellent idea. Mainly because whenever I see a plugin that uses permissions I start hitting my head on the screen. Up until recently I've pretty much ignored your permissions, now they haunt me in my sleep:eek:
    I think I might wait until you release your next spells before I put it back on my active server. Much less head to screen contact that way lol.

    But I still wanna figure out this permissions stuff. So... I've got my permissions yml that you gave me a few posts ago set up. Now when I start my server first there is no conformation that 3 profiles are loaded and when I type "grant player thorns_ofire admin" it says "permissions profile admin is unknown". I've read through the thread like a bajillion times but I've obviously missed or messed something up. Heres a screen shot of my .yml its location and my server. Any thoughts? (damn dynmap update already:mad:)

    Hmm well the forums not letting me upload the picture. I'll try again in a bit.

    I also get this when I login

    19:26:08 [INFO] Thorns_Ofire [/] logged in with entity id 44
    19:26:08 [INFO] java.lang.IllegalArgumentException: No permissions are defined f
    or NetherGate.commands.nether.world.go
    19:26:08 [INFO] Persistence: There's an error with permissions.yml - hopefully m
    ore info about that above.
    >grant player thorns_ofire admin
    19:26:21 [INFO] Permission profile admin is unknown
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
    NathanWolf likes this.
  4. Offline


    Thorns_Ofire I had to comment out the part below to get rid of the error you have.

    # Defines the "friend" profile
    # friend:
    # NetherGate:
    # commands:
    # nether:
    # world:
    # go: true
    # Spells:
    # commands:
    # cast: true

    Then re-start the server and you should see something about persistance loaded 3 profiles from the yml. Then you can run that grant command from the console.
    NathanWolf likes this.
  5. Offline


    @RagerX - AHHA yes that worked thank you very much sir! :D
  6. Offline


    hey when i load my server everything is loaded perfectly it says but when i try to do, lets say /cast blink nothing happens, theres no error or anything. same goes for everything else, :(
  7. Offline


    It has to do with the internal permissions. Read the last 2 pages of posts me and NathanWolf talked about it quite a bit:)

    @NathanWolf - Everythings working now except for one thing. Every slot in my hot bar casts the active spell:eek: I can cycle through the spells and materials, all the spells work fine. Which ever item is in the first available spell slot is what casts. Even with no wand in my inventory.

    Edit: It's actually which ever spell item is first in the inventory. So if the first 8 slots are cobblestone and the last slot is a feather I can cast blink with any of them.
    NathanWolf likes this.
  8. Offline


    Op means nothing, for now. I'll get this resolved- too much trouble to set up permissions.

    Awwww :(

    yes, I can definitely make a version of that spell ASAP that just summons wolves. I'll make controlling a separate thing.

    That was my original plan, but I did this for sake of speed. Today was my last day at my current job, and it's been a long day..... I plan to do lots more wolf stuff once I recoup a bit.

    I really am very sorry to hear this! I did notice that "making him angry" generally translates to "eating your face", not, like, attacking things like you'd like him to. My first wolf killed me, over and over again (summoned near spawn)- until I logged out so he despawned.

    Yes! (Always excited when I think I have an easy answer)

    That can happen if you use the permissions.yml that is bundled with elBukkit, but you remove NetherGate.

    Use this for Spells/Wand-only: permissions.yml, or just hand-edit out the NetherGate stuff.

    Hope that helps! :D

    EDIT: Bah! I just noticed that @RagerX already fixed you up! Sorry, still catching up- thanks for getting my back on that one! :D

    And, so much for my easy answer :\ Guess it was too easy!

    Yeah- this is a Wand bug :( Remove Wand.jar for now if you want to actually not use magic....

    I'll get it fixed ASAP- I'm sure I botched something in the quick re-write of the event handlers needed for 612. I probably accidentally deleted the "are you holding a wand?" check, basically :p

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  9. Offline


    Lol nice well I think I can survive until the next update. I've got to delete the 1000 or so torches I placed while messing with it anyways XD. Keep up the excellent work. :D
    NathanWolf likes this.
  10. Offline


    "19:59:01 [INFO] added a chest!!"
    WTF is this?

    Not me! :D

    Already fixed :D

    Persistence v0.64 is a minor update to the permissions system, which now supports and recognizes an "ops" permissions profile- automatically assigning it to ops.

    I've also updated the linked permissions.yml for Spells, and made it the same as the one in elBukkit (The NG permissions are not required, so I just removed them).

    I have set it up so that ops have access to "/cast" and "/su", but players do not. They can still use spells, but they must use a wand. You can obviously edit this however you want, but it's meant to be drop-in.

    This way, you can set up your admins/ops in ops.txt and just use the default permissions.

    Let me know how this works out for everyone- I want this to be as easy to use as possible!


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  11. Offline


    We're having way too much fun with this on my server. Thanks!
    NathanWolf likes this.
  12. Offline


    /grant player PlayerName profile" my minecraft name is adamweb so what do i fill in there?
  13. Offline


    YAY!!!! :D

    Edit: Just tested it out everything works except for material cycling.

    In the server console type "grant player adamweb default". Player name is case sensitive so be careful about that.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
    NathanWolf likes this.
  14. Offline


    it says permission profile default is unknown
  15. Offline


    How come after i have installed Permissions, i can nolonger place or mine blocks? They just instantly respawn

    EDIT: But i can use spells to destroy blocks.
  16. Offline


    Go to my post on the last page and read the posts that follow.

    You need to set up your permissions file in "yourserverlocation"/plugins/persistence. In the permissions.yml put...
    # Defines the "default" profile
    # All players have this profile by default
          spells: true
          - heal
          - blink
          - torch
          - fireball
          - pillar
          - absorb
          - fill
          - cushion
          - undo
          - alter
          - blast
          - mine
          - tree
          - arrow
          - frost
          - gills
          - familiar
          - blob
          - superblob
          - paint
          - recurse
          - transmute
          - recall
          - disintegrate
          - manifest
          - peek
          - fire
          - window
          - lava
          - portal
          - phase
          - invincible
          - fire
          - tunnel
          - bridge
          - rewind
          - ascend
          - descend
    # Defines the "admin" profile
    # These players can use "/su" to access any command
          su: true
  17. Offline


    uhk were do i put this

    # Defines the "friend" profile
    # friend:
    # NetherGate:
    # commands:
    # nether:
    # world:
    # go: true
    # Spells:
    # commands:
    # cast: true

    Can you um post your permissions file This is confusing im new to bukkit hahah

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  18. Offline


    You don't need it to use spells. It also gave me a bunch of errors.:eek:

    Edit: Its for use with nethergate. If its not installed you don't need it.

    @NathanWolf - If your planing on keeping the permissions.yml would it be possible to make the .jar create it just like with the data base file? Would probably help a lot of people out ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  19. Offline


    This is strictly necessary anymore, but if you had an "admins" group or something, you'd do "grant player adamweb admins". From the server console- no "/", you can't do it in-game.

    I don't think that's related to Spells. You're not right by spawn, are you?

    Hm.... ya. Agreed :)

    It could spit out a default file ... the only tricky part is I need to give plugins the ability to write to it- so Spells could set up "default" with access to all spells, for instance. I'll think about this!

    Definitely going to be a Magic thing, at least, I think. Should be made easier once Persistence allows for multiple perm files- though I'll need to check and see what happens if you put the same profile in multiple files- I'm hoping it will merge them together somehow.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  20. Offline


    I got uber lag from this plugin, its sad because its epic.. :) if anyone had lag and solved it, please quote this and tell me what to do! :D
  21. Offline


    did exactly this still getting error when using su command or any spells in console it did work prepatch 1.4 i just changed the .jar files and it stopped working :s
  22. Offline


    Could you update to Bukkit version 617 please :D that would be grate!
  23. Offline


    why is it just saying spells [category] when i use spells commands?

            default: false
                prefix: '&4[&4Admin&4]&4 '
                suffix: ''
                build: true
                - '*'
                - 'nocheat.*'
                - 'citizens.basic.create'
                - 'citizens.basic.settext'
                - 'citizens.general.remove.singular'
                - 'citizens.general.remove.all'
                - 'citizens.help'
                - 'citizens.general.color'
                - 'citizens.general.setitem'
                - 'citizens.general.move'
                - 'spawnmob.mspawn.Zombie'
                - 'spawnmob.mspawn.PigZombie'
                - 'spawnmob.mspawn.delay'
                - 'towny.admin'
                - 'towny.town.claim'
                - 'towny.nation.new'
                - 'towny.wild.*'
                - 'towny.wild.build'
                - 'towny.wild.destroy'
                - 'towny.wild.switch'
                - 'towny.wild.item_use'
                - 'towny.wild.block.[block id]'
                - 'towny.spawntp'
                - 'towny.publicspawntp'
                - 'towny.town.claim'
                - 'achievements.admin.check'
                - 'achievements.admin.reload'
                - 'stats.admin'
                - 'auction.end'
                - 'localshops.manage'
                - 'localshops.manage.owner'
                - 'localshops.creat2e'
                - 'localshops.create.free'
                - 'localshops.destroy'
                - 'localshops.reload'
                - 'localshops.admin'
                - 'auction.bid'
                - 'auction.start'
                - 'warp.admin.give'
                - 'warp.admin.invite'
                - 'warp.admin.uninvite'
                - 'warp.admin.delete'
                - 'warp.admin.message'
                - 'warp.admin.update'
                - 'warp.admin.to.all'
                - 'warp.admin.private'
                - 'warp.admin.public'
                - 'warp.admin.global'
                - 'warp.admin.reload'
                - 'warp.admin.convert'
                - 'warp.admin.export'
                - 'warp.admin.editors.remove'
                - 'warp.admin.editors.add'
                - 'warp.admin.warp.others'
                - 'factions.create'
                - 'factions.manageSafeZone'
                - 'Spells.commands.cast'
                - 'Spells.commands.spells'
                - 'Spells.cast.<spellname>'
  24. Offline


    612 is compatible with 617.

    Next time try before asking for an unnecessary update.
  25. Offline


    oh, im sorry i did not read that anywhere, thanks for telling me. :)
  26. Offline


    Am i not able to set certain spells to certain groups?

    It stops working after every /reload, and i need to restart the server all the time.
    (Relog and it works again)
  27. Offline


    Amazing I love it!

    Finally something that works for MAC, I just downloaded your zip file. Blink is my favorite by far. 1 problem, some spells such as torch, and superblast do not work. with torch nothing happens, with superblast it just shows that it does not exists. (cast<spellname>)

    Edit: torch works, you just have to manually find a torch. typing /wand torch will not spawn one.
  28. Offline


    Sorry if this has already been answered, but I'm not keen on wading through 33 pages of comments to see... But when i use "cast blink" from the console, i get an error that says: Persistence: can't find callback 'OnCast for plugin spells. Also, none of my spells seem to be working. Does anyone know what I'm doing wrong?
  29. Offline


    How do you learn spells? Every time I do /spells. Nothing happends.
    /wand reload says it has no spell
    /cast doesn't work with any spell

    And when I right click though with the wand, it does nothing.
  30. Offline


    Is the "can't find callback" still happening with everyone? Because I just re-downloaded and still happening on RB 617. It would be great to finally get this on my server ;-)

    No pressure :D

Share This Page