[DEAD] Spells v0.996

Discussion in 'Inactive/Unsupported Plugins' started by NathanWolf, Jan 16, 2011.

  1. Offline


    Some issues in your config re inheritance. No Moderators group for starters...
  2. Offline


    Do I need a Moderators group? Is it required? Because I don't have mods and don't want them :p

    Anything else wrong with my inheritance, specifically? I really only need a couple of groups- I'm about ready to copy+paste.

    God, I hate Permissions and YML. Really ready to move on from this now. Well, the Permissions at least- I guess we're stuck with the YML.
  3. Offline


    Problem is you refer to Moderators in the inherits section of Admins. If you want to have just admins and users then remove the inheritance altogether. I've updated your example file:

  4. Offline


    Spells use to work for me but now /cast doesn't do anything no errors no messages nothing in console also had to disable the Wand plugin as while loaded any user could cast any spell through it. Using CB 440 and spells and persistence from this thread at the time of making this post.
  5. Offline


    Ahhhhh! Thank you :D
    --- merged: Feb 27, 2011 12:51 PM ---
    Permissions? Groups?
    --- merged: Feb 27, 2011 2:05 PM ---
    Ok, so I changed the Admin inheritance to "Default"- I think that's all you changed there?

    Still doesn't work- and, besides, the "Friends" group still should've worked.

    Nothing I do seems to give me any permissions- I'm going to trace my code a bit, but I'm pretty sure I'm just returning whatever Permissions tells me.

    UPDATE: This extends to the single NetherGate.commands.go permission I've given directly to the Friends group. So, it's not about inheritance or wildcards- I've traced the code to the Permissions.Security.has(player, key) call- the player is in the Friends group, the key is "NetherGate.commands.go" - and it returns false.

    What am I doing wrong here? I'm not sure I'm going to figure this system out before it's obsolete :p
  6. Offline


    Permissions 2.0
  7. Offline


    Then, you also need Groups.jar, and you also need to give persmissions to anyone you want to be able to use things.

    I, personally, have not been able to get this to work. I've been testing it myself, and I can't get a config.yml made that actually gives people permissions. I've traced my code, I think it's doing the right thing- calling Permissions.Security.has() with the player and the right pnode.

    So, let me know if you're able to get this working...

    Really can't wait for bukkit permissions :p
    --- merged: Feb 28, 2011 4:31 PM ---
    I'm now recommending CB#478 for Spells- there's a fix in for the block breaking bug which really messes up a lot of spells badly (especially "self building" spells like bridge and pillar) - so I recommend you update!
  8. Offline


    For some reason, when I hit /spells, it only lists a few of teh catagories, and some of them don't work /spells contruction says I don't know any spells.

    Any ideas?

    this plugin is great =)
  9. Offline



    otherwise, no idea :(

    Thank you! :D
    --- merged: Mar 1, 2011 5:44 AM ---
    I just released Groups 0.15, which I'm hoping has better support for all the insane half-breeds of Permissions that are out there now. I followed this API reference guide, which was not what I was doing before.

    However, I still haven't been able to get it to work at all, myself. I just thought I'd share in case of you wanted to play with it.

    Clearly, the current state of permissions is a total disaster and mess- I don't really understand why we couldn't have just left well enough alone with Permissions until bukkit was ready with their own- I know this was all working at some point, before the Phoenix and all this other stuff :p
  10. Offline


    I have a bit of a noob problem, I think. I love your magic plugin, my friends and I use it on my server for magic wars, but we have problems with the shell and blob commands. Whenever I use them, it doesn't spawn a shape, instead, it bores a hole into the ground. I've tried to make a circle in the air several times, sometimes pointing to the air and sometimes at the ground or distant cliffs, but this doesn't seem to be working. We've only managed to get the mod to work twice, once a floating glass sphere, and another time a gigantic lightstone sphere. Sorry if this has been asked before, but what are we doing wrong?
  11. Offline


    You are, most likely, holding a material? Make sure your active inventory is either free of materials, or you have whatever you want to build with in your right-most slot.

    The material selection system is moving to Wand soon-ish, so hopefully it will stop confusing core Spells users then :)
  12. Offline


    Yeah, I'm an admin so permissions shouldn't be an issue. Mind you, all the spells work, including with the wand, I just can't see all the spells in game by typing /spells.

    Is there a list somewhere where I can find the materials that correspond to the spells? (Since I can't in-game)
    Also, is this list editable?

    Thanks! This mod has completely changed the game for me, for the better =)
  13. Offline


    Glad to hear it!

    So... that's really weird.... the spells list goes through the same permission checks as actually casting the spell... clearly something is messed up with my permissions support- but I guess we knew that already :(

    As for the list- no. People keep asking for that, I keep putting it off because it's going to move over to Wand soon anyway, and be editable, as you request- at which point, keeping a list around will be moot- though I'll probably make and maintain one in the Wand thread for the default variant/material bindings, so you know what you get "out of the box".

    If that doesn't happen soon, I'll put a list together before then :)
  14. Offline


    Hello, it's me again! I have a pair of requests!

    The first is a modification of the box and shell spells; Could there be an option, shift or otherwise, to make these spells function as selectable range spells just like Fill does?

    I was extremely excited when I heard about 'box', because I assumed that it would let me paint boxes into place like Fill currently does when creating filled boxes. Unfortunately it makes a fixed size box which is useful in limited applications.

    Since I've installed ClassicWater mod I now have a gigantic ocean that reaches right down to the bedrock. In conjunction with a boosted range Redstone Sponge mod I've been working on a fantastic underwater city using Box to create a glass container, then blasting all the water out of it with the sponge. Due to the nature of ClassicWater, the water immediately floods right back in against the sides of the box, but the box itself remains clear. The more I use box the more I crave more fine grained control over the size and location of each, even resorting to 'four walls and a roof' fill style, though if I didn't have god mode running such a method would have me drowned. If I could just say, 'pillar up to the right height.. ok, corner here, corner there.. SHAZAM, Sponge, ok we're done!' I'd have it done in a day :)

    The second request is more of a bug report. Blast and SuperBlast are ignoring my instructions in the config file to destroy ANYTHING other than bedrock. Here is my config line;


    (Note the missing 7, I want bedrock to stay)

    That should do it, right? Well, it's not doing it, my blasts and superblasts have me left with an ocean full of floating ore. I run a creative style server, this ore is just garbage that I have to snipe away using the 'mine' spell (thank you so much for that). I would vastly prefer to be able to set it to blow completely empty holes in the countryside that I can then let Classic Water fill up to make a lovely round (and deep) lake

    Incidentally, with ClassicWater enabled, get in a boat and boat up to the side of a mountain, then blast a tunnel through it. The water flows out to half-fill the tunnel before you; instant tunnel of loooove
  15. Offline


    Yes indeed! I'm thinking that 1.0 will "collapse" a lot of spells. fill and construct will probably become the same spell- if they remain different, they will both be capable of single and double-click construction.

    Hm- some solutions, maybe, in the meantime?
    • Box should take a parameter for size! I haven't tried this- the variant itself specifies a size, but I think it'll use the last one on the effective parameter list - meaning you should be able to override it.
    • If that doesn't work, try "/cast blob cuboid hollow 32", where 32 is whatever size box you want. "blob" is really the name for "construct" right now- it's the default variant, until I get that sorted properly.
    • One thing I like to do is build something solid first, then cover it in glass (you can just blob if you don't mind it being irregular- I think it ends up looking really cool, personally). Then, if rewind is actually working (I've been having issues since 1.3...) you can rewind the solid structure inside through the glass covering.
    • If the box parameters work, you can first fill with air (after pillar, you figured that part out already), then build a box. (I don't think box will fill with air- so box alone will just get you a box full of water, probably not what you want...) Gotta do the box quick, though, I imagine that air pocket will start filling up quickly :) You could also just do a filled cuboid with air first, I guess- omit the "hollow" parameter.
    All of this, of course, will be the kind of things you can do in the new variant system, making your own spells, giving them a wand icon, and then never using the console again... that's the idea, anyway. Really wish I could get to work on that- Real Work has been harsh lately. :p

    Yah- sorry, I didn't know anyone was really squeaking things to this level :) I'd always hoped...

    A lot of the customizeable material lists were removed (by me) after all the world-corrupting bug reports.

    I'm going to add them back in, in the form of per-player permissions and/or spell variant lists (as appropriate), when bukkit.permissions is here, and when I can make sure I'm able to do it in a safe way (e.g. there will be a master "materials" list that, at the very least, does not include items- and probably another that doesn't include "sticky" things like doors and torches, which can also break the world if you fill with them).

    Anyway, "better safe then sorry" is the answer- however, this really only applies to construction spells. If I can turn it back on easily, I'll do so for blast- it should be safe to do whatever you want with that, really- even bedrock, assuming you're ok with falling through into the void :)

    I'll try and get that into 0.98 for you- I enjoy the thought of people doing this. You can actually make mine do some really awesome stuff by messing with its material lists... a tree mining spell, perhaps? Can't wait for that variant system...

    Yeah, I hear you, for sure. My server started out as fairly "vanilla"- I'd planned on slowly introducing all these spells via an experience tree. And then I just made it public and handed them all out- so I guess I'd call it a creative server now :)

    There have been many a times when I really wished I could modify blast, preferably on the fly, to blast through glass. I (and many of my guests) seem to enjoy superblob'ing glass all over the place- which looks really cool, but disintegrating my way through one, one block at a time, is no fun.

    All the "destruction" type spells, you'll notice, are currently labelled "mining". Once variants are here, that will be a distinction only really made by the material lists you give the variant. And it'll all just be construct and/or fill - so the current blast would become the equivalent of something like "/cast construct sphere with air 4", including a material list that specifies only "common" materials. You could easily have another variant, maybe obliterate, that is like a big spherical disintegrate (again, this is just a construct variant now...) and would destroy anything but bedrock (I think that's what disintegrate's material list looks like...)

    So, basically I guess what I'm saying is the "construct" spell will also let you set up any kind of destruction you want... maybe that spell needs a better name in 1.0 :)

    I think I need to check out this ClassicWater plugin... sounds fun!
    --- merged: Mar 1, 2011 8:13 PM ---

    Well, I'll be dipped! I was finally clued in to how Permissions 2.1+ handles multi-world, and after "fixing" my permissions config, it all seems to work as I'd expect.

    So, grab Groups 0.15 if you haven't already- make sure to create per-world config files (you have to at least rename config.yml to your default world name!), and let me know if you still have Permission issues.
  16. Offline


    Sounds good! Keep up the fantastic work =)
  17. Offline


    0.98 Released!

    There is only one change in here- I made invincible work!

    It's not a duration spell- it will be when I have a good system for that. So, it's really a very powerful/admin type of thing- just on/off invulnerability.

    The post-1.0 variant-capable version of this spell will have parameters to protect from specific damage types, so it could be used for a gills spell, or a safefall, or fireproof, or whatever.
  18. Offline


    Thanks, that seemed to help some of the issues. I tried the wand mod, but it just won't load in my server for some reason, also, not sure if this is a bug or something we're just doing wrong, but the blink, ascend, and descend spells seem a bit fickle about when they want to work and when they don't, with no way of knowing when one will work, and despite my careful planning of where to actually spawn a shell or other shape, aiming at the selected pillar I rose twenty blocks off the ground usually results in the stupid thing attaching to the sky roof, or much more likely, the large structure 3 miles away that I didn't want to ruin, instead of the one 3 blocks away designed for the purpose of spawning the object. Also we seem to have problems with a few other spells arbitrarily deciding when they want to function, most noteably the rewind spell, which makes deleting some of the failed experiments impossible. (It's a good thing I keep server backups.) The same problem exists with mine and blast. (I've never once been able to use superblast.) The only reliable spell I've used is frost.

    Still love the attempt to bring magic into Minecraft though.
  19. Offline



    So, some of you may not be aware, but Bukkit is buggy beta software :)

    Right now, things are a bit rough because of 1.3, which completely changed the map format- and, hence, the internal representation of map data.

    The biggest bug I've seen, in terms of how it affects my plugins, is not something I've been able to get reproduction steps for. But I know it exists at least in 478, still, and that it completely breaks both Spells and NetherGate when it happens.

    From what I've seen, the problem is that World.getBlock() seems to "ignore" world mods- like it gets confused or "out of time" and is showing me the world in its natural state (no mods).

    This completely breaks spells like pillar and bridge, which rely on building on top of themselves.

    It will also apparently break targeting in heavily-modified areas, you'll constantly target "through" anything that wasn't there when the world was created.

    It's incredibly frustrating, and frankly I'm so sick of taking the flack for "my plugin being broken" because of it, that I'm considering pulling both Spells and NG downloads until it's fixed.

    However, I'm hoping (though really not expecting) that making a post about this will help, in some way- at least for me to not get complaints about it directed at me, if it all posssible- there's really nothing I can do about it.

    That aside, Spells is working great for me- I'm sorry you had so many issues, but I think most of them I can explain with the above, if it was happening to you at the time. If you think this is happening, a logout/login often fixes is, as does switching worlds (if that's something you can do on your sever).

    Thanks for your patience- I will definitely let you know (and RB that CB!) as soon as this gets fixed.
  20. Offline


    Just wanted to let you know that a friend and I used Spells and Wand with (mostly) great success last night on CB440. Aside from some misunderstandings with how recall and transmute work, we had a lot of fun with it.

    I did want to let you know that stalactite, upon hitting the bottom of the world, then started dropping a stalactite from the sky. It was actually quite amusing, so I'm not sure if I'd want it changed.
    NathanWolf likes this.
  21. Offline

    SweetCraft Girl

    Let's talk about the Lava spell, yes?

    Major havoc spell.

    Did i think the 16-20 block stream of lava would really appear as a stream of lava and travel that distance? No. Did it go away? No. Did i uselessly /replacenear 20 lava air ? Yes. /drain however - eventually worked after the drunken panic and destruction had been wrought.

    It really is a spell that needs some parenthesis on it that states (stream of lava that will not go away). Because, if you are on a cliff, and your target is on a tree, then you create a nice long lava bridge of OMGWTFBBQLOLCOPTERISTHIS!?

    It did make for some nice panic and freak out as the builders ran 69 different directions...LOL.

    But, yes, that spell needs a nice red text beside it (Will cause a permanent lava stream).

    Oh, we were at about y=100 so it made for a very nice and long lava wall too.
  22. Offline


    Sorry to bother you about bugs with the mod and server program, I do keep in mind that sometimes it can be bugs with the actual software and not the plugins or other content developed indipendantly but I'm not a programmer and I have no way of knowing whether it's a bug with the server or with the plugin or just an isolated issue because of something I did.

    Thanks for explaining this though, as these things are, indeed, happening to me and to know that it's a known issue is really nice.

    Do these issues also branch to the Fill tool? It seems that at one point I made an incomplete fill, because a friend beat me to it, and now whenever I try to use the command, it says something about the distance being too far... I don't know how to get rid of the original pointer, if there is a way.

    I think I'll just uninstall the mod and wait for these things to be fixed. The people on my server are getting frustrated and I'll be sure to tell them it isn't your fault.
  23. Offline


    That's cool! Glad you had fun- the current bug that is really a problem, I think, happens more with multi-world. I've seen it happen without portaling, but it does seem to be rare, I'm happy to say.

    Ha! :)

    That's kinda funny... clearly I need some sort of min y check on that spell- thanks for pointing that out :D
    --- merged: Mar 3, 2011 5:58 PM ---
    Eh, I posted on it, with screenshots. It's labelled as very dangerous and experimental in the OP. My general reaction to this is that, if two people complain, I "wip" the spell. Meaning you don't get it anymore (see: tunnel, stairs, etc).

    So, FYI there :)

    Some spells are dangerous, yeah? They're even more dangerous when I slapped them together in 5 minutes and didn't think about the repercussions of "temporary" lava dripping, etc- for this spell to really work well, I'll need to control the lava physics to keep it maintained in a stream.

    I'd also like to be have a variable duration, and track eye movement- so you can wave it around like a ridiculously dangerous firehose.

    But its still always going to be incredibly destructive. It's reactions like this that are exactly why I've waited so long to do any kind of lava/fire spell- certainly not because it was difficult.

    The onus is really on you, the admins, to go somewhere safe and test these spells before giving them out! Heck, you probably should be testing permissions, too, since I can never seem to get that right :p

    I suggest a test world, using NetherGate and a private portal :D
    --- merged: Mar 3, 2011 6:00 PM ---
    Unfortunately, this bug affects everything other than the vanilla functionality. I have no reason to believe other plugins aren't affected, unless I'm just doing something basically very wrong.

    I know that it affects NetherGate, at least- it breaks portals since NG no longer "sees" them there.

    Yeah, no big deal- I more want you, the admins to know. I really don't just let stuff break if I can help it :(
  24. Offline


    I miss tunnel! Was a favorite of mine, made extending the underground rail system on my new map much less work. Any chance you could "fix" it (I'd be fine with the "auto-torches" stuff being dropped. I just want to be able to make a long 3x3 hole).
  25. Offline


    I miss it, too :)

    Funny thing is, it works fine- there was a minor bug in how it put torches on the wall.... In fact, one sec. [coding]

    There. It's back :) Re-download 0.98 if you want tunnel- I didn't want to bump the version number because I'm running out of pre 1.0 numbers :p

    It was really more spiteful than anything else that I removed tunnel- it was basically working, minus the torches (which I just commented out). Too many complainers, though- and I never had time to go back to it.
  26. Offline


    Just wanted to say that I tested with groupmanager 1.0 and it worked with no flaw. :D
  27. Offline


    Wow! Cool! :D

    I'll make sure to try and not break it when I kill Groups :)

    Thanks for testing, anon!
  28. Offline


    I can confirm it working with groupusers 1.0 as well
  29. Offline


    We haven't bothered to do multi-world stuff, as we have no need for it at the moment.

    If you add one, could you make it an option? I find it quite hilarious and awesome to be able to drop pillars from the heavens.

    So, FYI there :)[/quote]
    Don't take the lava spell away. I'd be sad. It's cases like that where I think permissions would be handy, '-Spells.cast.lava' to take away the ability from "Default" users (though I haven't tested using Spells with Permissions directly or indirectly through Groups, as I'm currently just running a server for me and a friend, so I have no idea if this would actually work as I've typed).

    Lastly, I had some trouble last night getting Blink and Ascend to place me on a glass surface. Any ideas with that?
  30. Offline


    Ha! Yeah, after I replied I saw that you actually liked it.... I'll leave it alone for now- but I think what I'd like is for you to be able to aim at the sky for this affect- so you could purposely pull stalactites down from the "ceiling" :)

    Well, funny thing, there is Permissions support (right now, via Groups- going to kill that ASAP)... so, you should be able to give out individual spells (instead of Spells.cast.*), just as you request. From the posts above you, it sounds like it might even work ;)

    Yeah- I think it's a bit buggy, but it should work OK. Blink (It's the same spell- ascend and descend are blink variants) will first look through glass for a target- the idea is that you can blink through glass (I think I do this for ice, too, not sure). If it doesn't find a target that way, it will re-target, this time including glass/ice. So, you should be able to ascend/blink (just point up/down with blink to ascend/descend btw, if you don't know already) up onto a glass platform- but also blink through a glass wall.

    I may remove all this, now that you can blink through anything just by getting close enough to it- but it's still handy, so maybe not.

    Really, the main use case is underwater construction- if you have a glass dome underwater, you should be able to blink right into it from the surface.

Share This Page