CraftBukkit 1.3.1-R1.0 is now available!

Discussion in 'Bukkit News' started by EvilSeph, Aug 7, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    A new CraftBukkit Recommended Build (1.3.1-R1.0) that provides Minecraft 1.3.1 compatibility is now available.

    Important information about this first Recommended Build following a Minecraft update:
    The first Recommended Build, as always, is a slightly more polished development build that we're promoting to a Recommended Build so that people who rely on a Recommended Build being available can try out our development builds and decide if they want to use them.

    Will plugins break with this build?
    Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine.

    Download CraftBukkit 1.3.1-R1.0 here
    hansolo23, flap, Terence and 37 others like this.
  2. Offline


    Still lots of lag, I'm sure this wont be fixed for quite a long time either. Maybe it has to do with chunks? idk, all i know is the more players = more lag.

    Edit: Just examined my server, chunk creation is using 697.22 ms/500 ticks with over 100 players. In 1.2.5 i only hit around 40-60 ms.
  3. Offline


    I believe I saw a twitter update about it. They might be fixing it? Also the a new version of craftbukkit is gonna be coming out! It might be version Craftbukkit 1.3.1R-1.1
  4. Offline


  5. Offline


    Thank you, CB team! My server updated very well from 1.2.5, to some 1.3.1 prebuild, to this release, almost painlessly. I appreciate your efforts for working on this. Once again, thank you!
  6. Offline


    I has downloaded the 1.3 RB for my server and an error code comes up when i try to use citizens plugin any help?
  7. Offline


    Edit: Using build 2322: Haven't noticed any decrease in lag, TPS dropped faster than before..
  8. Offline




    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  9. Offline


    I have a problem with the update. Ever since I updated to 1.3.1, when anyone tries to go to spawn its all a void and it never comes back, but in other places its fine. And this has never shown up before until this very update. Any suggestions?
  10. Offline


    I have an issue, when I log into my server, chunks do not load up at all or it takes literally forever for them to load. If they do load then there are giant gaping chunks missing (you can look down and see a massive hole) and that chunk will not load at all. Can anyone help with this issue please?
  11. Offline


    ok so i fixed it it was orebfuscator no1 helped so im angry :mad:
  12. Offline


    This new build also has very bad lag. When you type and hit enter there is a 2 second lag. There is also block lag with lights and redstone. This build needs more work! Please fix? Also I get read time outs.
    flyingtacoz likes this.
  13. Offline


    A fatal error has been detected by the Java Runtime Environment:
    # SIGSEGV (0xb) at pc=0xf713b3c1, pid=1506, tid=691477360
    # JRE version: 6.0_25-b06
    # Java VM: Java HotSpot(TM) Server VM (20.0-b11 mixed mode linux-x86 )
    # Problematic frame:
    # V [] ClassVerifier::verify_invoke_init(RawBytecodeStream*, VerificationType, StackMapFrame*, unsigned, bool*, constantPoolHandle, Thread*)+0x2f1
    # An error report file with more information is saved as:
    # /home/julio/minecraft/sm3/hs_err_pid1506.log
    # If you would like to submit a bug report, please visit:

  14. Offline


    Use the next dev build (2321) which supposedly alleviates lag issue.
  15. Offline


    Go Bukkit guys!
  16. Offline


  17. Offline


    ||23:11:24 [WARNING] **** FAILED TO BIND TO PORT!||
    ||23:11:24 [WARNING] The exception was: Address already in use"||

    Anyone else having this error?
  18. Offline


    The IP address in your server properties file is not set properly

    not sure where I should post this....using bukkit 2322 and just got this massive error. I have no idea what it means...

    2012-08-07 19:53:13 [INFO] Connection reset
    2012-08-07 19:53:14 [SEVERE] java.util.ConcurrentModificationException
    2012-08-07 19:53:14 [SEVERE] at java.util.ArrayList$Itr.checkForComodification(Unknown Source)
    2012-08-07 19:53:14 [SEVERE] at java.util.ArrayList$ Source)
    2012-08-07 19:53:14 [SEVERE] at net.minecraft.server.WorldServer.getTileEntities(
    2012-08-07 19:53:14 [SEVERE] at net.minecraft.server.EntityPlayer.h_(
    2012-08-07 19:53:14 [SEVERE] at net.minecraft.server.World.entityJoinedWorld(
    2012-08-07 19:53:14 [SEVERE] at net.minecraft.server.WorldServer.entityJoinedWorld(
    2012-08-07 19:53:14 [SEVERE] at net.minecraft.server.World.playerJoinedWorld(
    2012-08-07 19:53:14 [SEVERE] at net.minecraft.server.World.tickEntities(
    2012-08-07 19:53:14 [SEVERE] at net.minecraft.server.MinecraftServer.q(
    2012-08-07 19:53:14 [SEVERE] at net.minecraft.server.DedicatedServer.q(
    2012-08-07 19:53:14 [SEVERE] at net.minecraft.server.MinecraftServer.p(
    2012-08-07 19:53:14 [SEVERE] at
    2012-08-07 19:53:14 [SEVERE] at
    2012-08-07 19:53:14 [SEVERE] Encountered an unexpected exception ConcurrentModificationException
    at java.util.ArrayList$Itr.checkForComodification(Unknown Source)
    at java.util.ArrayList$ Source)
    at net.minecraft.server.WorldServer.getTileEntities(
    at net.minecraft.server.EntityPlayer.h_(
    at net.minecraft.server.World.entityJoinedWorld(
    at net.minecraft.server.WorldServer.entityJoinedWorld(
    at net.minecraft.server.World.playerJoinedWorld(
    at net.minecraft.server.World.tickEntities(
    at net.minecraft.server.MinecraftServer.q(
    at net.minecraft.server.DedicatedServer.q(
    at net.minecraft.server.MinecraftServer.p(
    2012-08-07 19:53:14 [SEVERE] This crash report has been saved to: /servers/w84/minecraft/./crash-reports/crash-2012-08-07_19.53.14-server.txt
    2012-08-07 19:54:36 [INFO] Read timed out
    2012-08-07 19:55:07 [INFO] Read timed out
    2012-08-07 19:58:19 [INFO] Connection reset
    2012-08-07 20:00:43 [INFO] Read timed out
    2012-08-07 20:00:48 [INFO] Connection reset
    2012-08-07 20:01:37 [INFO] Read timed out
    2012-08-07 20:02:14 [INFO] Connection reset
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  19. Offline


    is there any specific IP i should set it to?
  20. Offline


    Yes. If you are using a hosting servers, they assign you an IP, it should be that. If you are hosting this from home, it should be your Home IP address. Check your server properties file too, Ive come across a few times where my server crashes and some how the server properties file gets corrupted and only half the text is there.

    The best bet is to remove your server properties file, start your server, let it generate a fresh one, edit it and input the proper IP address and ports (25565) I believe is the norm.
  21. Offline


    ok, now it's not even running. it just goes to an immediate crash. i have the IP address set to (home IP here):25565. am i doing something wrong still? everything is there in the file.
  22. Offline


    Ok I have read every comment and only seen this mentioned once: This update kills Zombe's Fly Mod in SMP. It's fine and dandy for Survival Servers, but our's is a Build Server and we use it all the time. The server kicks back a "PLAYERNAME moved too quickly" console message and forces the player down a few blocks, even into the water, essentially rendering Zombe's unusable. To us this is a serious issue. On the Bukkit ticket system this problem has been marked as "will not fix" in issues 2147 and 2123. On behalf of my server I would like to request a fix for this issue.
  23. Offline


    In troubleshooting my own server, I've set-up a test server for v1.3.1
    1. Installed recommended Bukkit v1.3.1 build #2317
    2. snooper-enabled=false (in
    3. Generated a new v1.3.1 world
    4. Completely removed all plugins
    This is on a server with 2.0 GB of dedicated RAM, access to 32 cores and server runs at a constant 20 TPS and I'm still experiencing massive lag spikes. I've had 24+ players on this very same server without any lag in 1.2.5 but now with 1 player (myself) and NO plugins, I'm still experiencing the lag spikes. Ready to try any recommendations that aren't listed above.. thank you in advance!
    flyingtacoz likes this.
  24. Offline


    It is an issue with Zombe's Fly Mod, not with Bukkit.... you'll probably want to contact the creators of it.
  25. Offline


    Oh. good!
  26. Offline


    Leave it blank.
  27. Offline


    That improves it, but does not fix it.

    EDIT: I should say minimally improves it. We just tested that theory, but when you stop moving it still shoves you down. Also Zombe's4Bukkit has little to do with the flying part of Zombes as far as I know. Zombe's Fly Mod has always worked with or without Z4B.
  28. Offline


    You might try build 2322. They changed some stuff with chunk saving. That being said, I am updated to that build, and this is still along the lines of what is happening to me. It seems fine as long as it's just me in the server, but when someone else enters and starts, for example, exploring new chunks, the server becomes extremely laggy, to the point of disconnecting us. I observed the java process during this time, and it jumps from ~40% to 100% and stays that way for a while, and cannot be connected to via the Minecraft client. After a few minutes, the CPU usages dies down and the server reappears, and I can reconnect. This happens multiple times--I just stand still and someone else goes flying off in Creative exploring unexplored chunks, and we both get kicked after the CPU usage goes up.

    I got on your server and everything seems fine to me, but I suspect the issue can't be reproduced as easily with just one person in the server, if it's CPU usage-based. What is your CPU usage doing the lag spikes?

    If you check out the last couple pages on the the development for it over on Minecraft Forums, it looks like there's a bit of discussion on the issue with some suggestions; some with suggestions of other plugins to use. That's not always an option, though. (

    This probably wasn't particularly helpful....

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  29. Offline


    Hip Hip HOORAY for bukkit!
  30. Offline


    ok so I've solved my Lag issues. I removed -Xincgc from my startup line. I am using Bukkit 2322 and its running 100% lag free for well over an hour now where as before it died after 20 min

    can anyone explain why? the reason I tried this was because I read something about how the newer bukkit loads chunks differently so I thought, maybe unloading them F'ed it shot in the dark but it seems to have worked.

    btw I have Java 1.7 installed on my Linux box with 64 gigs of Ram

    Also, the Garbage collection code I was using above I read is for Java 1.6

    What if I used -XX:+UseG1GC ? that's java 1.7's improved garbage collection code

    I think I will try this next reboot
Thread Status:
Not open for further replies.

Share This Page