Solved Craftbook permission

Discussion in 'Bukkit Help' started by NormallyRelativelyEz, Sep 5, 2020.

Thread Status:
Not open for further replies.
  1. I wanted some redstone ICs and found craftbook.
    I run a server, which is currently only used by myself (having op permissions)

    I already had worldedit as a plugin and thought I just needed to copy craftbook into the plugins folder as well.
    I read the craftbook docs and enabled redstone ICs in its config.

    But I cannot see any additional ICs. From the docs I could see that I needed to add the craftbook permission.

    After several days of unhelpful googling (solution for older versions/abandond permission plugins), I would appreciate some help/clarification.

    Is there any way to give this permission without any additional permission plugin? (I copied the permission.yml example from the bulkit docs and made craftbook a defaut permission.)

    If I need a plugin, which one works on 1.16.2 and takes the least amount of time/setup to give myself that permission?
  2. I have been lucky to find some answers myself. After 2 weeks I found the right combination of Google terms.

    Firstly, craftbook doesn't add new blocks as I expected. ICs are constructed using vanilla blocks. Duh, no wonder I couldn't see any new redstone blocks.

    Secondly, for permissions LuckPerms is working with 1.16.2 and was easy enough to set-up.
    Probably could have not used it, but I won't remove it to find out.
  3. Offline

    timtower Administrator Administrator Moderator

    Plugins are not capable of doing those things anyways.
Thread Status:
Not open for further replies.

Share This Page