Problem/Bug Could not reserve enough space for object heap.

Discussion in 'Bukkit Help' started by Darrell2608, Mar 6, 2016.

Thread Status:
Not open for further replies.
  1. Offline


    Hey guys!

    i've got a problem, i want to run a minecraft bukkit server but when i start the .bat file it says: could not reserve enough space for object heap...

    i ran this command in my cmd prompt to try and fix it (got it from another forum):

    "C:\Program Files\Java\jre7\bin\java.exe" -Xms2048m -Xmx2048m


    But it didn't work. This was what came as "solution"...

    Program Files\Java\jre7\bin\java.exe" -Xms2048m -Xmx2048m
    Usage: java [-options] class [args...]
               (to execute a class)
       or  java [-options] -jar jarfile [args...]
               (to execute a jar file)
    where options include:
        -d32          use a 32-bit data model if available
        -d64          use a 64-bit data model if available
        -server       to select the "server" VM
        -hotspot      is a synonym for the "server" VM  [deprecated]
                      The default VM is server.
        -cp <class search path of directories and zip/jar files>
        -classpath <class search path of directories and zip/jar files>
                      A ; separated list of directories, JAR archives,
                      and ZIP archives to search for class files.
                      set a system property
                      enable verbose output
        -version      print product version and exit
                      require the specified version to run
        -showversion  print product version and continue
        -jre-restrict-search | -no-jre-restrict-search
                      include/exclude user private JREs in the version search
        -? -help      print this help message
        -X            print help on non-standard options
                      enable assertions with specified granularity
                      disable assertions with specified granularity
        -esa | -enablesystemassertions
                      enable system assertions
        -dsa | -disablesystemassertions
                      disable system assertions
                      load native agent library <libname>, e.g. -agentlib:hprof
                      see also, -agentlib:jdwp=help and -agentlib:hprof=help
                      load native agent library by full pathname
                      load Java programming language agent, see java.lang.instrument
                      show splash screen with specified image
    Could someone please help me? I suck at scripts...

    reply would be nice! :p

    Oh and i've got a quad-core i5 with 8 gigs of RAM.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Mar 6, 2016
  2. Offline


    You need to be running 64-bit Java. Make sure you have it installed. Then change your command to just start with java.exe
  3. Offline


    I already am running java 64-bit. I tried other commands to but it didn't do anything...
  4. Offline


    What's actually in your .bat file? Post it here. What you posted above is not it, there's no .jar file specified.
  5. Offline


    @Darrell2608 wWhatever you used, that's totally wrong...

    Try this.

    java -Xmx1G -Xms1G -jar (NameOfJarFile).jar

    Change the active directory to your server folder using the cd command before running this and replace the parenthesis part with the jar name.
    Last edited: Mar 7, 2016
Thread Status:
Not open for further replies.

Share This Page