Console consult

Discussion in 'Bukkit News' started by Dinnerbone, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Dinnerbone Bukkit Team Member

    Give me your output of "plugins" in the console, and a list of all plugins that you have in the /plugins/ folder.
  2. Offline

    Hugo mass

    I have just Mobrider which load and
    extendday, fencedoor, fencestack, mobrider, permissions in the plugin folder.
  3. Offline

    Dinnerbone Bukkit Team Member

    And the output of "plugins" from the console? (/plugins ingame)
  4. Offline


    In the folder I have: Permissions, Essentials, EssentialsWarp, EssentialsTele, EssentialsSpawn, EssentialsHome, EssentialsBan.

    Typing plugins in the console I only get "[INFO] Plugins:"
  5. Offline

    Dinnerbone Bukkit Team Member

    Pastebin the output of your console as it starts up.
  6. Offline


    Thanks for all the work you all do on bukkit. Your complaints made me want to point you to a mod I found called "Towny"(runs thanks to the work you all do with bukkit). Maybe you know about it and just thought more control should be on a bukkit level directly.
    I am looking at Towny as a means to create a real interactive environment for giving server protection to the users. It has the potential to create a self sustaining(well, as close to self sustaining as you can get) server environment. I brought it up because it sounds like you have the same concerns and I think close collaboration between your two groups(if not there already) would make for a really great MC environment.
  7. Offline


    Great change for direct console access!
    Is there a way to disable this when using a wrapper? It seems to affect stdin of our server manager daemon ( and generates some output that's not required (the '>' lines).
  8. Offline


    Lol, I was trying some things and Permission loads now, so it was my fault. Sorry for the trouble
  9. Offline


    Could someone telling me where to download it. I also followed the twitter but I didnt find any download -link.
    Wouldn't it better if you just made a little "Download-Button" on the Home-Page?
    Dont want to force anyone, great job! And many many thanks for this awsome mod!
  10. Offline

    Dinnerbone Bukkit Team Member

    We haven't officially made a release yet. You can try the dev builds by reading out FAQ (Don't worry, they're perfectly stable, it's purely licensing issues stopping us from releasing fully)
  11. Offline


    I'd like to see Color's in Windows :(
  12. Offline


    thank you dear god bukkit is making everything so much easier for us. thanks everyone
  13. Im geussing that since I'm using a Linode (so I control the console through SSH/putty) it wont take effect for me? Or am I wrong? Anyways, that sounds totally amazing, Dinnerbone, you are epic.
  14. Offline


    Aaah, command history, that's amazing.

    It should work fine for you fofogogo23, even through ssh.
  15. Offline


    You can still pipe bytes to the standard input streams of the server just fine. I haven't looked into exactly what they've done, but i'm going to have to become very familiar with it today.
  16. Offline

    Nathan C

    Nevermind, I actually saw some green text in my console today!

    I got excited. [​IMG]
  17. Offline


    After you have a chance to examine it I would like to hear what u find if u don't mind. Was it a VT/ANSI implantation and also what was involved with getting your wrapper to coexist seamlessly.. A basic tech overview that I can infer from on my own would be nice. I have a single board serial VT terminal board kit I put together from the guy who makes the Altair reproduction kits. I have been looking for something to use it for for years. Lol.

  18. Offline


    i went to the wiki and downloaded latest 1 and its just the same console

    im running vista 32-bit
  19. Offline


    How would you install this, I can't get it to work.
  20. Offline


    Eh, works for me. Maybe you guys are expecting a drastic change in the look of the console, it's not like that.

    Here it is for me using Putty on windows to my CentOS server. You can see that I'm moving the cursor around (left/right keys) and that the plugins command outputs colors.

  21. Offline


    I guess Ill post again since I was ignored the first time =/

    I downloaded the build 456.

    When I run the server this comes out of the console.

    I can't type, and nothing happens...

    I run W7, 64 bit.

    ALL the plugins I use =

    build 440 ( the recommended one and the last version that I tried that works ) I tried 446 ( which I think is when the change was made for the console. ) 447 and 450. They all do the same thing.

    between 440 and 446 I didn't try any.
  22. Offline


    Nice work Dinnerbone! Lookin' forward to tab completion!
  23. Offline


    Will it take much longer for a simple permissions built-in on craftbukkit?
    These plugin wars are making me nuts.
  24. Offline


    Now that is what i call "Console".
    Great job here!
  25. Offline


    I've been wanting this since day 1.. so yay!
  26. Offline


    Basic answer: Your installed ASCII parser supports the character OR your system's command is Unicode by default. It seems their application is ASCII only and they chose an ASCII table that didn't had those characters in it (or are simply running the basic ASCII table, not the extended one.)
  27. Offline


    yes YES!!!!
  28. Offline


    I second this. This new console is not wrapper friendly at all, and there are a lot of people that use them. It should be possible for me to write in a reimplementation of whatever you're doing (haven't looked yet), but it is a gigantic hassle for something purely cosmetic. There is also the problem that many wrappers (including mine) are not server mod dependent and so fixing it for bukkit may well break it for every other server mod.

    That's not to say I don't love the new console, I do (great work!) and will probably implement something similar into my wrapper. It just that I don't feel people should be forced into what I believe is a large amount of unnecessary work like this.

    @Dinnerbone ^
  29. Offline


    Does anyone else's server freeze while you are scrolling through the window or highlighting text? No new entries show up on the console until you enter a command, and then all the entries get spit out at once, and everyone gets kicked due to disconnect.endofstream?

    Bukkit 447
  30. Offline



    Add that to your startup options and see what happens.
Thread Status:
Not open for further replies.

Share This Page