"Connection Refused: Connect"

Discussion in 'Bukkit Help' started by Draygon, Feb 28, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Up until last month or so, I have been able to run my server without fail, able to connect to it and for my friends to connect to it as well.
    My modem broke a while ago, so I had to get a replacement. Afterwards, after re-portforwarding, setting my new ip address to static, and updating java and craftbukkit, it shows the error "Connection Refused: Connect".
    I've seen plenty of other threads like this, but haven't ever found a solution that helps me.
    OS: Windows 7 Home Premium
    Architecture: x86
    I'm running Java Version 1.6.0_31, build 1.6.0_31-b05, 64-bit Server VM build 20.6-b01, mixed mode.
    I'm not currently running Hamachi, but it is installed on my computer.
    I've been trying to run my server on the 1.1 build for a while now. (Not sure if this is what it means by build, as I can't find it right now.)
    The command I use to run my bukkit server is: " Echo OFF
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="64" java -Xms1024M -Xmx2048M -jar "%~dp0craftbukkit.jar"
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="86" java -Xincgc -Xmx1024M -jar "%~dp0craftbukkit.jar" "
    I'm not running any plugins right now, I deleted everything in the folder and had it generate new files.
    I've tried running the default MineCraft Server, but I can't run that either, nor can I run any other server I used to have.

    If anyone could give me any advice to help solve this problem, it would be much appreciated.

    P.S. No, deleting the ip address from my properties file does not work, nor has it ever.

    Oh, and before I forget.
    The router I use is the Netgear WNDR3700
    And the replacement modem is a ZyXel P-600 Series.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
  2. Offline


    1) Make sure your Java is allowed through the firewall. If you have multiple java versions installed, make sure they're all allowed.
    2)Make sure you port is forwarded (obviously)
    3)If you run the server on your own pc, you should enter localhost in minecraft. If it's on LAN, you should enter the internal IP. If it's on the internet, you'll have to enter the external IP.

    Check this:
    Does the modem have a small switch or router built-in? If you can configure your modem (most likely throug a web interface), check if you can find any settings about ports. If your modem has a router/switch built in, you should redirect all ports to your router, and your router should redirect them to the correct device.
    (To redirect all ports, you can use a DMZ host if available. If you eneter a DMZ host, all ports will be forwarded to this host)
  3. Offline


    I allowed Java in just yesterday, actually. No effect.
    The port forwards have been repeated to no effect as well. (Meaning I deleted the old ones and made new ones of the same kind.)
    The problem isn't with just me connecting or friends connecting. Even with canyouseeme.org it won't show the port being active, which is a major problem for me, as I don't know what could be wrong with it.
    My modem and router are separate, and the modem strangely doesn't have a configuration page for me, all it shows is status.

    Thanks for feedback, I was worried people wouldn't reply... >.<
  4. Offline


    Draygon I just solved this exact problem five minutes ago. When you do your port forwarding make sure you have the right ending to your local ip address. For some reason over the last month, my ip address changed on my computer by 1 number so I couldn't get my port forwarding to open. Check your IPv4 address and see if it has changed at all. As soon as I updated the address, my ports opened and the server worked again. Hope this helps!
  5. Offline


    Thanks snuggle, I'll check tomorrow morning as I'm posting this from my phone. Sadly, I'm fairly sure it hasn't, as I've also set my static ip and it ends with 152 now (bit of a favorite number.)
    But I'll double check :D

    Sadly, the ipv4 address was not changed. That, and it's still set to the correct static ip I assigned it.
    Any other solutions?

    Thanks for feedback!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
  6. Offline


    ok, lets do it again from the start:

    Your modem: Incoming internet on WAN. Connect the out port of your modem to the in-port of your router. If you don't have a specific "in" port on your router, use the first LAN port. If your modem has a router built-in, just connect the first LAN port of the modem to the router.

    Your computer is connected to your router.

    If your modem has a router built-in, all ports are forwarded to your "real" router.

    Your router forwards port 25565 TCP/UDP to the correct internal IPv4 address of your server.
    Your firewall allows all of your java versions.
    Your firewall allows traffic on port 25565
    Your firewall allows the starting (.Bat/.exe/...) and the .jar file (not needed, but just to be sure)
    Your server.properties contains following settings:

    Your server runs as administrator
    You have all rights in the folder you put your server in. (rightclick on the folder, properties, security. Your username should be granted all permissions)

    this tool I quickly wrote gets your external and internal ip addresses:
    the file is attached to this post, and also available here:
    (you might need to run as admin)

    If multiple internal address are shown, this means that your computer is connected to multiple networks.

    Attached Files:

  7. Offline


    My firewall is currently allowing all of my java versions.
    I use the port 152 due to well, being able to, mostly.
    I haven't yet understood how to allow the .bat through the firewall, help on that one?
    My server ip is blank.
    I'm the only account on my computer and therefore have full access to everything.
    Are the multiple internal addresses a problem?
    I'm currently connected to hamachi and teamviewer as well, even if they have been closed.
  8. Offline


    Multiple IP addresses are no problem, they would only be a problem if you fill in the server-ip.
    What firewall are you using?
    and you are using port 152? I would change that to a number above 16000.
  9. Offline


    Yeah, any port I change it to doesn't currently work.
    I'm using Windows Advanced Firewall.

    Is it possible to use TeamViewer? I think it would be more convenient.
  10. Offline


    That modem has a router built-in. You should take a look at the modem settings and your netgear router settings.
    However, independent from your router/modem, you should be able to join a server that is running on your current computer
  11. Offline


    When I open up the modem's configuration page, all it'll show me is status.
    There are no configuration options, and it took my router's old ip "" and gave my router a new one.

    I'm sorry, but what do you mean by independent?
  12. Offline


    whatever type of modem or router you have doesn't matter if you try to connect to a server on the same computer as your minecraft. Sorry, english isn't my native language ;)
  13. Offline


    Aw well I was hoping it would work =[ Goodluck Draygon!
  14. Offline


    did u open ur server.properties file and add the IP in?
  15. Offline


    darelle Yes, that's what I used to do, incidentally.
    @Snuggle Ah well, I'll keep trying xD
    @ Bertware It's fine :D But yeah, I used to be able to connect to it in general, even if my friends couldn't. Now I'm no longer able to.
  16. Offline


    This means it has something to do with the computer that is running bukkit, or bukkit itself. Try to run a fresh copy at a different computer?
  17. Offline


    Sorry I took so long.
    The server still won't work, even on the other computers tied to the same network.
  18. Offline


    tried a virus scan, connect from another computer with another minecraft , latest bukkit and minecraft versions?
  19. Offline


    No viruses, don't have another minecraft but asked my friend to help when he came over, latest versions are 1.2.5 and the recommended build. Sorry I took so long to get back to you. My computer was in for repairs.
  20. Offline


    My brother host server and he join but when i try to join i got error -connection refused:connect- :(
    (We connect with tunnge, we want to play lan ) PLS HELP MEEEE
  21. Offline


    Hey. I also got this problem. I tried hosting from my brothers computer will a fresh copy of bukkit and it didn't work so its a problem with my router. YAY!
  22. Offline


    I got the same problem...
  23. are you guys connecting fron the same account? i get the same thing on lan
  24. Offline


    Use a program called PortMapper to portforward, does it automatically, my manual portforwarding wasn't working and with Port Mapper it does.
  25. Offline


Thread Status:
Not open for further replies.

Share This Page