[CONFIG] Bukkit Recipe Creator (v0.5.3) [1.7 support and new textures]

Discussion in 'Bukkit Tools' started by DerEchteNexus, Mar 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    @DerEchteNexus - I'd think it would be more logical to just put "true" to avoid confusion.

    Exporting puts improper recipe names as comments the proper parse format is #!Name or #~Name - your comment code isn't detected properly with the recipe -> html converter.

    Also any chance to get a 'merge' option? - I have multiple recipe files to keep them organized and smaller, but it'd be nice to be able to merge and export.

    CustomCrafting supports Smelt recipes that provide more than 1 of an item back which currently it's not changeable in the gui.

    Also - FurnaceRecipes aren't exporting properly to cookbook format.
    They should look something like this
    Also: RedStone torches get detected as id 75. this is actually their unpowered state. The crafting recipes should be using id 76.
  2. Offline


    Furnace recipes are not completely implemented yet ;)

    and with the names: The format I use was there, before the recipe viewer(or at least before I saw it)
    That's why I used a different format than Celtic Minstrel, but I think it shouldn't be too hard to change that^^
  3. Offline


    I forgot this in my original post in case you missed it.

    Thanks for the util, seems to be coming along really well!
  4. Offline


    fixed, for the next update!
    if you want it in the current version, just open "!#Blocks.db"(in plugins folder) and replace "75,0=RedstoneTorch" with "76,0=RedstoneTorch" ;)
  5. Offline


    Was there a way to get a larger display? I have a 26" monitor and it's nearly impossible to tell the difference between a lot of the blocks/items without squinting and moving really close to the screen.
  6. Offline

    Celtic Minstrel

    While we're on formats, my recipe viewer uses the ID key as the recipe's name for the CustomCrafting format, so if you could output the normal comments for the Cookbook format but not output comments for the CustomCrafting format, that would be great.

    And before you ask, spaces in the keys are perfectly fine, but if in doubt, you can quote them (just make sure the name doesn't include any quotes when you do that!). Or you could use the actual YAML libraries to handle all that for you.
  7. Offline


    Right now he outputs generic IDs starting at '200' for the recipe IDs - because the recipe IDs for customcrafting must be unique, and the gui doesn't force this to the name of the recipe. I think the better option might be to use the overrided name your script parses perhaps?
  8. Offline

    Celtic Minstrel

    I suppose that works too.
  9. Offline


    Working on it ;)
  10. Offline


    say I wanted 2 seeds and 1 cobble to make mossy cobble how can i stack 2 seeds in 1 slot with this... I can't seem to figure it out.
  11. Offline

    Celtic Minstrel

    You can't stack. Put seeds in two different slots.
  12. Offline


    ive downloaded the files but i dont know what to do now all i have is the rar files and i cant do anything with it
  13. Offline


  14. Offline



    where should I put those folders and .jar?
  15. Offline

    Celtic Minstrel

    Anywhere you like; this is a standalone program, not a plugin.
  16. Offline

    Grief'd man

    How do you use this?
    How to you run the files?
    I downloaded The latest version, and I have a modded server.
    MineCraft # 1.7.3
    Bukkit # 1000
    Just not sure how to use this download.
  17. how the fuck do i use this shit. there are just about 2934545 files and folders that just sit there. u dudes need to remeber that not all server hosts know java.
  18. Offline


    Perhaps I'll make really wacko recipes, k'now to throw my players off.
  19. how do u make the recipes. i dont know what to do with thesse folders and turn them into that program
  20. Offline


    How does one run this program? It isn't identified by my server as a plugin, it crashes when i run it with Java using Command Prompt, and you can't double-click it.

    wtf IS this thing???
    suckadickchicken likes this.
  21. i figured out how to use cookbook without this thing cus no 1 will answer me and all of the other comments where ppl do give them an answer i cant under stand it. soo i tried to make my own recipe but i didnt work for some reason so i changed 1 and it worked. i ran out of recipes to change so i copied 1 i changed and changed that. its all gud. just takes a long time and is very unvisual
  22. Offline

    Celtic Minstrel

    You double-click it to open it. If that doesn't work, then you need to configure Windows to open jar files with Java (or run it from the command prompt). If that also doesn't work, then it would probably be helpful to post the error Java gives you.

    I'm sorry, but if you don't understand basic computer concepts like this you should not be running a Minecraft server.

    Oh, and don't private message me for stupid little things like that. Just post in the thread and wait.
    Claustric likes this.
  23. im 14 how should i understand this, and ill have a server if i want to. ur nerd ass shouldnt feel cool for being old. ur still playing a game and not playing with girls. go find a girl and stop trying to tell ppl what they can and cant to.
  24. Offline

    Celtic Minstrel

    I'm not telling you what you can do; if you want to run a Minecraft server there's nothing I can do to stop you. I am telling you, however, that it sounds like you need to learn more about using a computer before you try something as potentially complicated as running a server.
    Claustric likes this.
  25. Offline


    Sounds awesome! Ill try it! :)

    I read it... sounds confusing. i'm not a computer geek. [creeper]

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  26. Offline


    [2011/08/26 16:46:30]Config created.
    [2011/08/26 16:46:31]DBLoader: Can't load 'Items1.6.DB'.
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]PluginLoader: Loading plugin (Blocks).
    [2011/08/26 16:46:31]PluginLoader: Loading plugin (Items).
    [2011/08/26 16:46:31]PluginLoader: Loaded 2 plugins.
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    [2011/08/26 16:46:31]Can't read file "language\English.lang"
    Whenever I doubleclick on the MCRC file, i appear to get the above error in the log.txt file that generates. Help anyone?
  27. Offline


    OK...it works and it's really cool. BUT, wtf is the save format??? I can't even get legible stuff from Notepad++. Doesn't work with custom crafting. The end.
  28. Offline


    Update for 1.8?
  29. Offline


    @Trollkemada It works for 1.8, i tested.

    Note: The new items for 1.8 isn't there, it works though.
  30. Offline


    hey i have problem : how to open MCRC v0.5.3 :D idk how to open it :(
Thread Status:
Not open for further replies.

Share This Page