Command block teleportation help

Discussion in 'Plugin Help/Development/Requests' started by devildog999, Dec 20, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    So I'm trying to make a teleportation building on my server so that people can tp to the various biomes because they are so far away from the main area. I am doing it via a loop with a command block so that when a person walks onto the coords I have set, they tp to area I want them to.

    The formula (for lack of a better word) I am using is tp @p[x,y,z,r=1] x y z

    Now I know the issue is essentials related because when I have essentials off, this works fine. As soon as I turn essentials back on, it no longer works. Is there a work around so that I can still have essentials running or am I **** out of luck?

    I've tried re writing it with my name instead of the @p because I know I can telly with a command block if I use my name and I have the block set on a button and redstone but with the loop and radius format, it doesn't work. Either does @a. Any help greatly appreciated.

    Oh, and I am running 1.8 spigot and Essentials-2.x-SNAPSHOT.jar

    edit: I forgot to mention that I have tried it with tppos and it does not fix it
    Last edited: Dec 20, 2014
  2. Offline


    Moved to Alternatives Section.

    Essentials overrides the tp command. You need to use tppos instead.
  3. Offline


    Sorry, I should have mentioned that I did try the tppos command as well and no go

    I GOT IT!!!!!! The command is /tele

    I was looking at essentials command list and it has aliases for the /tp command. /tele (there are a couple others I did not try) worked first go!!!! THAT IS IT :)

    excuse my over excitement, I have been working on this for hours...


    <Edit by mrCookieSlime: Merged posts. Please don't double post. There is an Edit Button right next to the Date.>
    Last edited by a moderator: Dec 21, 2014
Thread Status:
Not open for further replies.

Share This Page