Inactive [CHAT] Simple Prefix v1.4 - Easy prefixes & API (PermissionsBukkit)[1.1-R3]

Discussion in 'Inactive/Unsupported Plugins' started by Flabaliki, Jul 17, 2011.

  1. Offline


    JesseG17 and TimboHSV like this.
  2. Offline

    Racer Of All

    This doesn't seem to work with bPermissions?

    This is my setup:
            prefix: '&2[Owner]&f'
            suffix: ''
    Then on my bPermissions world group file:
        - simpleprefix.owner
    (I also tried - simpleprefix.owner: true but it doesn't work either).

    I'm not getting errors on the console or anything, it simply doesn't style the chat.
  3. Offline


    @Racer Of All That's odd. I just setup bPermissions and it doesn't work for me. I see no reason for this, I use the inbuilt Bukkit permissions and there doesn't appear to be anything on my end that would be causing it, unless I'm completely missing something.
  4. Offline

    Racer Of All

    I don't know anything about plugin devving but I did notice something with the plugins I've installed on my server:

    If it uses :true, :false, :eek:p or any of those, it doesn't work with bPerms (I tried mChat before and it didn't work, that's how I found your Simple Prefix).

    Plugins with regular nodes (for example, Towny Advanced: '') it works flawlessly. I don't know if this helps you at all, but its my 2 cents.
  5. Offline


    @Racer Of All It's really odd, it shouldn't need true or false. Considering it's nearly midnight and I have to get up early tomorrow, I'll look further into this later. The whole idea of this plugin is so that it works on all systems, which clearly it is not. I'll do my best to resolve this issue.
  6. Offline

    Racer Of All

    Figured out the problem! At least here on my end, I assume it's probably the same problem you had. Either way, if someone is having issues with this as well, do the following:

    Go to Essentials folder, edit config and make sure the third options reads this way:

    # Disable this if you have any other plugin, that modifies the displayname of a user.
    change-displayname: false
  7. Offline


    Am I mistaken, or did this used to support Permissions 3.x? If so I need to go elsewhere
  8. Offline


    @Racer Of All Glad to hear you found the problem :), I don't even have an essentials folder, or that config line, so I don't know what the issue on my end is :/

    @OZ4RK Yes, it used to, you can download the Permissions 3.x version here: SimplePrefix[Permissions_3.x].jar
    It's an older version that uses Permissions 3.x. Please note, that you set the prefixes inside of your Permissions yml file, not the simpleprefix one.
    At this time, I am not supporting this version and no updates will be made. In future, if it is in demand, I may add 3.x support back.
  9. Offline


    i am having the same problem as nextem.....everyone has the same nick and rank in chat,,,,they all show up as me.
  10. Offline


    @BSF As I said to neX!Tem and I quote
    EDIT: Issue has been resolved in 0.7.1
    @neX!Tem I fixed the issue of the same names in 0.7.1
  11. Offline


    For some reason, prefixes refuse to show. I capitalized the permission nodes, and double checked everything, and it's all set up exactly how it needs to be...but the prefixes aren't there.
  12. Offline


    @FlatSyx Latest recommended build? Which permissions plugin are you using? Any other plugins that could possibly tamper with users names?
  13. Offline


    How do I remove the "<" ">" from the chat message? I don't want it to say "<[Member] Username> message" I want it to say something like "[Member] username: message"
  14. Offline


    i have some requests you might want to look into.
    1. ability to remove the '<' '>' signs.
    2. let the color of the prefix/suffix continue. like when i have a suffix that ends with '&e' it will make the entire text yellow. Now the color just stops at the '>' sign and the text is always white.
    3. the use of color codes in the text itself.
    4. When i change a users group, the user still has the prefix of his old group. He has to disconnect and then reconnect for the new prefix to show up. Dont know if this is something you can fix or a limitation of the permissionsbukkit plugin, but if you can fix it i would really appreciate it.
    even if it would use a seperate command i would be fine with that. I just don't want to force people to reconnect before everyone can see they are in a different group.
  15. Offline


    @Flabaliki Hey im owner, of my server i just added some groups, as i logged in it didn't show my rank? how can i rank my self.
  16. Offline


    Find the problem with bPermissions yet?
  17. If you haven't figured it out yet:


    I personally use (integrated with permissions)
    event.setFormat("[" + (prefix.replace("&", "\247")) + "\247f] " + (name) + (suffix.replace("&", "\247")) + ":\247f " + (event.getMessage()));
  18. Offline


    hey i was wondering why this plugin only allows a max of 3 different groups?
    all my groups work, but when i have more than 3, it disables some of them. help cuz i really like this prefixer more than the others i have tried.
    thanks, btw if you need the files, just ask.
  19. Offline


    @Athelestan It does. I have found it can be quite odd when acting with inherited permissions. That was a problem I personally had in my own server. I'm not sure of the best way to set it up, I'll have to do a bit of research to find out. I would assume the topmost group you would need to put first in the config.yml. So if Admin was your top group, put those settings first, then if Golden was your second group, put that second in the config. Now, this is just a guess, I have to do some testing first, do not take my word on that.

    @Snowy007 I've implemented most of the suggestions you have there. The only one I did not was; colours in the actual message. I believe that is going beyond the aim of this plugin. I understand it's only a very small thing, and would be easy to implement, but I fear that I'm stretching what I set out for this plugin to be as it is.

    @XZeenon You can now do that in the latest version of the plugin.

    @Pawned Thanks for that! I didn't see that as I set user prefixes and suffixes on player join, so naturally, the event didn't have that function. I've played around with my code and added that ability in the latest version.
  20. Offline


    [quote="Flabaliki, post: 620934@XZeenon You can now do that in the latest version of the plugin.[/quote]

    Now whenever I use the /who command or /players command to see who is online, they pop up as "[Member] Randomguy: , [Admin] Coolguy: ," etc.
    How do I remove the colon from there? I just want the colon to be in the chat.
  21. Offline


    @XZeenon By default, Bukkit doesn't have /players or /who . It has /list, and that doesn't seem to cause any issues for me. I suspect that whatever plugins are creating these lists, are using the users display name and not just their name. In that case, there is nothing I can do.
  22. Offline


    Could you upload the old version of simple prefixes? I prefer it over this new version...
    Because even when a user sends private messages to someone, it says "(From [Member]Username: ): <message>" Which looks horrible.
  23. Offline


  24. Offline


  25. Offline


    @XZeenon Nothing is messed up. It works perfectly. OTHER plugins are your problem. If you use the built in method of displaying who is online, there is no issue.
  26. Offline


    Didn't you even read about the default messaging system?
    When someone sends a message to me, it appears as "(From [Member]Username: ): <message>"
    When my template is
    format: '[prefix][name][suffix]: '
    time: hh:mm a

    Please fix. I'm not using any chat plugins.
  27. Offline


    @XZeenon Is this when you use /tell? If so, that does not happen for me, mine appears as it should, without the (, ). Which again means, there is probable something interfering with it. The default whispers doesn't have From nor is it surround in brackets, you have a plugin that is doing that.
  28. Offline


    Yes, I use /tell and it appears as I stated before.
  29. Offline


    thanks flabaliki it was weird, but the order thing works :D
  30. Offline


    I'm having a problem. When I type something in game, the plugin says:

    12:30:21 [INFO] [Simple Prefix v1.0.1] Permissions node is incorrect or Dayshade doesn't have a node.
    This is the config:

        format: '[prefix][name][suffix] '
        time: hh:mm a
            prefix: '&6[Owner]&f'
            suffix: ''
            prefix: '&4[Admin]&f'
            suffix: ''
            prefix: '&5[Mod]&f'
            suffix: ''
            prefix: '&1[Builder]&f'
            suffix: ''
            prefix: '&2[Member]&f'
            suffix: ''
            prefix: '&7[Guest]&f'
            suffix: ''
        register: true
    I'm running a Mac with 4 GB RAM, and I have two other chat plugins, OKSpamSecurity (which seems to not be working either) and HeroChat. Can anyone help?
  31. Offline


    @Dayshade That means that you haven't given yourself a permission node. If you wanted to give yourself the Owner one, you would need this node:
    This uses super perms, so if you do not have a manager of sorts, you will need one.

Share This Page