Inactive [CHAT/MECH] DimensionDoor v2.1.1 Multiworld management made easy [1.3.1-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by grandwazir, Jun 28, 2011.

  1. I'm not familiar with BananaMaze, but I did have a similar issue. Today I tried to reenable the Dreamland plugin, but I thought I was getting a corrupt chunk so I was experimenting around with recreating the world with the known seed. After removing the world and then deleting the physical files, I would recreate the world with the command /dd create dreamland SKYLANDS s:<iforget> , which seemed to go fine. When I teleported it to it (/dd teleport dreamland) however, I would end up a world called planetoids. I was a little suspicious that the world I was teleporting to was NOT a skylands world, and when I relogged, I saw in my server's console log that I was in a totally incorrect world. But restarting the server fixed the issue for me.

    This actually brought to my attention another issue.

    I've recently started playing with custom generators. One is called Planetoids, which doesn't seem to work very well with DD, but it wasn't an issue as after I installed it it auto-created a world called planetoids for me. Which DD automatically and as expected and perfectly normally decided to manage for me. I didn't realize I was teleporting to planetoids because it didn't look anything like the world I was at before. In fact, the original planetoids world wasn't anywhere to be found, I had no idea why planetoids was a completely different normal world. So I deleted it and restarted the server, Planetoids hooked in and created the world, I checked it out, it looked okay. Oh, I forgot to turn take Dreamlands out again. Stop the server, remove, start it up again, and
    Console (open)
    23:28:41 [INFO] [DimensionDoor] External permissions system found (Permissions v2.7.7)
    23:28:41 [INFO] [DimensionDoor] Registering and loading worlds...
    23:28:41 [INFO] [DimensionDoor] Applying world configuration: world
    23:28:41 [INFO] [DimensionDoor] Applying world configuration: world_nether
    23:28:41 [INFO] Preparing start region for level 5 (Seed: 6682773429564767051)
    23:28:42 [INFO] [DimensionDoor] Applying world configuration: riverworld
    23:28:42 [INFO] [DimensionDoor] Applying world configuration: nightmare
    23:28:42 [INFO] Preparing start region for level 6 (Seed: 1420013959)
    23:28:42 [INFO] [DimensionDoor] Applying world configuration: mikesworld
    23:28:42 [INFO] Preparing start region for level 7 (Seed: 1972704199307007113)
    23:28:43 [INFO] [DimensionDoor] Applying world configuration: mikesworld_nether
    23:28:43 [INFO] [DimensionDoor] Applying world configuration: sphere
    23:28:43 [INFO] Preparing start region for level 8 (Seed: 1313604957500)
    23:28:43 [INFO] [DimensionDoor] Using custom world generator: BananaCakeTown v0.6
    23:28:43 [INFO] [DimensionDoor] Applying world configuration: thecake
    23:28:43 [INFO] [BananaImageToMap] Reading heightmap from plugins/BananaImageToMap/earth.jpg...
    23:28:46 [INFO] [BananaImageToMap] Read 4096x4096 pixels in 2.7 seconds
    23:28:46 [INFO] Preparing start region for level 9 (Seed: 1313605517793)
    23:28:46 [INFO] [DimensionDoor] Using custom world generator: BananaImageToMap v3.1
    23:28:46 [INFO] [DimensionDoor] Applying world configuration: testmap
    23:28:46 [INFO] [DimensionDoor] Applying world configuration: dreamland
    23:28:46 [SEVERE] Could not set generator for default world 'planetoids': Plugin 'Planetoids' is not enabled yet (is it load:STARTUP?)
    23:28:47 [INFO] Preparing start region for level 10 (Seed: -2002115536221921627)
    23:28:48 [INFO] Preparing spawn area for planetoids, 12%
    23:28:49 [INFO] Preparing spawn area for planetoids, 28%
    23:28:50 [INFO] Preparing spawn area for planetoids, 40%
    23:28:51 [INFO] Preparing spawn area for planetoids, 57%
    23:28:52 [INFO] Preparing spawn area for planetoids, 65%
    23:28:53 [INFO] Preparing spawn area for planetoids, 73%
    23:28:54 [INFO] Preparing spawn area for planetoids, 77%
    23:28:55 [INFO] Preparing spawn area for planetoids, 85%
    23:28:56 [INFO] Preparing spawn area for planetoids, 93%
    23:28:57 [INFO] Preparing spawn area for planetoids, 97%
    23:28:57 [INFO] [DimensionDoor] Applying world configuration: planetoids
    23:28:57 [INFO] [DimensionDoor] 11 worlds configured!
    23:28:57 [INFO] [DimensionDoor] DimensionDoor v1.6.3 is enabled!
    23:28:57 [INFO] Planetoids version 1.2.1 is enabled!
    As you can see, Planetoids doesn't load until after DD, so DD respawns the world. Additionally, I can't figure out how to actually get Planetoids to work with DD in-game. I've tried the command /dd create planetoids NORMAL g:planetoids , but the most info I get out of this is what's printed to the console window:
    Console (open)
    23:42:19 [INFO] [DimensionDoor] {generatorID=, seed=1313725339754, generatorPlugin=Planetoids}
    23:42:19 [INFO] Creating Planets (this may take a while)
    23:42:19 [SEVERE] Plugin Planetoids v1.2.1 does not contain any generators that may be used in the default world!
    23:42:19 [INFO] Generator plugin does not support that generator!
    This isn't so much a big deal, and I suspect it has to do more with the way Planetoids is coded than anything to do with DD, but I thought I might as well mention it. My real issue is DD overwriting the Planetoids world. Any thoughts?
  2. Offline



    Further to this, I came to this thread as DD was the only World manager out of the three I tried that this happened under. Well it's just happened under Multiverse2 as well. It could just be chance but under DD it happened more reliably whereas under WorldWarp I never saw it happen and under Multiverse2 it took about 3 days before it did.

    Still have no idea what it is. I'll let the bananaMaze guys know and see if they have a clue.
    Thanks for your interest.
  3. Offline


    Apparently when i updated dimension doors it didn't on the old version of bukkit. I didn't want to update the bukkit because the permissions was buggy. I did eventually down grade the mod, it worked after that. So i'm guessing updating the mod doesn't work on every version of bukkit
  4. Offline


    Yeah in one of the versions (I forget which one) I start using the built it bukkit permissions which requires #1000. It should be safe to upgrade now though.
  5. Offline


    Ok, so when I have the pluggin and have been using it for awhile fine but then the bukkit update came and now when I try to use it, it says I don't have the permission to do so when I'm an op and the admin for that matter. Any idea why this could be happening?
  6. Did you also update your server? PermissionsBukkit is the official permissions plugin (not that all plugins support it yet) but I'm pretty sure DD does. As it's 2 AM I don't have a quick guide to get your permissions all set up properly from a fresh load with it added in, but with it installed the /perm command should give you a good basic of how to start updating your permissions if you explore it a bit. And this way you'll be prepared as more plugins transition over.
  7. Offline


    alright, thanks, I'll try to look more into this and if the problem persists I'll bring it to the topic's attention and etc.
  8. Offline


    I don't like that in the 1.6.3 version I have to use permissions when i don't have permissions on bukkit activated. My bukkit says it ignored permissions but when i use /dd it says i don't have permission. I guess i'm sticking with 1.4.0
    dma likes this.
  9. Offline


    One glitch found !

    CleanroomGenerator doesn't work on the main world !


    It will not work on "flat_world" and simply generate a normal world.

    It work only if "flat_world" isn't the main world.
  10. Offline


    DD does not support doing that no. You can however doit by changing your bukkit.yml. I think the PhoenixTerrian Mod has some documentation on how to do this.
  11. Offline


    Thanks. =)

    Simply add this in bukkit.yml :
            generator: CleanroomGenerator
    Or CleanroomGenerator:62,3,1,2,62,0,1,20 for example.
  12. Offline


    Bukkit 1060, DimensionDoor version 1.6.3. I can provide server.log or anything else if necessary.

    DimensionDoor supports four worlds, smd, smd_nether, world, and world_nether. The portals between smd and smd_nether work fine, and these two worlds were automatically detected when I first ran DimensionDoor. I then copied the world and world_nether folders into the correct place and imported them using "dd create world NORMAL" and "dd create world_nether NETHER" respectively. Both worlds work, though the spawnpoint for world_nether is on the roof of the nether, but the portals between world and world_nether are broken. Stepping into one gives you the swirly effect, but it doesn't load a new world.

    What should I do to fix it?
  13. Offline


    By default Minecraft only supports a single nether world, and when using a portal from anyworld that isn't itself a nether goes looking for the _nether world that is for the default world listed in the Minecraft settings file.

    There are some plugins I've seen that correct this issue. Search the bukkit plugins for nether and I'm sure you'll find them. I know that SpoutNether does it, but it may be dependant on Spout. I do now there are other, standalone plugins that will let each world have it's own nether by following the naming convention you have used.
  14. Hey, Grandwazir -- I just added you to a conversation I'm having with the Cleanroom Generator plugin dev. There seems to be an issue with the way DD starts up and isn't hooking right all the time into Cleanroom. Just a quick FYI since the conversation doesn't really start off talking about DD at all. :)
  15. Offline


    Hi @grandwazir - I've just been doing some debugging with @HereInPlainSight and I've uncovered a bit of a bug in DD relating to custom WGENs.

    03:37:13 [INFO] [DimensionDoor] Registering and loading worlds...
    03:37:13 [INFO] [DimensionDoor] Applying world configuration: world
    03:37:13 [INFO] [DimensionDoor] Applying world configuration: world_nether
    03:37:13 [INFO] Preparing start region for level 4 (Seed: 12345)
    03:37:13 [INFO] [DimensionDoor] Applying world configuration: sphere
    03:37:13 [INFO] [DimensionDoor] Applying world configuration: Planetoids
    03:37:13 [INFO] [DimensionDoor] Applying world configuration: cleanroom
    03:37:13 [INFO] [DimensionDoor] 5 worlds configured!
    03:37:13 [INFO] [DimensionDoor] DimensionDoor v1.6.3 is enabled!
    As you can see, the world 'cleanroom' doesn't have a "[DimensionDoor] Using custom world generator:" line before its Applying world configuration line - as you'd usually expect... So misconfigured world? Except...

    >dd info cleanroom
    03:59:55 [INFO] World information for cleanroom:
    03:59:55 [INFO] - seed: 1315159930250
    03:59:55 [INFO] - environment: NORMAL
    03:59:55 [INFO] - pvp: false
    03:59:55 [INFO] - isolatedChat: false
    03:59:55 [INFO] - spawnAnimals: false
    03:59:55 [INFO] - spawnMonsters: false
    03:59:55 [INFO] - generatorID: 60,dirt,1,grass
    03:59:55 [INFO] - generatorPlugin: CleanroomGenerator
    As you can see, there is a generator specified for that world! How this happened, I'm not sure - I tried creating another world called "test" with the generator, then restarted the server and it loaded up fine - but the "cleanroom" world remained without a custom WGEN passed to Bukkit.

    Have a chat with either myself, or HereInPlainSight if you need more information (I suspect a copy of the sqlite db will be useful in any case). Bukkit #1060 and DD v1.6.3. I'm on as NVX.

    I had a look at the code and didn't see anything immediately obvious, but your configuration seems a little convoluted to me, so I've very easily missed something.
  16. Offline


    Same problem here !

    I've update DD 1.4.2 > 1.6.3, and make mySQL (SQlite with 1.5), i dont use any permission plugin in my server, but now i always have a error message "You do not have permission to do that" with all /dd command :mad:

    I'm OP in my server, i dont use permission plugin, how to use DD without any permission plugins ??

    Do i downgrade to DD 1.4.2 ?

    (sorry for my poor english^^)
  17. Offline


    Yeah Downgrade, I had to in order to get it working
  18. Offline


    Ok, i downgrade to 1.4.2 (1.5.x has a same problem)
    Thank's ^^

    I hope that by updating DD to the 1.8 Grandwazir correct this trouble;)
  19. Offline


    It is completely unnecessary, and not recommended, to stay on Version 1.4.2 - all you have to do is copy and paste the section marked "Give server operators all permissions by default" into your permissions.yml and it will work exactly like you were used too.

    Alternatively you can wait until DD next release when this will not be necessary.

    At the moment DD does not add any additional support for nether teleporting through portals. Besides this is something that really should work without a plugin needing to interfere. Unless you are very attached to the nether gates, I would just make stargates to your different worlds instead.

    I've replied with greater detail in the conversation but the short answer is I can not reproduce this locally. Creating a world with those exact settings here works fine (on the test server you provided).

    Just out of interest - what part of the configuration did you find convoluted?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  20. Offline


    I'll leave the conversation about the bug in that thread to save the spam in here.

    Oh, I mean the code to read/parse the config when having a quick look to see if I could spot the bug - the configuration itself I didn't look much at - on the other hand I end up favouring plain text configs for their simplicity for most things - so personal preference in coding style probably has a decent chunk to say there too :p.
  21. Offline


    Very thank's :D

    It works perfectly with 1.6.3, you'r best !
  22. Offline


    My permission.yml file is blank
  23. Offline


    Which is why if you copy and paste what I said into it - it will work.
  24. Offline


    when i do all what i need to do its write this
    you don't have permission to do taht
    wtf is that now ???
  25. Offline


    Copy/paste this code to your permissions.yml (in the root of your server) even if this file is empty, and restart your Minecraft server.
      description: Assign all permissions for DimensionDoor.
      default: op
        dimensiondoor.create: true true
        dimensiondoor.list: true
        dimensiondoor.load: true
        dimensiondoor.modify: true
        dimensiondoor.modify.pvp: true
        dimensiondoor.modify.isolatedchat: true
        dimensiondoor.modify.spawnanimals: true
        dimensiondoor.modify.spawnmonsters: true
        dimensiondoor.remove: true
        dimensiondoor.spawn: true
        dimensiondoor.teleport: true
        dimensiondoor.template: true
        dimensiondoor.unload: true
  26. Offline


    Very good plugin.
    Please add support to #1185 ! I dont want to use another portal plugin.
  27. Offline


    Already supports the new build - works perfectly with it
  28. Offline


    Request : Support multiworld difficulty. =)

    Something like this : /dd modify world difficulty X

    Where X is :

    0 Peaceful
    1 Easy
    2 Normal
    3 Difficult
  29. Offline


  30. Offline


    This has been added to the latest version of DimensionDoor, together with the ability to set different game modes.
    HereInPlainSight likes this.

Share This Page